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About Lytrod Software, Inc.
Established in 1985, Lytrod Software is a privately held company committed to producing high-quality
variable document design tools. For over 25 years Lytrod has developed software tools that help Xerox
customers get the most out of their production printers.

Lytrod Designer Suite generates personalized documents and business forms for Xerox VI Compose
(Variable Data Intelligent PostScript Printware), and legacy environments. Lytrod Software’s innovative
solutions for high volume enterprise printing environments implement modern advances in the print
industry, while preserving the means to utilize and enhance legacy form resources.

Lytrod has extensive knowledge and experience with Xerox customers and continues to exceed industry
expectations with new and innovative products.

Our products are continually refined, and your input is our number one source for product improvements.
Send comments to:

Lytrod Software, Inc.
2573 Clay Bank Road, Suite 4
Fairfield, CA 94533
Phone: 707/422-9221
Fax: 707/429-5179
email: support@lytrod.com
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Lytrod Software Services and Support
Technical support is offered to customers who have purchased a maintenance contract through either
Lytrod Software or Xerox.

Lytrod Support

If you have a current maintenance contract purchased through Lytrod Software, the following options are
available to you:

Telephone Support

1-707-422-9221

Lytrod Software technical support is offered Monday through Friday, 7:00 am to 4:30pm
Pacific Time.

Email Support

support@lytrod.com

Response to email will be within 4 hours during the standard technical support hours.

Xerox Support

If you have purchased support through Xerox, please call 1-800-821-2797

Web Site

The web address for Lytrod Software products is http://www.lytrod.com. Current product, training and
sales information is readily available at this site, as well as online live tutorials.

Training

Lytrod offers a variety of training options, including web-based training. Please visit
http://www.lytrod.com/services/training.php for details and pricing.

Lytrod also offers a wide variety of 1-2 minute "How-To" videos on our YouTube channel. Please visit
http://www.youtube.com/user/LytrodSoftware

xx



Proform Designer Protection Key (Dongle)
Lytrod Software products are protected via a protection key (also referred to as locking device or dongle)
that is designed to be attached to the parallel or USB port of a computer. The protection key retains the
software license of operation. A licensed key must be attached to the parallel or USB port of the system
that is attempting to access the software during the entire session of operation.

New Software Licenses

Software protection keys are programmed for operation according to the licensing agreement. A code
(numeric string) and instructions may be issued from Lytrod Software that will enable the protection key
with a license of operation.

Each Lytrod Software product purchased from Xerox is shipped without a license of operation. These
products purchased from Xerox can be enabled by contacting Lytrod Software to register each new license.

Products purchased directly from Lytrod Software will be shipped with a 30-day temporary license of
operation. Once full payment is received within the 30-day grace period, established in the Lytrod Software
purchasing terms, Lytrod Software will issue a license to enable the software for full operation without an
expiration date.

Lost Software Protection Keys (dongles)

Software Protection Keys will not be sold individually if lost or stolen. Full purchase price of the software will be
charged for all dongle replacements, with no exceptions.

Defective Software Protection Keys

If dongles are damaged or fail to perform, there will be a fee to obtain a replacement dongle after the
original dongle has been returned to Lytrod Software, Inc. Replacement dongles will not be shipped until
the original dongle is received.

xxi





Chapter 1

Getting Started with Proform Designer

Lytrod Software Proform Designer is a user-friendly variable data layout and forms design tool.
Sophisticated one-to-one marketing pieces and transactional/promotional statements can be easily
created from either mainframe, XML, or database delimited data. The Microsoft Windows GUI

interface includes wizards and drop-down menus for easy drag-and-drop data placement. The simplest
personalized letter, or the most complex rule-based job, is created without any scripting. Specialized OMR
drawing tools with data-driven pre-slugging create a more efficient scannable document. Proform Designer
can be used to convert and/or create fonts, images and forms for PostScript, PCL and Xerox Metacode
printers.

Easily create simple personalized letters or sophisticated variable documents (conditional rule-based text,
images, page designs, media, slipsheet, etc.). Take full advantage of the operational flexibility and speed of
Dynamic Document Construction – building data-driven, personalized documents at the moment of
output, and at the rated speed of the device.

Getting Started with Proform Designer 1



Lytrod Software's 'Just Send the Data' Workflow
Lytrod Software Designer suite of products support the Xerox FreeFlow VI Compose template and
resource driven variable data workflow, referred to as Dynamic Document Construction (DDC). Proform
Designer can generate DDC VI resources for production print within seconds, regardless of the number of
variable records in the job. VI resources and template instructions generated from Proform Designer are of
minimum file size and are easily transmitted through the network. VI Compose caching capabilities RIP
resources once, processing only the data records, after the initial RIP, at the rated speed of the engine. This
workflow is ideal for repeated jobs (transactional statement printing, etc.) and one-off jobs that need to be
out the door A.S.A.P. (postcards, personalized letters, etc.).

Dynamic Document Construction:

� The variable document is designed in Proform Designer.

� VI Compose resources are sent from Proform Designer to the DFE of a VI Compose-enabled
production print device(s), the hard drive of a VI Compose-enabled office printer, and/or the FreeFlow
VI eCompose (formerly VIPO).

� Once the resources are housed at the engine, the data is transmitted directly to the printer and/or the FF
VI eCompose. The document is dynamically constructed at the time of printing.

2 Getting Started with Proform Designer



Installation
Before beginning, you need to install Proform Designer onto your computer. There is a Proform Designer
setup program on the enclosed CD that will lead you through the installation process.

System Requirements

To run Proform Designer you will need the following:

� Microsoft Windows operation system XP, Vista, Windows7, Windows8

� PC user rights for periodic access to and editing of system registry during software operation (may
require Admin Rights or that User Account Controls are turned off)

� USB Port (for license dongle)

� 256 MB of RAM

� 1 GB hard disk space

� Pentium IV 2.8 Ghz/AMD Athlon 2800 Mhz or faster processor

� CD-ROM Drive

� Two-button mouse

� 17” Super VGA monitor or larger (recommended)

� Internet access and software *.exe download rights for Automatic Software Update Service

Installing Designer

Installation of the software requires PC administrative rights that enable the installation of software, access
to the system registry, and installation of a device driver for the dongle.

� To install Designer (USB dongle)
� Insert the installation CD into the CD ROM drive. An automatic setup menu will appear. Follow

the directions on the menu. International versions of the software will offer the installation in the
English, French, German or Spanish languages.

� Reboot

� Attach the USB dongle and use the Windows New Hardware Device Wizard (Should
automatically appear) to find a driver for the USB dongle.
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If installing on a 64-bit Windows7 or Windows8 system, the software may default to be installed on the
Program Files (x86)\Proform Designer folder. Click on the Browse button and choose the Program Files\Proform
Designer folder instead.

� To install Designer (parallel port dongle)
� Attach the parallel port dongle to the system prior to the initial boot up before installing the

software.

� Insert the installation CD to the CD ROM drive. An automatic setup menu will appear. Follow
the directions on the menu. International versions of the software will offer the installation in the
English, French, German or Spanish languages.

If the installation wizard does not automatically launch, run the setup.exe program from the CD.

Multiple software licenses are required to run the software on multiple workstation seats.

What Printer are You Designing Forms For?

When Designer opens for the first time, the printer and
forms language that will be used can be selected. There is the
additional option of enabling the International Defaults check
box. If this box is enabled, Designer will automatically set
A4 as the default paper size, millimeters as the default page
size unit, all rulers to centimeters and the OMR default to 40
channel.
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Automatic Software Updates

This feature is only available to customers who are current on their software maintenance or who are Xerox
Internal personnel. Proform Designer will automatically check for version updates upon installation and
every 7 days thereafter.

� To enable an automatic software update

1. With no forms open, go to the Edit menu and select Preferences.

2. Access the System tab.

3. Check the Enable Internet Based Software Updating check box.

4. Click OK.

� To force an automatic update to occur

1. With no forms open, select Designer Software Update from the Help menu.

2. If your maintenance is current or you are a Xerox Internal user, Designer will update your software if
a new version is available.
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Using the Documentation
In addition to the printed documentation, much of Proform Designer is documented in an on-line help
system.

Proform Designer Documentation Set

Online Help Within Proform Designer an online help system is available for access during the operation of the program.
This online help can be quickly accessed and the help window can be displayed while you continue your
work.

Context-Sensitive Help Integrated within Proform Designer is a context-sensitive help system that displays information relevant to
the current task. Context-sensitive help is accessed by clicking What’s This and then clicking on the item for
which to view information.

Fly-by ToolTips Information on icons and buttons will display as you position the cursor over an icon or button within the
toolbars.

User Guide The written documentation you are currently reading provides an in-depth description of Proform Designer.
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Documentation Conventions
The conventions used in this documentation are defined as follows:

Mouse Conventions

The following conventions are used when referring to the mouse:

When you read this… Do this…

Click a button Position mouse over the button and click

Open menu Position mouse over the main menu, depress mouse, position mouse over the requested menu item and click
the mouse button.

Enable check box Click the check box to place an “X” in the box.

Disable a check box Click the check box to remove the “X” in the box.

Select Text Click and hold down the left mouse button at the beginning of the text selection, drag mouse to the end of
the selection and release the mouse key.

Select Object Be sure no other object is selected. Position mouse over object until the mouse pointer changes to the shape
of the object, then click. The object will now have markers at various points on the edge.

Keyboard Conventions

The following conventions are used when referring to keyboard actions:

When you read this… Do this…

Press ENTER Press the Enter key on your keyboard

SHIFT + MOUSE Press the Shift key and click the left mouse button at the same time.

CTRL + MOUSE Press the Control key and click the left mouse button at the same time.

User Guide Conventions

When you see this… It means this…

� A note

� A tip

� An Item of Interest

� Look Here
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Using Online Help

� To access help topics

1. Select Help topics from the Help menu.

2. Click one of the following tabs:

� Contents tab to browse topics by category.

� Index tab to list index entries. Enter the first
letter(s) of the index entry to jump to that topic.

� Find tab to search for a particular word or phrase.

Accessing Context-Sensitive Help

Context-sensitive help is accessible from anywhere within
Proform Designer. When accessing context-sensitive help,
use these guidelines:

To get help on… Click here…

Windows The Context Help button on the toolbar, drag the context help icon to item within the window.

Menu Commands The Context Help button on the toolbar, drag the context help icon to the menu and click.

Tools and dialog controls The Context Help button on the toolbar, drag the context help icon to the item you want help on and click.

Selected object Right-click the object and select the Properties menu item for information on that object's Fly-by ToolTips.

Fly-By ToolTips

Fly-By ToolTips are available for all toolbar buttons and provide a brief description of its operation.
Position the mouse over the toolbar button and wait for a few seconds. The Fly-By ToolTips will appear
below and slightly to the right of the toolbar button.
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Proform Designer Screen Layout

Design Area
The design area is used to display and edit any forms that may be open. More than one form may be open
at a time. The most recently opened form will be displayed. All will be listed in the Window menu. Selecting a
form from this list will cause it to be displayed. Each form is displayed in its own window in the design area
with associated Minimize, Maximize, Restore, and Close buttons. Minimizing or reducing the current
window will allow other open forms to be viewed. Only the active form can be edited. The active form is
designated by clicking in the form’s window or selecting it from the Window menu.

Toolbar Button(s) Screen Item

The view of the design area can be enlarged or decreased using the Zoom buttons on the View
toolbar or by choosing the desired view from the View menu.

Rulers can be displayed at the top and left or the bottom and right of the design area to aid in
placement of form elements. These rulers can be undocked and moved around the design area
by dragging them onto the form. They can be redocked by clicking on them with the right
mouse button and choosing the desired location.

A grid can be displayed on the screen (as well as printed on a proof print) to assist with form
layout and measurement. Grid values are defined in the Form Setup window. See page 72.

Scroll bars are available at the right and bottom of the design area. These are used to move the desired area
of the form into view. Information pertaining to the active form is displayed in the Ribbon bar, which is
beneath the design area.
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Menu Bar

The Menu bar is displayed at the top of the screen and provides access to all menus available in Proform
Designer. Each menu contains a list of commands that will be displayed when the user chooses a menu
title. Non-selectable commands will be grayed out. Non-selectable commands are features that are not
available to the user at the time of selection based on the type of form element selected.

Some Menu bar commands are followed by an arrow marker indicating that a cascading menu will appear.
These cascading menus typically request further clarification as to the function being performed. For
example, the Import command from the File menu has a cascading menu. This menu requests further
information regarding the Import function (Font, Image, Text, etc.)

Some Menu bar commands are followed by an ellipses (…) indicating that a pop-up menu will appear.
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Quick Keys

Most commands have their associated quick key listed to the right of the command. Quick keys provide
users with quick access to various functions via the keyboard. Most commands also have a corresponding
button on a toolbar.

Quick Key Command/Action

Ctrl + A Select All

Ctrl + C Copy

Ctrl + F Find

Ctrl + G Group

Ctrl + H Replace

Ctrl + N File New

Ctrl + O File Open

Ctrl + P File Print

Ctrl + R Rotate

Ctrl + S File Save (Must select Save As from File menu before this command is enabled.)

Ctrl + V Paste

Ctrl + X Cut

Ctrl + Y Edit Redo

Ctrl + Z Edit Undo

DEL Delete

F1 Help

F2 Attach Object, Text Box, Data

F3 Find

F5 Position Object

F6 Next Pane

F7 Format Object (Not Text Box)

F8 Zoom Fit To Page

F9 Preferences

F10 Refresh Screen

Shift + F1 Context Help

Shift + F6 Previous Pane
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Pop-up Menus
Pop-up menus appear when further information is required from the user. Information is requested in the
form of edit boxes, drop-down boxes, spin boxes, radio buttons, and check boxes. Pop-up menus also
contain action buttons.

Radio Buttons

Radio buttons represent a group of choices in which only one option
can be selected. They appear as a set of small circles along with their
associated descriptions. A radio button is set when a dot appears in the
middle of the circle. The circle will be empty if the choice is not
selected.

Check Boxes

Check boxes are similar to radio buttons in that a group of items are listed and
can be set or not. They differ in that check boxes are used for independent or
nonexclusive choices. One or more check boxes can be set as desired.

A check box appears as a square box with accompanying label. When the
choice is set, a check mark appears in the box. The box will be empty if the
choice is not selected.

Action Buttons

Each menu has one or more buttons that provide control over the pop-up menu. This control may be to
accept the changes or cancel changes. It may also control the pop-up of additional menus. Action buttons
are OK and CANCEL.

Edit Boxes

Edit Boxes prompt for input of user defined information.
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Drop-Down Menus

A drop-down menu typically displays a list of choices. The choices can
be shown as text, icons or other graphics. The purpose is to display a
collection of choices from which the user can make their selection. The
list is displayed upon demand. In its closed state, the control displays
the current selection. The user opens by clicking the down arrow to the
right of the control to change the selection.

Spin Boxes

Spin boxes are edit boxes that accept a limited set of values. Spin
boxes have up-down control buttons to increment or decrement the
value. The user can also type a value directly into the box by clicking
the mouse over the value and typing the desired value.

Ribbon Bar
The Ribbon bar displayed at the bottom of the design area provides various information to the user. The
left side of the Ribbon bar displays messages based on the current menu field or mouse position. The right
side of the Ribbon bar displays information pertaining to the current form.

The right side of the Ribbon bar contains twelve fields. From left to right, the purpose of the fields are to
define the following:

� The current Resource Set

� Name of Job

� Job and Data Record Counter

� Number of record being viewed of total records (example shows 1st record of 9 records)

� The X coordinate of the element selected or the cursor if no elements are selected

� The Y coordinate of the element selected or the cursor if no elements are selected

� The ordering position of the selected item on the page. Higher numbers indicate forward
positioning.

� The unit of measure in which the X/Y coordinates are displayed, as defined in the Preferences
menu

� The zoom level of the active form

� The current time or the total amount of time spent on the active form, based on the selection in
the Preferences menu. The 24 hour clock time format is supported for international operating
systems.

� Number Lock

� Scroll Lock

� Insert/Overwrite
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Scroll Bars
Scroll bars are available to maneuver quickly throughout your form. Scroll bars appear whenever the user is
in a view such that their entire form is not able to be displayed in the Design Area. Scroll bars will appear
on the bottom and right sides of the screen. Click and drag the scroll bar to move the form up/down,
left/right as necessary. Page Up and Page Down keys also allow for quick maneuvering. Arrow keys are
located at left/right side of bottom scroll bar and top/bottom of right scroll bar to allow scrolling in
smaller increments.

Toolbars

Various toolbars are available within Proform Designer to provide quick access to commonly used
functions. Users are given the ability to organize the commands to suit their needs. You can easily customize
the tools on the toolbar. For example, you can add and remove menus and buttons, create custom toolbars,
hide or display toolbars and re-locate toolbars. Toolbars contain not only buttons, but drop-down menus as
well. ToolTips are available for toolbar buttons to identify their function.

Individual toolbars can be undocked and moved around the design area. This is done by dragging the
toolbar onto the design area. They can be re-docked by dragging them back to the toolbar area.

Display/Hide Toolbars

Toolbars can be removed from the screen if desired. Toolbars buttons are grouped according to
functionality and placed with similar functioning buttons on a single toolbar. For example, all drawing
toolbar buttons can be found on the Drawing toolbar. This not only makes locating buttons simplified, but
assists users in organizing their desktop.

� To display/hide toolbars

1. Select Toolbars from the View menu.

2. Toolbars will be listed by name in the Toolbars list.

3. Check on/off the appropriate Toolbar.

Change Appearance of Toolbars

Toolbars can be displayed as normal, cool look, and/or large buttons. Toolbars will be displayed in normal
view by default.
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� To change toolbar appearance

1. Go to the View menu and select Toolbars.

2. Enable the Large Button and/or Cool Look button as desired.

3. Disable the check boxes to return to normal view.

Enable/Disable ToolTips

ToolTips provide a brief description of the purpose of a toolbar button. They appear automatically when
the mouse is held over a button for a short period of time when the Show ToolTips option is set on.

� To set the Show ToolTips option

1. Go to the View menu and select Toolbars.

2. Check the Show ToolTips button.
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Customize Toolbars

Toolbars can be tailored to the users needs by removing and adding toolbar buttons to them.

� To customize a toolbar

1. Go to the View menu and select Toolbars.

2. Select the Commands tab to enable toolbar edit mode.

3. Remove and rearrange buttons from toolbars by dragging the buttons off toolbars or to a new
location.

4. Add buttons to toolbars by dragging buttons from the Buttons list in the Commands tab onto the desired
toolbar.

The user can further tailor the toolbars by creating a new custom toolbar.
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Create Custom Toolbar

� To create a custom toolbar

1. Select Toolbars from the View menu.

2. click the New button.

3. An edit box will appear allowing the user to name the toolbar.

4. The new toolbar will now appear in the Toolbar list.

Working with Rulers

Rulers

Rulers are a helpful tool in form measurement. The rulers can be displayed in a variety of units (inches,
centimeters, dots, and grids) and can be docked/re-docked as necessary.

� To display rulers

1. Click Show Ruler on the View toolbar.

<OR>

2. Select Options from the View menu.

3. Select Rulers from the Options menu.

� To define ruler unit

1. Select Preferences from the Edit menu.

2. From the Design tab, check Show Ruler to show/hide rulers.

3. Select unit of measure by choosing desired unit in Ruler Unit drop-down list.

Docking/Re-Docking Rulers

Rulers will be shown on the top and right side of the Proform Designer screen when first enabled. The user
can re-dock the rulers to the left and bottom as desired. Rulers may also be undocked to better assist users
with form measurements.

� To undock ruler, drag the ruler to a location within the design area.

� To re-dock ruler, click the right mouse button over the ruler and select location at which to
re-dock the ruler (left/right for vertical ruler or top/bottom for horizontal ruler).
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Welcome Menu
Upon starting up VisionDP, the Welcome Menu will appear. This menu will give you access to the most
commonly used functions and assists in quickly and easily opening up and creating new forms/projects.

Open button After selecting a file (project .pfj or single form .fsl,.dtd) you can click on Open to open your
design file.

New Form button The New Form button will create a new single blank form

Template button Clicking on the Template button will open up the Choose Template menu. Templates allow for
easy creation of projects in a few simple steps. Templates are explained in detail on page 265

Create VI Compose Output button Once a project file has been selected from the Design Files list, and an output type is selected
from the Create Type drop-down, click the Create VI Compose Output button to automatically
create the output for the selected project without having to open the design.

Create Type drop-down Use this drop-down menu to select the type of VI Compose Output you would like to create
when using the Create VI Compose output button.

Show Form Files check box Selecting ths check box will display all single forms(.fsl, .dtd, .frm) in the Design Files list.

Design Files List of all available .pfjs/.dtd that are associates with the active Resource Set

Resource Sets List of all resource sets. To edit Resource Set settings, double click on resource set name.
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Design Planes
Proform Designer places document objects within three design planes that affect the layering of the
objects. Each plane can be viewed individually or in combination. The order of the planes are as follows
from bottom to top: Background, Static Form, Data Plane.

There is also an optional Secure Plane in which the user can define a secure password that will need to be
provided any time editing to the secure plane is made.
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Static Form Plane

All elements that are drawn in Proform Designer that do not include a data element are part of the Static
Form Plane by default. Elements in the Static Form Plane will be placed in the form file created upon output.
Therefore, the elements in the Static Form Plane will be saved into the following files:

� PostScript environment: extension .PS

� PCL environment: extension .PCL

� XES environment: extension .XES

� Metacode environment: extension .FRM.

� Images and fonts will be saved as well.

Data Plane

Objects that contain, or are produced from, variable data elements will be placed in the Data Plane (except
variable images placed on the Background Plane). This would include text blocks with data, data-driven
images, conditional images or text, variable fields, etc. The Data Plane is the topmost plane, in front of the
Static Form and Background Plane. Upon output, data elements and/or their placement will be stored as VI
Compose commands in the *.JDT, *.DBM or *.XJT files.

Background Plane

The Background Plane can contain a printable image file, or objects that are viewable in the Designer
interface but are non-printable. The Background Plane is always below the Static Form and Data Planes.
Objects placed in the Background Plane are locked into the place of import, so they are anchored into place
and cannot be selected when placing or drawing objects in the static or data planes. Background objects can
only be edited or moved in Edit Background mode.

The Background Plane has two main uses:

� Pre-printed stock:

Non-printable background images are useful in emulating pre-printed stock. Drawn objects (lines,
boxes, circles, etc.) can also be placed in the background plane to assist in the design process
(emulating perforated paper, folds, etc.), and will not print.

� Pre-designed pages:

Printable background images are useful in anchoring full page design images that may have data or
static objects drawn on top. The option for printable background images is only available for forms
designed with variable data (VI Compose) and are limited to *.EPS, *.JPG, *.TIF, and *.PS file types.
Background images can also be variably driven (data-driven backgrounds and conditional rule-based)
but will always be on the bottom layer (under the Static Form and Data Planes).
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� To add static elements to the Background Plane

Select the static element that is to be added to the Background Plane. Right click the mouse and select
Background Plane. The element is now part of the background plane.

Only static form elements can be added to the background plane. Conditional background images can be
created by importing a background image when creating the new form or by importing background images
through the File menu.

� Working with the Background Plane

Elements in the Background Plane can only be selected for modification (moving, resizing, deleting), if you
select the Background Plane option from the Edit menu. Background elements selected will have a special fly-by
graphic to distinguish them from non-background elements as defined on page 97.

Viewing Document Planes

Each plane can be viewed individually or in combination. To view the various design planes, select from the
View menu the Plane Option. The planes currently being viewed will appear with a check mark as shown above.
Select the appropriate plane to either remove or add it to the display.

It is recommended to work with the background plane not activated since it makes it easier to select objects
on the page. To enable/disable the background plane access Background from the Edit menu. If this Edit
Background option has a check mark, then the background plane is activated. When the background plane
is active, it is more difficult to select static form plane elements.
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Secure Plane

Designer gives you the option to create a Secure Design Plane within your form that can only be accessed
when an administrator-defined password is provided. All elements created within the other design planes
can be edited while the Secure Plane is selected, but will only be password-protected once they have been
“sent to the Secure Plane”. All elements can be sent to the Secure Plane.

� To Create a Secure Design Plane

1. Access the Form Layout window by either creating a new form or selecting it from the Edit menu.

2. From the Form Setup Tab, enter a password in the Secure Password entry box.

Note: Password can be up to 256 characters.

3. The Verify Password window will appear prompting you to re-enter your desired password.

Click Ok.

� To Change Password of Secure Design Plane

1. Go to the Edit menu, and select Form Layout.

2. From the Form Setup Tab enter in the new desired password.

3. The Verify Password window will appear prompting the user to enter in the old password before a new
password can be defined.

4. Enter the old password and click Ok.

� To View elements within the Secure Plane

1. Go to the View menu and select the Plane Option.

2. A drop down list of the planes will appear with check marks next to the planes that are currently
visible.

3. Select Secure Plane from the list to enable the Plane.

4. A prompt will appear requiring the input of the password associated with the secure plane.

� To send selected elements to the Secure Plane

1. Select element you wish to send to Secure Plane.

2. Right click the mouse, and choose the Secure Plane from the Properties menu.
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Chapter 2

Resource Sets

Resource Sets provide the ability to organize the files and printer information associated with a
project or a group of projects. A Resource Set contains information about your printer and any
resources available on the printer. This helps Proform Designer guide the forms design process

based on what it knows about your printer. For instance, a Xerox HighLight Color printer needs different
ink information than a full color printer, and an 11X17 form should only be designed if your printer
supports tabloid paper.

Resource Sets also provide an avenue for resource management. A service bureau or the design department
of a large company may want to keep resources separated based on customer or department. A Resource
Set can be defined for each client containing logos and custom fonts specific to that client's needs, even if
all of the forms are eventually printed on the same printer.

You will be provided with a basic Resource Set (PRO-FORM) that defines standard printer defaults based
on the information gathered during installation. This Resource Set can be used as a basis to create a unique
environment. Additional Resource Sets can be created as needed.

When designing forms for a production environment, use a Resource Set based on the production printer,
even if other printers may be used for pre-production proof printing. Proof printers do not necessarily
need to have an associated Resource Set.
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Working with Resource Sets

Selecting a Resource Set
The Resource Set selected should represent the final destination printer. For example, if a page will
eventually be merged with data on an iGen3, but will be proof-printed on an HP LaserJet. The PostScript
Color Resource Set should be chosen when designing this page, since that is what will be used to print to
the iGen3.

The current Resource Set name is displayed in the Ribbon Bar. The Resource Set must be selected before
form design begins and cannot be changed while a form is open. When a form is saved, the Resource Set
information is stored in the form. Therefore, when opening the form in the future, the correct resource set
will be enabled.

� To select a resource set

1. Close all forms.

2. Select Resource Set from the Edit menu.

3. From the Resource Set drop-down menu, select the desired
Resource Set. The information in the window will update
to reflect the selection.

Creating a Resource Set
There may be an occasion in which a new Resource Set needs to be created. A Resource Set for each printer
type supported should be maintained. A basic Resource Set (PRO-FORM) that defines standard printer
defaults based on the information gathered during installation is created during setup. All other Resource
Sets need to be created if necessary.

� To create a new resource set

1. Close any open forms.

2. Click the Create Resource Set button from the Standard toolbar.

3. Enter the name of the new Resource Set into the Resource Set field. All existing Resource Sets are listed
in the drop-down so that you can avoid duplicating Resource Set names. You may also choose to use
the name that is generated for you and displayed in the Resource Set field.
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Supported Printers
Printer types supported within Proform Designer include Xerox Metacode (Monochrome and HighLight
Color), Hewlett Packard PCL (Monochrome, HighLight Color and Color), Xerox XES (Monochrome and
Color), PostScript (Monochrome, HighLight Color and Color) and IBM AFP.

� To choose destination printer

1. Close all forms.

2. Select Edit and then choose Resource Set.

3. From the General tab of the Edit Resource Set menu, choose a printer type from the Type drop-down menu.
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Selecting a specific default printer model aids in defining limits as to what you are allowed to do in
Designer..

Choose Printer Driver for Font Support (Default Printer Button)
Windows defines PostScript printer fonts by the active PostScript printer driver. Although the Designer
products use Lytrod Software developed output drivers, the defined Windows PostScript printer driver is
used for the Proof Print function as well as for determining available PostScript printer fonts.

To ensure that the correct print driver has been selected, it is recommended that users go to the Resource
Set and select a PostScript printer when updating the software to a newer release. The printer information
will then be stored in the Resource Set and the available PostScript printer fonts will be gathered.

Installing PostScript Print Driver in Windows

Installing print drivers into the Windows environment is the first step to adding a printer into any software
product. Print drivers can be obtained from disks provided upon purchase of the printer or from printer
manufacturers website. You can download Xerox print drivers from www.xerox.com.

Forms Language
Resource Sets identify which type of forms language you will be creating. This information affects the
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Proform Designer source file as opposed to the actual print file. However, you should choose the language
appropriate for your printer. Xerox FDL should be chosen for all printers other than AFP printers.

� To choose forms language

1. Close all forms.

2. Select Resource Set from the Edit menu.

3. Check the Xerox FDL or IBM OGL radio button as appropriate.

Xerox Options
The Xerox Options section of the Resource Set window defines the options available on a Xerox printer.
The options are as follows:

� Tape Label – This options should be selected if the Resource Set is being defined for a Xerox
Metacode printer that requires a tape label record header at the start of each form, font or image
file (FRM, FNT, LGO and IMG files). These headers are used to identify the files. If None is
selected, no tape label will be created. The Standard option creates a tape label that is the usual 128
byte record as designed by Xerox to proceed Metacode resources. An Extended tape label is a
Standard tape label padded with zeroes to 512 bytes. Extended tape labels are used to ease storage
of files on systems that do record blocking (mainframe computers).

� Xerox Office Printers – Special settings are available for using VI Compose on Xerox N-Series, Phaser,
and DocuCentre printers. When the Xerox Office Printers check box is enabled, it becomes
possible to print VI Compose applications to a local, networked office printer.

� VI Compose – If the Resource Set is being defined for a VI Compose enabled Xerox PostScript
printer, then choose the version of VI Compose installed on the printer. This will enable all of
Proform Designer’s data mapping capabilities for that particular version of VI Compose. Select
from Disabled, Version 2.1, Version 2001, Version 4.0, Version 5.0 or FreeFlow 4, through
FreeFlow 10.

� Low Precision Calculations – When performing calculations, Designer can either use the VI Compose
method or the PostScript method. The VI Compose method is less precise than the PostScript
method. If you do not require a high amount of precision (VI Compose will produce out to 9
decimal places) enable the Low Precision Calculations check box.
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� Static Font List – This check box will be available when working in a metacode environment.
Enabling this check box will prevent Designer from modifying and reloading the font list before
every page is printed. By using the same font list for each page, printing speeds are optimized.

Short Edge Feed – This check box is available when working in a metacode environment. Enabling this check
box allows Designer to correctly rotate the images being used on the form when the paper is being fed into
the printer using the Short Edge Feed direction.

Xerox Specialty Imaging – Five Specialty Imaging capabilities are possible: MicroText, GlossMark Text,
Correlation Text, Fluorescent Effect and InfraRed Effect. You may tailor the availability of these within
Designer by checking one or more of the checkboxes to allow Specialty Imaging to be designed into your
applications. By checking MicroText, GlossMark Text or Correlation, Designer will ask for the fonts
associated with this Specialty Imaging effect.

Printer Capabilities
Resource Sets contain information regarding the type of printer being supported with each Resource Set. In
regards to printer type, the user will choose a type as opposed to a specific printer model. Additional printer
information is also defined to specify unique capabilities of the various printer models.

Non standard printer capabilities can be defined in the Printer Capabilities section of the Edit Resource Set window.
The following printer capabilities can be defined:

� Graphic Capability – This option defines the availability of graphics hardware on Xerox Metacode
(LPS) printers. Xerox 3700 and 4235 printers have the necessary hardware to handle graphics.

� Edge-to-Edge – This option defines whether or not the printer can print to the edge of the paper.

� Paper Support – This option defines the maximum paper size the printer supports.

� Resolution – This option defines the resolution the printer supports. NOTE: Some Xerox printers
are limited to 300dpi.

� To define printer information in a Resource Set

1. Close all forms.

2. Select Resource Set from the Edit menu.

3. From the General tab of the Edit Resource Set menu, specify the appropriate printer information for the
current Resource Set as follows:

� Check the Graphic Capability box if applicable.
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� Check the Edge-to-Edge box if applicable.

� Choose maximum Paper Size supported from the Paper Support drop-down menu.

� Choose printer resolution from the Resolution drop-down menu.

� For PCL Printers, the Symbol Set default can be defined. Symbol Sets define character mapping
for the fonts.
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AFP/OGL Printer Specifications
There are several printer options specific to AFP printers. If you have selected AFP as the printer type, the
following options will be available:

� IBM O/S - Defines mainframe operating system. This is important when creating fonts and page
segments for AFP printers. The choices are VM, VSE, MVS and AS/400.

� Default Code Page - Sets a default code-page. The code-page is used when creating fonts for AFP
printers and serves as a guideline as to which characters to include in the font and in what
positions.

� Landscape Default Orientation - Sets Landscape as 0� orientation. (i.e. IBM 3800 printer)

� Maximum Record Size - Mainframe operating systems usually have a maximum size for a variable
length record. To prevent a font or page-segment from exceeding this limit, specify the maximum
record size in kilo bytes.

� Unbounded Font - Specifies that AFP fonts will be produced in a Unbounded box format.

� CR/LF Separation - Places a carriage-return line-feed combination at the end of each structured field
record, easing the transfer of the AFP files to the mainframe by allowing each record to be placed
in a variable length record.

� To set AFP printer specifications

1. Close all forms.

2. Select Resource Set from the Edit menu.

3. From the General tab, specify AFP specifications as follows:

� Choose the Operating System from the IBM/OS drop-down menu.

� Choose the Default Code Page from corresponding drop-down menu.

� Define the maximum structured field record size.

� Check the Landscape Default Orientation box to set landscape as 0� orientation.

� Check the Unbounded Font box to create AFP fonts in unbounded box format.

� Check the CR/LF Separation box to place carriage-return line-feed combination after each structured
field record in font files.
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HighLight Color Specifications
If you have selected the HighLight Color printer type, a default ink catalog, palette, and ink must be
identified for the Resource Set.

� To set color options

1. Close all forms.

2. Select Resource Set from the Edit menu.

3. From the General tab, select Ink Catalog, Palette and Ink from the corresponding drop-down menus.

Other than by importing resources directly onto a form, Resource Set information can only be modified
when no forms are active in Proform Designer.
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Working with Fonts
Designer provides automatic access to any fonts expected to be standard on your printer. These fonts
should already be displayed in your Font List. Designer also allows access to all of the TrueType fonts
available on your system. Any additional fonts that you wish to use can be added to your Font List by
importing them into your form or into the Resource Set.

Supported Font Formats

Metacode Fonts Font format supported by Xerox Metacode printers, (LPS printer) - .FNT.

Xerox XES ASCII Dynamic Fonts Decentralized printer fonts that are typically used by minicomputers and microcomputers that
are connected to the decentralized printer through either a parallel printer interface or sync
serial interface.

Xerox XES EBCDIC Dynamic Fonts Fonts that are used by mainframe computers communicating to the decentralized printer
through a synchronous serial data communications protocol such as the IBM 3770 SNA or
3780 bisync.

Xerox DSBU Fonts Format (DSBU) supported by Xerox 3700, 4235, 4700, and 4045CP (with Signage cartridge)
printers to bypass cell size, total font size and orientation limitations of the XES font.

AFP Bounded/Unbounded Fonts IBM AFP fonts consisting of three different files, coded font file, character set and code page
using the EBCDIC character set.

PCL Fonts Font format supported by PCL printers including Hewlett Packard and Xerox. PCL 5 supported on
late model, PCL 4 on many previous printers.

PostScript Type 1 and Type 3 Fonts Supported by all PostScript printers

Various techniques are used by laser printers to place toner onto a page. For example, text using the same
bitmap font may print significantly darker on a HP LaserJet than on a Xerox printer. Proform Designer
does not make any automatic adjustments to a font for this printing difference. Manual adjustments can be
made in the Bitmap Editor available in Lytrod Software’s font tool, BitCopy, if necessary.
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Adding Bitmap Fonts to the Resource Set

Once a Resource Set has been created, bitmap fonts can be added. Existing bitmap fonts must be added to
the Resource Set for use within Proform Designer. Importing fonts directly into the resource set is a
convenient way of adding multiple fonts to the resource set in a single pass.
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� To add bitmap fonts to the Resource Set

1. Close all forms.

2. Select Resource Set from the Edit menu.

3. From the Fonts tab, click Import.

4. An open menu will appear allowing file selection. Click the Files of type drop-down to select the file
type.

5. Select the font or fonts to be imported and click Open. Multiple fonts may be selected by holding
down the <SHIFT> or <CTRL> keys.

6. The Available Fonts list will now reflect the imported font(s).

This method is only available if no forms are active within Designer.

Importing Bitmap Fonts

It is also possible to import fonts, one at a time, when the form is open in Designer. An imported font will
automatically be added to the Resource Set. The imported font will also be set as the current font in the
font list.

Before any bitmap fonts can be added to the resource set, however, they must be present in the Windows
Fonts directory. To place a font in this directory, access the Start menu and select Control Panel. Open the
Fonts folder, go to the File menu and choose Install New Font.

� To import fonts while a form is active

1. Select Import from the File menu.

2. Select Font from the Import menu.

3. An open menu will appear allowing file selection. Select a file type from the Type drop-down menu.

4. Select the file to be imported and click Open.

5. A menu will appear allowing the user to define font family. Select font family from the family
drop-down list or type family name in the edit box. The purpose of font families is discussed later in
this chapter.

6. The Font drop-down list will now reflect the newly imported font as the current font.
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Importing Scalable Fonts

PostScript scalable fonts can be imported into Designer. Importing scalable fonts will update Designer's
PostScript table, as well as download the fonts to PostScript printers. These fonts can then be output to the
VI Compose resource directories when creating VI Compose jobs. Once the fonts are imported into
Designer, they will be displayed with a PS icon in all Designer font drop-down menus. Importing scalable
fonts is a useful way of diminishing bitmap font resources and creating the most efficient VI Compose
Jobs.

Only the .pfb font should be imported into the resource set.

Before any scalable fonts can be added to the resource set, however, the .pfm must be present in the
Windows Fonts directory. To place a .pfm font in this directory, access the Start menu and select
Control Panel. Open the Fonts folder, go to the File menu and select Install New Font.

� To Import PostScript Scalable Fonts

1. Select Resource Set from the Edit menu.

2. Select the Fonts tab from the Edit
Resource Set window.

3. Click Import.

4. The Import Bitmap Font window will
appear. Select PostScript font (*.fnp, *.pfa,
*.pfb) from the Files of type drop down.

5. Select a .pfb PostScript Scalable font.
Click Open.

6. The Import PostScript Font window will appear. The Internal Name and Style fields will automatically be
populated.

7. Choose the Display Font. This will define how the Font is displayed on-screen.

8. Define the encoding vector to be used for the font. The encoding vector defines the characters that
are available to the font. ISO Latin 1 Encoding and Standard Encoding are available for every font.
Other vectors may be available as well.

9. Click the ellipses next to the Kerning Table field to browse for the appropriate .afm table. This table will
provide kerning information to the VI Compose enabled printer.

10. Click OK.
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Edit the PostScript Table

It is possible to edit Designer's PostScript table from within the Fonts tab of the Edit Resource Set menu.

� To edit the postscript table

1. Click the Edit Map Tables button from within the Fonts tab of the Edit Resource Set menu.

2. The Edit Printer Font Mapping Table window will appear.

3. Make necessary font additions or deletions.

4. Click OK.

Font Location

Each Resource Set has an associated default location for fonts. Designer uses this location as the output
directory. Any font files created when a form is saved are stored in this location.

� To set font location

1. Close all forms.

2. Select Resource Set from the Edit menu.

3. From the Locations tab, specify a font location in the Font edit box or click to browse in order to locate
the desired location.
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Font files are always stored in Designer's default font directory, as specified in the Locations tab of the Edit
Resource Set window. Existing fonts can be imported into this directory from anywhere on the system.
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Font Specifications

The Resource Set contains point size and style information about each font. This important information is
used when listing available fonts. Designer cannot always determine style characteristics when the font is
imported, so it is also possible to define those characteristics manually.

� To define font specifications

1. Close all forms.

2. Select Resource Set from the Edit menu.

3. From the Fonts list, select the font you wish to define.

4. Check appropriate attributes as follows: Bold and/or Italic

Xerox Metacode and XES fonts do not contain style (bold or italic) and point size information. To use
these fonts in the most efficient manner requires setting the information manually.
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Font Family

Assigning a family name allows similar imported fonts to be grouped in a font family. The family name is
then displayed in the Type drop-down menu instead of each individual font minimizing the size of the font
list. When a family name is selected only the available point sizes are displayed in the Point Size menu.

� To define a font family

1. Close all forms.

2. Select Resource Set from the Edit menu.

3. From the Fonts list, select the font(s) you wish to define.

4. Select an existing family name from the Family drop-down list or define a new one by typing it into the
Family edit box.
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Internal Printer Fonts

Fonts that reside on your destination printer do not need to be downloaded every time they are used in a
form. In order for Designer to know they are printer resident, an Internal flag must be set in the resource
set.

� To set a font(s) as internal

1. Close all forms.

2. Select the Resource Set from the Edit menu.

3. From the Fonts list, select the font(s) you wish to define as Internal.

4. Check the Internal check box.
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Removing Fonts

Fonts can be removed from a Resource Set if necessary. Removing fonts from a resource set simply
removes the reference to that font in the resource set. It does not delete the actual font file.

� To remove a font(s)

1. Close all forms.

2. Select Resource Set from the Edit menu.

3. From the Fonts tab, select the font(s) to be removed.

4. Click the Remove button.

Converting Fonts

The Convert Font function allows for the manual conversion of Windows TrueType, PostScript or bitmap
fonts to bitmap fonts or logos. This is useful when the need arises to have a font used outside of the form.
(e.g. for data if not using VI Compose).

� To Convert Fonts

1. Close all existing forms.

2. Go to File menu and select Convert.

3. Select Fonts…

4. Select the Font type, Style, Size and Orientation.

5. Select the File of Type in the drop-down menu.

6. Click the Convert button. One bitmap font will be converted with the font type, style, size and orientation
settings selected.

7. Click the Close button when finished with all font conversions.
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Determining PostScript Printer Based Font Selection
Windows defines PostScript printer fonts by the active PostScript print driver. Although the Designer
products use Lytrod Software developed output drivers, the defined Windows PostScript print drivers are
used for the Proof Print function as well as for determining available PostScript printer fonts.

Installing Windows Print Drivers

Installing print drivers into the Windows environment is the first step to adding a printer into any software
product. Print drivers can be obtained from disks provided upon purchase of the printer or from the
printer manufacturers website. You can download Xerox print drivers from www.xerox.com

� To install windows printer drivers

1. From the Windows Start button, select Settings and then choose Control Panel.

2. Double-click on the printer icon.

3. Double-click on the add printer icon.

4. Follow the Wizard directions to complete the driver installation.

Determining Printer Fonts in Designer
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Installing the PostScript print drivers into your Windows environment will enable the specific printer font
information provided by the drivers to be accessible to Designer. The PostScript drivers will then need to
be defined within the Resource Set.
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� To access the PostScript print driver in Designer (enabling PostScript printer based type 1 font
selection)

1. Close all forms.

2. Select Resource Set from the Edit menu.

3. From the General tab of the Edit Resource Set menu, select the Default Printer button.

4. Select the installed PostScript printer from the drop-down menu in the Print Setup window.

Selecting the PostScript print driver allows access to standard printer fonts in the design process. It is much
more efficient to select printer fonts. If TrueType fonts are selected, then bitmapped fonts (.pfa for VI
Compose) are created on output.
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Installing Additional PostScript Printer Fonts
After installing the PostScript print driver, a list of available printer fonts will be represented by a printer or
PS icon in the font list. Additional printer fonts (which will also be represented by a printer icon in the font
list) can be installed by using products such as Adobe Type Manager.

When printing in a PostScript environment, it is highly recommended to use PostScript printer fonts,
instead of TrueType fonts. When using Windows TrueType fonts in a form, the fonts are converted to
bitmapped fonts (.PFA files) during output to the printer. For this reason, Lytrod Software offers various
utilities which allow for the conversion of TrueType fonts into PostScript Type 1 fonts. (For more information,
please contact Lytrod Software) Using PostScript printer fonts ensures the cleanest and crispest printout of
fonts on a PostScript printer.

Once a PostScript Type 1 file is created, the font file will need to be installed into the Windows operating
system and downloaded to the printer. Adobe Type Manager offers the ability to install PostScript printer
fonts into Windows. A light version is available at no cost from the Adobe website. Windows 2000 and XP
have this capability built into the operating systems. Once the font is installed in Windows, Designer will be
able to utilize the new font as a printer font.

� To Install Fonts into windows using Adobe Type Manager

1. Within Adobe Type Manager, select the Add Fonts tab.

2. Select Source Font from the drop-down menu.

3. Select the desired font and then click the Add button. The font is now in the destination folder.

4. Download the font to the printer.

Installing and Converting TrueType Fonts
TrueType fonts are commonly available through the Windows operating system and are installed through
the Windows font utility. Although TrueType fonts are convenient, they are converted upon output from
Designer into bitmapped fonts, which are inefficient and do not offer the high quality print of scalable
fonts. It is recommended that either the use of TrueType fonts in Designer is restricted or that they are
converted to printer fonts.

� To restrict TrueType fonts

1. Open Designer.

2. Access the Edit menu and select Preferences.

3. Select the System tab and check the Restrict TrueType fonts check box.

4. Click the OK button to accept the default settings.

Installing TrueType fonts into Windows
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TrueType font files obtained from other sources than the operating system must be installed into the
operating system before it is recognized in the Proform Designer software.

� To install TrueType fonts in windows

1. From the Windows Start button, select Settings and then choose Control Panel.

2. Double-click on the Fonts directory icon.

3. In the File menu select Install New Font.

4. Select the appropriate drive and directory in which the font files are located.

5. Select the font file.

6. Click the OK button to accept.

48 Resource Sets



Working with Images

Supported Image Formats

Designer allows the import of most standard image formats.

Standard Image Formats

(.pcx) Zsoft PC Paintbrush

(.tif) Tagged Image File Format

(.bmp) Windows Bitmap

(.jpg) JPEG File Interchange Format

(.psd) Adobe Photoshop

(.png) Portable Network Graphics

(.tga) TARGA

(.gif) Graphics Interchange Format

(.wmf) Windows Metafile

(.pdf) Portable Document Format

TIFF, IOCA, FAX compressed or uncompressed using CCITT, with different groups and dimensions

It is also possible to import standard print-format graphics.

Print-Format Image Formats

(.psg) IBM Page Segment Monochrome

(.img) 9700 Graphic Image Xerox Format Monochrome, Xerox Raster Encoded Format 2.1, Two Plane HighLight Color raster image

(.pcl) HP PCL 4/5 Raster Graphic Monochrome, Hewlett Packard PCL Imaging Color Mode, 256 Color

(.eps) Encapsulated PostScript image file Monochrome, 256 Color (created in Lytrod Software’s ImageCopy)

(.xes) Xerox XES Graphics Window Monochrome, Four Plane CYMK Full Color

Print-Format Logo Formats

(.lgo) 9700 Logo Format Monochrome, Two Plane HighLight Color

(.lgh) HP PCL 4/5 Logo Monochrome

(.lgp) Encapsulated PostScript Logo Monochrome

(.lgx) Xerox SEX Logo Monochrome
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Any imported graphic will be converted to the proper print format when a form is saved. These image files
will be located in the Resource Set’s default image location.

Multi-Page PDF Images

PDF files that are multiple pages can be imaged and imported into Designer. Once imported, the pages can
be scrolled through and the desired page can be placed on the form. The image will be placed on the form
with the same dimensions as the original PDF page, but it can be resized and rotated once on the form.

� To Choose a page of a multi-page PDF

1. Click the Import Image button on the Drawing toolbar, or select Import and choose Image from the File
menu.

2. Choose a PDF file with two or more pages. Import the file.

3. Click on the form to place the PDF image.

4. Right click and choose Change Page from the context menu.

5. An Extract Image from Multiple Pages window will appear. The window will show the name of the PDF file
and the current page. The Previous Image and the Next Image buttons can be used to move backward and
forward through the pages of the PDF.

6. After choosing the desired page, click Close to close the window. The page selected will be imaged.
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Adding Images

Once a Resource Set is established, images can be added. Images must be added to the Resource Set for use
within Designer. Adding images through this method is a convenient way of adding multiple images to the
resource set in a single pass.

1. Close all forms.

2. Select the Resource Set from the Edit menu.

3. From the Images tab, click the Import button.

4. An open menu will appear allowing file selection. Click on the File of type drop-down menu to choose the
file type.

5. Select image to be imported and click Open. Multiple images may be selected by holding down the
<SHIFT> or <CTRL> keys.

6. The Image List will now reflect the imported image(s).
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Importing Images

Importing of images is the method of choice while a form is active in Designer. It is convenient while
designing a form and coming across an image that requires importing. An imported image will be added to
the Resource Set automatically. The imported image will also be placed onto the current form and displayed
in the Image List drop-down on the toolbar.

� To import images while a form is active

1. Click on the Import Image button from the Drawing toolbar, or go to the File menu and choose Import and
then Image…

2. An open menu will appear allowing file selection. Click on the Files of type drop-down menu to set file
type.

3. Select the file to be imported and then click the Open button.

4. Click on the location in the form where the image should be placed.

Image Location

Each Resource Set has an associated default location for images. This is where Designer will automatically
look for images.
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� To set the image location

1. Close all forms.

2. Select Resource Set from the Edit menu.

3. From the Locations tab, specify an image location in the Images edit box or click to browse in order to locate the
desired location.

While new image files are always stored in the default directory, existing images can be imported from anywhere. The
location of the original image is displayed in the Images tab of the Resource Set menu. If an image file is no longer
found in this location when a form is opened, the Missing Resources menu will appear. The image can then be
imported from its new location.

Internal Printer Images

Images that reside on your destination printer do not need to be downloaded every time they are used in a form. In
order for Designer to know they are printer resident, the Internal flag must be set in the Resource Set.

� To set an image(s) as internal

1. Close all forms.

2. Select Resource Set from the Edit menu.

3. From the Images list, select the image(s) you wish to define as Internal.

4. Check the Internal check box.

Removing Images

Images can be removed from a resource set if necessary. Removing images from a resource set simply removes the
reference to that image in the Resource Set. It does not delete the actual image file.

1. Close all forms.

2. Select Resource Set from the Edit menu.

3. From the Images tab, select image(s) to be removed.

4. Click the Remove button.

Resource Sets 53

�



Working with Logos
A logo is essentially an image that is stored in a font format. The image is broken into tiles, one tile per
character cell. These tiles are used to rebuild the image when the logo is displayed or printed. Most printers
restrict the dimensions of a logo and require that they are only one color. For this reason, the logo format is
most appropriate for small, simple images, such as company logos. There are several benefits to the logo
format when an image fits this criterion.

Logos can be used several times in a form without having to repeat the actual image information, therefore
reducing the file size of the form. It is also possible to call logos from the variable data stream. Another
advantage is the ability to colorize a logo within a form. When designing forms for full-color printers, all
colors in the image are converted to the selected color producing a one-color logo. Xerox HighLight Color
logos support one-color or two-color logos. Two-color logos consist of the HighLight color and black.

Once imported into Designer, logo files are handled just as any other image, and include the ability to resize
and scale. There are several output options based on image size, printer capabilities and the Resource Set
default settings. Images within the logo size limits can be saved as a logo or an image. This is determined by
the Logo specification in the Resource Set. Any image exceeding the dimension limits will be saved in an
image format.

Some Xerox printers require additional hardware in order to print images. If the selected printer does
support the IMG format, images within the logo limitations can be created as an LGO or IMG as
mentioned previously.
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� To convert an image to a logo

1. Close all forms.

2. Select Resource Set from the Edit menu.

3. From the Images tab of the Resource Set menu, select the desired image.

4. Select Logo from the Convert To drop-down menu. This will convert the selected image to a logo format.

5. Click on the Yes button at the Convert Image window

6. Define Logo Parameters: Choose Orientation, Color Planes, enable the Highlight Color check box, and set Highlight Color
parameters as applicable.

Highlight Color Image and Logo parameter options are expanded on in Chapter 6: Working with Images.
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Converting Images

The Convert Image function allows for the creation of specialized bitmapped images without the limitations of
the resource set. Bitmapped images can be created independent of the form for use in other applications.

� To Convert Images

1. Close all existing forms.

2. From the File menu select Convert.

3. Select Images.

4. From the Image drop-down menu, select the image file to convert.

Only image files already imported into your Resource Set will be listed in the Image drop-down. The
Import… button will allow you to import additional images while still in the Convert Images window.

5. Select the type of file the image will be converted to in the File of Type drop-down menu.

6. Click on the Convert button, and then click the Yes button when the conversion is complete.

7. Click the Close button when finished.
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Working with Data Files
Data files that can be processed by VI Compose can be imported into Designer as defined below. The types
of data that can be imported are database (delimited), line data (print ready ASCII files) and XML. In the
Resource Set you can define the default data directory as well as the directory where you would like your VI
Compose files to reside.

Supported Data Formats

Delimited Data typically generated from a database where each line represents a record with field information in each
record delimited with a common character such as a comma. If the delimiter is used within a data field, then
single or double quotes must surround the data field to act as a text qualifier. The first record must define the
field names delimited. Non-printable characters are restricted from existing in field names.

Line data Line data is data that is a flat ASCII file in a “print ready” format. This type of data is typically generated
from a mainframe computer for printing on line printers. The record is now defined as the data relating to
one source. For example, a phone bill. Each record may contain several pages of data which varies based on
the customer call usage. It now is critical to define the record break as well as the maximum number of lines
that can be printed on each page.

XML Data XML is a grammatical system for constructing custom mark-up languages, where the data is organized into a
tree structure. Designer will treat XML data fields in the same manner as delimited data fields. After the
data file is imported, all of the data fields will be listed in the data drop-down menu.

Line Data Record Breaks

Fixed length Fixed length records have the same number of lines in each record.

PCC PCC (print carriage control) is examined in the first byte of each line. ASCII PCC bytes are supported.

ASCII Character A single character can be defined as the record break. For example a Form Feed.

Text String In records that have varying length, a common text string can break the record before or including the line
which contains the text.
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Data & VI Compose File Location

Each Resource Set has a default location for VI Compose files. VI Compose Local files are stored within the
C:\xgfc directory in appropriate sub-directories (i.e. fontlib, imglib, mislib, jdtlib, formlib). The VI Compose
Printer location gives the option to map the VI Compose files to the \xgfc directory on a VI Compose
enabled network printer. When saving Jobs, the VI Compose files will be saved to the location specified in
the Resource Set. Thus, if three VI Compose printers are defined, the VI Compose Job will be saved to all
three printers; the same is true for Office Printers. However, since VI Compose Jobs are saved in a different
manner depending upon if they are being saved to VI Compose or an office printer, a job cannot be saved
to both a VI Compose and Office printer at the same time.

The VI Compose enabled network printers must be recognized as workstations on a Windows network.
Network connectivity software may be required.
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Archive Resources
Designer can archive the critical user files
(forms, fonts, images, data and resource sets)
into a single file for easy backup/archiving
purposes. Any resource set that is archived
can also be un-archived with the simple click
of a button.

� To archive resources

1. Access the Archive tab of the Edit Resource
Set menu.

2. Select the resource set that you want to
archive from the Resource Set drop-down
menu.

3. By default, the archived resources will
be placed in C:\Program
Files\Proform Designer\ARCHIVE.

Click the ellipses (...) button to designate a
different location for the resources to
be stored.

4. A default file name will be entered into the Archive File Name field. To change the default name to a
custom name, delete the default name and enter the desired name into the field.

5. Create a password if desired. The password will be required whenever the archive is opened.

6. Define which resources will be included in the archive. Enable or disable the check boxes to choose
from Resource Sets, Form, Font, Image, and Data.

7. Click the Archive button to archive the resources.

To un-archive resources, specify the information in the same manner as described above, and click the
Unarchive button.
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View Form Resources
When transferring forms to the printer, it may be necessary to identify resources associated with the form
to be transferred. This tool will list all fonts, logos, images and data that are used within the form, so that
they can be transferred to the printer. This is especially important when printing on Xerox LPS printers as
all resources must be located on the printer. It may also be important when transferring PCL/PS and Xerox
XES forms in which the resources have not been included in the form file.

� To View Form Resources

1. With your form open, select View and then choose Form Resources.

2. The View Resources menu will appear listing fonts, logos and images used in the current form.

3. To print the View Resources menu, click Print. To close the menu, click Close.

For more information on including resources in PCL/PS and Xerox XES form files, see page 80.
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Chapter 3

Opening, Creating and Saving Forms

There are several different file types Proform Designer supports on input. Full support of Xerox
source and object form files along with IBM form source is provided. File formats supported are:
Proform Designer Source (.FSL), Xerox FDL Source (.FSL), Xerox Metacode Form (.FRM),

Xerox EPS Printer Source (.FSL), Red-Titan (Mode R and Mode X) Sources (.FSL), DeskTop Designer
(.DTD),Office Designer (.DTD), IBM OGL Version 2.0 (.OSL) and Designer Jobs (.PFJ). The default file
type will be determined from information in the current Resource Set.

Newly created forms will be created in a format compatible with the printer information provided in the
Resource Set. This printer specification is also used to determine the available functions allowed when the
form is being created.

Opening Forms
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� To open a form using the Welcome Menu

1. Select the desired Resource Set from the bottom list on the Welcome Menu, this will display the .pfj's
associated with the resource set in the Design File list.

To display single page .fsl/.dtd files, click on the Show form files check box.

2. Double click on the form, or select it and click the Open button.

� To open a form

1. Click Open Form from the Standard toolbar or select Open from the File menu.

2. In the Look in box, click the drive or folder location that contains the form.

3. Browse to the folder containing the form that you wish to open.

4. Double-click the form, or select it and click Open.

To open a recently used document, click the appropriate file name from the history list at the bottom of the
File drop-down menu.

� To show/hide recent file list

1. Select Preferences from the Edit menu.

2. From the System Preference tab, use arrow keys in the Recent File List field to specify number of recently
used files (if any) to be displayed in the File menu.
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� To open a Xerox LCDS form object file (.FRM)

1. Click Open Form from the Standard toolbar or select Open from the File menu.

2. In the Look in box, click the drive or folder location that contains the form.

3. Browse to the folder containing the form to be opened.

4. Double-click the form, or select it and click Open.

5. The FRM Resources menu will appear as follows:

� The FRM Resources menu will assume the form setup traits based on the information contained in
the file. These traits include paper size, orientation, grid setting, etc. The user can modify this
information as necessary and should not rely upon the assumptions made. Always verify the
information before the form is opened.

� The Resources tab of the FRM Resource menu will list the resources used in the form. The orientation
of the fonts is used to assume the orientation of the form. If this information is not available, the
orientation setting for the form may be inaccurate.
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The ability to open .FRM files is provided mainly as a method to salvage forms when the .FSL is no longer
available. In most cases, it is best to edit from the .FSL file if at all possible.

The actual grid format cannot be determined from the .FRM file. Portrait forms will default to FMT6 and
landscape forms to FMT1. The grid settings can be changed from this menu or from the Form Layout
menu after the form has been opened.
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� To open a backup file

1. Locate Backup File, stored in Designer's Forms folder.

2. Rename the file to have the appropriate form source extension (.FSL or .OSL) as appropriate.

3. Click Open Form from the Standard toolbar or select Open from the File menu.

4. In the Look in box, click the drive or folder location that contains the form.

5. In the folder list, browse to the folder containing the form to be opened.

6. Double-click the form you want to open.

The backup file will have the same name as the form with a .BAK extension. It will also be located in the
same folder as the form.

Multiple Document Interface
Designer uses a Multiple Document Interface (MDI). This allows multiple forms to be active/open within
Designer at the same time.

� To switch between forms

1. Select the Window menu.

2. Select the desired form from the list at the bottom of the Window menu.

3. If multiple forms are already open, the user can minimize and maximize forms to switch between
them.

Missing Resources
Upon opening forms in Designer, a check will be made to verify that all of the resources (fonts, logos and
images) are located in the folders defined in the active Resource set. A menu will appear allowing users to
correct any missing resource issues.

Missing resources can be handled in one of five ways:

1. Locate the resource file and import it into the Resource Set.

2. Select a resource to substitute for the missing resource permanently.

3. Modify the current form to use a new resource.

4. Make a temporary substitution in order to simply view the form.

5. Images/Data can be removed from the form to allow the form to be displayed.
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In most cases it is best to import the resource that is missing. Any resource that is substituted will probably
not be identical to the original. Therefore, some redesigning of the form may be required, resizing or
repositioning text blocks, re-wrapping text, etc.

If the original resource is no longer available, a permanent substitution may be made. This is done by
importing a similar resource or by choosing a font from the Substitute font list. The Substitute font list
contains all of the fonts in the current Resource Set along with the list of available TrueType fonts. A
permanent substitution affects all forms that may contain the missing resource. Once the substitution is
made any readjustments needed to account for the substitution can be made to the form.

There is also the option to modify only the current form. This is done by choosing a substitute resource
and disabling the Permanent check box. The resource reference in the current form will be permanently
changed to reflect the substitution, but this in no way affects other forms opened in the future. This
method also allows a temporary substitution to be made for the purpose of viewing a form, because the
form is not actually modified until it is saved. This means, however, that no changes can be made to the
form unless the substitution is to be permanent.
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� To import a missing resource

1. Select the font, image or data name to be assigned.

2. Click ellipsis button (...) adjacent to the Import file field.

3. A Select File window will appear.

4. In the Look in box, click the drive or folder location that contains the resource.

5. In the folder list, double click folders until you open the folder containing the missing resource.

6. Double click the resource you want to import, or highlight it and click Open.

� To substitute missing resources

1. Select the font or image name to be substituted.

2. Select a substitute resource from Substitute drop-down menu.

3. When a scalable font is selected, an Assign Font window will appear.

4. Select Font, Style, Point Size and Orientation from corresponding list boxes in the Assign Font window.

Temporary font substitution will only affect the form being opened.

� To make a permanent resource substitution

1. Check the Permanent check box to indicate permanent substitution.

2. Select font/image name to be used as the substitution.

3. Select a substitute resource from the Substitute drop-down menu.

4. When a scalable font is selected, an Assign Font window will appear.

5. Select Font, Style, Point Size and Orientation from corresponding list boxes in the Assign Font window.

Permanent font substitution will make a reference of the substitution for all forms which reference the
missing resource.
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Creating New Forms
When creating a new form, the user will be prompted to setup the form in the Form Layout window. The form
setup information defines the basis of the form layout. Initial setup is accomplished in the Form Layout
window defining many form basics such as name, measurement, sizes and orientation.

There are three ways to create a new form, listed below:

� To create a new form

� Click on the Blank Document button within the Welcome menu.

� Click New on the Standard toolbar

� From the File menu, select New.

The Form Layout window will appear, prompting form setup.

Form Layout
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Form Name
Form Name refers to an internal name. This name is used to reference the form on most printers. It is
recommended that this form name match the eventual file name given to the form. It is important to be
aware that the number of characters of the internal name is limited on some printers. For example, internal
names can only be six characters on Xerox LPS printers, and eight characters on AFP printers.

� To specify a form name

1. Open the Form Setup tab from the Form Layout properties window.

2. Indicate the Form Name in the edit box provided.

Form Title
Form title provides the ability to provide comment information regarding the form. It can be used to
indicate form title, clarify form usage, track revisions, etc.

� To specify a form title

1. Open the Form Setup tab from the Form Layout properties window.

2. Indicate a Title in the edit box provided.

Form Resolution
Two form resolutions are available: 240dpi, 300dpi, dependent on Resource Set definitions. 240 resolution
will be available only if the form is OGL, otherwise the form will be 300 dpi.

� To specify form resolution

1. Open the Form Setup tab from the Form Layout properties window.

2. Select the desired resolution from the Form Resolution drop-down.

Color
Permits a color form to be globally changed to a monochrome or HighLight Color form.

Secure Password
Defines the global password for the secure plane. Once defined, one or more elements on the page can be
switched to the secure plane.
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Paper Size
This selection defines the size of the physical paper. Designer supports various predefined paper sizes, and
paper size support is dependent on the output printer specified in the active Resource Set. Custom paper
sizes are also available by defining the Width and Height in the appropriate fields.

Supported Paper Sizes:

8.5 x 11" (letter) 14 x 17" 14.33 x 26.0 "
8.65 x 11.67" 17 x 17" A3 (297 mm x 420 mm)
8.5 x 13.7 12 x 18" A4 (210mm x 297mm)
8.5 x 14" (legal) 12.6 x 19.2" B4 (257mm x 364mm)
11 x 17" 14.33 x 20.5" B5 (182mm x 257mm)
14.33 x 22.5" SRA4 (225mm x 320mm)

� To specify paper size

1. Open the Paper Size tab from the Form Layout window.

2. Select paper size from the Paper Size drop-down list.

� To specify default paper size

1. Select Preferences from the Edit menu.

2. Select the paper size from the Paper Size drop-down list.
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Form Orientation
Form orientation determines which way the page faces. Form orientation is either portrait (shortest edge of
the page at the top), or landscape (longest edge of the page on top), or inverse of portrait or landscape.

� To specify form orientation

1. Open the Paper Size tab from the Form Layout properties window.

2. Select orientation.

� To specify default form orientation

1. Select Preferences from the Edit menu.

2. Select orientation.

When designing forms for printers in an AFP environment, the OGL forms language defines page
orientation based on the degree of rotation: 0°, 90°, 180°, or 270°. The actual orientation is based on the
paper size and printer model. For an IBM 3800 printer, a 0° rotation is assumed by Designer to be
landscape. For all other IBM printer models, a 0° rotation is assumed to be portrait.
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Grid Settings
The position of each element on a form
is determined by a particular unit of
measure. The default unit of measure is
a grid. The grid is a user-defined
measurement in the X and Y direction
as well as an origin from which all
measurements are distanced. This is
convenient when designing a form
around variable data. A grid can be
defined that matches the spacing of the
variable data font being used on the
form. Multiple grids can be defined on a
single form.

Predefined grid formats (FMT1 -
FMT13 and FMT1A - FMT9A) are
available for use within Designer. In addition to these formats, users can create custom grids to be used
with the current form or add a custom grid format to the current resource set for future use.

The origin value is the point from which all placements are measured. Changing the origin will cause form
elements to be moved in relation to the new origin. This is a convenient way to assure alignment with
variable data.

If the A4 paper size is selected in the Paper Size tab of the Form Layout menu, the FMT1A-11a grid
settings will automatically appear in the Pre-defined drop down menu.

� To select a grid format

1. Select Edit then click on Form Layout. The Form Layout menu will appear.

2. Select the Grid Settings tab.

3. Specify Grid Size Width and Height values along with Form Origin

<OR> Select a Pre-defined Grid Format

<OR> Select Custom Grid Format

4. Click Update in the Define Grid List.

� To add a custom grid format

1. Select Edit then click on Form Layout. The Form Layout menu will appear.

2. Select the Grid Settings tab.

3. Specify Grid settings (width/height and origin) in the Grid Size/Form Origin section.
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4. Click the Save button. The new custom Grid Format will be added to the Custom list and is
automatically named. A user-defined name can also be defined before saving to make it easier to
remember the grid settings in the future.

� To specify form origin

1. Select Edit then click on Form Layout. The Form Layout menu will appear.

2. Select the Grid Settings tab.

3. Specify origin in the Left (X coordinate) and Top (Y coordinate) fields.

Current unit of measure is shown in the Unit drop-down. Units of measure available are inches,
centimeters, and dots.

� To display grid

1. Click the Show Grid button on the View toolbar.

<OR>

1. Select Options from the View menu.

2. Select Grid from the Options menu.

Grid Exchange
Use Grid Exchange to change the grid
used by the form if you do not want to
affect the positioning of objects on the
form. This may be handy if the form was
not originally designed using a grid. This is
a convenient option is the size of the
variable data font used with the form has
changed.

� To exchange the form grid

1. Select Grid Exchange from the Tools
menu.

2. Select the grid you wish to change from the Defined grid List.

3. To change the Grid Size and Form Origin, select a Predefined grid format, or select a custom grid
format.

4. Click the OK button to perform the grid exchange and close the window.
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Margins
Page Margins define the printable area of a page. These margins are used as guides for design purposes.
Changing page margins does not affects the form origin or move form elements.

� To specify page margins

1. Select Edit then click on Form Layout. The Form Layout menu will appear.

2. Select the Margins tab.

3. Use the arrow keys to specify margins in Left, Right, Top and Bottom fields.

� To view page margins

1. To display Page Margins, click Margins on the View toolbar.

<OR>

1. Select Options from the View menu.

2. Select Margins from the Options men
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FreeFlow VI eCompose (VIPO) Setup
The VI eCompose Setup tab
within the Form Layout menu
allows the user to create a
FreeFlow VI eCompose (VIPO)
profile and bookmark. For
multiple-page jobs, a profile and
bookmark can be defined in the
Layout window for each form, but
only one profile and bookmark will
be recognized and must be chosen
in the Proform Designer Job tree
before creating VI Compose
resources. In the VI eCompose
Setup tab, field names or
user-defined variables can be used
to populate the fields to automate
an email client or communicate
other information to the FreeFlow
VI eCompose.

When the VI eCompose setup is complete, Designer will create a profile (.pfl) file in the
xvtp\users\designer\profiles directory and name it [formname].pfl. If the Automate email check box has
been enabled, Designer will also create a rule file in the xvtp\dispatch\rules directory.

� To Define a VI eCompose Profile and Bookmark

1. Select Edt and choose Form Layout. Click on the VI eCompose Setup tab.

1. Define a Bookmark Delimiter. This can be anything but a comma or a period.

2. Check the Automate email box if an automated email client is being set up.

3. Select an Output File Name. This must be a variable or a field name containing the name of the .PDF file
that will be created by FreeFlow VI eCompose.

4. 1 through 4 of the Fields are designated for email automation and will be greyed out if the Automate
Email check box is enabled.

� ToEmail - a variable or a field name containing the email address of the recipient.

� From - a variable or a field name containing the email address of the sender.

� Subject - a variable or field name containing the text of the email's subject line.

� Contents - a variable or field name containing the path to the text file that contains the email's
contents.

5. Fields 5-8 can be used for other VI eCompose information.
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Import a Background, Document Style or Template
When creating a new form, the layout of the form can be borrowed or created from existing forms,
documents, or templates. By importing a background, style, or template, the creation of forms is much
easier than starting from scratch each time.

Importing Background

The Import Background option allows you to choose an image that the newly created form will be based
off of. The selected image will define the page size and orientation. The image will be placed in the
background plane, and will be assumed to be a printable background. To change this assumption, enable
Background mode in the Edit menu drop-down, select the image and from the properties menu, remove
the Print Image name.

Importing Document Style

Any existing form can be chosen to borrow it’s “Document Style”, including form name, title, page size,
orientation, grids, margins and data settings. A substantial time savings can be achieved when developing
multiple pages for the same application.

Importing Templates

Many pre-defined Templates are available for Labels, Cards (business and postcards), Letters and PDF
documents. Templates are separated by general categories, and once the template is selected from a list, you
will be guided through various menus showing which Multi-Up settings, Paper and Form Sizes, Cut Marks,
and images to be used as backgrounds are pre-selected. Any of these settings may be changed along the
way. If changed, the last menu gives you the ability to save this to either a new template or overwrite the
existing template.
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� To import a Background Image

1. From the file menu, select New Design... or select the New Form button.

2. The Form Layout menu will appear. Name your new form.

3. At the bottom of the menu, select the Import Background button.

4. Browse and select the desired imaged to be used as the background for your form. The new form will
automatically be sized to fit the dimensions of the selected image.

5. Click OK to create the new form with background image.

� To import a Document Style

1. From the file menu, select New Design... or select the New Form button.

2. The Form Layout menu will appear. Name your new form.

3. At the bottom of the menu, select the Import Style button.

4. Browse for the desired form that would like to copy the "document style" from. This will create a
new form with the same dimensions and data file used from the form you selected. Any images, text,
and drawn form items will not be copied onto this new form.

5. Click OK to create a form with a borrowed Document Style.
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� To import a Template

1. From the file menu, select Template Design.

2. The Choose Template menu will appear. Use the check boxes to the right to select options for bleed and
crop-marks if desired. Selecting these check boxes will narrow the list of available templates to
choose from. Use the Template Type drop-down menu to select the type of template you would like to
use.

3. Select the desired template and click Next. The following menus will display the default settings that
have been defined for the template.
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4. Once all the settings have been reviewed, click Finish. If any settings have been altered from the default
settings and you would like to keep them for later use within the template, click the Save Template
button to either same the current template or create a new one.

5. Click OK to finish defining settings in the Form Layout menu.

6. The Import Data menu you will appear. Browse and select the desired data file to be used, or select the
No-Data button if creating a simple application that does not require a data file.

7. Once the all settings have been defined, the form will open with the data window also showing. In
most cases, a job will also be opened with settings for Multi-Up, Paper Size, and cut marks defined.
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Saving Forms
You can save the active form you are working on, whether it is a new or a previously existing form. Active
forms can be saved with a different name or in a different location than they were previously saved.

You can save a document in source format and/or in print file format as defined by the current Resource
Set. To convert your form to a new format other than that defined in the current Resource Set, see Export
Form on page 89.

Supported Source Formats:

(.FSL) Proform Designer/Xerox FDL/HFDL Source

(.OSL) IBM OGL Version 2.0 Source

Supported Print Formats:

(.FRM) Xerox Metacode Object File

.PCL) PCL Form (

(.PS) PostScript Form

(.XES) Xerox XES Form

(.DBM, .JDT, .XJT) Xerox VI Compose Form

Xerox VI Compose forms (.DBM, .JDT, and .XJT)are discussed on page 355.

� To save new form

1. Click Save on the Standard toolbar or select Save As from the File menu.

2. To save the document in a different folder other than the default, click a different drive in the Save in
box, or double-click a different folder in the folder list.

3. To save the document in a new folder, click Create New Folder.

4. In the File name box, type a name for the form. The internal name of the form will by default appear
in the File name box.

5. Select output format from the Save as drop-down menu.

6. Click the Save button.

Output formats listed in the Save As drop-down are based on printer definitions in the current Resource Set.
The Save As menu will be different depending upon the type of file being output.
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� To save an existing form

1. Click the Save button on the Standard toolbar or select Save from the File menu.

2. The form will be saved in the same folder by the same name.

Saving the form in a printable file format will not only create a print file, but it will also create all of the
necessary resources, as well as update the Proform Designer source file (.FSL). Saving the form as a
Proform Designer AFP source form will only create resources for AFP forms(page segments and fonts).

Auto-Save
You can protect your work by using the Auto-Save feature. Auto-Save will save your form as a Proform
Designer form periodically as you work. The Auto-Save will save at user-defined intervals. A form file must
be named before Auto-Save will be activated.

� To activate auto-save

1. Select Preferences from the Edit menu.

2. From the System tab, check Auto-Save.

3. Use arrow keys to indicate interval time in minutes.

Take caution when setting the Auto-Save interval. Setting the interval too short can cause unwanted
over-saving of files.

Create Backup Files
You can protect your work by using the Backup File feature. By activating this feature, the previous copy of
the form will be renamed to form.BAK every time you save a form. It will also be located in the same
folder as the form.

� To create backup files

1. Select Preferences from the Edit menu.

2. From the System tab, check Create Backup File.
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Xerox FRM Save Options

There are several options unique to creating Xerox FRM files. The Save As window will reflect unique
options based on the type of file being output.

Disable Color

The disable color option will produce a monochrome form object file from an FSL file containing
highlight/full color commands. This enables the same forms to print on a full line of Xerox printers
regardless of color capability. All box FILLS will be converted to SHADING MEDIUM. All colored lines
and borders will be made black.

� To enable disable color option

1. Begin the File Save Process as follows:

� Select Save As from the File menu.

� To save the document in a different folder other than the default, click a different drive in the Save
in box, or double-click a different folder in the folder list.

� To save the document in a new folder, click Create New Folder.

� In the File name box, type a name for the form.

� Select output format from Save as Type drop-down.

2. Check the Disable Color checkbox.

3. Click the Save button.
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Create Tape Label

Proform Designer allows Xerox FRMs and resources (fonts, logos and images) to be created with or
without a Tape Label record at the front of the file. Depending on how these files are transferred to the
LPS printer determines if a tape label is necessary or not. Most transfer methods require a tape label.

� To create files with a tape label

1. Begin the file save process as follows:

� Select the Save As from the File menu.

� To save the document in a different folder other than the default, click a different drive in the Save
in box, or double-click a different folder in the folder list.

� To save the document in a new folder, click Create New Folder.

� In the File name box, type a name for the form.

� Select output format from Save as drop-down.

2. Enable the Tape Label Files checkbox.

3. Click the Save button.

Ink-Result

The Ink-Result command defines a default action that the printer can use if black dots are placed over color
dots. A limitation on the HighLight color printer prevents color and black dots to occupy the same spot on
the printed page. Selecting BLACK gives priority to the black dot, while selecting COLOR gives priority to the
color dot. By selecting SYSTEM, whatever default that has been defined at the printer will be used.

� To define ink-result

1. Begin the file save process as follows:

� Select Save As from the File menu.

� To save the document in a different folder other than the default, click a different drive in the Save
in box, or double-click a different folder in the folder list.

� To save the document in a new folder, click Create New Folder.

� In the File name box, type a name for the form.

� Select output format from Save as drop-down.

2. Choose Ink-Result from drop-down menu as either Black, Color or System.

3. Click the Save button.
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PCL/PS/XES Save Options
There are several options unique to creating PCL, PostScript and Xerox XES form files. The Save As
window will reflect unique options based on the type of file being output.

Create A Form

File format allows one or more forms to be stored in printer memory. This feature provides for multi-page
forms to be cycled without the necessity of downloading the form for each page printed. A unique macro
ID can be assigned to each form. Variable data streams can then be formatted to call a specific macro to be
merged with the data when appropriate.

Macro creation options are available when saving as PCL, PostScript or XES. Macro ID capability is only available when
saving as PCL and PostScript.

� To assign a macro to a PCL, PostScript, or XES form

1. Begin file save process as follows:

� Select Save As from the File menu.

� To save the document in a different folder other than the default, click a different drive in the Save
in box, or double-click a different folder in the folder list.

� To save the document in a new folder, click Create New Folder.

� In the File name box, type a name for the form.

� Select output format from Save as drop-down.

2. Check the Create Form checkbox.

3. Specify macro ID number in the Macro ID field (not applicable for XES).

4. Click the Save button.

Shrink Form to Fit Page

This option allows the same form to be printed on a variety of printers regardless of edge-to-edge
capability. While some PCL/PS/XES printers can print to the edge of the page, many have restrictive
margins such as the HP series of printers. This option will scale and shift the form in combination in order
to fit the page.

� To enable shrink to fit

1. Begin the file save process as follows:

� Select Save as from the File menu or select Save from the File menu.

� In the File name box, type a name for the form.

� Select output format from Save as drop-down.

2. Check Shrink Form to Fit Page checkbox.
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3. Click the Save button.

Disable Color

The disable color option will produce a monochrome form object file from an FSL file containing highlight
color commands. This enables the same forms to print on a full line of printers regardless of color
capability. All box FILLS will be converted to SHADING MEDIUM. All colored lines and borders will be
made black.

� To enable the disable color option

1. Begin the File Save Process as follows:

� Select Save As from the File menu.

� To save the document in a different folder other than the default, click a different drive in the Save
in box, or double-click a different folder in the folder list.

� To save the document in a new folder, click Create New Folder.

� In the File name box, type a name for the form.

� Select output format from Save as drop-down.

2. Check the Disable Color checkbox.

3. Click on the Save button.

� To Include Resource Files

All resources used in a form (fonts and images) can be included in the output form file using the Include
Resource feature, thus providing a complete form in a single file. The Include Resource Files option only has
meaning when creating XES and PCL forms. Include Resources will automatically be done when creating PostScript.

1. Begin the file save process as follows:

� Select Save as from the File menu or select Save from the File menu.

� To save the document in a different folder other than the default, click a different drive in the Save
in box, or double-click a different folder in the folder list.

� To save the document in a new folder, click Create New Folder.

� In the File name box, type a name for the form.

� Select output format from Save as drop-down.

2. Check the Include Resources checkbox.

3. Click the Save button.
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Embed Resources in .DTD File

Saving a form in .dtd format will make that form accessible to all of the Designer products. Resources
(data, fonts, and images) can now be embedded in the .dtd file in order to contain all resources into a single
file for transfer.

� To embed resources in .dtd file

1. Open the form that will be saved as a .dtd file.

2. Go to the File menu and select Save As.

3. Go to the Save as type drop-down menu and select Designer Form (*.dtd).

4. Enable the Embed Resources check box.

5. A .dtd form can be opened by any of the products in the Designer series.

� To open a .dtd file with embedded resources

1. Go to the File menu and select Open. Highlight the .dtd form that you want to open, and click Open.

2. The embedded resources are automatically placed in the appropriate Font, Image, and Data folders.

3. The form will be displayed using the embedded resources.

This option should only be used when archiving the form or transferring the form to another system.
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Output a Static Form to an Image
Static forms can be saved as .tif, .jpg, .pcx, .bmp, or .eps images as well as the standard PS, PCL and XES
form formats.

� To output a static form to an image

1. Open the form that you wish to output.

2. Select Save As from the File menu of the open form.

3. Choose the Static Form as Image option from the Save as type drop-down menu.

4. Click OK.
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Close a Form

� To close a form

1. Select Close from the File menu.

� If the file has not been saved, you will be prompted to do so.

� If the file has been saved, the form will be closed.

Designer has a Multiple Document Interface. Therefore, multiple forms can be open at one time,
eliminating the need to close a form in order to open or start a second.

Proof Print
At any time while designing a form, you can
print a quick “proof ”. This “proof ” can be
printed on any type of printer that is attached to
your PC and has been properly set-up in
Windows. You can also use the Print Preview
function to get an idea of how the form will
print. The Proof Print is used solely for assisting with design
and will not necessarily create the same image as that
created when using the Save, Save As or Export options.
This is due to the fact that the proof print
option is using the Windows print drivers and
the Save, Save As or Export options use Lytrod
Software created printer drivers.

� To proof print

1. Select Proof Print from the File menu.

2. Select Printer from the Name drop-down. Additional printer properties can be selected by clicking the
Properties button.

3. Choose the number of copies to be printed using the spin arrows or by entering the number
manually.

� To view print preview

1. Select Print Preview from the File menu.
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Form Export
The form export function allows forms to be converted to a printer format other than the one for which it
was originally designed. This function also allows you to change a form's associated resource set. It
provides an automated conversion of the form along with all resources, including fonts, logos and images.

Supported Print Formats:

Xerox Metacode Object File (.FRM)

PCL Form (.PCL)

PostScript Form (.PS)

Xerox XES Form (.XES)

Xerox VI Compose Form (.DBM), (.JDT) or (.XJT)

� To export a form

1. Select Export from the File menu.

2. Choose Form from the Export menu.

3. An Export Form window will appear.

� To export the document to a different folder other than the default, click a different drive in the
Save in box, or double-click a different folder in the folder list.

� To export the document to a new folder, click on Create New Folder.

� In the File name box, type a name for the form. The current form name will already be filled in.

� Select the output format to which the form will be exported from the Save as drop-down.

4. Click the Save button.

Change the Resource Set used by a Form/Job
Once a form or Job has been created, the resource set that is associated with it can be changed.

� To change resource sets

1. Go to the File menu of an open form and select Export.

2. Choose either Form or Job.

3. Click the Option button.

4. Select the new resource set with which the form will be associated.

Opening, Creating and Saving Forms 89



PCL/PS/ XES Export
Forms may be exported to PCL, PostScript and Xerox XES from any of the other supported printer
formats. The form, along with all resources, will be converted. There are options available upon exporting
to handle any conversion issues that may be involved in the export.

� To specify PCL/PS/XES options

1. Select File and choose Ecport.

2. Choose Form from the Export menu.

3. An Export Form window will appear.

� To export the document to a different folder other than the default, click a different drive in the
Save in box, or double-click a different folder in the folder list.

� To export the document to a new folder, click Create New Folder.

� In the File name box, type a name for the form. The current form name will already be filled in.

� Select output format as PCL object form (.pcl), PostScript object form (.ps) or XES object form (.xes) from the Save
as Type drop-down.

4. Click Options to view PCL/PS/XES export options.

5. An Export PCL/PostScript window or Export XES window will appear with the following export options:
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Export Option Description

Create Form Will create a form file that can be stored on the printer for later merging with variable data. If not checked, a
file that prints the form is produced.

Form ID Allows an ID to be assigned to the form file so that the form can be referenced by variable data. This option
is not available when exporting to XES.

Shrink Form to Fit Page Specifies that the exported form needs to be shrunk to fit more restrictive print margins than what it was
originally designed for.

Edge to Edge Printing Specifies that exported form can print edge to edge.

Print Grid on Form Allows the printing of the grid lines over the form. Assists in measurement and design modifications.

Color Specifies what type of color, if any, should be included in the exported form.

Resolution Specified resolution of exported form. This option is not available when exporting to XES: resolution must be
300 dpi in this case.

Include Resources Includes fonts, logos and images in the actual form file so that only one file needs to be transferred to the
printer.

Paper Support Defines largest paper size supported on destination printer.

Form Optimizations Allows print driver to combine/eliminate elements to create a smaller form file.

6. Click OK to accept options and return to Export Form window.

7. Click Save to complete export process.
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Metacode FRM Export
Forms may be exported to Metacode FRM from any
of the other supported printer formats. The form
along with all resources will be converted. There are
options available upon exporting to handle any
conversion issues that may be involved in the export.

� To specify Metacode FRM options

1. Select File and choose Ecport.

2. Choose Form from the Export menu.

3. An Export Form window will appear.

� To export the document to a different folder
than the default, click a different drive in the
Save in box, or double-click a different folder
in the folder list.

� To export the document to a new folder, click Create New Folder.

� In the File name box, type a name for the form. The current form name will already be filled in.

� Select output format as Xerox object form (.frm) from the Save as drop-down.

4. Click Options to view Metacode export options.

5. An Export Metacode window will appear with the following export options:

Export Option Descriptions

Color Specifies what type of color, if any, should be included in the exported form. Choices are limited to HighLight
color or Monochrome.

Ink-Result A limitation on the printer prevents color and black dots from occupying the same spot on the printed page.
Ink-Result allows specification of which should take priority.

Tape Label Files Creates the exported form with a Tape Label. Select None, Standard or Extended.

Graphic Capability Specifies whether or not graphics/images can be created. Some Xerox printers require additional hardware to
support image files.

Paper Support Defines largest paper size supported on the destination printer.
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File Transfer
Once a form has been completed, it must be transferred to the laser printer. The method of file transfer is
dependent on the type of laser printer you are using. Some common methods of file transfer include
network, parallel, floppy disk, and host transfer. Proform Designer provides the ability to gather all
resources associated with the form and place into a folder or zip file to ease the transfer problem.

Please see page 60 for more information on viewing form resources.
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Send Form to Folder
In addition to being able to send a form and all its resources to a floppy disk for file transfer, Designer can
also send a form and all its resources to a specified folder.

� Send form to folder

1. Open the form that you want to send to the folder.

2. Select Send Form To from the File menu and choose Folder.

3. The Browse for Folder menu will appear.

4. Select the folder to which you will send the form and all its resources.

5. Click OK.

Send Files To Archive
Designer will determine all resources of a form or application, zip all of these files together and save a zip
file in the Archive folder.

� To send files to archive

1. Open the form that you want to send to archive along with all it's resources.

2. Select Send Form To from the File menu and choose Archive.
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Chapter 4

Basic Form Drawing

All form elements can be drawn using the mouse. To draw an element, select the appropriate draw
mode and place the mouse where you want to start the element. To create an element, you must
drag the mouse and release to end. Paths require that you drag and click at each point location.

Drawing Form Elements

Drawing Lines, Boxes, Circles, OMR Responses, and Paths

Icon Draw Mode

Line Draw

Box Draw

Circle Draw

OMR Response Draw

Path Draw

� To draw lines, boxes, circles and OMR responses

1. From the Drawing toolbar, click the appropriate draw tool.

2. Position mouse where the element should begin, press and hold the left mouse key to begin drawing.

3. Drag to draw the element and release the mouse key to end.
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Drawing Paths

� To draw paths

1. From the Drawing toolbar, click the Path Draw button to enable path draw mode.

2. Position mouse where the path should begin and press and hold the left mouse key to begin
drawing.

3. Click the left mouse button to indicate each point of the path and continue drawing.

4. Double click the left mouse button to end drawing or single click the right mouse button.

� To close a path

1. Select path(s) to close.

2. Click Close/Open Path on the Format toolbar to toggle between closed and opened path.

� To continue a path from the ending point

1. Select path(s) to continue.

2. Click Continue Path from End on the Format toolbar.

� To add a point to a path

1. Select path.

2. Select point to the right of the location of the new point to be added. To select a point, click the
left mouse button on the point handle while holding the <SHIFT> key.

3. Click Add New Point on the Format toolbar to add a new point to the left of the point selected.

Grid Snap

Grid Snap is an important design feature when
drawing, resizing and moving form elements. The
grid snap option ensures the user that all form
elements will fall on ¼ grid, ½ grid or full grid unit
and not on any other fractional values thereof. This
guarantees creation of lines that intersect and eases
alignment.

� To define grid snap interval

1. Select Preferences from the Edit menu.

2. From the Design tab, specify Mouse Snap increment.
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Selecting Form Elements
In order to manipulate a drawing element, it must first be selected.

It is often difficult to tell if you are positioned properly over a particular form element. Designer’s cursor
will change to indicate proper positioning. The various cursor shapes indicate the type of element over
which the cursor is positioned. The mouse must be positioned over the border of an element in order to
select it except in the case of shaded or filled boxes, circles and path. In these cases, any position over the
element will be sufficient for selection.

Cursor Background Object Cursor Selected Object

Horizontal Line

Vertical Line

Diagonal Line

Box

Circle

Path

Text

� To select a form element

1. From the Drawing toolbar, click Select Mode.

2. Position the mouse over the element to be selected and click the left mouse key.
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Selected items will be displayed with selection handles. To select overlapping objects, it may be necessary to de-select all objects
prior to making selection.

� To select multiple elements

1. From the Drawing toolbar, click Select Mode.

2. Position your mouse over the element and hold the
<SHIFT> key while clicking the left mouse key over the
desired elements.

<OR>

3. Click Group Mode from the Drawing toolbar, and draw a box
around the elements to be selected. The <SHIFT> key
in combination with the left mouse key can be used to
add or remove individual elements from the group.

� To select all elements

1. Choose Select All from the Edit menu.

2. All elements on the form will be selected. The <SHIFT> key in combination with the left mouse key
can be used to remove individual elements from the selection.

When multiple items are selected, a group is automatically created. Elements will be shown in blue with one
round selection marker per element. A group box will surround the elements.
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Moving and Copying Form Elements

� To move using the mouse

1. Select the element(s) to be moved.

2. Position the mouse over the element(s) and drag element(s) to a new location.

� To copy using the mouse

1. Select the element(s) to be copied.

2. Position the mouse over the element(s)and drag element(s) to a new location while holding down the
<CTRL> key.

When moving and copying elements using the mouse, grid snap will affect the interval in which an element
is moved or copied. Grid Snapping is described in detail on page 96.
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� To position an element through the Properties window

1. Select the element.

2. Select Object from the Format menu or click the right mouse button and select Format from the context
menu.

3. From the Size and Position tab of the Properties window, use the arrow keys to specify position (X and Y
coordinates).

� The X/Y coordinates for lines represent the starting point and ending point. Both values need to
be changed to re-position a line rather than resize a line.

� The X/Y coordinate for boxes represent the origin or top left corner.

� The X/Y coordinate for circles represent the center point.

� The X/Y coordinates for paths represent the individual points in the path. All point coordinates
would need to be modified by the same amount to affect overall Path position.

� To position a group of elements

1. Group form elements to be formatted.

2. Select Group from the Format menu or click the right mouse button and select Format from the context
menu.

3. From the Size and Position tab of the Group Properties window use the arrow keys to specify X/Y values
for the group origin (top left corner).

Current unit of measure is shown in the Unit drop-down. Units of measure available are grids, inches,
centimeters and dots.

Keyboard Snap

Keyboard Snap is an important design feature when moving form elements using the keyboard (grid
stepping). The keyboard snap option ensures the user that all form elements will fall on a pixel, ¼ grid, ½
grid or full grid unit and not on any other fractional values thereof. This guarantees creation of lines that
intersect and eases alignment.
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� To set keyboard snap

1. Select Preferences from the Edit menu.

2. From the Design tab, specify Keyboard Snap increment.

� To move using the keyboard (grid stepping)

1. Select the element(s) to be moved.

2. Use arrow key representing the direction in which to move.

Horizontal/Vertical Hold

When drawing, moving or copying form elements, either the horizontal or vertical placements can be held.
Once the position of an element is correctly placed in one direction, the position in the opposite direction
can be changed without altering the held placement.

� To hold vertical position (move horizontally)

1. Select form element(s) in which the vertical position is to be held.

2. Hold the left or right arrow keys while performing draw, move or copy operation.

� To hold horizontal position (move vertically)

1. Select form element(s) in which the horizontal position is to be held.

2. Hold the up or down arrow keys while performing draw, move or copy operation.

Resizing Form Elements

� To resize using the mouse

1. Select the element(s) to be resized.

2. Position mouse over appropriate handle and drag to new size.

When resizing boxes, corner handles resize both width and height proportionally. Center handles resize
width or height respectively. When resizing circles, the center point will remain constant as the radius is
increased or decreased.

When resizing elements using the mouse, grid snap will affect interval in which element is resized. Grid
Snapping is described in detail on page 96.
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� To resize through the Properties window

1. Select element(s).

2. Select Object from the Format menu or click the right mouse button and select Format from the context
menu.

3. From the Size and Position tab of the Properties window use the arrow keys to specify size.

Paths are not resized through the Properties window in the same fashion as other elements. The X/Y
coordinates in the Size and Position tab of the Path Properties window represent the individual point locations.

Group Scaling

� To scale a group of elements

1. Group form elements.

2. Select Group from the Format menu or click the
right mouse button and select Format from the
context menu.

3. From the Size and Position tab of the Group Properties window use the arrow keys to specify width/height
values for the group or percentage to scale.
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Grid Settings

Changing the grid for a form element or a group of form elements
can be done. By doing so, the element or group of elements will
realign with the new grid. Therefore, the element(s) will be resized
accordingly and the position may be affected based on a new grid
origin.

� To change the grid of a form element or group of elements

1. Select an element or a group of form elements.

2. Choose the new grid from the Defined Grids drop-down menu in the Drawing toolbar.

In the previous example: The grid setting for the box has been changed. The width and height of the box
remain the same (20 grids by 10 grids). However, because the grid size is different, the width and height
values are now based on the new grid size causing the box to be resized accordingly.
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OMR objects are drawn based on predefined OMR grids. All grids used on the form are displayed in the
Defined Grids drop-down. The grid for the entire form can be set to the OMR grid if the OMR element is
drawn before any other element is placed on the form.

Current unit of measure is shown in the Unit drop-down. Units of measure available are grids, inches,
centimeters and dots.

Keyboard Snap

� To resize using the keyboard (grid stepping)

1. Select the element to be resized.

2. Hold the <CTRL> key in combination with the arrow key representing the direction in which to
resize.

Stepping can be used when fine movement or resizing is difficult to achieve through mouse movements.
Detailed information on setting keyboard snap interval is described on page 100.

Moving, Copying and Resizing Summary

Cursor Shape Operation

Move

Move holding vertical position

Move holding horizontal position

Copy

Copy holding vertical position

Copy holding horizontal position

Resize width

Resize height

Resize width and height respectively
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Deleting Form Elements

� To delete a Form Element

1. Select the element(s) to be deleted.

2. Click the <DELETE> key on the keyboard.

Form Element Repetitions
Repetitions are useful when there are multiple elements to be drawn that are the same size and share the
same attributes. There are two different types of repetitions available: even and exact. Even Repetitions
allow users to create a group of items evenly spaced at a user-defined interval, and can be vertical,
horizontal, or staggered. Exact Repetitions allow users to create a group of items in which each item is
placed at varying user-defined intervals, and can be vertical, horizontal, or random. Repetitions not only
save time when initially designing forms, but also when making modifications later. Line, box, circle and
path repetitions can be created.

Icon Repetition Mode

Even Repetitions

Exact Repetitions

Staggered Repetitions

Random Repetitions

Creating Even Repetitions

� To create even repetitions using the mouse

1. Select element to be repeated.

2. Click the appropriate repetition button from the Repetition toolbar.

� Click Even Repetition to create evenly spaced horizontal/vertical repetitions.

� Click Staggered Repetition to create evenly spaced staggered repetitions.

3. Click left mouse button at the appropriate distance and direction (on the first repetition) from
original item to set interval.

4. Continue to click left mouse button to add additional repetitions.
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� To create even repetition through the repetition window

1. Select the element to be repeated.

2. Select Object from the Format menu.

3. Open the Repetition tab from the Properties window.

4. Choose the appropriate radio button indicating repetition direction (horizontal, vertical or random).

5. Specify the number of repetitions in the Number of Repetitions edit box or by using the spin arrows.

6. Check the Evenly Spaced checkbox.

7. Specify the interval in the appropriate X/Y edit box. Specify X value if creating horizontal
repetitions and a Y value if creating vertical repetitions. Specify both if creating staggered repetitions.

� To change interval through mouse

1. Select the repetition group to modify.

2. Click the Even Repetition or Staggered Repetition tool as appropriate on the Repetition toolbar.

3. Position the mouse over an individual element in the group.

4. Drag element to new location to change interval.
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� To change interval through repetition window

1. Select the repetition group to modify.

2. Select Object from the Format menu.

3. Open the Repetition tab of the Properties window.

4. Modify appropriate X/Y value(s).

Creating Exact Repetitions

� To create exact repetitions using the mouse

1. Select the element to be repeated.

2. Click the appropriate repetition button from the Repetition toolbar

� Click Exact Repetition to create horizontal/vertical repetitions.

� Click Random Repetition to create random repetitions.

3. Click the mouse pointer at the location of each desired repetition.
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� To create exact repetitions through the Repetitions window

1. Select an element to be repeated.

2. Select Object from the Format menu.

3. Open the Repetition tab from the Properties window.

4. Choose appropriate radio button indicating repetition direction (horizontal, vertical or random).

5. Specify number of repetitions in the Number of Repetitions edit box or by using the spin arrows.

6. Specify repetition locations in X/Y edit boxes.

� To reposition individual elements using the mouse

1. Select a repetition group to modify.

2. Click Exact Repetition or Random Repetition as appropriate on the Repetition toolbar.

3. Position the mouse pointer over an individual element in the group.

4. Drag the element to a new location.

� To reposition individual elements through the repetition window

1. Select a repetition group to modify.

2. Select Object from the Format menu.

3. Open the Repetition tab of the Properties window.

4. Modify X/Y location of the individual repetition to re-position by clicking on a value in the list and
then editing the value in the corresponding edit boxes.
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Adding Elements to Repetitions

� To add an element to a repetition using the mouse

1. Select a repetition group to modify.

2. Click the appropriate Repetition Mode button on the Repetition toolbar.

3. Click the left mouse button to add items to the group.

� For Even and Staggered repetitions, added elements will be placed at the end of the group.

� For Exact and Random repetitions, added elements will be placed at the location where the mouse
is positioned.

� To add an element to a repetition through the Properties window

1. Select a repetition group to modify

2. Select Object from the Format menu.

3. Open the Repetition tab of the Properties window.

4. Increase the number in the Number of Repetitions edit box.

5. Specify the location of the added repetition in corresponding X/Y edit boxes.

Deleting Elements from Repetitions

� To delete an element from a repetition

1. Select repetition group to modify.

2. Click on appropriate Repetition Mode button on the Repetition toolbar.

3. While holding down the <SHIFT> key, select the element you wish to remove.

4. Once selected, press the <DELETE> key to delete the element.
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Breaking Elements from Repetition Groups
All elements in a repetition group must have the same attributes applied and be the same size. There may be
times in which an individual element requires unique traits. In this case, the element must be broken away
from the rest of the repetition group. Once broken, it will no longer be associated with the group and will
be seen as an individual form element.

� To break an element from a repetition

1. Select a repetition group.

2. Click on the appropriate Repetition Mode button on the Repetition toolbar.

3. While holding down the <SHIFT> key, click left mouse button over the element you wish to break
way from group.

4. Click Break on the Repetition toolbar.

The “broken” item will not be deleted. It will only be removed from the repetition group.

Form Element Joining
Line, Box, Circle, and Path elements can be joined together and can be repeated together. However, only
like elements can be joined (e.g. path elements to path elements, circles to circles, etc), and the elements
must be the same size. Text blocks can also be joined into a single block.

� To join form elements

1. Click the Select Group Mode button from the Drawing toolbar.

2. Click the left mouse button to begin drawing. Drag a grouping box around the form elements and
release the mouse key to end.

3. Click the Join into Repetition button on the Repetition toolbar.
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Formatting Elements
Several attributes can be defined for form elements. These attributes are the same whether formatting an
individual element or a repetition.

Some of the formatting attributes can be applied to all of the different form elements (lines, boxes, circles
and paths), while a few may only be applicable to certain form elements.

Several formatting options are available to a group of elements. These options are similar to those found
when formatting individual lines, boxes, circles and paths. The group formatting tool allows universal
formatting of different form elements simultaneously. Some formatting options will not affect all of the
elements in a particular group if not applicable to that element. For example, shading will not affect any
lines just as line direction will not affect anything other than lines. The pointer icon will identify attributes
that can be applied to a group of elements.

Formatting tools unique to groups will be described in detail at the end of this chapter.

Detailed information regarding the formatting of OMR responses can be found in Chapter 9 - Creating
OMR Forms.

Thickness and Style

Line/Border thicknesses are represented in POINTS from 0 - 14, except in the OGL environment (0-99
points). Three styles are available including solid, dotted and broken. Thickness and style will affect lines of
all directions along with box, circle and path borders. It will also affect diagonal lines within boxes and
circles. In the FDL environment, fractional values cannot be entered.

This attribute can also be applied to a group of elements.

� To define line and border thickness and style

1. Select the element to be formatted.

2. To change the thickness, click the appropriate thickness button (Increase Border
Thickness/Decrease Border Thickness) from the Format toolbar.

� To increase border thickness, click Increase Border Thickness.

� To decrease border thickness, click Decrease Border Thickness.

3. To change the style, click the Change Border Style button from the Format toolbar to rotate through
available styles.
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Zero Thickness Lines/Borders

Line/Border thicknesses can be set to 0. These lines/borders will be invisible and will not print. The
benefit of using zero lines is the ability to create invisible boxes or circles so that text, data, data graphs, and
images can be placed within them and positioned using the attach and position functions. Invisible lines can
also be used to complete a box for this same purpose.

This attribute can also be applied to a group of elements.

� To create a zero line object

1. Right click the object, and select Format from the context menu.

2. Access the General tab.

3. Go to the Thickness field and use the spin buttons to set the thickness to 0.

4. Click OK.

� To view zero lines

1. Select Options from the View menu.

2. Select Zero Lines from the Options menu.

Color

Color changes will affect lines of all directions along with box, circle and path borders. It will also affect
diagonal lines within boxes and circles, and shadings within boxes, circles and closed paths. It will not affect
fill within boxes, circles and closed paths. Please see page 115 for information on color fill.

� To change line/border color

1. Select the item(s).

2. To change the color of a selected item(s), click Palette or Border Color from the Format toolbar.

3. Select the appropriate color.

The availability of colors is dependent on whether the form has been defined as monochrome, highlight
color or full color.

When applying color to a group of elements there are additional capabilities implemented to specify type of
coloration. Please see page 115 for more information on applying color to a group of elements.
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Adding Diagonal Lines

Diagonal lines can be added to boxes and circles. The attributes of the diagonal lines will match the border
attributes.

This attribute can also be applied to a group of elements.

� To add diagonal lines

1. Select the box or circle to which you will add the diagonal lines.

2. Click the Toggle Diagonal Lines button on the Format toolbar. Two diagonal lines will be toggled on or off.

3. To specify a particular diagonal line to be added/removed, click the left mouse button on the corner
handle, while holding down the <SHIFT> key. The corners will then be selected.

4. To add/remove only one diagonal line in a specific direction, select Object from the Format menu or
click the right mouse button and select Format from the context menu.

� From the General Attributes tab, check the appropriate button (Top-Left to Bottom/Bottom-Left
to Top) to enable/disable diagonal lines.

� To add diagonal lines to a group of elements

1. Click the Toggle Lines button on the Format toolbar. Two diagonal lines will be toggled on or off.

2. To add/remove only one diagonal line in a specific direction, select Group from the Format menu or
click the right mouse button and select Format Group from the context menu.

� From the Lines and Borders tab, check the appropriate button (Top-Left to Bottom/Bottom-Left to
Top) to enable/disable diagonal lines.

Basic Form Drawing 113

�

Diagonal Line section of the General Attributes tab of the Properties
window.



Shading Form Elements
Shading can be applied to boxes, circles and closed paths.

This attribute can also be applied to a group of elements.

� To shade element

1. Select element(s).

2. Click the appropriate shading button on the Format toolbar to apply shading.

� To specify shading pattern

1. Select element(s).

2. Select Object from the Format menu.

3. From the Shading/Fill tab select a shading type from the drop-down menu.

� To specify shading pattern for a group of elements

1. Group elements.

2. Select Group from the Format menu.

3. From the Shading tab select a shading type from the drop-down menu.

Shading with diagonal lines

When shading boxes/circles with diagonal lines, the user has control
over which areas are shaded and not shaded and what type of
shading is applied to each area. Each area is considered separate and
can have its own type of shading.

� To shade elements with diagonal lines

1. Select box/circle(s) with diagonal lines to be shaded.

2. Select Object from the Format menu.

3. Access the Shading/Fill tab. Use the Area and Shading/Percentage
drop-down menus to select the area to be shaded and which
type of shading, if any, will be applied.
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Color Fill

Color fill is available for boxes, whole circles and closed paths. Color fill will
flood fill the element with the selected ink. When using fill, it is not advised
to use box shading unless a solid color is chosen for the fill. Box shading
combined with a patterned fill may produce undesirable results. Diagonal
lines do not affect the fill, unlike shading.

� To fill an element

1. Select element(s) to fill.

2. Select Object from the Format menu.

3. Check Fill to enable fill.

4. From the Shading/Fill tab select color from the Fill drop-down.

Rounded Corners

Rounded corners can be applied to boxes and paths. The amount of roundness can also be controlled.

This attribute can also be applied to a group of elements.

� To round corners

1. Select the element(s).

2. Click Round/Square Corner on the Format toolbar to toggle between rounded corners and square corners.

3. To specify a particular corner(s) to be rounded, click the left mouse button on the corner handle
while holding the <SHIFT> key. The corners will then be selected.

4. Click Round/Square Corner on the Format toolbar to toggle between rounded and square corners.
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� To specify amount of corner rounding

1. Select the element(s).

2. Go to the Format menu and select Object, or right click and choose Format from the context menu..

3. For boxes, select roundness from the General Attributes tab of the Properties window. If the predefined
values are not precise enough, a value (radius of corner) can be specified in dots.

4. For paths, select roundness on a point by point basis in the Size and Position tab of the Properties window.

116 Basic Form Drawing

Rounded Corner section of Path Properties window



Roundness options include SMALL, MEDIUM, LARGE, HALF and MAXIMUM. A value in dots may
also be specified. SMALL is equivalent to 12 dots, MEDIUM is equivalent to 25 dots, and LARGE is
equivalent to 37 dots. HALF and MAX are the same for boxes (half the distance of the smaller of the two
sides), while a MAX corner length for a path extends the arc as far as possible on both path segments.

� To specify amount of corner rounding for a group of elements

1. Group the elements.

2. Go to the Format menu and select Group.

3. For boxes, select roundness from the Lines and Borders tab of the Properties window.

Line Direction

The three line directions available are horizontal, vertical and diagonal. Diagonal lines will initially be drawn
at a 45 degree angle. When changing between the three line directions, the starting point (X/Y coordinate)
will remain the same while the ending point will change accordingly to accommodate the new line direction.

This attribute can also be applied to a group of elements.

� To change line direction

1. Select the line(s).

2. To change the line direction, click Toggle Line Direction from the Format toolbar.

The angle of diagonal lines can be rotated by holding down the <CTRL> key and positioning the mouse
over a line endpoint handle and rotating as needed.

Diagonal lines within boxes and circles cannot have their angle changed. They always begin and end at
corner points.
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Quarter/Half/Three-Quarter Circles

Circle segments can be selected and removed to create quarter, half and three-quarter circles.

This attribute can also be applied to a group of elements.

� To create quarter/half/three-quarter circles

1. Select circle(s).

2. While holding the <SHIFT> key, click the left mouse button over desired
segment handle(s).

3. Click Toggle Circle Segment on the Format toolbar to toggle indicated circle
segment on and off.

When filling quarter, half or three quarter circles, the entire circle will be filled.

Path Ends

The path end specifications determine the look of the start and end points of a non-closed path.

� To format path ends

1. Select path.

2. Select Object from the Format menu.

3. From the General tab of the Properties window, select path start and endpoint style as trimmed, square
or rounded.

Square will draw the endpoint as a rectangle. Trimmed will draw the endpoint trimmed to the horizontal
and vertical. Round will draw the endpoint with a semicircle, where the center point is the path endpoint.
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Default Formatting
The default setting is available to set the default attributes of a particular type of form element (line, box,
circle, response etc.). There is a default set of attributes for each type of element. These attributes include
border thickness, style, color, shading options, diagonal lines, etc. When set, attributes will affect the current
element selected as well as each new element drawn until the default is changed.

� To set Formatting options as Default

1. Select element.

2. Select Object from the Format menu or click the right mouse button and select Format from the context
menu.

3. From the General Tab or the Shading/Fill tab of the Format Properties menu, select the desired attributes and
check Set as Default.

The Set as Default check box will appear in both the General and Shading/Fill tabs in order to give more
flexibility in choosing default attributes. Setting the default option in one tab and not the other only sets the
attributes in the chosen tab as the default.
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Aligning Objects
Alignment guides will appear when designing if they are enabled through your preferences menu. These
are lines that appear to assist in positioning items based on a nearby items center, top, or bottom
positioning.

� To enable alignment guides

1. From the Edit drop-down, select Preferences.

2. The Preferences menu will appear.

3. From the Design tab, select the Show Alignment Guides check box.
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Group Formatting Tools
When multiple items are selected, a group is created. In addition to the standard formatting that can be
applied to form elements, groups have unique formatting tools available. They are only available when
working with a group of elements.

Keep Only Grouping

The Keep Only grouping function allows the selection of specific form elements in a group. After grouping
several elements or applying the Select All function (go to the Edit menu and choose Select All), the Keep Only
function is useful in keeping only the elements of one particular type within the group. This provides an
efficient way to format one type of form element.

� To apply keep only grouping

1. Group elements on the form by selecting the Group icon and then left clicking and dragging a box over
the desired form elements, or by using the Select All function.

2. Right-click and select Keep Only from the context menu.

3. Select one element that will be maintained within the created group.
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Individual form elements can be selected one at a time by holding down the <Shift> key and using the left
mouse button to click over the desired element.
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Remembered Grouping
The grouping of form elements can be remembered for future group formatting. After remembered
grouping is applied to a set of elements, whenever one form element in the group is selected, the entire
group becomes selected. Multiple groups can be remembered, and elements can also be ungrouped.
Remembered grouping however is not saved when a form is closed.

� To apply remembered grouping

1. Click the Select Group Mode button on the Drawing toolbar.

2. Click and drag a box around the form elements to be grouped.

3. Right click in the selected area to show the context menu

4. Select Group from the Grouping cascading menu.

� To ungroup form elements

1. Click on any element of a previously remembered group.

2. Right click in the selected area.

3. Select Ungroup from the Grouping cascading menu.

The Keep Only function cannot be used with form elements with remembered grouping applied to them,
since they are no longer considered individual form elements.
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Aligning Group Elements
The alignment tools allow quick alignment of a group of elements. When using the alignment tools a
“master” element is defined as the element for all other elements to be aligned to.

Toolbar Button Alignment

Left Align

Right Align

Center Align

Top Align

Bottom Align

� To define the “master” element

1. Group the elements to be aligned. The default “master” element will be identified with a round, pink
handle.

2. While holding the Shift key, click the left mouse button over the special round handle of the element
you wish to define as the “master” element. The rounded handle will turn pink to indicate selection.

� To align elements

1. Group objects to be aligned.

2. Define a “master” element if different from the defaulted “master”.

3. Click appropriate button on the Tools toolbar to align objects.

124 Basic Form Drawing

Grouped Form Elements
Box defined as “master”

Grouped Form Elements
Aligned Left



Resizing/Stretching Group Elements

Resizing Group Elements

The resizing tools allow quick resizing of a group of elements. When using the resizing tools a “master”
element is defined as the element for all other elements to be resized to.

Toolbar Button Resize Operation

Make Same Width

Make Same Height

Make Same Size (both width and height)

� To resize elements

1. Group objects to be resized.

2. Define a “master” element if different from the defaulted “master”.

3. Click appropriate button on the Tools toolbar to resize objects.

Some functions are not able to affect certain objects in the group. For example: When using the Make Same
Height function with a group that contains horizontal lines, the horizontal lines will not be modified.
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Stretching Group Elements

Stretching tools are available for groups of elements. It combines the alignment and resizing tools to
provide a different approach to resizing elements within a group. There is again a “master” element by
which to measure. With stretching, the items will be stretched to align with the “master” element.

Toolbar Button Stretch Operation

Stretch Left

Stretch Right

Stretch Top

Stretch Bottom

� To stretch elements

1. Group objects to be stretched.

2. Define a “master” element if different from the defaulted “master”.

3. Click appropriate button on the Tools toolbar to stretch objects.

When performing resizing and stretching operations to groups that contain circles, it is important to note
that circles are measured in terms of radius rather than width and/or height. Therefore, by increasing the
width or stretching larger (as in the above example) the overall circle size will be increased by a greater
amount than non-circles.
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Applying Color to a Group of Elements

Color changes can be applied to a group of elements in various ways. Special tools have been included to
specify the type of coloration to be applied to a group of elements.

Changing Border Color

Border color will affect lines of all directions along with box, circle and path borders within a group. It will
also affect diagonal lines within boxes and circles, as well as shadings within boxes, circles and closed paths.

� To change line/border color

1. Group objects.

2. Click the Border Color button on the Grouping toolbar.

3. Select appropriate color.

Fill Color

Fill color will affect boxes, circles and paths fill color within the group.

� To change fill color

1. Group objects

2. Click the Fill Color button on the Grouping toolbar.

3. Select appropriate color.

Text Color

Text color will affect text within the group.

� To change text color

1. Group objects

2. Click the Text Color button on the Grouping toolbar.

3. Select appropriate color.

Available colors are dependent on whether the form has been defined as monochrome, highlight color or
full color.
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Chapter 5

Working with Text

Proform Designer has an extensive text editor that allows you to enter and manipulate text much as
you would in a word processor. The text cursor is represented by an upper and lower bracket that
encases the area where text is being entered.

The text editor allows text to be quickly placed onto forms. Text boxes can be drawn for insertion of text
or Proform Designer will automatically create a block for text insertion. Formatting of text is done on a
text block basis and through the text editor allowing character by character formatting. Advanced text
functions include justification, spell checking, search and replace, and font changes on a character by
character basis.

Proform Designer can import and export ASCII text (.TXT), Rich Text Format (.RTF) and Microsoft Word
Documents (.DOCX). This allows users to transfer large amounts of text to and from Proform Designer
with little effort and without losing all formatting when using .RTF format.

Text from the Windows Clipboard is also available to be pasted into Proform Designer allowing users to
copy/cut text from other Windows applications.

Text Placement
In order to place text onto a form, a text block must first be defined. There are two ways to create a text
block. Each method creates a different type of text block.

� To create a text block

1. Click the Text Draw button on the Drawing toolbar to enable text mode.

2. Click the left mouse button where a text block should be drawn.

3. Type the desired text when the cursor appears.

This method should be used when entering titles or short lines of text. There will be no column width
associated with these text blocks. Text will not automatically word wrap.
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� To draw a text block

1. Click Text Draw on the Drawing toolbar to enable text mode.

2. Click the left mouse button and drag to draw a rectangular text block.

3. Type the desired text when cursor appears.

This method should be used when entering a paragraph of text. It will create a columnar block of text that
will be the column width of the block drawn. As a result, text will word wrap at the end of each line
accordingly.

X/Y location is indicated on the ribbon bar location at the bottom of the screen to assist in placing
elements in the desired location. More precise size and positioning can be accomplished in the Size and
Position tab of the Text Properties window.

Selecting Text Blocks
In order to manipulate a text block, it must first be selected.

It is often difficult to tell if you are positioned properly over a particular form element. Proform Designer’s
cursor will change to indicate proper positioning. The various cursor shapes indicate the type of element
that the cursor is positioned over.

� To select a text block

1. From the Drawing toolbar, click Select Mode.

2. Position your mouse over the text block to be selected and click the left mouse key.

Selected text blocks will be displayed with selection handles. To select overlapping objects, it may be necessary to de-select all
objects prior to making selection.
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Moving/Copying Text Blocks

� To move using the mouse

1. Select the text block(s) to be moved.

2. Position the mouse over the element(s) and drag element(s) to a new location.

� To copy using the mouse

1. Select the text block(s) to be copied.

2. Position the mouse over the element(s)and drag element(s) to a new location while holding down the
<CTRL> key.

� To move using the keyboard (grid stepping)

1. Select the text block(s) to be moved.

2. Hold the <SHIFT> key in combination with the arrow key representing the direction in which to
move.

� To position element through the Properties window

1. Select the text block.

2. Select Text from the Format menu or click the right mouse button and select Format from the context
menu.

3. From the Size and Position tab of the Properties window use the spin arrow to specify position (X and Y
coordinate) or type values in the respective edit boxes.

The current unit of measure is shown in the Unit drop-down. Units of measure available are grids, inches,
centimeters and dots.

Resizing Text Blocks
When resizing width, column width specification will be changed causing text to word-wrap to new column
width. When resizing vertically, line spacing will change to accommodate new text box size.

� To resize using the mouse

1. Select a text block to be resized.

2. Position the mouse pointer over a resize handle and drag to new size.
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When resizing text blocks, corner handles resize both width and height proportionally. Center handles resize
width or height respectively.

� To resize using the keyboard (grid stepping)

1. Select the text block to be resized.

2. Hold the <CTRL> key in combination with the arrow key representing the direction in which to
resize.

� To define grid step interval (for moving and resizing)

1. Select Preferences from the Edit menu.

2. Open the Design tab.

3. Indicate the Keyboard Snap by selecting the appropriate radio button (Pixel, ¼ grid, ½ grid or full grid).

Stepping can be used when fine movement or resizing is difficult to achieve through mouse movements.
Moving an element to an exact X and Y coordinate or defining a specific element size is available in the Size
and Position tab of the drawing element’s respective Properties window.

� To resize through the properties window

1. Select the text block to be resized.

2. Select Text from the Format menu.

3. From the Size and Position tab, specify width and height values to resize text block.
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Text Block Formatting
Several attributes can be defined for text blocks.

Several text formatting options are available to a group of elements. These options are similar to
those found when formatting individual text blocks. The group formatting tool allows universal
formatting of multiple text blocks simultaneously. The pointer will identify attributes that can be
applied to a group of elements.

Text Direction

Proform Designer supports both horizontal and vertical text. Horizontal text reads left to right, while
vertical text reads top to bottom, placing characters below the previous. Text can also be made to flow from
right to left. This feature is intended for use with Arabic fonts, and will be enabled as a default if Arabic is
defined as the language when starting up Proform. However, the option is always available, and any font can
be made to flow from right to left if desired.

This attribute can be applied to a group of text blocks.

� To orient text vertically or horizontally

1. Select text block.

2. Select Text from the Format menu, or right click and choose Format Text from the context menu.

3. From the General tab, select the desired text direction (vertical or horizontal).

� To orient a group of text blocks vertically or horizontally

1. Group text.

2. Select Group from the Format menu, or right click and choose Format Text from the context menu.

3. From the Text and Images tab, select the desired text direction (vertical or horizontal).

When editing vertical text, text will appear horizontally.

Text can also be rotated by angle. Please see Rotate/Flip Images on page 168 for additional information.
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� To enable text flow from right to left

1. Select that text to be edited and right click the selection.

2. Choose Format Text from the context menu.

3. The Text Properties window will appear. Access the General tab.

4. Enable the Right to Left Direction check box.

5. Click OK to save this specification and return to the form.

Font Selection

When working with text blocks, font changes applied will affect the entire block of text.

This attribute can be applied to a group of text blocks.

� To select text block font

1. Select text block(s).

2. Choose font typeface and point size from the Text Format toolbar as follows:

� Choose typeface from the Typeface drop-down.

� Choose point size from the Point Size drop-down.

<OR>

� Press <ALT>< F10> keys together to make font selection from the typefaces and point sizes
listed.

More detailed font information can be found in the Text Editing section of this chapter.

Underline, Bold and Italic Styles

When working with text blocks, all style changes applied will affect the entire block of text. To apply style
changes on a character-by-character basis, please refer to Text Editing later in this chapter.

Icon Style

Underline

Bold

Italic

� To apply character styles
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1. Select a text block to be modified.

2. Click Bold, Underline and/or Italic as desired.

Underline Style

There is one underline style associated with each text block. If more than one style is required in a single
text block, the block must be broken into multiple text blocks as described on page 142.

� To define underline style

1. Select the text block to be formatted.

2. Select Text from the Format menu.

3. From the Underline Style tab of the Properties window:

� Click Single or Double to choose underline type.

� Choose style (solid, broken, dotted) from Style drop-down.

� Define underline thickness (0-14, hairline) using the spin arrows.

� Choose underline color from Color drop-down.

� Use arrow keys to specify Distance value of underline below text baseline.
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Text Color

When working with text blocks, color changes will affect the entire block of text.

This attribute can also be applied to a group of text blocks.

� To change the text color

1. Select text block(s).

2. Click the Palette button on the Format toolbar to select text color or select Font from the Format menu to
choose color.

Bullets

Bullets can be applied to text blocks by selecting the Bullet button.

� To apply bullets to text and edit bullet styles

1. Select the desired text block.

2. Click on the bullet button to enable bullets at each carriage return within the text block.

3. Right click and choose Bullets from the context menu to access options for other types of bullets.

Select a different bullet type if desired.

� To define default bullet settings

1. Access the Preferences menu by selecting Edit > Preferences from the top menu bar within VisionDP.

2. Click on the Bullet Definitions tab within the Preferences menu.

3. Select the radio button below the icon that you wish to be the default bullet character.
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Text Block Spacing

Line Spacing

Predefined line spacing options include single, 1.5 and double line spacing. The Custom option allows other
line spacings to be defined in the Custom Line edit box.

� To define line spacing

1. Select text to be formatted.

2. Select Text from the Format menu, or right click and choose Format Text from the context menu.

3. From the General tab of the Properties window, choose line spacing from the Line drop-down.

Character Spacing

Character spacing controls the width of each character. By defining a character spacing, proportionally
spaced fonts will appear fixed pitch.

� To define character spacing

1. Select text to be formatted.

2. Select Text from the Format menu, or right click and choose Format Text from the context menu..

3. From the General tab of the Properties window, specify character spacing (pitch) using the spin arrows
or by typing in the Character edit box.

The value shown in the Custom and Character fields are represented in the unit selected in the Unit drop-down.
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Alignment
There are seven different alignment options available depending on text direction. The alignment affects the
entire text box formatted.

Icon Alignment

Left Align Text

Center Align Text

Right Align Text

Justify Text

Top Align Vertical Text

Bottom Align Vertical Text

Center Align Vertical Text

This attribute can be applied to a group of text blocks.

� To define alignment

1. Select text block(s).

2. Click appropriate alignment button on the Text Format toolbar to apply justification style.

Interword Spacing

If working with justified text, there is an additional option to modify the width of the space in between the
characters in order to adjust the number of words that will fit on each line.

� To modify text interword spacing

1. Select the text block containing the justified text.

2. Right click, and select Format Text from the context menu.

3. Access the General tab of the Text Properties window.

4. Make sure that the text alignment is set as Justified. Select a percentage value for the interword spacing.
This is a percentage of the normal interword spacing. To make the spacing smaller, select a number
that is less than 100%.
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Alignment to Character

Characters within a text box can be vertically aligned to the first occurrence of a user-defined character.
The characters in each line of text thereafter will line up, forming columns depending on the occurrence of
the user defined character to be aligned to.

� To enable character alignment

1. Right click the text to be aligned and select Format Text from the context menu.

2. Access the General tab of the Text Properties window.

3. Select Character from the Alignment drop-down menu.

4. Define the single character that will be used for alignment. A period is commonly used to align a
column of numbers.

5. Click OK to apply the alignment and return to the form.

Attach to Box/Circle
Text blocks can be attached to boxes and circles. By attaching text to a box or circle, the user simplifies later
form modifications. The text block will remain attached during moving and resizing operations. The text
cannot be moved out of the box or circle unless it is detached first.

This attribute can be applied to a group of text blocks.

� To attach/detach text

1. Select text block.

2. Click Attach to Box/Circle on the Text Format toolbar to toggle between attached and detached.
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Attach to Artificial Box

Designer is able to automatically create an artificial box to which text, data, or an image can be tied.

� To tie to an artificial box

1. Select the form element, either text, data or an image, that will be attached to the artificial box.

2. Right click the form element, and select Format Text, Format Data, or Format Image from the context menu.

3. Access the General tab of the Properties window.

4. Enable the Attach to Box/Circle check box.

5. A pop-up box will appear, asking if a box should be created. Click Yes.

6. Click OK.

Positioning Text in Boxes/Circles
Text can be positioned in boxes and circles once they have been attached. The same procedure can be used
for repositioning text.

� To position text in box/circle

1. Select element.

2. Click Position in Box/Circle on the Text Format toolbar.

3. A matrix will appear showing the nine locations available for positioning.

4. Click the mouse pointer within one of the nine boxes to select a location.

There are nine positions available for positioning: Top-Left, Top-Center, Top-Right, Center-Left,
Center-Center, Center-Right, Bottom-Left, Bottom-Center and Bottom-Right.
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Positioning Margins

When positioning within circles, or rounded corner boxes, there are two different types of margins
available: squared and rounded.

� To select positioning margin
� Click Toggle Text Margins on the Text Format toolbar to toggle between squared and rounded margins.

Attach Element to Center Page
If there is no box defined, an element can be tied to the center of a page.

� To attach element to center of page

1. Select the element that will be attached to the center of the page.

2. Go to the Text Format toolbar and click the Attach to Box/Circle button, or go to the Format menu and choose
Tie Object.
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Breaking Text Blocks
Certain text attributes can only be applied to an entire text block; for example: underlining style, column
width, text direction, justification, etc. There are times in which multiple attributes need to be applied to
different sections of a text block. In these cases, it is necessary to break a text block into multiple text
blocks.

� To break a text block

1. Double click the text block to open the text block.

2. Highlight the text to be removed from the text block.

3. Click Cut to Clipboard from the Standard toolbar to remove the text.

4. Click Text Mode from the Drawing toolbar to invoke text mode.

5. Click left mouse button and drag to draw text region.

6. Click Paste from Clipboard from the Standard toolbar to paste text.

Default Text Setting
The default setting is available to set the default attributes of text blocks. There is a default set of attributes
for each form element. For text this includes alignment, text direction, spacing, attached status, etc. Setting
default text attributes causes future text blocks to have these default attributes.

� To set attribute defaults

1. Select Text from the Format menu or click the right mouse key and select Format from the context menu.

2. From the General tab of the Text Properties window, select the desired attributes and check the Set as
Default button.

142 Working with Text



Text Flow
Static or conditional text can be made to flow from one text block to another when the amount of text
exceeds the dimensions of the frame in which it is located. Text flow can be implemented before or after a
text block has been filled to capacity, but it must first contain some amount of text. Use the Create New Frame
button, located on the Data View toolbar, to define additional, linked frames.

Frames will be linked in sequential order, based off of the frame that is selected when the new linked frame
is created. If the original frame is selected, the next box will be numbered 1. If a second linked frame is
created, but the original box is still selected, the second box will be numbered 1, and the previous box will
be bumped to number 2.

However, if the first linked frame is selected when the second frame is created, the new frame will be
numbered 2, and the first one will retain its position as frame 1. This convention makes it possible to easily
insert frames into the flow order without having to rearrange what is currently on the page.

� To apply text flow

1. Select a text box containing text that exceeds the dimension of the frame.

2. Click the Create New Frame button.

3. Click the left mouse button to drag a new frame onto the page of the desired proportions.

4. Overflow text will flow into this new frame.

5. Define as many frames as necessary to accommodate and shape the text.

Text contained within linked text boxes can only be edited from the original box. All linked text boxes will
appear with a number on the upper left corner. This number denotes which place the box holds in the order
of linking. This number will be displayed when the original box is selected.
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Text Editing

Editing Text
Text editing can occur from within the text editor. This includes the ability to insert and/or remove
characters.

� To open the editor and edit text

1. Double click on the text block to be modified to invoke the text editor.

2. A cursor will appear to indicate edit mode. Scroll through the text using the keyboard or mouse as
necessary to make modifications.

3. Edit text as desired.

There are two edit modes: Insert and Overtype. To invoke Insert mode, press the <INSERT> key. Edit mode
will be indicated on the far right corner of the ribbon bar located at the bottom of the screen by the OVR
symbol.

Edit Commands to scroll through Text (Keyboard)

Command Keystroke

Scroll up or down a line, or left or right one character Up, Down, Left and Right arrow keys

Position at the beginning of the current line <HOME>

Position at the beginning of a text block <CTRL-PAGEUP>

Position at the end of a text block <CTRL-PAGEDOWN>

Position on the previous word. <CTRL-Left Arrow Key>

Position on the next word <CTRL-Right Arrow Key>
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Text Formatting

Working with Fonts

Proform Designer can be used to create bitmapped fonts from scalable typefaces. This will provide an easy
and quick expansion to your printer font libraries. Windows TrueType scalable fonts are available for use
within Proform Designer.

A bitmap font created from a scalable font in Proform Designer is of high enough quality to not require
character cells to be edited (e.g. cleaned up). This depends on the quality of the scalable font, size of the
created bitmap font (smaller fonts have less quality), and style and appearance attributes applied to the font.
Lytrod Software does have a more complete font tool, BitCopy, which provides such editing if necessary.
From within the text editor, font changes can be made on a character by character basis.

Importing Fonts

Existing bitmap fonts can be imported for use within Proform Designer. An imported font will
automatically be added to the resource set. The imported font will also be set as the current font in the font
list.
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� To import a font

1. Select Import from the File menu.

2. Select Font from the Import menu.

3. An open window will appear allowing file selection. Use the Files of Type drop-down to choose the
desired file type.

4. Select the file to be imported and click Open.

5. The Font drop-down list will now reflect the newly imported font as the current font.

Font Selection

The font selection list of the Text Format toolbar will contain a list with access to Windows TrueType,
OpenType, PostScript fonts, any bitmap fonts which have been imported, and the fonts that are being used
in the active form.

TrueType and imported bitmap fonts can be distinguished in the list by the symbols to the left of the font
name.

“TT graphic” = Windows TrueType font

“printer graphic” = Local Printer fonts

"PS graphic"= PostScript fonts

"OT graphic" = OpenType fonts

Bitmap fonts that are imported will not have a symbol to the left of the font name.

Imported fonts may be listed by the font’s file name or a family name, as specified in the resource set.
Allowing a group of fonts to be listed based on a family name decreases the length of the Typeface list,
making it easier to locate fonts. Choosing a font’s family name will display all of the available point sizes in
the Point Size drop-down menu.
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� To make a font selection from the toolbar

1. Double click on text block to be modified to invoke the text editor.

2. Cursor will appear to indicate edit mode.

3. Using the mouse, highlight the character(s) to be modified.

4. Choose font typeface and point size from the Text Format toolbar as follows:

� Choose typeface from the Typeface drop-down.

� Choose point size from the Point Size drop-down.

<OR>

� Press <ALT>< F10> keys together to make font selection from the typefaces and point sizes
listed.

� To make a font selection from the Format Font window

1. Select Font from the Format menu.

2. Select Font, Style and Point Size from the respective drop-down lists.

If you are designing forms for a metacode, PCL or XES output driver, there will be an additional option in
this window: Reverse Background. Enabling the Reverse Background check box will create a bitmap font
made up of white characters on a solid, black background.
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Restrict TrueType Fonts

Any TrueType fonts used in a form are converted to the appropriate bitmap font on output. If there is no
desire to use TrueType fonts, they can be removed from the font list so that they are not used accidentally.
This is done by enabling the Restrict TrueType Fonts check box in the Preferences window.

� To set restrict truetype flag

1. Select Preferences from the Edit menu.

2. From the Systems tab, check the Restrict TrueType Fonts check box.

Font Exchange

The font exchange tool allows users to quickly change the font of multiple text blocks in a form. It allows a
font substitution of a particular font for another font. For example, in a document in which Arial-12 was
used, Tahoma-17 Portrait can be substituted for Arial-12 Portrait. All text referencing Arial-12 would then
change to Tahoma-17.

� To exchange fonts

1. Select Font Exchange from the Tools menu.

2. Select the font to be exchanged in the Select Font drop-down.

3. Choose new font typeface, size, style and orientation from the corresponding menus. The font
chosen from these menus will now be reflected in the Change To edit box.

4. Click OK to accept font exchange operation.

The orientation change will only occur if the font being exchanged is the only font used in the text.
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Underlining, Bolding and Italicizing

From within the text editor, style changes can be made on a character-by-character basis. The style changes
available include underline, bold and italic.

Icon Style

Underline

Bold

Italic

� To make a style change

1. Double-click on text block to be modified to invoke the text editor.

2. Cursor will appear to indicate edit mode.

3. Select character(s) to be modified.

4. Click Bold, Underline and/or Italic as desired.

Underline Style

There is one underline style associated with each text block. If more than one style is required in a single
text block, the block must be broken into multiple text blocks as described in detail on page 142. Underline
style is further discussed on page 135.

Subscript and Superscript

Subscript or superscript can be applied to text on an individual character basis.

� To apply subscript or superscript

1. Highlight the character(s) to which you will apply the formatting.

2. Click either the subscript or superscript button from the Text Format toolbar.

Working with Text 149

Underline Style tab of the Text Properties window.



Text Color

Within the text editor, color changes can be made on a character by character basis.

� To change the text color

1. Double-click on text block to be modified to invoke the text editor.

2. The cursor will appear to indicate edit mode.

3. Select character(s) to be modified.

4. Click Palette on the Format toolbar to select text color or select Font from the Format menu to choose
color.

Color Exchange

The color exchange tool allows users to quickly change the color of multiple items in a form. It allows a
color substitution of one color to another. In other words, in a form in which red was used, red can be
substituted for blue. All selected items would then change to blue.

� To perform a color exchange

1. Select Color Exchange from the Tools menu.

2. Select the color to be exchanged in the Original Color drop-down.

3. Choose whether you wish to exchange the object color or fill color.

4. Select new color from the Change To Color drop-down.

5. Click OK to accept color exchange operation.
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Paragraph Indentation

Paragraph indentation may be specified for both data and text. The user may define a specific amount of
indentation for the data or text block, including negative indentation.

� To define paragraph indentation

1. Right click the text to which the indent will be applied, and select Format Text from the context menu.

2. Access the General tab of the Text Properties window.

3. Select the unit in which the indentation will be specified from the Unit drop-down in the Indentation
section of this tab.

4. Enter an indentation amount into the Indentation edit box. Entering a negative number will create a
hanging indent.
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Tabbing

Designer's tabbing support allows users to define relative and absolute positioning of tabs. Absolute tabbing
allows you to define different length tabs, each based upon the left margin of the text block. Relative tabs
will space the sequence at even intervals, as defined in the Tab Every edit box.

� To define absolute tabs

1. Enter the string of numbers, letters or words that will be separated by tabs onto the form. Do not
include spaces between the items that will be separated by tabs: this will cause the tabbing to be off.

2. Right click the text string and select Format Text from the context menu.

3. Access the Tabs tab of the Text Properties window.

4. Choose the tabbing unit from the Unit drop-down menu.

5. Enter the distance that the first tab will cover into the Tab Stop edit box. Click the Add button to add this
value to the Tab Stop list.

6. Repeat this process to add the additional tab stop values into the list.

7. Click OK to save the settings and return to the form.

8. Once the tab stops are set, they must be inserted into the text string. Enable the text editor, and insert
the tab stops at the appropriate locations throughout the text string.

� To define relative tabs

1. Enter the string of numbers, letters or words that will be separated by tabs onto the form. Do not
include spaces between the items that will be separated by tabs: this will cause the tabbing to be off.

2. Right click the text string and select Format Text from the context menu.

3. Access the Tabs tab of the Text Properties window.

4. Choose the tabbing unit from the Unit drop-down menu.

5. Enter the tab distance into the Tab Every edit box.

6. Click OK to save the setting and return to the form.

7. Insert the tabs into the text string at the necessary locations.
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Dot Leadering

Up to two dot leadering sequences can be applied to a text string. Enabling dot leaders disables tabbing.

� To define dot leadering

1. Type the string of numbers, letters or words that will be separated by dot leaders onto the form. Do
not include spaces between the items that will be separated by leaders: this will cause the spacing to
be off.

2. Right click the text string and select Format Text from the context menu.

3. Access the Tabs tab of the Text Properties window.

4. Enable the Leadered check box.

5. Type the character(s) that will be used for the leadering into the Character edit box.

6. Select the unit in which the column width will be defined from the Unit drop-down menu.

7. Enter a value into the Column Width edit box.

8. Choose a color from the Color drop-down menu.

9. Click OK to save the leadering settings and return to the form.

10. Invoke the text editor, and insert a tab into the text sequence where the dot leadering should appear.
Up to two dot leaders can be inserted per one line of text.
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Find and Replace

Find Word or Phrase

� To find a specific word or phase

1. Select Find from the Edit menu.

2. Type the word or phrase to be located in the Find what edit box.

3. Click the Find Next button.

Find and Replace Word or Phrase

� To find and replace a specific word or phrase

1. Select Replace from the Edit menu.

2. Type the word or phrase to be replaced in the Find what edit box.

3. Type the replacement word or phrase in the Replace with edit box.

4. Click Find Next, Replace, or Replace All as follows:

� Find Next will search for the text in the Find what edit box.

� Replace will search for the text in the Find what edit box and replace upon user confirmation of each
case.

� Replace All will simply search for the text and replace it in all cases with the replacement text.
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To cancel a search in progress, click the CANCEL button.

Match Whole Word Only

To match only whole words during find and replace operations, the match whole word option must be set.
If it is not set, matches will be found that contain the word even if within another word.

� To set match whole word option

1. Select Find or Replace from the Edit menu.

2. Check Match Whole Word Only.

3. Continue with Find and Replace operation.

Match Case

To match case during find and replace operations, the match case option must be set. If this option is not
set, upper and lower case differences will be ignored during find and replace operations.

� To set match case option

1. Select Find or Replace from the Edit menu.

2. Check the Match Case checkbox.

3. Continue with the Find and Replace operation.
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Character Map
A character map is available and allows you to quickly see which characters are in a specified font. You can
insert special characters, international characters, and symbols with the help of the character map. You can
also view the character code assigned to a character or symbol in the character map. That character code
can later be typed out on the numeric keypad to insert the character or symbol it represents.

Designer uses the Windows tool Charmap.exe to display the character map. If this tool has not been
installed, you will need to install this tool from your Windows Installation CD.

View the Character Map
In order to insert special characters, the user must first view the character map.

� To view the character map

1. Select Character Map from the Edit menu.

2. The character map for the current font will be displayed.

Change Font to be Viewed

� To change the font being viewed in the character map

1. Select Character Map from the Edit menu.

2. Select the font to be viewed from the Font drop-down menu.

�



Insert Special Characters
The main purpose of the character map is to allow quick insertion of special characters and symbols.

� To insert special characters

1. Select Character Map from the Edit menu.

2. Choose font from the Font drop-down menu.

3. Double click character or select character(s) and press Select.

4. Press Copy to copy character(s) to the clipboard.

5. Press Close to close character map.

6. Select Paste from the Edit menu to paste the character(s) from the clipboard.

� To insert special character using character codes

1. Select Character Map from the Edit menu.

2. Choose font from the Font drop-down menu.

3. Highlight the character to be inserted.

4. Note keyboard code listed in the Keystroke field.

5. Press Close to close character map.

6. Type out keyboard code for character to be inserted; for example Alt+ 0173, on the numeric keypad.
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Importing and Exporting Text

Importing Text Files

If any formatting has been applied to text in another program, text should be imported as RTF. RTF files
will maintain any formatting applied.

� To import a text file

1. Click Import Text from the Drawing toolbar.

2. To import a text file from a different folder other than the default, click a different drive in the Look in
box, or double-click a different folder in the folder list.

3. Select the text file format of text to be imported from Files of type drop-down. Available formats
include .TXT (ASCII Text), .RTF (Rich Text Format)., and .DOCX (Microsoft Word Document).

4. Select the file to be imported and click Open.

5. Click the location on the form where text should be inserted.
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Exporting Text Files
Text blocks can be exported from Proform Designer.

� To export a text file

1. Select the text block to be exported.

2. Select Export from the File menu.

3. Select Text from the Export menu.

4. To save the text in a different folder other than the default,
click a different drive in the Save in box, or double-click a
different folder in the folder list.

5. To save the document in a new folder, click Create New Folder.

6. In the File name box, type a file name for text.

7. Select text file format from Files of type drop-down. Available formats include .TXT (ASCII Text) and
.RTF (Rich Text Format).

8. Click the Save button.

If you would like to export multiple text blocks, join blocks together and then proceed with export
operation.

Spell Checking
A spell checker is available to spell check the text on an individual form basis. It will look for spelling
mistakes, capitalization errors, and duplicate words. The user can spell check an individual text block, a
group of text blocks, or an entire form. If a text block(s) is not selected, the entire form will be checked
when running the spell checker.

� To run the spell checker

1. Click Correct Word Spellings button or select Spell Checker from the Tools menu.

2. Unknown words will appear in the Not in Dictionary field. The user then has several options involving
the unknown word. The additional options are all outlined on the following page.

3. Click the Done button to end spell checking.

Change Word

1. Click the Correct Word Spellings button or select Spell Checker from the Tools menu.
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2. The unknown word will appear in the Not in Dictionary field.

3. Suggested replacements will appear in the Suggestions list. The closest match to the unknown word will
be placed in the Change To field.

4. Change the word to one of the suggested replacements as follows:

� To change the word to the word in the Change To field, click the Change button.

� To change the word to a word in the Suggestions list, select the word from the list so that it is
defined in the Change To field. Click the Change button.

5. Change the word if not found in the suggested replace as follows:

� Click on the Change To field, and type in the corrected word.

� Click on the Change button.

Ignore Word

1. Click Correct Word Spellings or select Spell Checker from the Tools menu.

2. The unknown word will appear in the Not in Dictionary field.

3. Suggested replacements will appear in the Suggestions list. The closest match to the unknown word will
be placed in the Change To field.

4. Click the Ignore button to ignore the unknown word.

5. Click the Ignore All button to ignore the unknown word throughout the form.

Add Word to Dictionary

� To add a word to the custom dictionary

1. Click Correct Word Spellings or select Spell Checker from the Tools menu.

2. The unknown word will appear in the Not in Dictionary field.

3. Suggested replacements will appear in the Suggestions list. The closest match to the unknown word will
be placed in the Change To field.

4. Click the Add button to add the unknown word to the custom dictionary. The Spell Checker will
continue looking for misspellings without reporting this word as misspelled again. Words in the
custom dictionary can be viewed or edited by clicking the Options button and selecting the Custom
Dictionary tab.
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Spell Checking Options

Custom Dictionary

� To use a custom dictionary

1. Click Correct Word Spellings or select Spell Checker from the Tools menu.

2. Click Options to define spell checking options.

3. From the Spelling Options dialog, check the Custom Dictionary box to activate the custom dictionary.

Select Language Dictionary

There are ten different language dictionaries currently available, including English, French, UK-English,
German, Spanish, Italian, Swedish, Danish, Dutch, and Norwegian.

� To select a language dictionary

1. Click Correct Word Spellings or select Spell Checker from the Tools menu.

2. Click Options to define spell checking options.

3. From the Spelling Options tab, select Language Dictionary from the Language drop-down.

Ignore Capitalized Words

Many words that begin with a capital letter may be names or places that are not included in a standard
spelling dictionary. When using the spell checker, you have the option of bypassing all words that contain a
capital letter. This optional setting will save you time in the spell checking text that contains capitalized
names whose spelling can be ignored.

� To ignore capitalized words

1. Click Correct Word Spellings or select Spell Checker from the Tools menu.

2. Click Options to define spell checking options.

3. From the Spelling Options tab, check Ignore Capitalized Words to ignore all words containing capital letters.
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Modify Custom Dictionary

� To modify custom dictionary

1. Click Correct Word Spellings or select Spell Checker from the Tools menu.

2. Click Options to define spell checking options.

3. From the Custom Dictionary tab, the user can add or remove words from the custom dictionary.

� To Add words, type word to be added in the Add Word edit box and click the Add button.

� To Remove words, select word from the dictionary list and click the Delete button.
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Chapter 6

Working with Images

Proform Designer allows the import of most image formats. File formats supported include Zsoft
PC Paintbrush (.pcx), Tagged Image File Format (.tif), JPEG (.jpg), Windows Bitmap (.bmp), Raster
PDF uncompressed (.pdf), Adobe Photoshop (.psd), Portable Network Graphics (.png), TARGA

(.tga), and TIFF, IOCA, and FAX either uncompressed or compressed using CCITT and having different
groups and dimensions. It is also possible to import standard print-format graphics, including IBM Page
Segment (.psg), Abbreviated 9700 Graphic Image Xerox Adaptive Format (.img), HP PCL 4/5 Raster
Graphic (.pcl), Encapsulated PostScript image file (.eps), and Xerox XES Graphics Window (imx). Any
imported graphic will be converted to the proper print format when a form is saved. These image files are
then available in the resource set as default images.

Proform Designer can import images using either RGB or CYMK color values.

Placing Images on a Form
Images that have already been imported into the current resource set are available from the image
drop-down list on the text format toolbar.

� To use a previously imported image

1. Click Image List drop-down on the toolbar.

2. A list of image files in the resource set will be listed.

3. Select an image.

4. Click the location on the form where the image should be placed.
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Importing Images

Additional images can be imported while a form is open by choosing Import from the File menu. Upon
importing an image, the image will automatically be added to the resource set and be displayed in the Image

List drop-down on the toolbar.

� To import an image:

1. Click Import Image from the Drawing toolbar or select Import and Image from the File menu.

2. An open window will appear allowing file selection. Click the Files of type drop-down menu to set the
file type mask.

3. Select the file to be imported and click the Open button.

4. Click on the location where the image should be placed.

X/Y location is indicated on the ribbon bar, located at the bottom of the screen to assist in placing
elements in the correct location.

Selecting Images

In order to manipulate an image, it must first be selected.

It is often difficult to tell if you are positioned properly over a particular form element. Proform Designer’s
cursor will change to indicate proper positioning. The various cursor shapes indicate the type of element
that the cursor is positioned over.

� To select an image

1. From the Drawing toolbar, click Select Mode.

2. Position your mouse over the element to be selected and click the left mouse key. The cursor will
change according to the current object being selected.

Selected images will be displayed with selection handles. To select overlapping objects, it may be necessary
to de-select all objects prior to making selection.
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Moving/Copying Images

� To move using the mouse

1. Select the image(s) to be moved.

2. Position the mouse over the element(s) and drag element(s) to a new location.

� To copy using the mouse

1. Select the image(s) to be copied.

2. Position the mouse over the element(s)and drag element(s) to a new location while holding down the
<CTRL> key.

� To position element through the properties window

1. Select the image.

2. Select Image from the Format menu or click the right mouse button and select Format Image from the
context menu.

3. From the Size and Position tab of the Properties window, specify X and Y coordinates of the image origin

(Top Left corner).

Images, like text, can be attached to a box/circle. If an image is attached it must be detached before
moving. See Attaching to Box/Circle on page 205 for more information.

Resizing Images

� To resize using the mouse

1. Select the image to be resized.

2. Position the mouse pointer over the appropriate handle and drag to new size.

When resizing images, corner handles resize both width and height proportionally. Center handles resize
width or height respectively. Holding down the Alt key while resizing will preserve the aspect ratio.
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� To resize through the Properties window

1. Select an image.

2. Select Image from the Format menu or click the
right mouse button and select Format Image
from the context menu.

3. From the Size and Position tab of the Properties
window use the arrow keys to specify width
and height.

� To scale through the Properties window

1. Select an image.

2. Select Image from the Format menu or click
right mouse key and select Format Image from
the context menu.

3. From the Size and Position tab of the Format
menu use the spin arrows to specify scaling
percentages.

4. Check the Maintain Aspect Ratio box to scale
proportionally.

Cropping Images

After importing an image into Proform Designer, it is possible to crop it to a desired size.

� To crop an imported image

1. Right click the image and select Format Image from the context menu, or select Image from the Format
menu in the menu bar.

2. Access the Appearance tab of the Image Properties window.

3. Select which unit you would like to use when making the crop specifications: inches, centimeters, dots
or grids.

4. Enter the amount that you want to crop from each side of the image into the Crop From Edge fields.

5. Click OK to apply the crop specifications and return to the form.
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Editing Image Appearance

It is possible to modify the brightness and contrast levels, as well as to sharpen the look of an image.

� To edit the appearance of an image

1. Right click the image and select Format Image from the context menu, or select Image from the Format
menu in the menu bar.

2. Access the Appearance tab of the Image Properties window.

3. Use the Brightness, Contrast and Sharpen sliders to choose new levels for the selected image, or enter a
value into the field to the right of the sliders.

4. Click OK to apply the changes and return to the form.

Image Borders

Image borders can be defined in the Properties window. The border will be automatically resized with the
image if the image is resized.

� To define an image border

1. Select and right click the image to which the border will be applied.

2. Select Format Image from the context menu.

3. Access the General tab of the Image Properties window.

4. Go to the Border section, at the bottom of the window.

5. Define a Border Type, Thickness and Color.

6. Click OK.
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External File Option

When creating PCL/PS and XES forms, there is an option to
include all resources in the form file being created. Typically,
the logo/image information is embedded in the form file and
an actual stand alone file is not created. To isolate a particular
image for the creation of a separate image file, the external file
option is available.

� To create a separate external image file

1. Select a logo/image.

2. Select Image from the Format menu.

3. Check the Keep External File check box in the General tab of
the Image Properties window.

Image File Type Conversion

The image file type can be changed through the Convert Images menu.

� To change the image file type

1. With no forms open, select File>Convert>Images.

2. Choose an image to be converted
from the Image drop-down, or import
a new image using the Import button.

3. The File Name and Final File Name boxes
will be populated with the original
image name. To change the image
name, do so in the Final File Name box.

4. Choose the file type that the image
will be converted to using the File of
Type drop-down.

5. Click Convert.

6. A new image will be created based on
the defined conversion settings.
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Rotate/Flip Images

Images can be rotated by any user defined angle
through the image properties window, or to a
pre-defined angle by using the Flip/Rotate window.
Images can also be flipped horizontally or vertically.

� To rotate an image to a pre-defined angle

1. Select an image to be rotated.

2. Select Rotate from the Tools menu

3. Mark the rotation angle (0,90,180,270) radio button.

� To flip an image

1. Select image to be flipped.

2. Select Rotate from the Tools menu

3. Check appropriate flip option (horizontal/vertical).

� To rotate an image to a user-defined angle

1. Select the image that will be rotated. There are several menus from which you can rotate the image:

� Right click the image and select Rotate in Degrees from the context menu.

� Right click the image and select Format Image from the context menu. Access the Appearance tab.

� Select Image from the Format menu in the menu bar. Access the Appearance Tab.

2. Enter a rotation angle into the Rotation field.

3. Click OK to apply the rotation and return to the form.
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Working with Multiple Page PDF Files

Designer supports the import of *.pdf files as an image. A single page of the PDF must be chosen per
image (or sometimes form). Once a *.pdf file has been imported into Designer, it is possible to scroll
through the pages and select the desired page. The PDF image will be placed on the form with the same
dimensions as the original PDF page. Once the PDF is placed on the form it can be resized and rotated.

Designer will automatically convert *.pdf images placed on the static form plane to *.jpg upon output to a
VI Compose job. PDF image can be placed in the background plane for view, but not print. PDF images
must be converted to *.tif, *.jpg, *.eps prior to import onto the form page if they are to be referenced as a
data-driven concatenated image or conditional image.

� To import a PDF

1. Go to the Drawing toolbar and click the Import Image button.

2. Choose a PDF file and click Open.

3. Left mouse click on the form to place the PDF image. The first page of the PDF will display.

� To choose a page in the imported PDF image

1. Select a PDF image placed on the form.

2. Right-click and choose Change Page from the context menu. The Extract Image from Multiple Pages window
will appear. It will display the name of the PDF file and the current page number.

3. The Previous Image and the Next Image buttons can be used to move backward and forward through the
pages of the PDF. Or, key in the page number of the PDF in the Image Number prompt.

4. After choosing the desired page, click Close to close the window. The PDF page selected display on
the form.

Multi-page PDFs can be directly imported in a VI job and automatically split into separate form source files
(*.FSL). Refer to Chapter 8: Creating Jobs and Saving to VI Compose.
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Working with Logos
A logo is essentially an image that is stored in a font format. The image is broken into tiles, one tile per
character cell, which are used to rebuild the image. Most printers restrict the dimensions of a logo and
require that they are only one color. For this reason, the logo format is most appropriate for small, simple
images, such as company logos. There are several benefits to the logo format when an image fits this
criterion.

Once imported, logo files are handled just as any other image, including the ability to resize and scale. There
are several output options based on image size, printer capabilities and the resource set default settings.
Images within the logo size limits can be saved as a logo or an image. This is determined by the logo
specifications in the resource set.

Some Xerox printers require additional hardware in order to print images. If the selected printer does
support the IMG format, images (that meet the logo specifications) can be created as an LGO or IMG. If
the IMG format is not supported, images exceeding LGO limits must be saved in the FNT format.

� To enable logo specification

1. Close all forms.

2. Select Resource Set from the Edit menu.

3. From the Images tab of the Resource Set
menu, select the desired image.

4. Select Logo in the Convert To drop-down box.

5. Click the Yes button in the Convert Image to
Logo window.

6. Define the parameters of the logo file.
Click the OK button to accept.

Once an image has been defined as a logo, the Properties window will be labeled Logo Properties when working
with that logo.
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Color Logos

One advantage to saving an image in logo format is the ability to colorize a logo within a form. When color
is applied while designing the form, all colors in the logo are converted to the selected color. For this
reason, this is best done with solid logos.

� To colorize a logo

1. Select image.

2. Select Image from the Format menu or click right mouse button and select Format Image from the
context menu.

3. From the General tab of the Properties window, select the desired color from the Color drop-down menu.

Xerox HighLight Color printers allow for more options when colorizing logos, including support for
two-color logos. Please see HighLight Color Images and Logos in this chapter.

HighLight Color Images
Xerox HighLight Color printers provide support
for one color and two color images. One color
images are Xerox HighLight Color images
comprised of only the HighLight Color or black.
Two color Images are Xerox HighLight Color
images comprised of a combination of two colors,
the HighLight Color and black.

� To define highlight color images

1. Select image.

2. Select Image from the Format menu or click
the right mouse button and select Format
Image from the context menu.

3. From the Appearance tab of the Properties
window, select One-Color or Two-Color.

Additional options in the menu will become available based on this selection.
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� To define one color options

When one color is selected, select the desired color
from the Appearance drop-down. Additional options
include:

� Shaded – Images are dithered to create a
shading affect. This makes the image
appear to use more than one shade of the
selected color.

� Solid – All colors in the image are converted
to the selected color creating a solid, not
shaded, affect.

� To define two-color options

When two color is selected, options include:

� Extract – The dominant color in the image is
converted to the HighLight color. All other
colors are converted to shades of gray.

� Convert – All colors in the image are
converted to the HighLight color. Black
and shades of gray are maintained.
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Working with Background Images
Backgrounds can be imported into Designer to be used as visual aid in the design process. Many times the
background images will represent preprinted stock, and will only be viewed on screen and not printed.
However, the option always exists to define a background printing image as well, to be printed with the final
application. Designer has the ability to import backgrounds from other design packages, such as Quark,
PageMaker, InDesign, etc.

Importing Background Images
Images can either be set to the background plane or initially imported as a background.

� To import a background image file

1. Create a new form or open an existing form

2. In the File menu, go to Import and then select Background.

3. In the Images directory, choose the appropriate image file to set as a background and click the Open
button to accept.

4. The image will appear on the form at the origin point (top left).
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Setting an Image to the Background Plane
Images already placed on the form can be set to the background plane.

� To set an image as a background

1. Select the image that is to be added to the background plane.

2. Right-click the mouse and select Background Plane.

Editing Background Images
Images placed on the background plane can be
selected for modification (moving, resizing,
deleting, calling printing image) once the
Background Plane option is selected from the
Edit menu. Background images selected will then
have a special fly-by graphic to distinguish them
from non-background images.

Reference a printing image from an image
already set to the background plane

Background images can be edited to reference an
image file for printing (.EPS or .PS).

� To reference a printing image

1. Make sure that the View menu Plane option
for Background is selected.

2. From the Edit menu select the Background
Plane option.

3. Select the desired background image.

4. Right-click and select Format Image.

5. In the General tab of the Image Properties window, key in the printing image file name in the Printing Image
edit box or browse for the image file by clicking the ellipses (...). Click the OK button to accept.

It is also possible to create conditional background images and non-multi-up background images. For more
information about conditional images and conditional background images, please see Chapter 7:
Personalized Documents. For more information about creating non-multi-up background images, please
see Chapter 8: Creating Jobs and Saving to VI Compose.

Working with Images 175

(Background) Image Properties General tab

�





Chapter 7

Personalized Documents

V ariable data can be placed and formatted in Proform Designer for VI Compose enabled print
devices. VI Compose, also referred to as XGF or FreeFlow Core, is a PostScript merge engine
licensed by the Xerox Corporation. VI Compose (Variable-data Intelligent PostScript Printware) is a

PostScript-based language designed for creating dynamic documents. Proform Designer eliminates the
manual coding of the VI Compose language, which allows data to be interactively set up in conjunction
with the document design.

Be sure to check that VI Compose is enabled within your resource set. For more information see Chapter 2
- Resource Sets

Importing Data
Data can be imported from any ASCII file. The data import function will invoke a wizard that will walk you
through the various parameters required to use the data file (the wizard is explained in full in this section).
The data file is used by Designer in order to define the variable data scripting file (VI Compose code). It is
not necessary (and usually not desired) to have the entire data file imported. A small data file subset is
sufficient for the data design layout functions. The entire data file can be incorporated when it is time to
print.
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� To import a data file

1. Click the Import Data button from the Drawing toolbar, or go to the File menu and choose Import and then
Data.

2. In the Look in box, click the drive or folder location that contains the data.

3. Select the file to be imported. Either double-click the file or select a file and click the Open button.

4. The Data Wizard will assist in defining the data formats.

Only a single data file can be imported.

Data File Types
Proform Designer accepts line (host-based), delimited (database), and XML data files. Proform Designer
will attempt to auto-detect most of the attributes of a data file, but the settings should always be checked
for accuracy.

Data File Type

The preview window allows the data to be previewed in order to assist in the selection of either database,
line, or XML data file types. Once the data file type has been selected, click on the Next button to continue
through the Import Data Wizard.

� Data Base (Delimited) - Is created from database programs. Each data record is composed of a fixed
number of data fields. The data fields are determined by a delimiter, which is a special character
that defines one field from the next. The field names of the delimited file must be 127 characters
or less. All field names must be regular alphabetic text or alphanumeric (with at least one
alphabetic character). It is recommended that the first letter be capitalized, and the remainder of
the field name should be lowercase.

� Line Data (Print Ready) - Is typically found on the mainframe. Since line data files are flat text files, a
record break must be defined. Proform Designer supports fixed length records with either a user
defined record length, Printer Carriage Control (PCC) bytes, user defined hex characters, or a user
defined text string.
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� XML - Is a grammatical system for constructing custom mark-up languages. This type of data is
organized into a tree structure, and is often used to describe and organize genealogical,
mathematical, chemical or business data. Designer treats XML in the same manner as a
delimited data file. Each field is defined and will appear in the data drop-down menu after the
data file is imported.

Although VI Compose 4.0 and later uses [= name =] as the new field name identifier, $$name. must still
be used in Designer. The $ and . characters are accepted in field names in VI Compose.
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Create CSV Data Files
The ability to create simple numerical CSV (Comma Separated Value) data is available within your software.
This ability is usually used to create data files that are used for numerical counter sequences. For example,
when creating a ticketing application where each ticket needs to be uniquely numbered with a consecutive
value, but you do not currently have a data file that contains these values.

� To Create a CSV Data file

1. With no forms open, select the Edit button and choose Create CSV Data… from the drop-down menu.

2. The Create Delimited Data File menu will open.

3. Name your new data file, the *.csv extension will automatically be added upon output.

4. Define the number of data records to be created.

5. To begin creating field names, start by typing the name of the new field.

� Initial Value: Define the initial value (beginning value).

� Increment: Define the increment value. Default value will be "1".

� Length: Entering a value will create a fixed length value, adding preceding 0's to the initial value.

For example: If the Initial value entered was '100' and the Length was defined as '6', the first
value in the sequence would be "000100"

6. Click ADD to add this new field to the data file.

7. Continue defining fields in the same manner, if desired.

8. Click Build File to create your data file. It will automatically be saved in the Data folder that is defined in
the current Resource Set.
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Importing Database Data
Database data must be further defined by specifying the field delimiter, text qualifier, or maximum record
length. By clicking the View Data button from the first window in the Import Data Wizard, it is possible to
view the entire data record while it is being imported. This makes it much easier to define the correct data
parameters during import.

Field Delimiters

� If the delimiter is a Tab, Colon, Semi - Colon, or Comma, then select the appropriate radio button.

� If the delimiter is another character, then that single character should be entered in the Other field.

� If the delimiter is a non-printable character, then enter a slash ‘/’ followed by the decimal value of the
character in the edit field to the right of the Other radio button.

Field Delimiters Parameters



Database Delimited Parameters

� A Text Qualifier is used if any of the data has double or single quotes surrounding it. By selecting a text
qualifier, the quotes will not appear when your data is printed. By setting the text qualifier to (none), any
quotes in the data will remain intact.

� The Maximum Record Length must be set to at least the number of characters of the longest line in your data
file.

Importing Database Data without Field Names
If the delimited data file (e.g. csv) does not contain a header record of Field Names, this data can still be
handled by defining the names manually.

� To define Delimited data Field Names

1. Click the Import Data button, or go to the File menu and choose Import and then Data.

2. Select the desired data file.

3. The Data Wizard will appear. Select Data Base (Delimited) as the data type to be imported. Click Next.

4. In the Data Base Delimiter menu, select Comma as the delimiter.

5. Still in the Data Base Delimiter menu, select the Define Field Names button.

6. In the Data Base Field Names Definition menu:

� Add each field names by typing the field names one by one, clicking Add each time. Field names
must be entered in the order that they will appear within the data file. If you are unsure of the
correct order, click the View Data to see a preview of your data file.

� Remove field names by selecting the field name in the list and clicking the Delete button.

� To arrange field names that have already been entered, use the Up and Down arrows.
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Importing Line Data
Because line data files are flat
text files, a record break must
be defined. Proform Designer
supports fixed length record
breaks, Printer Carriage Control
(PCC) byte record breaks, user
defined hex character record
breaks, user defined text string
record breaks, and search area
record breaks. If the page being
designed is part of a multi-page
job, then further job properties
must be defined.

Define a Record Break Type

� Fixed Length - Records have a fixed Lines Per Page value that can be specified to denote the size of the record
breaks.

� ASCII Value -The record break may be any single character except a null byte.

� Text String - A specific string of text reoccurs throughout the data to signal a record change. The text
string must be specified in the Text String field.

� PCC Bytes - The first column is reserved for printer codes such as page breaks, etc. Custom printer
controls can be assigned using the VFU (vertical form unit).

� Channel 1 On - A text match at the beginning of a line causes a skip to channel 1. This record break is
similar in function as a multi-byte PCC, where the PCC column can still be accessed for the document
design.

� Search Area - a text match found within the designated search area will serve as the record break. This is
similar in function to the text string record break. However, applying the search area function will cause
Designer to only use the defined text when it is found within the specified Search Area, even if that text
is found in other locations on the page. This method is only available once data has been defined and a
search area has been created. Then, the record break can be edited.
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Job Properties

� If a multiple page job is being defined, and the same data record will be printed over multiple pages,
then you must define a starting record to indicate which page this will be in the job. For example, if you
are creating a 4 page job, and this is going to be page 3, then the Starting Record is 3.

� Define the Record Interval (typically the number of records for each set). For example, if the job contains
4 pages, then the record interval is 4.

Working with Printer Carriage Controls (PCC bytes)

PCC bytes can be assigned to a particular channel or to relative skips. Proform Designer supports ANSI,
IBM1403, IBM1403A, and user defined PCC bytes.

Predefined (non-modifiable) PCC bytes are as follows: 0 (skip 2 lines), 1 (new page), + (same line),
- (skip 3 lines) and space (skip 1 line). These preassigned PCC bytes can not be reassigned.

If Channel Assignments are used, then defining line data fields is not allowed. Only a full record can be
placed on a page. Formatting of line data fields must be applied using the search area conditions as defined
on page 255. Database fields can still be defined and used even if VFUs have been assigned.
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Page Break

If the line data file has an ASCII Value
or Text String as the record separator,
the Page Break Options will need to be
defined.

� Page break is on - Choose whether the
page break is on the first line of a
record or the last line of a record.

� Print portion of line - Choose which
portion of the line contains the page
break to print. The options are:

� Left if not empty

� Left

� Right

� Entire line

� None

� Multiple Breaks per Line - Select either Yes
or No to define whether there will be more than one break per line.

� The Page Break Code is generated automatically by the page separator choices made or may be entered
manually. This code is used for VI Compose output. (See your VI Compose documentation for its
meaning)

Line Data Parameters

� Maximum Record Size should be entered in terms of Characters Per Line and Lines Per Page. A maximum record
size is assumed by Proform Designer. If working with a sample of data rather than a complete data file,
or if using Fixed Length as a record separator, it is important to verify these values.

� Fixed Record Length (no cr/lf) -Designer supports data files that do not contain carriage returns or line feeds.
These files often appear to be a continuous line of data in a text editor. By selecting Fixed Record
Length (no cr/lf)when importing line data, Designer will display carriage return/line feeds at the
maximum character position. The characters per line must be set accurately.

� Prefix Data is data that contains a group of characters in the same column of every line that is used to set
formatting and positions. Prefixes are useful for data that has transactional information which does not
end on a fixed line number. If prefixes are used in the data file, then check the Prefix box and specify
the starting column and length of the prefix.

� The Data Overprint option allows interpretation of a carriage return as just a carriage return. If this option
is not selected, then a carriage return is interpreted as a carriage return, line feed.
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� The Tab Spacing option allows the use of fixed increment tabs and the expansion of tabs to spaces in line
mode display. The tab interval must be specified.

Data Definition Summary Window

The Summary window provides a list of the parameters given. Changes in parameters can be made by
clicking the Back button until the desired window is displayed. The Back button will not affect the other
previously set parameters which are saved unless re-entered. Click the Finish button if the information in
the Summary window is correct.

Search Area Record Breaks
Once the data file is imported and a search area is defined
(search areas are covered later in this chapter, on page 198)
you can edit the record break parameters to create a search
area record break.

� To define a search area record break

1. You will not be able to define this type of record
break during the initial import process. When the
wizard asks for a record break, define a text string to
serve as a placeholder.

2. Finish defining the data import specifications using
the data wizard.

3. Go to the data view window and define a Search Area.

4. Go the Edit menu and select Data Settings.

5. Enable the Condition radio button.

6. Select the Search Area from the drop-down menu, and enter the search value into the equals field.
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7. The data will now break whenever the defined text is found within the search area.

Importing XML Data
XML data can be imported into Designer as well. The data wizard will display an outline of the tree, and
allow you to select where the data break will occur. Once the data is imported onto the form, it will be
displayed in the same data view interface as a delimited data file.

� To import an xml data file

1. Go to the File menu and select Import and then Data.

2. Choose the xml file that you want to import.

3. Select the appropriate record to serve as data break from the XML Data Record Break window.

4. Click Next to proceed through the data import wizard.

5. The Summary window will appear before the
data file is imported into the form. This
outlines all of the previously defined
specifications. Review the definitions for
accuracy. If something needs to be modified,
click Back until the necessary information is
displayed. Make changes, and click Next to
proceed through the remainder of the
wizard. When everything is correct, click
Finish to import the data file.
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Working with Delimited or XML Data
Designer displays the current data record of either delimited or XML data in the Data View window on the
right side of the screen.

The Data View window can be closed to provide a full-screen view of the form. To open and close the data
view window, click the Toggle View Data Window button, located in the View toolbar.
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Delimited Field Definitions
When importing delimited data, the field names are extracted from the first line (or lines) of a data file. The
header record is used to identify individual fields of data. For example, if the data record appeared as
follows:

The first record would define the field names: Fname, Lname, Street, Secondline, City, State and Zip.

XML Field Definitions
When importing an XML data file, the field names will be defined from the data tree. These will then be
used as the individual data records when the data file is imported into Proform Designer. Each data record
will be displayed on the right side of the screen, as well as in the data drop-down menu, in the same manner

as a delimited data file.
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Data Layout

Data Placement on Form

Placing data onto a static form is the initial
step in formatting data. Placement onto the
form is done on an individual field basis.
Individual data fields can be used multiple
times on a single page. All fields in the data
file do not need to be used.

� To place a data field onto the form

1. Select the field to be placed onto the
form from the data drop-down on the
Data View toolbar.

2. Click the left mouse key at the desired location on the form.

Combining Text and Data

Data and text can easily be combined in the text
editor to take advantage of word-wrapping,
alignments and other features.

� To place a data field into a text block

1. Enable the text editor by either creating a
new text block or double clicking the left
mouse button on an existing text block.

2. Position the cursor where the data field should be entered.

3. Select the field to be entered from the data drop-down menu on the Data View toolbar. The field name
will be entered into text preceded by $$ and with a trailing period. Once the editor is closed, the field
name will change to the actual data values.

When formatting a data field be sure to select the entire data field (preceding $$ and trailing .), or the
format change will not take affect.

When data fields are inserted in a text block, word-wrapping will occur dynamically upon merging the data
into the text.
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Embedded Fields

If a data file contains VI Compose fields within VI Compose fields, Proform Designer will evaluate the
fields until all have been filled with a data value.

� To initiate evaluation of embedded fields

1. Right click the data that needs to be evaluated.

2. Select Format Data from the context menu.

3. Access the General tab of the Data Properties window.

4. Enable the Embedded Fields check box.

5. Click OK to save the setting.
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Viewing Data

By default the data view will be active, meaning that the actual data will be seen on the form rather than the
field name. The view can be toggled to view the field names or actual data.

� To toggle data view

� Click View Data from the View toolbar.

� To Preview Data Records

Tools are available to scroll through data records for preview purposes. To scroll through data records click
appropriate scroll key to scroll through data as follows:

Key Action

Rewind data to the first record

Scroll backward one record

Scroll forward one record

Fast forward data to the last record

In order to preview data records, Data View must be enabled.
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Working with Line Data
Line data is typically found on a mainframe and consists of data that has been formatted to print on a static
background. Line data was originally designed to be printed on line printers, which are limited in their
formatting capabilities. Page position, in many cases, was limited to vertical paper movement and affective
use of “spaces.”

Proform Designer takes advantage of these line data file formats in its WYSIWYG interface. By using cut
and paste data placement techniques, data field definitions, and other functions, line data can easily be
formatted and integrated into the form design.

In the case of line data, the data drop-down menu will fill-in with “Entire Record” signaling proper
importation of the data. In the case of delimited data, the data drop-down menu on the data toolbar will
list the field names as explained in the previous section. In either case, user-defined variables will also
appear in this drop-down, following the field names.

View Line Data Window
In this view, a split-screen will
appear showing the static form in
one window and a record of the
line data in the other. The data side
of the window will show a grid in
the background denoting individual
characters.

� To view line data

1. Click View Line Data button
from the View toolbar.

2. Resize the data window as
needed by placing the cursor
over the left edge of the window and stretching to a new size. As the data window size increases the
form window will decrease.

When the entire record cannot be seen due to the size limitations of the data window, then use the scroll
bars to navigate the data record. The size of the window and the zoom percentage will be remembered
when a form is closed. Line data fields can also be defined so that the data window may be closed and data
placed using the data drop-down by field name. See page 194 for more detailed information.
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Line Data Placement
Placing data onto the static form is the initial step to formatting data. There are three ways line data can be
placed onto the form.

� Entire data record placement: The entire data record can be placed at the origin of the form in its
original format. In this case, all of the data would be in the same font and color.

� Selective data placement: Placing data onto the form is done by dragging areas of data from the data
window to the form window.

� Named data placement: Areas of data may be defined as a support type (area, database field, search
area, delimited field) and named. The field names may be placed onto the form the same way as
with a delimited data file.

� To place line data

1. Hold down the left mouse key while dragging the mouse over the area of data to be selected. The
selected data will appear highlighted.

2. Position the mouse over the selected data region. Hold the left mouse key down while dragging the
data to the form side of the window.

3. The data area will be placed at the top left corner of the data cursor.

Defining Line Data Areas and Fields
When working with line data, there is an option to set-up areas of line data as “fields” similar to how one
would work with a delimited data file. This is helpful when creating a data-intensive document in which the
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same piece of data is used in multiple places throughout the document. The user can then close the line
data window and continue working with data as they would with a delimited data file.

� To define line data areas and fields

1. Hold left mouse key down while dragging the mouse over the area of data to be selected. The
selected data will appear highlighted.

2. Click the right mouse key.

3. Select which type of data field will be defined from the context menu as follows:

� Define Data Area - Used to segment data area (can contain more than one line) for placement

� Define Database Field - Used to define a portion of a single line for conditional processing, data
driven graphics, or for placement.

� Define Search Area - Used to define line by line search conditions (defined later in this chapter).

� Define Delimited Fields - Used to extract information out of a single line of data.

� Define AutoSum Area - Used to define rows or columns of data for addition.

� Define Conditional Field - Used to search an area of line data for a condition to be true.

� Define Variable - Used to define custom fields and counters (discussed later in this chapter).

� Edit Fields - Used to edit defined fields
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Data Areas

More than one line of data can be defined as a data area. Entire data areas can have a single font style and
color defined.

� To define a data area

1. Highlight the area of data to be defined as a Data Area. Right click on the highlighted data and choose
Define Data Area.

2. Enter the data area name in the Name field.

3. Edit the data area parameters in the Starting and Ending fields to change the field size (if different than
what is drawn in the Line Data Window).

4. Define any necessary field extractions.

� Enable the Extract check box.

� Define a separator. This will be the character that Proform looks for to split one field from
another, such as a space or dash.

� Enter the number of the field that should be separated. If the field contains the name, Jane Jones,
and you want to separate Jane from Jones, you would select field number 1. Jones would be field
number 2.

� This feature also allows you to separate fields from columns of data. By creating a multi-line data
area and defining a separator and field, you can create a new data area that contains only a portion
of the selected section.

196 Personalized Documents

Right click on highlighted data and choose:
Define Data Area



Defining Database Fields

Only one line of data can be defined as a database field. Line data is defined as a database field for use with
conditional text and image functions, custom variable fields, and data driven graph creation.

The defined field name must be 127 characters or less. All field names must be regular alphabetic text or
alphanumeric (with at least one alphabetic character).

� To define a database field

1. Highlight the area of data to be defined as a Database Field. Right click on the highlighted data and
choose Define Database Field.

2. Enter the data area name in the Name field.

3. Edit the Database Field contents through the Starting Column, Ending Column and Line Number fields.
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Define Search Area Columns

Search area columns can be defined for line-by-line conditional formatting functions explained later in this
chapter.

� To define a search area

1. Highlight the area of data to be defined as a Search Area. Right click on the highlighted data and
choose Define Search Area.

1. Enter the search area name in the Name field.

2. Edit the columns through the Start Column and End Column fields. Each row will be searched. The use of
the search area is further defined later in this chapter.

Define Delimited Fields

The define delimited fields feature is used to define fields from a single line contained in a line data file.
This is similar to the way that data is defined in a database file. Individual lines in the line data file can be
separated by delimiters, and defined into fields like a database file.

� To Define Delimited Fields

1. With the mouse pointer, select the desired row
of line data from the data window.

2. Right click the mouse, and select Define Delimited
Fields from the context menu.

3. Select the Field Delimiter type. The Field Delimiter
can be a tab, colon, semi-colon, comma, or
other specified delimiter.

4. Give the data field a name. Add or Delete the
defined field names as needed.

5. Click the OK button to accept the changes.
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AutoSum Variable

The AutoSum feature can be used in line data mode to add the contents of selected areas of data and store
them as a variable

� To define AutoSum area

1. Highlight the desired area of line data.

2. Right click to show context menu.

3. Choose Define AutoSum Area from the context menu.

4. The AutoSum Area window will appear.

5. Define the variable name, and starting and ending coordinates if different from the highlighted area.

If the contents selected for the AutoSum field are not numbers, the job will abort at printing. Commas and
dollar signs cannot be included in an area defined for addition, but decimals are allowed.
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Conditional Field Variable

Conditional field variables can be used in line data mode to search a defined area of line data for a
condition to be true and then assign that information to a variable. This operates in much the same way as
Define Search Area, but in this case a condition can be applied to obtain a value that is stored in a variable.

� To create a conditional field variable

1. Define a Search Area.

2. Highlight an area of line data.

3. Right click and select Define Conditional Field from the context menu.

4. The Conditional Field window will appear.

5. Assign a Name to the variable.

6. Verify that the Start and End column values are correct.

7. Select the Data Row Offset value. This is an offset from the row where the condition is first true. For
example, a value of -1 will assign the information from the previous row to the variable.

8. Define a condition.

9. Click OK.
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Edit Line Data Fields

Once areas of line data have been defined as fields, there is an option to edit the defined fields. The name
of the field and the area included in the field can be modified. Data fields can also be deleted if not
currently in use in your form.

� To edit line data fields

1. Click the right mouse key over the line data window.

2. Select Edit Variables from the
context menu.

3. Select the data field to modify
from the list of available
fields/variables.

4. To change the name, double
click on the Field name and
retype the name. Click OK to
save..

5. To change the area, select the
Field from the available
Fields/Variables list and modify
the Starting and Ending
coordinates.

6. Click the OK button.

� To delete a line data field

1. Click the right mouse key over the line data window.

2. Select Edit Variables from the context menu.

3. Select the data field to delete from the list of available Fields/Variables.

4. Click the Delete button (red X) in the top right corner of the list.

5. Click the OK button
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Formatting Data
Formatting the data can be done once the data has been placed onto the static form. All operations are
done by selecting data from the form window and formatting as described.

Selecting Data Fields
In order to manipulate a data element, it must first be selected. Proform Designer’s cursor will change to
indicate proper positioning in order to make it easier to select form elements. The various cursor shapes
indicate the type of element that the cursor is positioned over.

� To select data

1. Go to the Drawing toolbar and click Select Mode.

2. Position your mouse over the data to be selected and click the left mouse key.

Selected data will be displayed with selection handles. To select overlapping objects, it may be necessary to unselect all objects
prior to making selection.

Moving and Copying Data
It may be necessary to relocate a data element or copy a data field to another location once it has been
placed onto the form.

� To move a data element using the mouse

1. Select the data element(s) to be moved.

2. Position the mouse over the data and drag to a new location.

� To copy a data element using the mouse

1. Select the data element(s) to be copied.

2. Position the mouse over the data and drag to a new location while holding down the <CTRL> key.
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When moving and copying using the mouse, grid snap will affect the interval in which the element is moved
or copied. Grid Snapping is described in detail on page 96.

� To position data through the properties window

1. Select the data.

2. Select Data from the Format menu or click the right mouse button and select Format Data from the
context menu.

3. From the Size and Position tab of the Data Properties menu use the arrow keys to specify position (X and
Y coordinate). The X/Y coordinate for data represents the origin or top left corner.

The current unit of measure is shown in the Unit drop-down menu. Units of measure available are grids,
inches, centimeters and dots.

Deleting Data

� To delete data

1. Select the data element(s) to be deleted.

2. Press the <DELETE> key on the keyboard or right-click the mouse and select the Delete option.

Data Rotation
Data elements can be rotated by 90 degree increments.

Please see Rotate/Flip Images for additional information 169.

Font Selection
Multiple data fonts can be specified on each page with one font used for each data element. In the case of
delimited data, where multiple data fields are included in a text block, each individual field can be formatted.
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� To select data font

1. Select the data.

2. Choose font typeface and point size from the Text Format toolbar as follows:

� Choose typeface from the Typeface drop-down.

� Choose point size from the Point Size drop-down.

Icon Style

Underline

Bold

Italic

� To apply character styles

1. Select the data.

2. Click the Bold, Underline, and/or Italic buttons as desired.

Data Color

� To change the data color

1. Select the data.

2. Click the Palette button on the Format toolbar to select text color, or select Font from the Format menu
to choose color.

Line Spacing
Predefined line spacing options include single, 1.5 and double line spacing. The custom option allows other
line spacings to be defined in the Custom Line area.

� To define line spacing

1. Select the data to be formatted.

2. Select Data from the Format menu.

3. From the General tab of the Data Properties window, choose line spacing from the Line drop-down or
specify Custom line spacing.

The value shown in the Custom field is represented in the unit selected in the Unit drop-down box.
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Attach Data to Box/Circle/Center of Page
Data can be attached to boxes and circles on the static form. By attaching data to a box or circle, the user
simplifies later form modifications. This feature can be used to center data directly in the middle of a page,
as well. The data will remain attached during moving and resizing operations. The data cannot be moved
out of the box or circle unless it is detached first.

� To attach/detach data to existing box or circle

1. Draw a box or circle on the form where you want the data to be attached.

2. Select the data.

3. Click the Attach to Box/Circle button on the Text Format toolbar to toggle between attached and detached.

� To attach/detach data to an artificial box

1. Place the data in the desired location on the
form.

2. Select Data Object from the Format menu, or right
click the data and select Format Data from the
context menu.

3. Enable the Attach to Box/Circle check box, located
under the General tab of the Data Properties
window.

4. The following message will appear. Click Yes to
have Designer create a box for you.

5. Select the placement location and margin
specifications from the Placement and Margin
drop-down menus.

6. Click OK.

� To attach data to the center of a page

1. Select the data that you will attach to the page.

2. Either right click the data and select Tie Object from the context menu, select Tie Object from the Format
menu, or click the Attach to Box/Circle button from the Text Format toolbar.

3. If there is no box defined for the data to be attached to, the data will be attached to the center of the
page.
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Positioning Data in Boxes/Circles
Data can be positioned in boxes and circles once it has been attached. Data can also be repositioned using
the same procedure.

� To position data in box/circle

1. Select the data.

2. Click the Position in Box/Circle button on the Text Format toolbar.

3. A matrix will appear showing the nine locations available for positioning.

4. Click the left mouse button in the location where the data will be placed.

There are nine positions available for positioning: Top-Left, Top-Center, Top-Right, Center-Left,
Center-Center, Center-Right, Bottom-Left, Bottom-Center and Bottom-Right.

Positioning Margins

When positioning within circles, or rounded corner boxes, there are two different types of margins
available: squared and rounded.

� To select positioning margin
� Click Toggle Text Margins on the Text Format toolbar to toggle between squared and rounded margins.

There is a default set of attributes for each data element. For data this includes alignment, line spacing,
attached status, etc. Setting default data attributes causes future data elements to have these default
attributes.
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Scale to Fit Data in Box
When a data area is attached to a box, this feature allows the data font to be scaled down automatically if
the data cannot fit in the box using the defined font size. When this feature is enabled, the data will be
placed in the top-left corner of the box and scaled down to fit within the parameters of the box. This
feature greatly simplifies the design process for multi-up applications.

Resizing will only occur if the data needs to be reduced in width. If the data exceeds the height of the box,
scaling down will not result.

� To apply a data scale-down

1. Place a data area on the form.

2. Draw a box around the data area. The borders of the
box can be set to zero line thickness to make the
box invisible.

3. Attach the data area to the box using the Attach to
Box/Circle button. Or, select the data, right click, and
select Tie Object from the context menu.

4. Select the data, right click, and select Format Data from
the context menu.

5. Access the General tab of the Data Properties window.

6. Enable the Reduce to Fit in Box check box.

Data Border
Data border and fill can be defined in the Border/Fill tab
of the Data Properties window. The border style, thickness and color can be selected, corners can be
rounded to user defined levels, and fill/shading can be defined.

� To set a data border

1. Right click in the data area and select Format Data.

2. Select the Border/Fill tab from the Data Properties window.

3. Select desired border and corner styles. Selecting a border style of None will create a blue box on the
page that will not print.

All corners must have the same degree of roundness.
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Data Alignment within a text block
When data is defined within a word-wrapped text block, empty lines are automatically removed, causing
non-empty data lines to move up higher in the text block. While this is a common need, sometimes Right
or Center alignment of the data block is needed without empty text lines disappearing. In order to use
these alignment settings in a text block where word-wrapping is removed, the column width of the data
block needs to be defined.

� Setting a Data Column for use with Alignments

1. Right click on the data block containing the data to be aligned.

2. Select Format Data. The Data Properties menu will appear.

3. Select the Size and Position tab.

4. Select the Use for alignments check box. When this checkbox is checked, the Column field may be edited
with a value depending on the current Unit. When the data block is word-wrapped, the Use for

alignments checkbox is not shown and the Column field shows the width of the column, but is not
allowed to be edited. Data alignments are only enabled when this checkbox is checked or when the
data block is word-wrapped.

Show Data as 2D Barcode
Proform Designer allows you to format your data as five different types of 2D barcodes: PDF417,
MaxiCode, DataMatrix, Intelligent Mail BarCode and QR Codes.

2D PDF417 BarCodes

Designer can be used to create 2D PDF417 BarCodes. PDF417 BarCodes store a large amount of data
(around 2000 characters) in a symbol, which can be read and decoded by a 2D scanner. PDF417 BarCodes
are an industry standard for encoding data and are supported by every printer. In Designer, data can be
dropped onto a form and converted to a 2D BarCode. Compression, error level, row, column and aspect
can then be set to user-defined levels.
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Data converted to a 2D BarCode will appear as a shaded data area within Designer, but it will print as a 2D
BarCode. If you are using a version of FreeFlow VI Compose prior to 8.0, the PDF417 capability is a
separate module (xgf.417) in VI Compose and deactivated by default to decrease the use of system
resources. To activate the PDF417 capability, edit the src/xgfdos.run or src/xgfunix.run file by following
the path: C:>vide3>xgf>src>xgfdos.run, and uncomment the line by removing the “%” character. This
must be done before the PDF417 feature can be used.

� To show data as a 2D BarCode

1. Select data on form.

2. Right click on data and select Format Data from the context menu, or from the Format menu select Data
Object.

3. From the Data Properties dialog box, select the 2D Barcodes tab.

4. Choose 2D BarCode (PDF417) from the Show Data As drop-down menu.

5. Set the Compression, Error Level, Rows, Columns and Aspect as desired.
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Show Data as MaxiCode 2D Barcode
Data can be encoded as a MaxiCode 2D BarCode. MaxiCode is an international standard symbol used for
package sorting and tracking, most importantly as the standard shipping barcode for UPS. The symbol
consists of two messages: the primary message, which encodes the postal code, country code, and the class
of service number and the secondary message, which encodes address data or some other information.

� To show data as MaxiCode

1. Select data area on form that is to be transformed into a 2D
BarCode.

2. Right click on data and select Format Data from the context menu,
or from the Format menu select Data Object.

3. From the Data Properties window, select the 2D Barcodes tab.

4. Choose MaxiCode from the Show Data As drop-down menu.

5. In the MaxiCode Options area, select a Mode form the drop-down menu. The seven modes have the
following functions:

Mode 0 - The primary message is a Structured Carrier Message and the secondary encodes up to 84
uppercase characters, numeric or punctuation.

Mode 1- The primary and secondary messages together encode up to 93 uppercase characters, numeric
or punctuation.

The functionality of Modes 0 and 1 has been taken over by Modes 2 and 3. Modes 0 and 1 should only be
used by existing MaxiCode users with only Mode 0 and 1 capability.

Mode 2 (US Carrier)- The primary message encodes numeric postal codes up to nine digits in length, and
the secondary message encodes up to 84 characters.

Mode 3 (International Carrier)- The primary message encodes alpha-numeric postal codes up to six digits
long, and the secondary message encodes up to 84 characters.

Mode 4 (Standard Symbol)- The primary and secondary messages combined can be used to encode up to
93 characters. This useful for encoding information for applications other than shipping.

Mode 5 (Secure Symbol)- The primary and secondary messages combined encode up to 77 characters with
more error correction than Mode 4.

Mode 6 (Reader Program)- The primary and secondary messages combined encode up to 93 characters for
the purpose of programming barcode readers.
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DataMatrix
DataMatrix is a two-dimensional barcode that can store from one to about 2,000 characters. The square
symbol can range from .001 inch per side up to 14 inches per side, and about 500 characters can be encoded
in a 1 inch square. DataMatrix is often used to encode product and serial information and to identify items
during manufacturing.

� To show data as a DataMatrix BarCode

1. Select the data on the form to which the DataMatrix barcode will be applied.

2. Right click the data and select Format Data from the context menu, or from the Format menu select Data
Object.

3. From the Data Properties window, select the 2D Barcodes tab.

4. Choose DataMatrix from the Show Data As drop-down menu.

5. Enable the Square Symbol check box to create a square barcode. If you leave the box unchecked, a
rectangular barcode will be created.

6. Use the Scale % box to adjust the size of the BarCode.

7. Click OK to apply the specification.

211 Personalized Documents



Intelligent Mail BarCode
The USPS Intelligent Mail barcode is the next generation barcode used by the U.S. Postal Service, replacing
PostNet barcoding. It consists of a field placed on the page containing tracking data, as well as the zip code
(routing code) information defined within the 2-D Barcode dialog box. The tracking data must have 20
digits of information, defined as: 2 digit Barcode Identifier, 3 digit Service Type Identifier, 6 digit Mailer
Identifier, and a 9 digit Serial Number. The zip code is supported in the following formats: (1) empty, (2) 5
digit ZIP code, (3) 9 digit ZIP+4 code, or (4) 11 digit ZIP+4 + 2 digit DPC.

� To show data as a Intelligent Mail BarCode

1. Select the data on the form to which the Intelligent Mail Barcode will be applied.

2. Right click on the data and select Format Data from the context menu, or from the Format menu select
Data Object.

3. Access the 2D BarCodes tab on the Data Properties menu.

4. Choose Intelligent Mail BarCode from the Show Data As drop-down menu.

5. Define Routing Code and Alignment options from their drop-down menus in the Intelligent Mail BarCode
Options. In the case of 31 digits, click on Routing-Code is last 11 digits of Tracking-Code. Otherwise, use the
drop-down menu to select the select the zip code data field.

6. Click OK to apply the specifications.
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QR Codes
QR Codes are two-dimensional barcodes that store more information than traditional barcodes and can
include URLs or PURLs that are accessed quickly using a webcam or camera phone with a QR Code Reader
application. Designer provides easy to use templates to create variable QR Codes. These templates include:
Web Site, Bookmark, Phone Call, Send SMS, Send Email, vCard, Geographical Coordinates, meCard and
Calendar Event.

� To create a QR Code

1. Select data on the form.

2. Right click the data, and select Format Data from the context menu.

3. Access the 2D BarCodes tab of the Data Properties menu.

4. Choose QR Code from the Show Data As drop-down menu.

5. Click on the QR Code Templates button and choose a template from the drop-down menu. Enter
information in the appropriate fields as necessary.

� Web Site: Add a website.

� Bookmark: Add a website that will be bookmarked for later reference.

� Phone Call: Enter a phone number to initiate a phone call.

� Send SMS: Enter a phone number and a message to be sent through Text message.

� Send Email: Enter an email address along with a subject and message to be sent
through email.

� vCard: Enter business card information.

� Geographical Coordinates: Enter geographical coordinates to initiate Google Maps.

� meCard: Enter personal information.

� Calendar: Enter Subject and Date/Time for an event.

6. In the QR Code Options section, define (Optional):

� Scale: Define the size of the QR code by %.

� Version: Specify version of QR Code (1-40)

� Error Correction: Highest, Least, Medium, Medium-High

� Mask Pattern: Specify which mask patterns to be used (1-8 available).

7. Click OK to apply the specifications.
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Data Flow
A data area (e.g. a frame) can be made to transfer data from one frame to another. When data is too large to
fit in the frame, the excess will dynamically flow into the next defined frame. One or more frames can be
attached to the primary data area, and all linked frames will be displayed with a number in the top left
corner to show the order in which they are linked. Using this feature, data can be made to form columns or
to wrap around an image.

� To activate data flow

1. Select the area of data that will flow into the next frame.

2. Click the Create New Frame button.

3. Click the left mouse button and drag to create a new frame of the desired size and position for the
data to flow into.

4. Release the mouse to conclude the drawing of the frame.

Relative Form Object Placement
Form items can vertically float to accommodate differently sized images and data blocks to which they are
attached. Element 1 must be a variable image or data/text block.

� To attach a relative form item

1. Select the item, such as a conditional text block or a conditional or data-driven image, to which the
relative item will be attached.

2. Click the Attach Relative Item button.

3. Select the item that will be attached as a Relative Form Item.

4. Notice that a purple number will appear in the top left corner of the attached items. This number
denotes the order in which the items are attached.

5. Multiple relative form items can be attached, either one at a time or by selecting the group, naming a
master object, and clicking the Attach Relative Item button. The selected items will be relatively attached
to the master item.
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Edit Data File
The Edit Data window allows the ability to change the attributes of the data file that was initially imported
into the form or to re-import a new data file without deleting or changing the defined fields already
implemented. There are two sets of data windows, one is for line data and the other one is for database
data.

Edit Line Data Parameters

� To set data parameters

1. Select Data Settings from the Edit menu to open the Data Edit window.

2. Select the Data Parameters tab on the Data Edit window.

3. To import a new data file click the ellipsis button (...) adjacent to the Data File field, and select a new
data file from the Choose Data File window.

4. Edit the record separator by selecting either Fixed Length, ASCII Value (enter a character, or a decimal value
of an ASCII character preceded by a slash (e.g. /62)), Text String (enter text in the adjacent box), or PCC
Bytes (specify VFUs for user specified channel assignment).

5. To change the maximum record size edit the Characters Per Line and Lines Per Page fields.

6. Check or uncheck the Prefix check box as desired. When the prefix box is checked the Start and Length
of the prefix must be specified.
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When changing data files, all aspects of the new data file are expected to be the same as the original data. If
they are not, re-import a data file through the Import Data toolbar button.

� To edit the page break

1. Select Data Settings from the Edit menu and then open the Data Edit window.

2. Open the Page Options tab of the Data Edit menu.

3. If working with an ASCII Value or Text String as the record separator, set the Page Break options as follows:

� Page break is on -Choose whether page break is on first line of record or last line of record.

� Print portion of line -Choose whether to print information left of page break, right of page break,
entire line or none.

� End Portion of Page Break Line - Choose whether to ignore multiple page breaks per line or to start a
new page with each page break.

� The Page Break Code is generated automatically by the page separator choices made or may be
entered manually. This code is used for VI Compose Output. See your VI Compose
documentation for further information.

4. Set the Starting Record of the data file to be displayed in Proform Designer.

5. Set the Record Interval in which the records will skip.

6. Set the Tab Spacing option as desired. Tab Spacing allows the use of fixed increment tabs and the
expansion of tabs to spaces in line mode display. The increment of spaces for each tab must be
specified.

7. Click the OK button to accept the changes.
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Edit Delimited Data Parameters

� To edit delimited data file parameters

1. Go to the Edit menu and select Data Settings.

2. To select a new data file click the ellipsis button (...) adjacent to the Data File field. Select the new file
from the Choose Data File window.

3. To change the field delimiter, enter a character or a decimal value of an ASCII character preceded by
a slash (e.g. /62) in the Delimiter field.

When changing data files, all aspects of the new data file are expected to be the same as the original data. If
it is not, re-import a data file through the Import Data toolbar button.

4. Edit the Text Qualifier from the drop-down menu.

5. To edit the Maximum Record Length, enter a new value.

6. Click the OK button to accept the changes.
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Edit XML Data Parameters

� To edit XML data parameters

1. Go to the Edit menu and select Data Settings.

2. The Data Parameters window will appear.

3. If necessary, use the Data File ellipses (...) button to browse for a new data file.

4. If necessary, select a new record break from the XML data tree.

5. Click OK.
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Microsoft Mail Merge
Microsoft Word mail merge documents can be instantly converted to VI Compose using the Change
«Names» to Fields function.

� To convert «Names» to VI Compose fields

1. Import the data file.

2. Import the document in a .TXT, .RTF, or .DOCX format.

3. Right-click and select Change «Names» to Fields from the context menu.

All «Names» will be converted to the Designer field name format ($$names.) in the selected data block.
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Conditional Logic
Designer supports complex conditional logic functions, and allows users to create conditional text, images,
form objects (lines, circles, boxes and paths) and background images. Conditional text and images are
created by drawing a conditional area onto the form and then defining the necessary conditions.
Conditional form objects and background images are created by drawing the static image onto the form or
importing the background image, and then applying conditions to those elements.

“If ” logic is used to create conditions, and text, images or form objects are defined as a result. If a
condition is met, the result is displayed. “Else” logic, nested conditions and AND/OR conditions can also
be used to further drive conditional logic.

Conditional Text and Images

Creating Conditional Text or Graphic Areas

A conditional text or graphic area must be drawn to specify the placement and size of the text or graphic
on the form.

� To draw a conditional text area

1. Select the Conditional Text button.

2. Click the left mouse button and drag the mouse to draw the text field box.

3. The Format Image window will appear. Access the Conditions tab.

4. Define a text condition.

� To draw a conditional image area

1. Select the Conditional Image button.

2. Click the left mouse button and drag the mouse to draw the area of the graphic.

3. The Format Image window will appear. Access the Conditions tab.

4. Define an image condition.
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Conditional Background Images
Conditional background images are created in a slightly different manner than a regular conditional image.
You must first import the background image onto the form, and then define the conditions from within the
Image Properties window.

� To create a conditional background image

1. Import one of the images that will be used as a conditional background image onto the form. If you
would like to use a low resolution image for viewing and a high resolution image for printing, define
those images now.

2. Right click the image. You will have to enable background mode from the Edit menu in order to select
the background image.

3. Select Format Image from the context menu.

4. The Image Properties window will appear. Access the Conditions tab.

5. Define the necessary conditions and click OK to save the conditions and return to the form.

Conditional background images cannot be resized once they are on the form. All background images must
be the correct size before they are imported.

Conditional Form Objects - Lines, Boxes, Cirlces, Paths
A conditional form object must first be drawn on the form. Conditions can then be specified through the
Line, Box, Circle or Path window.

� To create a conditional form object

1. Draw a form object (box, circle, line or paths).

2. Right click the form object, and select Format Box, Circle, Line or Path from the context menu.

3. Access the Conditions tab.

4. Click Add to begin creating conditions.

5. Click the Format button to define thickness, color, or box roundness.

5. When all conditions are created, click OK to save the tree and return to the form.

Detailed instructions for creating conditional logic are defined in the following pages.
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Building Conditional Logic
A conditional statement must be formulated by a true or false statement, resulting in a designated output,
based upon that condition.

� To add conditional logic statements

1. Click the Add button to open the Add Condition window.

2. Select from the Field drop-down if applicable. This conditional variable classification drop-down menu
allows variables to be sorted as either Field, Variable, VI Compose Variable, Page Overflow (line mode only) or
Job Conditions. Selecting one of these classifications from the menu predefines only those variables of
the specified classification in the If: drop-down menu.

� Field: The variable field names defined in the data record.

� Variable: Customized variable fields (concatenated, incrementing, etc.)

� System Variable: One of the built-in System variables pre-defined in the drop-down menu. (These
variables will only be available in the drop-down menu if the Include System Keywords in Field List is
checked on the Data tab of the Preferences window.)

� Page Overflow (line mode only): This can be used for line mode applications (like a billing statement)
where a data record can flow for a variable number of pages before the next record break.

� Job Conditions: Job conditions can be set in order to apply special formatting at the end of sets or at
the end of the entire job.

3. Choose to create either an If or an If Not statement by enabling the appropriate radio button.
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4. Choose a field from the If/If Not edit box.

5. Choose a function (=, >, <, >, <, not equal to, contains).

6. Choose a field or enter a value into the drop-down menu to set the condition.

7. Specify whether the variable that sets the condition is a Number, Text, or Logical.

8. Click the OK button to accept.

Key Function

equal to

greater than

less than

greater than or equal to

less than or equal to

not equal to

contains
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AND/OR Conditions
AND/OR conditions can be used as a simplified alternative to nested conditions. The AND condition is
the equivalent of a simple nested condition, and the OR condition is the equivalent of an else-if statement.

� To add AND or OR condition

1. After adding the primary condition in the Conditions tab of the Data Properties window, click the Add AND
or Add OR button to open the Add Condition window. The order of the AND/OR conditions is important to
the logic, since they will be evaluated in sequential order.

2. In the Add Condition window, set the condition by selecting whether to create an If or an If Not statement
and choosing a field, function, and variable value. For a complete description of what each variable is
specifically for, please see page 222.

3. Choose number or text for the variable type.

4. Click OK to accept the conditions.

To aid in the design process, AND conditions will always be displayed with a red diamond, and OR
conditions will always be displayed with a green diamond.
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Nested Conditions
Nested conditions are used in circumstances where a condition is set after a primary condition. This
primary (parent) condition can have nested conditions (children) that will be evaluated when the primary
condition is true.

� To add a nested condition

1. After adding the primary condition in the Conditions tab of the Data Properties window, click the Add Nested
Condition button to open the Add Condition window.

2. In the Add Condition window, set the condition by selecting whether to create an If or an If Not statement
and choosing a field, function, and variable value.

3. Choose number or text for the variable type.

4. Click OK to accept the conditions.
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Final Else Conditions
Setting the Final Else condition allows text or images to appear when the prior conditions set are not met.
Without a final else condition, nothing displays if all conditions are not met.

� To add an else or nested else condition

1. Select a statement on the conditional tree in the Conditions tab of the Properties window.

2. Click the Add Condition button.

3. Select the Final Else check box at the top of the window.

4. Click OK to accept.

Editing Conditional Statements
Once defined, conditional statements can easily be edited.

� To edit a conditional statement

1. Right click the conditional image and select Format Image from the context menu.

2. Select the conditional statement from the Conditions Tree.

3. Click the Edit button.

4. Edit the statement and click OK to save the changes.
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Use the up and down arrows located at the bottom right of the Properties window to shift conditions
around within a condition tree.

Copying and Pasting Condition Trees
It is possible to copy an entire condition tree and paste it into another location on the form. This is a great
time-saving feature, and also reduces the amount of error that could occur when trying to duplicate a
condition tree exactly.

� To copy and paste an entire condition tree

1. Select the conditional area on the form.

2. Right click and select Copy from the context menu.

3. Select a data field, or a conditional image/data field.

4. Right click again and select Paste from the context menu.

5. The currently displayed conditional element will be copied. Move it to where you want it on the form.
It will be an exact duplicate of the original.

Displaying Conditions

You can display all the conditions currently defined on a page in the View Conditions window.

� To view conditions

1. Go to the View menu and select Data Conditions.

2. The View Conditions window will appear. All the conditions used on the page will be listed here.
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Adding Text to a Conditional Statement
Text can be added to logic statements from the
Data Properties window. The text will only
appear if the logic statement is true. Text can
also be imported from other applications, such
as MS Word, to be used in the conditional
statements.

� To create a conditional text block

1. Create a conditional statement to specify
when the text will appear.

2. Highlight the conditional statement to
which you will add the conditional text.

3. Click the Text button.

4. Type in the text, import text, and insert
database fields as necessary.

5. Click OK to save the conditional text.

Text imported into the conditional text window will replace any pre-existing text. It is recommended to
import the text file first, then add any additional text or database fields.

Format Text
Font formatting can be applied to conditional text. The font type, style, point size, color and underline can

be specified. The entire text block can be changed, or just a particular portion selected and specially
formatted.

� To format the conditional text

1. Right click on the conditional text block and select Format Data Condition.

2. Highlight the area of the text that you want to format.

3. Use the text formatting buttons at the top of the conditional text window to format the text.

4. Click OK to save the formatting and return to the form.
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Conditional Text Mail Merge
Conditional text that has been imported from a Word document can be mail merged within a conditional
text block.

� To perform a conditional text mail merge

1. Create a conditional statement.

2. Import a .txt or .rtf mail merge document into the Conditional Text window by clicking the Import Text
button.

3. Highlight the text within the Conditional Text window.

4. Click the Change Names to Fields button.

Editing Conditional Text
Conditional text can be quickly edited on screen using the text editor. The changes made on screen will be
reflected in the text displayed in the Conditional Text window as well. Only the conditional text that is
currently displayed can be edited from the screen. To edit the other conditional text, scroll through the data
and edit each as it is displayed, or open up the Conditional Text window and make necessary edits from
within that menu.

� To edit conditional text on screen

1. Double click the conditional text that is displayed on the form, or right click and select Edit Text from
the context menu. This will open up the text editor.

2. Make necessary text edits.

3. Exit out of the text editor by clicking elsewhere on the form.

4. Click Save to save the changes.

� To edit conditional text using the conditional text window

1. Right click the conditional text box.

2. Go to the Conditions tab.

3. Expand the conditional statement that you want to edit.

4. Select the conditional text.

5. Click the Edit button.

6. Make necessary edits to the conditional text and click OK.

7. Click OK again to save the edits and return to the form.
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Adding an Image to a Conditional Statement

Conditional images can be imported through the Image Properties window.

� To add an image to the conditional logic

1. Create a conditional statement.

2. Click the Image button from the Image Properties window.

3. Select the image file that will be used for on screen viewing. Specifying a lower resolution image for on
screen viewing will improve Proform Designer's response time when scrolling through data.

4. Click the ellipses next to the Printing Image field.

5. Locate the image that will be used for printing. This is where the high resolution .eps image should be
specified.

6. Click Open to select each image.

7. The image selections will be listed under the qualifying condition in the condition tree.

It is not required to select both a viewing and a printing image. If there is only one version of the image
and you would like to use it for viewing and printing, then there is no need to specify a particular printing
image. It is more efficient, however, if you are working with large image files, to specify a low res .jpg for
viewing and a high res .eps for printing.
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Conditional Data Driven Images

Conditional data driven images can be defined in the Image Properties window. The Conditional Data Driven
Image Name window allows the concatenation of a field name with an image extension, which results in a
conditional image that will appear based upon a field definition in the data.

� To create a conditional data driven image

1. After defining a conditional image statement, click the Image Field button.

2. Select the field that contains the data-driven images.

3. Type in the file extension if the data file does not already contain the file extension. Make sure that
the concatenated field is formatted to read $$data..extension. There must be a complete file extension
and a complete VI Compose field included for the conditional data driven image to work.

4. Click OK to return to the form.

Data-driven images must be manually imported into a job or placed in the C:\XGFC\IMGLIB folder if
sending a single form to VI Compose.
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Search Areas and Conditional Line Data Formatting
A line data area that has been placed onto the form can be conditionally formatted. The condition will
affect the entire line of data where the condition is found true. The line of data can be conditionally
formatted to undergo both font and color changes.

Defining Search Area Fields
A Search Area Field must be defined before a line by line conditional statement can be created. The Search
Area Field defines the columns that will be evaluated in the conditional statement. Proform Designer will
use the column(s) defined by the Search Area Field to evaluate the conditional logic statement. If the
conditional logic statement is true, then the entire line of data containing the condition will be affected. The
Search Area Field will not be displayed in the data drop-down menu on the data view toolbar since it is only

used for setting line by line search conditions.

� To define a search area field

1. Select the starting and ending column of data in the line data view window, located on the right side
of the screen.

2. Multiple lines can be selected, but despite row selections all lines in the data record will be searched.
Only the column values are used.

3. Enter the Search Area field name and verify or change the starting or ending column values.

4. Click OK to accept.
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Applying a Search Area Condition
Line by line formatting can be applied by using the Search Area Field and conditional logic. The search area
field must be specified after the If condition. The second value/field can not be a search area field name.

� To apply a search area condition for line by line formatting

1. Define a Search Area Field.

2. Place line data onto form.

3. Select the data that has been placed onto the form, right click, and select Format Data from the context
menu.

4. Access the Set Conditions tab, and click Add.

5. The Add Condition window will appear.

6. Choose a field to begin the If statement. Only fields set as Search Area Fields will be displayed in this
drop-down menu.

7. Select the function: =, <, >, etc.

8. Enter a value or database field to search for. Click OK to save the statement.

9. Add AND and OR conditions as necessary to properly define the condition.

10. Click the Format button. This will cause the Set Conditional Font window to appear.

11. Choose how the data line will be displayed when the condition is met.

12. If you would like the data to always be displayed in the same font as defined in the preceding
condition, enable the Use Current Font check box.

13. If you want the line on which the search condition is found true to not print, enable the Do Not Print
check box. This will cause the line to not print, and the following lines to be shifted up so that there
is no blank space.

14. Click OK to save the conditional formatting.
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Custom Variable Fields
Proform Designer allows the user to create variable fields, based off of information in the data record.
These variable fields can be used to perform concatenations, calculations and transforms and to create
conditional variables.

Concatenated Fields
Concatenated fields are made up of text and/or data
fields, and may contain multiple data fields. One use of
the concatenated field is to call data-driven images form
the VI Compose/imglib directory. Use the image's
suffix (either .tif or .jpg) and the field name that
contains the image names in the data file, to create one
variable field that, when placed on the form, will cause
the defined image to appear. See more about data-driven
images on the following page.

� To create a concatenated field

1. Import a delimited data file, or, if using line data,
define database fields.

2. Select Field Settings and choose Define Variable from
the Edit menu.

3. Select Concatenated Field from the Type drop-down
menu.

4. Name the field. This name will be listed in the data
drop-down menu.

5. Add the desired data fields by selecting them from the Field drop-down menu.

6. Add any necessary text.

7. Define extractions and transforms if desired. The following pages outline in detail how to perform
these functions.

8. Click OK to return to the form.
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Data-Driven Images
If the data file contains the name of a tiff or jpeg
image, this data can be dropped onto the page and
treated as an image. If the data file contains just a
partial name, you can use the concatenated variable
field to add on the missing part of the name,
generally the suffix. Once the image name field is
placed onto the form, Proform will query the user as to whether the field is an image name or just a regular
data field. Answer that it is an image name and the image will be shown.
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Incrementing Variable
The Incrementing Variable function (counter) counts the data records, using a user defined increment, and
displays an optional prefix and suffix along with the numeric value of the incrementing variable.

This function can be used to generate page numbers as well. The prefix "Page" could be set with a defined
increment of "1" to display one page number on the form per data record.

� To create an incrementing numeric variable

1. From the Edit menu, select Field Settings and choose Define Variable. If using line data, it as also possible to
right click the data and choose Define Variable Field from the context menu.

2. Create a Name for the variable field.

3. Select Incrementing Variable from the Type drop-down menu.

4. In the Start box, indicate which number to start the count with.

5. Define the Increment by which the counter will increase.

6. Add the desired Prefix and/or Suffix.

7. Define Transforms as necessary.

8. Click OK.
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Incrementing Text Variable
The Incrementing Text Variable function will
count each data record using a set increment and
then add zeroes to the left of the variable number
to create a number with a defined character
length. This is useful when creating serial numbers
based upon a record count and starting numeric
value. A prefix or suffix can also be added to the
variable. The added prefix or suffix will not be
recognized as part of the defined record length
and will not affect the variable or preceding zero
values.

� To create an incrementing text variable

1. Import a delimited file or define a database
field from a line data file.

2. From the Edit menu, select Field Settings and
choose Define Variable.

3. Enter a name for the new variable field. This
name will appear in the data drop-down menu.

4. Choose Incrementing Text Variable from the Type drop-down menu.

5. In the Start box, specify the number with which the counting will begin.

6. Define the increment by which the numbers will progress.

7. Add the desired Prefix and/or Suffix if necessary.

8. Specify the character length of the desired counter. If you choose a length of 3, and the counting
begins with the number 1, your counter will look like 001, 002, 003...100, 101 etc.

9. Define transforms as necessary.

10. Click OK.
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Variable
The Variable function allows new fields to be created from information already existing in the data file. This
function can be used to apply case and barcode transforms, as well as to extract portions of pre-defined
fields.

� To create a variable

1. Import a delimited data file or define a database field from a line data file.

2. From the Edit menu, select Field Settings and choose Define Variable.

3. Select a name for the variable.

4. Choose Variable from the Type drop-down menu.

5. Select which pre-existing field will be modified to create the new variable. Select this field from the
Field drop-down menu.

6. If performing a data extraction, define the type of extraction (by length or by separator). If by length,
define the beginning position and the length. If by separator, define the character that will serve as
the separator and which field will be separated.

� For example, you have a name field that is made up of a person's first and last name:

Jimmy Smith

� You want to extract the first name to make a field called Fname, containing only the name
"Jimmy".

� You set the separator as the space (actually use the space bar and type a space into the separator
field), and, since you want the first portion of the name, you set the field to be 1. If you were to
want the part that comes after the separator, "Smith", the field would be 2.

7. If performing a case transform (upper, title, or lower case), select which case you desire from the Case
drop down menu.

8. If performing a barcode transform, select the barcode type from the Barcode drop-down menu.

9. Click OK to save the new variable and return to the form. The new variable will now be listed in the
data drop-down menu.
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Barcode Transforms

The following barcode transforms are available and can be performed by creating a new variable: 2OF5,
CODE39, CODE128, EAN128, EAN8, EAN13, POSTNET, UPCA.

� To perform a barcode transform

1. From the Edit menu, select Field Settings and choose Define Variable.

2. Name the new variable.

3. Select Variable from the Type drop-down menu.

4. Select the field to be transformed from the Field drop-down menu.

5. Choose the desired barcode type from the Barcode drop-down menu.

6. Click OK to save the variable and return to the form.

7. You must apply a barcode font to the variable in order for the barcode to actually be displayed.
Proform Designer includes a WASP barcode library, so you will have access to these fonts. Drop the
data field onto the form, and select the barcode font from the font drop-down menu.

8. A place-holder barcode will be displayed for viewing purposes. The actual barcode will be rendered
upon output.
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Text Variable
The purpose of defining a Text Variable is to convert a
variable recognized as binary (numeric or decimal) into a
variable recognized as textual. Defined Calculation Variables
using only decimal values (no text) and binary Systen
Variables (some of the pre-defined variables built into the
VI Compose language) can be used to create a Text Variable.
Though other fields can be selected in the Field drop-down
menu (containing text and are non-decimal/binary), the
proper application of this function is achieved only with a
predefined binary variable (Calculation value or System Variable
not seen as text).

Numeric decimal variables offer a 32 bit limit to the variable
string and can be utilized with a PostScript Function to
produce highly accurate calculations. Converting a decimal
binary value into a text variable will limit the variable string
to 7 digits and simple textual (small numbers) calculations
(not as precise).

� To create a text variable

1. Import a delimited or XML data file, or define a database field from a line data file.

2. From the Edit menu, select Field Settings and Define Variable Field.

3. Establish a name for the variable field.

4. Under Type, specify Text Variable.

5. Go to the Field drop-down menu and select either a pre-defined Calculation variable or a binary
System Variable.

6. Specify the Length of characters.

7. Click OK to accept.

When defining a Text variable, a maximum text length must be defined. Text Variable content exceeding the
maximum length may halt the print job with errors.

The following System Variables are recognized as Binary: FRLEFT, FRCOUNT, LSP, VDISP, HDISP, SVPOS, SHPOS, RPLEFT,
RPCOUNT, PPCOUNT, LPICOUNT, LPCOUNT, CPCOUNT, COLW, PGCOUNT, DTCOUNT.
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Calculation Variable
The calculation variable allows a variety of functions to be
assigned to a variable. Math, text and boolean functions can
be added to data fields to create the calculation variable. A
formula editor is available to apply VI Compose, PostScript,
or calculator functions to fields or variables. Once a
Calculation Variable is created, it becomes available to use
multiple times on the form.

Math

� +, -, *, /, unary + -, ()

� Number is [<sign>]<number>, ([...] indicated optional)

� Real Number is [<sign>]<number>.<number>

� [<sign>] indicates optional + or -

Text Boolean

+ (concatenation) >, >=, <, <=, =, != (not equal)

'text' false, true

� To create a calculation variable

1. Select Field Settings from the Edit menu. Choose Define
Variable.

2. Enter a name in the Name edit box.

3. Select Calculation from the Type drop-down menu.

4. Click the Edit button. The Formula Editor will appear. All
database fields previously imported or defined will be
available in the Field drop-down menu.

� If a different field name is to be used, select a Field Name from the drop-down menu. Highlight the
Field Name in the Formula area.

� Select the desired Function from the drop-down menu. The syntax will appear in the Formula: edit
box.

� Click OK to return to the Define Variable window.

5. Additional Transforms can be applied if necessary.

6. Click OK.
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Data Functions
Designer's Formula Editor provides the user with access to 21 System transforms/functions and 18
PostScript functions, each having 0, 1, or 2 parameters. These VI Compose and PostScript functions can be
applied to data during the design process. The Formula Editor is useful for applying functions to data for
one time use. Data that has had transforms/functions applied through the Formula Editor will not be
available for later use within the Field Name drop-down menu.

� To implement data functions

1. On a form that contains a data file, click the Data Formula button on the Data View toolbar.

2. Click the left mouse button and drag a box where the data is to be placed.

3. The Data Properties window will appear, displaying the Formula Editor tab. The variable field defined in the
data field drop-down menu will already be listed in the Field Name drop-down menu and the Formula
edit box.

4. If a different field name is to be used, select a Field Name from the drop-down menu. Highlight the Field
Name in the formula area.

5. Select the desired Function from the drop-down menu. The syntax will appear in the Formula edit box.

6. Click OK to return to the form. The data will be placed onto the form.

242 Personalized Documents



Conditional Variable
The Conditional Variable function allows users to create a custom variable that is true only when a specified
condition in the data field is met, and is false otherwise.

For example, a user might create a conditional variable called CommonName. CommonName would be 'true' if a
person's last name was Jones or Smith. Therefore, if the last name was not Jones or Smith, CommonName
would be 'false' and would not be used.

� To create a conditional variable

1. Go to the Edit menu and select Field Settings. Choose Define Variable.

2. Enter a name for the conditional variable in the Name field.

3. Select Conditional Variable from the Type drop-down menu.

4. Click the Edit button to open the Conditions window.

5. Click Add to access the Add Condition window.

6. Create the condition and click OK to save. Add AND/OR conditions as necessary.

7. Click OK to save the defined conditions and return to the Define Variable window.

8. The condition will be displayed in the Condition area.

9. Click OK to save.
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System Functions

BarCode Transforms:

20F5, CODE39, CODE128, EAN128, EAN8, EAN13, POSTNET, UPCA

These transforms prepare data for properly displaying a barcode, by determining transforms, checksums,
start and end sequences.

2OF5(data)

2OF5 is to be used with an Interleaved 2 of 5 barcode font. Cannot accept space or alphabetic
characters.

Example: 2OF5($$BarcodeData.)

If BarcodeData contains 123456 the results of this transform would be —“³ÉÝ˜

CODE39(data)

CODE39 is to be used with a Code-39 barcode font. Only alphabetic and numeric characters are
acceptable in the input data.

Example: CODE39($$BarcodeData.)

If BarcodeData contains 123456 the results of this transform would be `123456~

CODE128(data)

EAN128(data)

CODE128 and EAN128 are to be used with a Code-128 barcode font. Accepts characters in the full
ASCII range (0..127) in its input data. Uses code-set C when possible to compress sequence of digits.

Example: CODE128($$BarcodeData.)

If BarcodeData contains 123456 the results of this transform would be é-CY¬ê

EAN8(data)

EAN13(data)

EAN8 and EAN13 are to be used with an EAN barcode font. EAN8 accepts only 7 digit character
sequences, and EAN13 accepts only 12 digit character sequences as its input data.

Example: EAN8($$BarcodeData.)

If BarcodeData contains 1234567 the results of this transform would be _~1234IFGHA*_

POSTNET(data)

POSTNET is to be used with a PostNet barcode font. Accepts only 5, 9 or 11 digits, or 10 or 12
characters with a dash character in the 6th position, as its input data.

Example: POSTNET($$BarcodeData.)
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If BarcodeData contains 12345-6789 the results of this transform would be *1234567895*

UPCA(data)

UPCA is to be used with a UPC version A barcode font. Accepts only 11 digit numbers in its input
data.

Example: UPCA($$BarcodeData.)

If BarcodeData contains 12345678901 the results of this transform would be ~v23456IHIJABM*-

Case Transforms:

CASEUP, CASELOW, CASETITLE

These transforms change the letter case of the input data to these functions, returning the transformed
text.

CASEUP(data)

CASEUP will convert every lower case character in the input data to upper case, without modifying
any non-alphabetic character.

Example: CASEUP($$FullName.)

If FullName contains ‘John Smith’ the results of this transform would be ‘JOHN SMITH’

CASELOW(data)

CASELOW will convert every upper case character in the input data to lower case, without
modifying any non-alphabetic character.

Example: CASELOW($$FullName.)

If FullName contains ‘JOHN SMITH’ the results of this transform would be ‘john smith’

CASETITLE(data)

CASETITLE will convert the first alphabetic character (and every first alphabetic character after a
space) to an upper case character, and all other upper case characters to lower case in the input data,
without modifying any non-alphabetic character.

Example: CASETITLE($$FullName.)

If FullName contains ‘JOHN SMITH’ the results of this transform would be ‘John Smith’
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Data Transforms/Functions :

ARABIC, BCOUNT, BSTRIP, BTRIM, CS, CVI, CVS, Extract, FORMAT, HMS, Maximum,
Minimum, QSTRIP, Quotient, REPLACE, Remainder, ROUND

ARABIC(data,option)

ARABIC will reverse the text and attempt merging of adjacent characters. Supports the Arabic and
Hebrew languages which display text in a right to left format.

option is one of the following:

0 base function

1 switch to a different font for non-Arabic characters

2 substitute European digits for Hindi digits

Example: ARABIC($$Paragraph1.,0)

If Paragraph1 contains ‘Our company is proud to announce our latest product’ the results of this
transform would be ‘tcudorp tsetal ruo ecnuonna ot duorp si ynapmoc ruO’

BCOUNT(data)

BCOUNT will determine the number of space characters in the input data, returning an integer
number.

Example: BCOUNT($$Paragraph1.)

If Paragraph1 contains ‘Our company is proud to announce our latest product’ the results of this
function would be the value 8

BSTRIP(data)

BSTRIP will remove any leading and trailing space characters from input data.

Example: BSTRIP($$Data1.)

If Data1 contains ‘ The winning entry belongs to: John Smith ’ the results of this transform would
be ‘The winning entry belongs to: John Smith’

BTRIM(data)

BTRIM will remove any leading, trailing and any duplicate space characters from input data.

Example: BTRIM($$Data1.)

If Data1 contains ‘ The winning entry belongs to: John Smith ’ the results of this transform would
be ‘The winning entry belongs to: John Smith’
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CS(data1,data2)

CS will merge two text fields into a single text field. data1 and data2 can be either data fields or
quoted text.

Example: CS($$ZipCode.,’-0109’)

If ZipCode contains ‘94533’ the results of this function would be ‘94533-0109’

CVI(data)

CVI will convert the text field into an integer value.

Example: CVI($$ZipCode.)

If ZipCode contains the text ‘94533’ the results of this function would be the number 94533

CVR(data)

CVR will convert the text field into a real number.

Example: CVR($$TotalPrice.)

If TotalPrice contains the text ‘1234.56’ the results of this function would be the number 1234.56

Extract(text,position,length) Extract(text,position,delimiter)

Extract will extract characters from a text based on position and length of the substring, or by field
number position (starting with 0) and a single character delimiter search, returning a subset of the
original text parameter.

Example: Extract($$DataLine.,3,’,’)

If DataLine contains ‘John,Smith,123 Main Street,New York,NY,00200’ the results of this function
would be ‘New York’

FORMAT(number,control)

FORMAT will format a number into a text based on a control string.

control is text that can be defined with:

- negative sign shown only if number is negative.

+ positive sign shown only if number is positive.

@ represents a formatting placeholder.

# represents a digit that is kept as it, or is filled with 0s if digit did not exist.

, thousand separator (not shown with leading 0s represented with @).

. decimal delimiter.

Any other character in the control text will be shown.

Example: FORMAT($$TotalValue.,’$-@,@@@,@@#.##’)

If TotalValue contains the value 12345.67 the results of this function would be ‘$ 12,345.67’
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HMS(number)

HMS will convert time defined in seconds to a format of HH:MM:SS (24 hour), where HH is a value
of 0 to 23, MM is a value of 0 to 59, and SS is a value of 0 to 59.

Example: HMS($$TimeInSeconds.)

If TimeInSeconds contains 12345 the results of this transform would be ‘3:25:45’

Maximum(number1,number2)

Maximum will determine the larger of two numbers. Either of the two parameters may be an integer,
real, variable or text number.

Example: Maximum($$Qty1.,$$Qty2.)

If Qty1 contains 12345 and Qty2 contains 12432 the results of this function would be 12432

Minimum(number1,number2)

Minimum will determine the smaller of two numbers. Either of the two parameters may be an integer,
real, variable or text number.

Example: Minimum($$Qty1.,$$Qty2.)

If Qty1 contains 12345 and Qty2 contains 12432 the results of this function would be 12345

QSTRIP(data)

QSTRIP will remove the first and last characters from the text.

Example: QSTRIP($$QuotedName.)

If QuotedName contains ‘”John Smith”’ the results of this transform would be ‘John Smith’

Quotient(number1,number2)

Quotient will divide number1 by number2, where either parameter can be an integer, real, variable or a
text number.

Example: Quotient($$Qty1.,4)

If Qty1 contains ‘12345’ the results of this function would be 3086.25

REPLACE(data,find,replace)

REPLACE will search the data parameter for any number of occurrences of the find parameter and
replace each one with the replace parameter.

Example: REPLACE($$SSN.,’-‘,’’)

If SSN contains ‘123-45-6789’ the results of this function would be ‘123456789’

Remainder(number1,number2)

Remainder will determine the remainder of dividing the number1 parameter from the number2
parameter. Either of the two parameters can be an integer, real, variable or a text number.
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Example: Remainder($$Qty1.,4)

If Qty1 contains ‘12345’ the results of this function would be 1

ROUND(number,position)

ROUND will round the real number parameter to the nearest digit at a given position to the left
(negative position) or right (positive position) of the decimal point.

Example: ROUND($$Number.,2)

If Number contains ‘12345.6789’ the results of this function would be ‘12345.68’

System functions are listed in the Function drop-down menu in uppercase letters.

BarCode and Case Functions take a single DataBase/Variable parameter (e.g. UPCA($$product.))

PostScript Functions

Math

abs absolute value (ex. abs($$total.))

atan arc tangent (ex. atan($$x.))

ceiling least whole value >= parameter (ex. ceiling($$amount.))

cos cosine (ex. cos($$x.))

floor greatest whole value <= parameter (ex. floor($$balance.))

ln natural logarithm (base e) (ex. ln($$y.))

log common logarithm (base 10) (ex. log($$z.))

mod remainder of parameter1 / parameter2 (ex. mod($$due., $$payment.))

rand random number generator (no parameters) (ex. rand())
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round convert real number to whole by rounding (ex. round($$r.))

sin sine (ex. sin($$t.))

sqrt square root (ex. sqrt($$s.))

truncate truncates toward zero by removing fractional part (ex. truncate($$income.))

Logical Functions

and bitwise and of parameter1 and parameter2 (ex. and($$logic., 255))

not bitwise complement of parameter (ex. not($$logic.))

or bitwise or of parameter1 and parameter2 (ex. or($$logic., 255))

xor bitwise exclusive or of parameter1 and parameter2 (ex. xor($$logic., 255))

bitshift shift parameter1 left by parameter2 bits (ex. bitshift($$logic., 2))

String Functions

length determines the number of characters in a string

PostScript Functions are listed in the Function menu in lowercase letters

250 Personalized Documents



System Variables
System variables are predefined variables built into the VI Compose language. System variables provide
information about a form, Job, the VI Compose software, or printer details such as time and date. System
variables can be used in a variety of ways in Designer. The variables are available in the Field drop down
menus within the Variable, Text Variable, Calculation Variable and Concatenated Variable windows. They
can be used to populate the second field when creating conditional logic statements. They can also be typed
directly onto a form as a System field (Ex. $$BACK.), where they will be converted to a number, boolean
value (e.g. "false" ) or a text string. System variables fall into several categories: boolean, numeric, text, time,
or date. When building conditional logic statements, if a System Variable is selected, the type will be
automatically selected from the Variables are: drop down menu. If the variable is boolean, Variables are:
Logical will be selected, and "true" and "false" will be added to the drop down menu.

Line Mode Only

YINIT YINIT is a numeric variable that provides the current vertical position as defined by SETGRID.
This variable will produce a numeric value representing vertical position measured in the current
form unit. If used in conditional logic statements, this variable is applicable to Image and Data
Conditions.

LNCOUNT LNCOUNT is a numeric variable that gives the number of lines of data on the current record. The variable will
produce a numeric value representing a number of lines.

GRIDSKIP GRIDSKIP is a new built-in boolean variable to determine how a page break occurred in line mode. It is true
if the lines-per-page (as defined by SETGRID) was exceeded, or false otherwise (PCC, SETPBRK, or SETSKIP
condition has occurred).

Database Mode Only

FRLEFT FRLEFT is a numeric variable used for text or data flow. It gives the amount of vertical space from the
current print position to the bottom of the current frame on the stack. The variable will produce a numeric
value in the units being used.

FRCOUNT FRCOUNT is a numeric variable that provides the current frame number.

Line and Database Modes

LSP LSP provides information about the line spacing of data. If used in conditional logic statements, this variable
can only be used for Data Conditions, and the value be an number in dots.

XGFVER XGFVER provides a string that displays the release number of the version of the VI Compose software, e.g.
3.0 or 4.0. The release number cannot be abbreviated.

VDISP VDISP is a numeric variable that gives the displacement between a saved print position and the current
position. This is used when, for example, a form contains paragraphs of variable lengths and a box will be
inserted between them. VDISP provides the displacement between the current vertical position, where the
second paragraph will begin and print position, where the first paragraph ended. VDISP produces a numeric
value representing a number of form units between these two positions.

HDISP HDISP is the same as VDISP, except that it deals with horizontal rather than vertical position.
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SVPOS SVPOS is a numeric variable that provides the vertical print position for a form element that is determined by
the saved print position of some other element. The variable produces a numeric value representing a
number of units between these two positions.

SHPOS SHPOS is a numeric variable that provides the horizontal print position for a form element that is determined
by the saved print position of some other element. The variable produces a numeric value representing a
number of units between these two positions.

RPLEFT RPLEFT is a numeric variable used when repeating a portion of a page, a page, or a sequence of pages that
determines the number of times the procedure will occur, i.e. the number of repetitions plus the first
iteration. The variable produces an integer representing the number of times a procedure will occur. This
could be used, for example, as a job condition in a job where pages are being repeated.

RPCOUNT RPCOUNT is a numeric variable that provides the current iteration (beginning with 1) of a procedure that is
being repeated. The variable will produce a numeric value representing an iteration. This variable can be
used in a condition to customize one or more pages in a series of repetitions or for a variety of other
purposes.

PPCOUNT PPCOUNT is a numeric variable that provides the number of the physical page in a job. The variable will
produce an integer representing a page number.

PGCOUNT PGCOUNT is numeric variable that provides a virtual page number for each data record.

LPICOUNT LPICOUNT is a numeric variable that represents one of the logical pages on a multi-up page. If this variable
is used to produce an action, this action will be applied to the logical page, not the physical page. The
variable will produce an integer representing a logical page number (1-the number of rows times columns
defined in the multi-up section of the Job Options. Note: This can be used in conjunction with Z-Sort only in
Database Mode.

DTCOUNT DTCOUNT is a numeric variable that provides a data record number.

LPCOUNT LPCOUNT is a numeric variable representing the number of the current logical page number in a multi-up
job. Note: LPCOUNT begins from 0. The variable will produce a an integer representing a logical page
number (1 - the number of rows times columns defined in the multi-up section of the Job Options.)

BACK BACK is a boolean variable that can be used to create conditions based on whether the current page is on
the front or back side of a physical page in a duplexed job. The variable will produce a value that is either
"true" or "false."

CPCOUNT CPCOUNT is a numeric variable that provides the current number of a copy (the logical number of a page
within cycle). E.g., if there are two forms, and Form A is being repeated in the job but the second is not, the
copy number of Form B is 3. The variable will produce an integer representing the copy number.

COLW COLW is a numeric variable that stores the column width of a form element. The variable produces a number
in the current unit.

PDFDEVICE PDFDEVICE is a boolean variable. If the device being used to print the job produces PDFs, PDFDEVICE can be
used to conditionally yield printed documents, PDF documents, or both. The value to be compared to must
either be the text "true" or "false."

PAGEH PAGEH provides the height of the current logical page.
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PAGEW PAGEW provides the width of the current logical page.

SHEETH SHEETH provides the height of the current physical page.

SHEETW SHEETW provides the width of the current physical page.

Time and Date Variables

Time and Date Variables refer to the current time/date when the Job initializes on the printer's internal
clock.

D_DD D_DD is the day of the current month in a two digit format. Ex. 21.

D_DOY D_DOY is the day of year represented as a number between 1 and 365.

D_DWL D_DWL is the day of the week written out in full. Ex. Friday.

D_DWS D_DWS is the day of the week abbreviated to three letters. Ex. Fri.

D_MO D_MO is the number representing a month. Ex. 9 for September.

D_MOL D_MOL is the name of a month written out in full. Ex. December.

D_MOS D_MOS is the name of the month abbreviated to three letters. Ex. Sep

D_YY D_YY is the year abbreviated to 1 or two digits (leading zeros are omitted). Ex. 3 for 2003

D_YYYY D_YYYY is the full year. Ex. 2003

T_HH T_HH is the current hour in the 24 hour clock format. Ex. 13 for one o'clock pm.

T_HH2 T_HH2 is the current hour abbreviated to 1 or two digits (leading zeros are omitted). Ex. 1 for one o'clock

T_MM T_MM is the current minute. Ex. 35.

T_SS T_SS is the current second. Ex. 6.

T_TZN T_TZN is a text variable representing the time zone. Ex. Pacific Daylight Time or Central Standard Time.

System Variable Keywords are accessible in the field list if enabled through the Preferences window (Edit
menu / Preferences / Data tab).
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Data Driven Graphs
The Data Driven Graphs wizard helps you to create a graph using values in a data file. Proform Designer
will place a representation of the graph on the page for visual purposes, but the actual graph will not be
rendered until VI Compose output.

If using a line data file, the data fields must be predefined. VI Compose also requires that there is an
additional blank line under the data.

� To create a data-driven graph

1. Click the data-driven graph icon on the Standard toolbar, or go to the Edit menu, select Draw Mode and
choose Graph Draw.

2. Draw the graph outline. A graphic representation will display in the area that the actual graph will
occupy upon output of the VI Compose form.

3. Once the Data Driven Graph wizard is displayed, select a Graph Type of either Curve, Bar, Pareto, Radar or Pie. If
you select Pie, you will then have the option to choose whether you will create the whole pie, the top half,
or the bottom half.

4. Continue through the wizard to make additional graph appearance selections. If you select Labels, the
labels will appear on the graph itself. If you select Legend, the labels will be color coded and displayed
to the right of the graph.

5. Select either a 2D graph or a 3D graph.

6. Define Graph Fields by clicking the Add Field button and defining a label and value. Enable the Stacked Bar
Chart check box to create a stacked bar.

7. Fields can be deleted by clicking the Delete Field button. Several fields can be added, and the order that
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they are presented in rearranged, by using the Up or Down buttons. Graphs created with line data
records can only use defined fields that are created with one line each.

8. The Summary window presents all of the define graph
information. If the information needs to be edited,
use the Back button to scroll through the Graph
Wizard and make appropriate changes.

9. Click the Finish button in the Summary window to
accept the parameters and return to the form.

Format Graph
After creating a graph with the graph wizard, you can add
additional attributes or edit changes in the Graph
Properties window. First, select the graph and right click
to select Format Graph, or go to the Format menu and
select Data Object.

General Graph Style

� To format graph style

1. Right click the graph and select Format Graph from
the context menu.

2. Access the General tab. Form this tab, multiple
specifications can be made that will determine the
final look of the graph.

� Graph Type: Select the graph type (bar, curve or
pie) from this drop-down menu.

� 3 Dimensional: Enabling this check box will
produce a 3 dimensional graph. Un-check the
box to produce a 2 dimensional graph.

� Rotation: The graph can be rotated to any 90
degree angle.

� Reverse Order: Enabling the Reverse Order check box will cause the graph labels and values to be
listed from right to left and top to bottom along the X and Y axis. Un-checking this box will cause
the labels and values to be listed in traditional left to right and bottom to top order.

� Attach to Box/Circle: Graphs can be attached to boxes and circles. Enable the Attach to Box/Circle
check box. If this box is enabled and there is no box or circle currently defined on the page to
which the graph can be attached, Designer will ask if one should be created. Click Yes and
designer will create a zero line box and attach the graph to it.

� Placement: Select from the Placement drop-down menu where you want the graph placed within
the box or circle that it is attached to.
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� Margin: The Margin drop-down menu allows you to choose between square or rounded margins. If
attaching the graph to a circle, selecting the rounded margin option will provide more placement
options for the graph within the circle.

� Set a Default: If you want Proform Designer to default to these parameters every time a graph is
created, enable the Set as Default check box.

3. Click OK to apply the settings and return to the form.

Graph Attributes

The Graph Attributes tab of the Graph Properties
window provides further graph formatting options.
Select graph segment colors, 3D thickness, label
width, label location, and if these parameters should
serve as graph defaults.

� To define segment colors

1. Enable either the Default radio button or the
Choose Colors radio button.

� Default: Proform Designer will supply the
colors for the graph segments based upon
default settings.

� Choose Colors: The user specifies which
colors will be used for the graph segments.

2. If you will use the default colors, there is no more color definition necessary. If you will choose the
segment colors, click the Add Color Button. The Color Selection window will appear.

3. Select a color from the display, type in a specific RGB or CMYK value, or select a Pantone color from the
Pantone drop-down menu.

4. Proform Designer also has the ability to pick up a color from anywhere on the screen and use that
color in the segment definitions. Left click the Select button, and drag the eyedropper tool to the
on-screen color that you would like to use. Let go of the mouse to select the color.

5. Click OK to save the segment color definition. Repeat this process until all necessary colors are defined.

� To edit segment colors

1. Select the defined color that you wish to edit.

2. Click the Edit Color button in the Segment Colors area.

3. The Color Selection menu will appear. Choose a new color and click OK to replace the old color with the
new color.

� To delete a segment color
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1. Select the defined color that you want to delete.

2. Click the Delete Color button.

3. The color will be deleted from the Segment Colors area.

� To move a color up or down in the color order

1. Select the color that will be moved to a different position.

2. Use the up and down buttons to position the color in a new place in the line-up.

� To specify the 3D thickness of the graph

1. Select whether the thickness will be based upon the Radius or Bar/Segment width or 1/5 of Graph Width.

2. Define a 3D Thickness percentage, based on the above settings.

� To specify the label location and width

1. Specify a width percentage.

2. Choose a Label Location from the drop-down menu: no label, X axis, end of bars.
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Graph Values

� To format graph values

1. Open the Graph Properties window.

2. Select the Graph Values tab.

� Outline Color and Line Width:
Choose an outline color from
the drop-down menu and
enter the width of the line in
the Width edit box.

� Background Color: Choose a
background color from the
Background Color drop-down
menu.

� Labels on Legend: Enter the spot
size percentage based on the
font size of the graph, and
enter the Distance of the
spots from the graph in the percentage value based on one half of the graph width.

� Display the Scale or Values on the Graph: The Scale check box is selected by default. Uncheck this box to
disable the x-axis scale of the graph and check the Value box to display the values of the
segments on the graph.

� Format a Pie Graph: The Pie Section drop-down menu provides a choice between a whole pie, the top
half, or the bottom half, to be used in the design of a pie chart.

� Slice Burst: Determine the distance between each pie segment. The value entered will be based on a
percentage of the radius.

� Labels on Graph: Enables label formatting for a pie chart. The formatting options are presented in
the Pie Labels window that is accessed by clicking the Labels button.

� Label Offset: This value determines the distance of the labels from the pie.

� Label Dash Width: Determines the dash line width. The color of the dash line can be changed by
selecting a color from the Label Dash Color drop-down palette.

� Space Between Bars: Enter the Space Between Bars as a percentage of the bar width.

� Format: Choose a format from one of the available selections in the drop-down menu or define a
custom format. For more information, see the definition of FORMAT as described in the
System Transforms section on page 244.

� Set as Default: Enable this check box to instruct Proform Designer to use the current settings in the
future when creating graphs.
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Graph Fields

� To add graph fields

1. Open the Graph Properties window. Select the Graph Fields tab.

2. Click Add Field.

3. The Graph Fields window will appear. Select a Label and Value from the drop-down menus.

4. Click OK.

� To edit graph fields

1. Select the graph field to be edited.

2. Click the Edit Field button.

3. Make necessary edits from the Graph Field
window.

4. Click OK.

Merge Data Values

If you want to bundle together two or more data
fields into one, label the fields with the same name
and select the Merge Data Values box. The
accumulated totals of all the combined fields will
appear as one field.

� To merge data values

1. Check Merge Data Values.

2. Click OK to accept.

Size and Position
You can specify an exact location for the graph to be placed on the form, as well as an exact size, through
the Size and Position tab.
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Chapter 8

Creating Jobs and Saving to VI Compose

Proform Designer can create single page VI Compose jobs as well as multi-page VI Compose jobs.
When saving a document to VI Compose, several files are created. The .FSL form file, .JDT, .XJT
and/or .DBM files will be saved in the FORMS directory specified in the resource set. In the

specified VI Compose output folder, automatically named XGFC upon installation, another copy of the
.JDT (\\jdtlib), .XJT and .DBM (\\formlib)will be created. The form to be loaded to the printer will be
saved as a .FRM in the \\formlib directory. The .JOB, .INI, .PFA (bitmapped fonts), .PFB (PostScript
fonts) and data files with the appropriate printer header will be added to the \\misib directory. The image
files will output to the \\imglib. All data-driven images will need to be copied into the \\imglib manually, or
listed in the Additional Resources folder when building the job.

Saving a Single Form to VI Compose
Single forms can be saved to VI Compose without having to take the additional step of building a job. All
necessary resources will be created automatically and placed in the appropriate directory within the XGFC
folder.

� To save a single form to VI Compose

1. From the open form, select Save As from the File menu.

2. Choose Xerox VI Compose Form (*.frm, *.dbm) from the Save as type drop-down menu.

3. Click Save.

4. Proform Designer will automatically save the form to VI Compose and place all resources in the
appropriate directories.
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Creating VI Compose Jobs
Designer can create VI Compose jobs for multiple page variable documents. Creating a VI Compose job is
useful and necessary when you have multiple forms that need to be combined together in a variety of
configurations and contained in one job.

The Job Menu is organized into a tree structure. The tree structure can be expanded to reveal forms
contained in the job, as well as all specified job parameters. Each job option is listed next to a blue circle. To
change the setting of each option, double click the option. The job menu drop-downs will re-populate
depending upon the option selected. You will know which option you are editing because the circle next to
an active option will be yellow.
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Creating a New Job

Name the Job

The first step in the job creation process is to define a new job and give it a name.

� To create a new job based off a form

1. Open the form that will appear first in the job sequence.

2. Go to the File menu and select New Job.

3. The Job Menu will appear on the left hand side of your screen.
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4. Enter a Name for the job into the Job Name field. Notice that the information entered into this field
is also reflected in the name of the job folder in the
tree structure below.

Specify a Data File

The data file that is currently imported into the form will automatically be defined in the Data File Name field.
If this is not the data file that you want to use when printing, you will need to define a different data file to
be contained in the job.

� Specify a data file for printing

1. Click the ellipses next to the Data File Name field.

2. Browse to locate the needed data file.

3. Highlight the file and click Open.

4. The new data file will be displayed in the Data File Name field.

Remote Data File

When saving a job to VI Compose, it is now possible to use a data file that is not stored at the printer. This
feature is particularly useful for very large data files since they can be selected from anywhere on the
network or your computer and will not consume space at the printer. When using a remote data file
however, the data file will not be included in the container.

� To use a remote data file

1. Define a job by selecting New Job from the File menu of an open form, or open a previously created .pfj
file. To open a .pfj, go to the File menu and select Open. The list of .pfj files will be provided.

2. Enable the Remote Data file check box.

3. Use the Data File Name ellipses to browse for the desired data file.
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No Data

If you are creating a VI Compose job that does not use data, such as a lottery ticket that simply uses a
counter, you must first define a number of records to be created within your "No Data" form. In order to
create a Job, your form must have either a data file imported, or "No Data" settings defined.

� How to define "No Data" mode within your form in order to create a Job

1. With your single form open, select Edit and then choose Field Settings, and then choose Define Variable.

2. The Data Parameters menu will appear. Select the number of records you would like to create and click
OK.

3. You can now create a job by going to File and
then selecting New Job.
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Creating a Job using the Template Manager

Many pre-defined Templates are available for Labels, Cards (business and postcards), Letters and PDF
documents. Templates are separated by general categories, and once the template is selected from a list, you
will be guided through various menus showing which Multi-Up settings, Paper and Form Sizes, Cut Marks,
and images to be used as backgrounds are pre-selected. Any of these settings may be changed along the
way. If changed, the last menu gives you the option to save overwrite the existing template, or create a new
one..

� To create a job using a Template

1. Templates can be accessed three different ways:

� Select File, and then choose Template Design.

� Select the Start Template Wizard button from the Standard toolbar.

� Select the Template button from the Welcome Menu.

2. The Choose Template menu will appear. Use the Template Type drop-down menu to select the type of
templates you would like to display. Selecting a specific paper size using the Paper Size drop-down will
narrow down the list of supported templates.

3. Select the desired template, or click Custom Template and click Next. The following menus will display the
default settings that have been defined for the template. If desired, these settings can be changed
before continuing onto the next menu.

4. The Template Identify Pages menu has drop-downs that allow you to choose existing forms to be used
within the template. If no forms are chosen, new forms will be created.

5. Once all the settings have been reviewed, click Finish. If any settings have been altered from the default
settings and you would like to keep them for later use within the template, click the Save Template
button to either save the current template or create a new one.

6. The Import Data menu will appear. Browse and select the desired data file to be used, or select the
No-Data button if creating a simple application that does not require a data file. Continue through the
Data Import Wizard to define the data settings.

7. Once the all settings have been defined, the project will open with a blank form(s) and is ready for
images and data to be placed onto the design.
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Job Sets
After creating a job, it is possible to establish job sets as part of that job. Job sets contain lists of pages to
be named as separate sets within a job, all of which must use the same data file. Creating job sets is a highly
flexible and efficient way of building and managing complicated variable data documents. Once defined, job
sets can be manipulated using job conditions to create highly sophisticated VI Compose jobs.

� To create a job set

1. After creating a job, double click on the job folder, listed within the job tree (This will usually be the
first folder). A drop-down menu will appear, select Add Job Set.

2. The Job Set Name menu will appear prompting you to name your new job set. Once named, press OK.

3. A confirmation menu will appear asking if you'd like to create this new Job Set, click Yes.

4. You may now continue creating additional job sets, or adding new/existing forms to your job sets.
Instructions on adding forms can be found on the next page.
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Managing Forms
An unlimited number of forms can be added to a job or job set. The form that was open when you created
the job will already be contained in the job tree.

Adding Existing Forms

Forms that have already been created can be added to a job or job set.

� To add an existing form to a job

1. Double click on the job folder that contains the existing form. From the drop-down menu, select Add
New Page.

2. The Add New Page menu will appear. Click on the browse button to browse for the existing .fsl/.dtd.

3. Once a .fsl/.dtd file is selected, click OK and it will be added to the project.
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Adding New Forms

New, blank forms can also be added to a job. A new form must use the same data file as the rest of the
forms in the job, and the data file that is included in the job tree will automatically be used on the form as
well. Once the new form is added you can add images, text and form elements as necessary.

� To add a new form

1. Double click on the job folder that you would like to add a new form to.

2. From the drop-down menu, select Add New Page.

3. The Add New Page menu will appear. Name the new .fsl/.dtd file and click OK.

4. The new page will be added to the job.

Selecting the Blank Form check box will create a blank uneditable form that will act as a placeholder. Blank
forms can be used for multi-page duplex applications.
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Changing File Names

Pages that have been added to a project can have their file names changed within the job tree.

� To change a page name

1. Double click on the page to which the name change will be applied.

2. The file name can be changed by either typing the new name into the edit box, or using the
drop-down menu to select Edit Page Name.

3. If Edit Page Name is selected, an edit menu will appear where you can update the file name.

Removing Pages

Pages can be removed from the project.

� To remove pages from the project

1. Double click on the page that is to be removed.

2. Select Delete from the drop-down menu.

Ordering Forms in a Project

Pages can be reordered once they've been added to a job.

� To reorder pages in a project

1. Double click on the page to moved.

2. From the drop down menu, you may either select Move Page Up, or Move Page Down.
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Defining Form Options
Once a form has been added to a job, additional options, such as job conditions, can be defined. These
options will only affect the form on which they are defined, and may be used to modify the behavior of a
job on a form by form basis. For example, use the Plex Control to define one form to print simplex, while
the rest of the job is printed duplex.

Add Background

Backgrounds can be added to forms or can be called in
without a form (a blank sheet). A background may be an
image or page created outside of Proform Designer. It is
possible to define a background for each form that is listed
in the job tree by dropping down the information that is
contained within each individual form folder and selecting
the Background option.

� X Origin: Define the X location for the top, left
corner of the image.

� Y Origin: Define the Y location for the top, left
corner of the image.

� Orientation: Define the orientation of the
background image. Choose from Landscape,
Portrait, Inverse Landscape and Inverse Portrait.
This information is critical so that Proform
Designer will place the background image in the
correct location on the form.
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� To add a background

1. Double click on the form folder for which a background will be defined, this will expand additional
options.

2. Double click on the Background option. If you have not previously defined a background for this form,
it will be listed as <None>.

3. The drop-down menu will be populated with a list of images. Choose the appropriate image to serve
as the background for the form, or click the browse button to browse elsewhere for an image.

4. Once selected, the image file will be listed in your job tree and appear on your design.
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Plex Control

Defining a Plex control for a particular form will override the Plex control that is set for the job as a whole.
This allows you, for example, to print a simplex form in the middle of a duplex job. Set the Plex control for
the form by enabling the Plex Control option and choosing either simplex or duplex from the drop-down
menu. Note that the Page Format for the job must be set to duplex in order for these options to be
available.
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Green Bar

Applying this feature will cause alternating white and colored stripes to be printed on the form. This can
make it easier to read forms that contain many lines of data, such as financial statements. Define the Green
Bar function by double clicking on the option and selecting Yes from the drop-down menu. This will enable
the feature and provide a list of additional Green Bar options that can be defined..

� Color: This will define the stripe color. Select an option from the drop-down menu.

� Lines in Stripe: Choose how many lines will appear in the stripe. Enter the number into the Edit Box.

� Lines in White: Choose how many lines will appear in the white. Enter the number into the Edit Box.
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Select Media

This option makes it possible to specify that certain forms will be printed on special media. To enable
additional options, double click on the Select Media option and select Yes from the drop down menu.
Additional media options will now be able to be defined.

To edit any of the sub options within the Select Media folder, double click to enable the applicable
drop-down menu and edit boxes.

� Type: Select a pre-defined paper type from the drop-down menu, or enter a custom type. Custom
paper types will be recognized as long as they are defined in the same manner at the printer.

� Color: Select a pre-defined paper color from the drop-down menu, or enter a custom color.
Custom colors will be recognized as long as they are defined in the same manner at the printer.

� Weight: Select a pre-defined weight from the drop-down menu, or enter a custom weight. Custom
weights will be recognized as long as they are defined in the same manner at the printer.

� Front Coating: Select a pre-defined front coating from the drop-down menu, or enter a custom
description. Custom coatings will be recognized as long as they are defined in the same manner at
the printer.

� Back Coating: Select a pre-defined back coating from the drop-down menu, or enter a custom
description. Custom coatings will be recognized as long as they are defined in the same manner at
the printer.

Offset

Enabling the Offset feature will cause the printed pages of each set to be shifted in the output bin. In order
for this feature to work properly, Set Delimiting must also be activated from the Options folder. Defining
an offset from a form will cause the offset to begin only once that form has been called, and will continue
until Designer reaches the end of the set.

� To enable offset

1. Double click on the Offset option.

2. Select Yes from the drop-down menu.
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Output Bin

Individual forms can be sent to output bins that are different from where the bulk of the job is sent.
Defining an output bin from a form will only affect that form and not the entire job. Enable the Output
Bin option and select a pre-defined output bin from the drop-down menu, or enter a custom output bin.

� To define an output bin

1. Double click on the Output Bin option within the Job Tree.

2. Select from Top Tray, High Capacity Stacker, Face-Up Tray.

Bookmark

If you will be using VI eCompose (VIPO) bookmark feature, you must tell Designer on which form that
bookmark will be located. Define the bookmark within the job tree. Only one bookmark can be defined per
job.

� To define a Bookmarked Page

1. Go to the Job Menu and expand the form to which you will add the bookmark.

2. Double click on the Bookmark node and select Yes to specify that there is a bookmark on the form.
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Job Conditions

Multiple conditions can be defined on each page of a job. A job condition is created in much the same way
as a conditional text or image statement. Job conditions, however, require actions to be defined, rather than
text or images. Actions determine how the job is printed and can be used to control things such as the
sequence of forms and the use of job sets.

� To define job conditions

1. Expand the form folder from which the Job Condition will be defined.

2. Double click on the Job Conditions option and select Yes from the drop-down menu to enable more
options.

3. The Job Condition window will appear. Click Add to start defining conditions.
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4. The Add Condition window will appear. It is from this window that the conditions can be defined.

5. Conditions are added in the same manner used when specifying conditional logic statements. Specify
the Field/Variable that the condition will be based off of, the Function, and value that the condition is
being compared to. Once the condition is defined, click OK.

In addition, there is a variable type called Job Conditions. The job conditions variable includes End of Set
and End of Job.

� End of Set: Define special formatting to occur at the end of each set.

� End of Job: Define special formatting to occur at the end of each job.

Job Conditions have an additional function, changed, that is not available with data conditions. This
function is used to test if the contents of a field have changed from those of the previous data record.
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6. Specify Job Condition Actions by clicking the Action button after the Job Condition has been defined. The
following Action options are listed below.

Additional Pages

If job conditions are set that require extra pages to be inserted, such as Insert Form or Replace Form, the
form that will be called will be stored in the Additional Pages folder. This folder will automatically be
created when a job condition that requires an additional form is defined. The additional forms will be
automatically added to and deleted from this folder as necessary. Users are not able to manually included or
delete forms from this folder.

Job Condition Actions

Once job conditions have been established, various actions can be defined to direct what happens when the
conditions are met. Actions can be used to control the sequence and number of forms in a job, as well as
job sets and the use of the data record. The function of each available action is defined below.

Form Actions:

Next Form: This is the default setting. The current form will be printed, and then the next form defined in the
job will be printed.

Replace Form: The Replace Form Action will replace the form on which this condition is set with another
form specified in the Forms drop-down menu.

Repeat Form: This action will print the form on which it is defined for the number of times specified in the
Repeat Count drop-down menu, then continue to print the next forms in the job. The Repeat condition will
not be reevaluated on the repeated forms. All other conditions, however, will be evaluated on all repeat
forms.

Skip to Form: This action will skip to another form within the same job set, as designated in the Form
drop-down menu. It will not print the current form.
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Insert Form: This action can be used to insert any desired form into the series of forms in the job set. The
form, however, must use the same data file. After the inserted form prints, the current forms in the job will
continue to print.

Escape From Job Set: This action will end printing after the current form and resume printing from the
beginning of the job set, automatically advancing the data record. This is a convenient way to create subsets
within a job set or to eliminate forms conditionally from within a job set.

Restart Job Set: This action can be used to skip out of the current data record at any point during printing and
move on to the next data record. The job set will restart without printing the current form. This is similar
to the Escape from Job Set action, yet the Escape from Job Set action will print the form on which the
condition is located. The data record will be advanced automatically.

Ignore Data Record: This action will exclude an entire data record from printing, and the job will proceed to
print the next data record. The job set will not be restarted.

New Job Set: This action provides a means of moving from one job set to another. If more than one job set
has been established, the New Job Set action can be used to manipulate the flow of the sets. (The only
other way to manipulate multiple job sets is to use the Insert Job Set action) New Job Set can be used at any
point in the job set. The form on which the condition is set will not print, and the job set specified in the
Job Set field will begin to print.

Insert Job Set: This action will print the entire contents of a specified job set before the form on which this
condition is set. For example, if the condition is met on form 5, Job Set 2 will print after form 4, and then
Job Set 1 will continue to print. This is very useful in cases where more than one form is to be inserted into
a job set. If only one form is to be added, it is best to use the Insert Form action. Insert Job Set can only be
used with one level of insertion. A job set can't be inserted into a second job set, which will in turn be
inserted into the third job set.

Control Actions:

The following Control Actions can also be applied from within the Job Condition Action window.

Advance Page To: Choose from Next Side, Back Side, or Front Side. Next Side will print the current page on
the next physical page. Front Side will print the current page on the next front of a new sheet. Back Side
will print the current page on the next available back side of a sheet. This feature is only available if
duplexing is enabled.

Advance Data Record: If this box is enabled, every page will use a different data record. Advancing the data
record is the default setting for applications using database or xml data, whereas holding the data record is
the default setting for applications using line mode data.

Delimit Set: Enabling this box will insert commands defining the end of a set.

Job Set: Allows list of pages to be named as separate sets within a job, if these sets will use a single data
record.

Repeat Count: If Repeat Form is defined as the form action, the Repeat Count option will be enabled. Repeat
Count allows the user to define how many times the form will be repeated.
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Page Format: Define if the action will include a page format change. Choose between No Change, Simplex,
Duplex, or Tumble Duplex.

Orientation: Choose from No Change, Landscape, Inverse landscape, Portrait, or Inverse Portrait.

Binding: Select from No Change, Off, or On.

Stapling: Select from No Change, Off or On.

Select Media: When this box is enabled, the paper type, color, weight and coating can be defined.

Slip Sheet: When this box is enabled, it is possible to select one of the forms in the job to serve as a slip
sheet. Define a paper type, color and weight.

Output Bin Control: Jogging can be controlled (select from No Change, Off, or On)to offset pages and the
output bin can be defined.

Change Variable: Enabling the Change Variable check box makes it possible to replace the value of a variable
with another. Select the variable that will be replaced from the Change Variable drop-down menu, and
either select a replacement variable or enter a replacement value into the To Value drop-down menu.

Ordering Forms in a Job

The order that the forms appear in a job can be easily edited one at a time.

� To change the order of forms in a job

1. Double click on the form that needs to be moved.

2. Using the drop-down menu. select either Move Up Page or Move Down Page to move the form.

Delete a Form from a Job

� To delete a form from a job

1. Double click on the form to be deleted.

2. Using the drop-down menu, select Delete Page.
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Multi-page PDF
Multi-page PDFs can be directly imported into a job for immediate PDF splitting to a VI Compose
compatible TIFF format. Once the PDF is split into separate design pages, variable data can be applied to
each page in the job build interface.

� To import a multi-page PDF into a job

1. Create a New form and import a data file (or create a variable to work in No Data Mode).

2. Go to the File menu and choose New Job.

3. Within the job tree, double click on the existing
form.

4. Select Add Page After from the drop-down menu

5. The Add New Page menu will appear, select the
browse button to browse for the desired PDF and
click OK to add the selected PDF to the job.

5. This will create new editable forms for each page
of the PDF.

If there is no need for any additional pages in your job aside from the ones created when importing your
multi-page PDF, then the initial page that was created can be deleted.
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Options

There is a selection of job options available from within the Options folder in the job tree. Double click the
options folder to expand its contents and reveal the list of job options. Job options effect the entire job
unless a form option and/or job condition is applied to a particular page.

� To define job options

1. Select the option for which you would like to make a specification.

2. The drop-down menu will be automatically populated with options, depending upon the selection.
Choose from the drop-down list which selection you would like to use.

3. The options are defined as follows:

� Page Format: This option describes how the forms will be printed. Choose from simplex, duplex, or
tumble-duplex.

� Output Bin: Enter a user-defined output bin, or choose from top tray, high capacity stacker, or
face-up tray.

� External Finisher: This option is only available for environments where external finishing devices are
used. Entering the name of the external finisher as defined on the DocuSP printer into the
External Finisher field will disable the output bin, staple, bind, and offset job options.

� Staple: This option allows you to specify if and how the application will be stapled. Choose from
SingleLandscape, SinglePortrait, DualLandscape, DualPortrait, RightLandscape, RightPortrait, or
RightDualPortrait.

� Bind: Specify if and where the application will be bound. Choose from RightPortrait or
LeftPortrait.

� Abort on Missing Resources: Proform Designer can behave in two different ways when coming across
missing resources: abort or no display. By choosing Abort on Missing Resources, the job will be
stopped if resources are missing. By choosing No Display on Missing Resources, the job will still
be processed, but the missing resources will not be displayed.

� Advance Record: The data record can be advanced at job or page break. This option must be enabled
for jobs using line mode data if page conditions are being used.

� Collate: Select yes if you want the pages to be collated as they print.

� Precache Images: Choosing to precache images will send all the images to the printer ahead of the
job, where they will be cached. This may greatly increase your printing speeds on printers
supporting PRECACHE.

� Booklet: Select Booklet if the application you are creating is a booklet.

� Set Delimiting: This option enables staple, bind, collate and offset to occur at the end of each set.

� Offset Job: Sorts printer output for easy separating, handling, or stapling. Note that this feature is
available based upon printer capabilities.

� Maximum Pages in Job Cycle: Usually set automatically and determined by the number of forms.

� Multi-Plex Tolerance: If it is necessary to switch between simplex and duplex within a single print job,
specify the number of consecutive pages that can occur before switching modes.
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� Demographics: Choose how the VI Compose files will be handled. Choose Save and Print if you
want to print the job immediately, or Save if you just want to create the VI Compose resources
now and will print later.

Output Paper Size
The output paper size defines the physical size of the substrate the application will print on. This differs
from the paper size of the form when Multi-up is defined. The Output Paper Size should be defined prior
to enabling Multi-Up options.

� To update paper size

1. Double click the Output Paper Size folder and select Yes to enable more options.

2. By default, the Output Paper Size will be defined with the same dimensions as the form size. To
change this, double click on the two options within the Output Paper Size folder to change the
Orientation and Size dimensions. The paper size can be chosen from a pre-defined list in the drop-down
menu, or if Custom is selected, custom values can be entered.

Multiple-Up Jobs
Multi-up forms contain two or more logical pages on a single page and
are a useful way of creating postcards, labels, lists, or any application
when there is a need to have multiple pages, records of data, or a single
data record printed multiple times, on a single page. Simplex, duplex, and
tumble-duplex multi-up jobs can be created using line, delimited and
XML data files. The VI Compose Z-Sort capability makes it possible to
match data records on the front and back sides of a multi-up application,
and is available in both delimited and XML data modes.

� To create multi-up jobs

1. Double click the Multiple Up folder and select Yes from the drop-down
menu to enable additional options.

2. Edit the sub-options in the multi-up folder by double clicking on
each node to change the settings, or double click on the Multi-Up folder and select Edit Multi-Up Settings
to display an easy-to-use Edit menu.
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3. A list will appear, containing the following options:

Repeat Direction: Choose from rows, columns, or custom. Selecting custom will allow the user to define the
exact (x, y) location, as well as the rotation, of each form on the multi-up page. This makes it
possible to specify a dutch cut layout in order to utilize leftover space on the paper.

Rows: Specify how many rows will be on each multi-up page.

Columns: Specify how many columns will be on each multi-up page.

Data Repeat: Specify how many times, if any, the data record should be repeated on one page.

Offset-X: If necessary, enter an offset value. This will shift the application along the X-axis.

Offset-Y: If necessary, enter an offset value. This will shift the application along the Y-axis.

Z-sort: To enable z-sort (to be used when the data on the back of a multi-up application needs to match
the front) enter a stack size number. A z-sort with a value of '0' will denote no z-sort.

Background: This option allows you to select a non-multi-up background to be printed behind a multi-up
application. This is an excellent way to implement crop marks.
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Z-Sort

Z-sort can be used for two different functions that can work
independently or in conjunction with one another. When z-sort is
enabled, it can be used to match record locations on duplexed forms.
Z-sort will perform the caching that is necessary to place the data
record on the back of the form to match that which is on the front.
Z-sort can also be used to create stacks so that the job can be cut and
placed into piles, while the original order of the data file is preserved.
This unique function requires that the user set the stack size to the
number of forms that will be placed in each stack.

The stack size is displayed as a numeric value next to the Z-Sort
option. This value will, by default, be set to '0' before any z-sort
functions are defined. A stack size of '0' cannot exist. By defining a
realistic stack size, you also enable the z-sort option.

� To create a multi-up job using z-sort

1. Create a job, adding only the form that will be used for the front of the application.

2. If multi-up has not yet been enabled, double click on the multi-up folder and select Yes from the
drop-down menu.

3. Select the Z-Sort node and double click and choose Yes to enable additional option.

4. The Z-Sort option will now be populated with additional options: stack size, shorten last stack and slipsheet
form.

� Shorten Last Stack: Enabling Yes for this option will allow the last stack to consist of fewer forms than
what is defined as the stack size. This prevents the last stack from being filled with blank pages to
compensate for an uneven number of data records.
Selecting No for this option will make the last stack the same size as all the other stacks, filling in
with blank pages what is not filled with forms.

� Slipsheet Form: Choose a form to be used as the slipsheet. You may choose a form from the
drop-down list, manually enter a form name, or click the ellipses button to browse in other
locations for the desired form.

� Slipsheet Media: Choose the type of media on which the slipsheet will be printed. Either select a
pre-defined type from the drop-down menu, or manually enter a user-defined type.

To finish setting up the multi-up, z-sort job, you must define a page condition that will call in the
appropriate form for the back of the application. Follow the directions below to implement the necessary
page condition.
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� To create a z-sort job condition

1. Click the + next to the form folder to expand and display its contents.

2. Select the Job Condition option.

3. Click the Add button.

4. The Job Conditions window will appear. Click the Add button to start adding conditions.

5. The Add Condition window will appear. Define the following condition:

If System Variable BACK = true

Change the drop-down menu to the right to "System Variable" first, and then change the left drop-down to
"Back". Lastly, use the drop-down on the bottom of the menu to choose "true".
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6. Click OK. You will be returned to the Add Job Condition window. The condition that you just defined will
be listed here.

7. To define the action that will take place when the condition is met, click the Action button.

8. The Job Condition Action window will appear. Select Replace Form from the Form Action drop-down menu.
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9. Use the ellipses '...' button to browse for the desired form.

10. Click OK in the Job Condition Action window, the Add Job Condition box, and the Job Conditions box to save the
new condition.

11. The new job condition will be listed in the job tree.

Include System Keywords, located in the Data tab of the Preferences menu, must be checked in order for System
Variable to be an option in the Add Condition menu. This option will be enabled by default upon installation.

Creating Jobs and Saving to VI Compose 289

�



Page Numbering
You can choose to include a page number on applications. VisionDP allows you to select from four
different locations for that page number: bottom center, bottom right, top center, or top right.

� To apply a page number

1. Double click the Page Numbering folder and select Yes from the drop-down menu to enable more
options.

2. Double click on any of the options listed within the Page Numbering folder to define settings other
than the default.
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Additional Resources
Data-driven images and externally referenced fonts are not automatically included when Proform Designer
generates VI Compose resource files. Adding these images and fonts will ensure that the project and
container contains all the needed resources.

� To add additional resources

1. Go to the Job Tree and select the Additional Resources folder.

2. The drop-down menu will be automatically populated with the list of images that are contained in the
Images folder of the current resource set. Either make a selection from this list, or click the ellipses
button to browse in other locations.

Vector based images (*.eps) often reference external font files (*.pfb, etc.). Unless the external fonts are
used in the design of the document elsewhere or otherwise specified as an Additional Resource, Designer
will produce fonts (*.pfa bitmap fonts) rather than reference PostScript Type 1 (*.pfb) scalable printer fonts.
All PostScript Type 1 fonts should be imported into the Windows Control Panel and Proform Designer
Resource Set prior to using them.

Line Mode Banner Support
Designer supports one or more pages of Banner data within a job. Banner data can be ignored, printed, or
formatted. Banner data is usually used to separate jobs at printing.

� To define banner support

1. Select the Banner option from the Job Menu and double click to expand its contents. If there has been no
banner data previously defined, the contents will be displayed as None.

2. Select the Banner option. Click Add to specify that there is banner data associated with the job and to
create a list of banner data options.

3. Select an option. The Edit Information menu will become available to define and change the specifications
associated with each of those options. The following options will be available:

� Banner Pages: Key in a number to define how many banner pages will be included.

� Print: Select Yes or No to define whether the banner data will be printed or not.

� Jog On Next Page: Select Yes or No.

� Output Bin: Key in an output bin.

� Media: Selecting Yes will populate the Media folder with additional options of Paper, Color, and
Weight. These can be defined as well, to further customize the banner data.

� Slip-Sheet: Selecting Yes will enable further options by which to define the slipsheet: form, paper,
color, and weight.
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Creating Print Job Files

To create the necessary VI Compose printing files, click the Save to VI Compose button, located at the bottom
of the Job Menu. This will produce a .pfj job file, along with all the necessary VI Compose resources. These
resources will be stored in the appropriate subdirectories, as specified in the Locations tab of the resource
set, located within the XGFC folder.

� To create VI Compose job files

1. Define the necessary job parameters as outlined in the
previous section.

2. Select the type of VI Compose files to be created from the
Create drop-down menu:

� VI Compose Job: Creating a VI Compose Job will save all
the VI Compose files in the subdirectories of the
XGFC folder.

� VI Compose Project: Creating a VI Compose Project will
save all of the VI Compose files in the project folder,
located in the XGFC directory.

� VI Compose Container: Creating a VI Compose Container will also save all of the VI Compose files in
the project folder, but will also create a *.vpc file. The *.vpc file contains all of the resources
associated with the job in a compressed format.

� FreeFlow VI eCompose (VIPO): Selecting this option will automatically launch the VI Compose files to
the FreeFlow VI eCompose (VIPO).

� Adobe Distiller PDF: Selecting this option will automatically launch the VI Compose files to VI
Compose enabled Adobe Distiller.

� FreeFlow VI Designer (IDE): Auto-launches the FF VI Designer to screen view VI Compose output
results.

� FreeFlow VI Explorer: Auto-launches the FF VI Explorer to screen view VI Compose output results.

� Click & Print: Creates a VI Compose Container and submits job to a predefined FreeFlow Print
Server hot folder.

3. Click the Save to VI Compose button.

4. All the resources will be output to the appropriate destination according to the selection made in the
Create drop-down menu.

For more information on setting up the auto-launch features, please refer to Chapter 10: Set Up Auto-Launch.
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Editing Jobs
Once a job is created it can be edited.

� To edit a job

1. Open the .pfj file of the job to be edited. This file is stored in the Data folder, within Proform
Designer.

2. Make any necessary changes to the job in the Job Tree.

3. Click the Save to VI Compose button to output the new files.

Submit Data File via LPR
LPR (Line Printer Remote) is a printer protocol that establishes connections between printers and
workstations over a network. When a job is saved to VI Compose, Designer creates all the VI Compose
resource templates that are to be stored on the print device. These resources can be submitted
automatically by mapping the networked print device through the Locations tab of the resource set, or by
sending the files to the printer through FTP. Once the VI Compose resources are at the print device, VI
Compose requires the data file to be sent via LPR. Designer further supports this workflow by providing
the LPR capability within the Designer interface rather than requiring a manual submission through a DOS
command, greatly simplifying the process.

� To submit a data file via LPR

1. Click the LPR button, located at the bottom of the Job Menu.

2. The Submit Data File to Printer via LPR window will appear.

3. Select a printer from the Printer drop-down menu.

4. Click the ellipses button (...), next to the Data File field. Browse to locate the desired data file. The
sample data file that was used to design the job will be placed here by default.

5. Select a data file from the Choose Data File window.

6. Select or enter a Printer Queue, if one is defined at the printer.

7. Precede with INI File will be checked by default. When this check box is enabled, Designer will insert the
INI file into the data file, and printing will automatically start.

8. Click Submit to send the data file.
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Select VI Compose Locations
If you have more than one VI Compose Printer defined within the current resource set, you can use the
Select VI Compose Locations button to specify to which printer the job will be sent.

� To select a VI Compose location

1. Click the Select VI Compose Locations button.

2. The Select VI Compose Output Locations window will appear.

3. Enable/disable the appropriate locations by checking the
boxes to the left of the location to which you want the
output to be sent.

4. Click OK. The job will be sent to only the enabled
locations.
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Manage Job Source File Resources
All job source files are saved by default in the locations mapped in the Resource Set.

� Form (job source *.pfj, form sources *.fsl / *.dtd)

� Font (PostScript Type 1 *.pfb and other bitmap fonts)

� Images

� Data

Individual job source files, for just one job, can also be archived in a single directory or *.zip file. Most of
the files required to open the job will be included except fonts and data-driven images that were not added
as Additional Resources to the job. Windows TrueType fonts and PostScript Type 1 display files (*.pfm) will
not be included.

Copy Single Job Source to Folder

� To Send Job Files to Folder

1. Create a directory to house the job files (using Windows Explorer, etc.).

2. Launch Lytrod Designer and create a New Job or Open a job (*.pfj).

3. Go to the File menu, choose Send To and Folder.

4. Browse for the folder created in step #1 and click Open to send the job source files to the directory.

Zip a Single Job Source (Send To Archive)

� To ZIP Job Source Files

1. Create a New Job or Open a job (*.pfj).

2. Go to the File menu, choose Send To and Archive.

3. Click OK to create zip file of job in the \Proform Designer\archive directory displayed. A *.zip file
with the job name will be created in the \archive folder.
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Chapter 9

Creating OMR Forms

OMR forms are special forms that allow high speed capturing of hand input data. These forms are
distinguishable by the bubble shapes that are used to capture information; therefore, they are
frequently referred to as bubble forms or scannable forms. This type of form is commonly used

in standardized testing, surveys, payroll data collection, and other applications where a limited number of
responses are required.

OMR is an acronym for Optical Mark Reader. Optical Mark Readers are LED scanning devices that
interpret the black marks strategically placed on a page. The OMR scanner initially detects a tracking bar
placed on the edge of a sheet and is then triggered to scan that row for black marks. These black marks
must be placed exactly in relation to the tracking bars as dictated by the density (even placement of the
LEDs) of the scanning device. In order to get the user to place the marks at the exact position, a
circle/oval/rectangle/square is drawn precisely where the scanner will look for a mark.

A total of three OMR modes are supported in Lytrod Software::

(1) Character, which is the normal type of OMR

(2) Binary Decimal

(3) Binary Litho

By default, Character OMR will be automatically enabled. Binary Decimal and Binary Litho modes can be
enabled through the Preferences menu.

It is optimum if the bubbles, and the text within the bubbles, are designed in a color other than black. If
OMR elements are placed on a monochrome form, the text within the bubbles is not drawn. If it were, it
would cause scanning problems since the black toner would appear to the scanner to be a filled in mark in
the middle of each bubble.
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OMR Form Setup

Scanner Type
Proform Designer supports two types of OMR scanners: 40 channel and 48 channel. Typically, 40 channel
scanners are used outside of the United States, and 48 channel scanners are used primarily within the
United States. It is important to identify the type of scanner that will be used in order to create the OMR
form properly.

� To select a scanner type

1. Select Form Layout from the Edit menu.

2. Access the OMR Settings tab.

3. Mark the appropriate radio button to indicate the scanner type.

� To set default scanner type

1. Select Preferences from the Edit menu.

2. Access the OMR tab.

3. Select the default scanner type, either 40 or 48 channel, from the Channel drop-down.
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Tracking Mark Placement

Tracking bars are used to notify the scanner that responses lie in a particular row/column. Their placement
is critical in creating a scannable form. Proform Designer will automatically place tracking bars at the
correct distance relative to the edge of the paper and spaced at the column/rows per inch specified.
Designer also assures that the tracking bars that are placed on the form are accurately aligned with the
responses.
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� To define tracking bars

1. Select Form Layout from the Edit menu.

2. From the OMR Settings tab, select the desired tracking bar location. (left/right for portrait forms, or
top/bottom for landscape forms)

3. Choose columns per inch or rows per inch based on form orientation, from the respective drop-down menus.
Support for 5, 6, or 8 columns/rows per inch is available (along long edge of paper).

This sets the default spacing for the form. Spacing can be different for each set of responses as long as all
of the responses associated with the individual tracking bar use the same spacing. Specific response spacing
is done in the OMR Response Properties window. Tracking bar spacing will automatically be adjusted,
based on the response spacing.

Tracking Bar Size

The default tracking bar size is 15. This size is measured in dots (300/inch) and refers to the thickness of
the tracking mark. Users can modify this size in order to increase the scanning area of each scan row. This
helps to insure that the form is able to be scanned.

� To set default tracking bar size

1. Select Preferences from the Edit menu.

2. Open the OMR tab.

3. From the Tracking Bar Size drop-down, choose one of the predefined sizes.

Selective Tracking Bars

Tracking bars are not necessary for rows/columns that do not contain responses to be scanned. The
Selective Tracking Bars option automatically places tracking marks in relation to responses on the page and
updates them as responses are moved or deleted, etc. Individual tracking bars can also be turned off and
on as desired with the mouse.

� To enable selective tracking bars

1. Select Preferences from the Edit menu.

2. From the OMR tab of the Preferences window, click Selective Tracking Bar Drawing.
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� To add/remove individual tracking bars

1. Click the left mouse button over the tracking bar to be added/removed. The mouse pointer shape
will change over valid positions on the screen where tracking bars are allowed. Clicking the left
mouse button will toggle the tracking bar on and off.

Form Identification Marks (FIM)
Form Identification Marks are used to identify each scanner form. These marks can be located on the
bottom or top of a landscape OMR form, or along the right or left side of a portrait OMR form.

Form Identification Mark Setup

� To define form identification marks

1. Select Form Layout from the Edit menu.

2. From the OMR Settings tab, check the appropriate FIM locations.

3. Choose individual FIM mark locations by clicking on the appropriate column locations on the form.
Chosen column locations will be blackened on the form, indicating selection.

Removing Form Identification Marks

� To add/remove form identification marks

1. Position the mouse over the area of the form where the FIMs are defined. The mouse pointer shape
will change when over a position on the screen where FIMs are allowed. Clicking the left mouse
button will toggle each individual FIM off or on.

Form Identification Marks are commonly referred to as Skunk Marks.
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Working with OMR Elements

Drawing Response Blocks
The main element of the OMR form is the response block. These blocks are defined using the OMR
response drawing tool.

� To draw response blocks

1. From the Drawing toolbar, click OMR Response to enable OMR response draw mode.

2. Position the mouse where the response block should begin and press the left mouse key to begin
drawing.

3. Drag to draw the response block and release to mouse key to end drawing.

More precise positioning and sizing can be accomplished in the size and position tab of the OMR
Properties window. The OMR response block will snap to the closest OMR grid position as the box is
drawn.

� To select an OMR response

1. From the Drawing toolbar, click Select Mode.

2. Position the mouse over the element to be selected and click the left mouse button. The cursor will
change according to the object being selected.

Selected items will be displayed with selection handles. To select overlapping objects, it may be necessary to
de-select all objects prior to making the selection.
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Response Spacing

� To specify response spacing

1. Select the responses to be formatted.

2. Select OMR from the Format menu.

3. From the Size and Position tab, choose the spacing in either LPI or CPI, as applicable.

Only certain spacing options are available, based upon the orientation of the form. This helps to maintain
compliance with the OMR specifications set in the OMR Properties window. For example, on a portrait
form, the CPI of a response block cannot be modified.

� To skip rows/columns

1. Select the responses to be formatted.

2. Select OMR from the Format menu.

3. From the General tab of the OMR Properties window, select spacing by specifying the number of
rows/columns to be skipped between each scan row/column.
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Response Formatting

Response Shape

� To change response shape

1. Select the responses to be formatted.

2. Click Response Shape from the OMR toolbar to toggle through shape options.

Response shapes include circles, horizontal/vertical ovals, horizontal/vertical rectangles, horizontal/vertical
rounded rectangles, and square boxes. To improve scanner detection, response shapes will be limited based
on form orientation and default OMR LPI/CPI.

Response Shapes

Circle (not available in 8 LPI/CPI)

Horizontal Oval (portrait page only)

Vertical Oval (landscape page only)

Rounded Horizontal Rectangle (portrait page only)

Rounded Vertical Rectangle (landscape page only)

Horizontal Rectangle (portrait page only)

Vertical Rectangle (landscape page only)

Square (not available in 8 LPI/CPI)
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Response Shape and Text Defaults

� To set default response shape

1. Select Preferences from the Edit menu.

2. From the OMR tab, select the desired bubble shape from the Shape drop-down menu.

� To set default response text size

1. Select Preferences from the Edit menu.

2. From the OMR tab, select text size in points from the drop-down menu.

Response Direction

� To change response direction

1. Select the responses to be formatted.

2. Click Response Direction from the OMR toolbar to toggle between horizontal/vertical responses.
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Response Sequence

Support for common response sequences, as well as user defined sequences, is available.

� To select predefined response sequences

1. Select the responses to be formatted.

2. Open the Sequence drop-down from the OMR toolbar and select a response sequence.

Pre-Defined Response Sequences

A-Z Uppercase Alphabet

a-z Lowercase Alphabet

0-9 Numeric

A-Z, 0-9 Uppercase Alphabet followed by Numeric

a-z, 0-9 Lowercase Alphabet followed by Numeric

TF True/False

YN Yes/No

� To define custom response sequences

1. Select the response to be formatted.

2. Choose OMR from the Format menu.

3. Access the General tab of the OMR Properties window and type the desired OMR sequence into the
Sequence edit box. For temporary or blank responses, use the space bar. The length of the response
sequence is not limited to the size of the edit box. The edit box can scroll left to right to handle
more text than is visible.

The custom sequence tool can be used to create responses in reverse order. For example, a response
sequence of 9876543210 can be defined instead of the standard 0123456789.
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� To place a special character in a custom response sequence

1. Select Character Map from the Edit menu.

2. Select the font that is being used for the OMR sequence. You want the special character's font to be
the same font that is already being used on the form.

3. Choose the special character by highlighting the character and clicking Select, or by double clicking on
the special character.

4. Click Copy to copy the special character to the clipboard.

5. Close the Character Map window by clicking Close.

6. Select the OMR form.

7. Select OMR from the Format menu.

8. From the General tab, place the cursor in the Sequence edit box and paste the special character by typing
<Ctrl> and V at the same time.

Persistent OMR Sequences

A commonly used custom OMR sequence can be saved for later use. This saved sequence will appear in
the Sequence drop-down menu when future OMR forms are defined.

� To save a custom OMR sequence

1. Right click the desired OMR form, and select Format OMR from the context menu.

2. Access the General tab of the OMR Properties window.

3. Define the custom sequence.

4. Click Remember.

5. The custom sequence will be saved in the Sequence drop-down menu for future selection.
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Two Character Bubbles

OMR forms can contain 2 different characters within each bubble. The top drop-down menu allows the
user to select the characters that will be contained within the bubble. The bottom drop-down menu tells
Designer which single character will be represented by the double characters in the bubbles.

For example:

A user defines the double character sequence to read A B C D E F and so on. Each bubble would contain
two characters: a letter and a space. However, when pre-slugging data, such as a name, Designer will slug
for single letters, as specified in the data file. By defining which single character to look for, Designer will
be able to recognize that the pre-slug for the letter S will go in the bubble that contains the S and the space.

� To define two character OMR sequences

1. Right click the OMR block that you wish to format.

2. Select Format OMR from the context menu.

3. Access the General tab of the OMR Properties window.

4. Enable the 2 Characters in Bubble check box. This will cause the second sequence drop-down menu to
appear.

5. From the first drop-down menu, select the sequence of letters and/or numbers that you want to
appear in the bubbles.

6. From the second drop-down menu, select the single character series that will be defined by the double
characters.

308 Creating OMR Forms

The sequence in the second menu is identical to the sequence in the first menu, minus the extra space characters.



Response Numbering

Initiating Response Numbering

� To activate response numbering

1. Select the responses to be formatted.

2. Click Numbered from the OMR toolbar to number response rows/columns.

Numbering Interval

When numbering OMR responses, the default number interval is 1. The user can specify any number
interval to be used when numbering.

� To set numbering interval

1. Select the responses to be formatted.

2. Select OMR from the Format menu.

3. From the general tab, specify the interval in the Interval edit box or by using the spin arrows.
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Starting Number

When numbering OMR responses, the default starting number of the sequence will be 1. However, the
user can specify any starting number. This is particularly helpful in situations where there are columns of
continuing responses.

� To set starting number for response numbering

1. Select the response to be formatted.

2. Select OMR from the Format menu.

3. From the General tab, specify the start number in the Start edit box, or by using the spin arrows.

Trailer

Trailers are available when numbering responses. Trailers can be defined as a character(s) that will follow
the numbers. Common trailers include periods "1." and parenthesis "1)".

� To set trailer

1. Select the responses.

2. Choose OMR from the Format menu.

3. From the General tab, define the trailer character(s) in the Trailer edit box.
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Written Response Boxes
Written response boxes are a unique feature that allows for a space on the OMR form in which answers can
be written. The written response box will be indicated to the scanner by a corresponding OMR mark. Any
formatting applied to the OMR border will also be applied to the written response box.

� To draw written response boxes

1. Select the responses to be boxed.

2. Click Written Response Boxes from the OMR toolbar to toggle boxes on and off.

Response Title

� To create a response title

1. Select the responses to which a title should be added.

2. Select OMR from the Format menu.

3. From the General tab, type the title text into the Title edit box.

4. Add a box around the title by checking Title Box. It is not necessary to have a box around the text.

Change the font of the title by selecting the title and choosing Font from the Format menu.
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OMR Pre-Slugging

� To pre-slug an OMR response

1. Select the response to be pre-slugged.

2. Select OMR from the Format menu.

3. From the General tab, type the characters to be pre-slugged into the Pre-Slug edit
box. For empty or blank responses, use the space bar. The length of the
pre-slug is not limited to the size of the edit box. The edit box can scroll left
to right to handle more text than in visible.

� To create a variable for pre-slugging

1. Select Define Variable from the Field Settings cascading
menu on the Edit menu.

2. Select Variable from the Type drop-down menu.

3. Name the variable.

4. Select the field name to be pre-slugged from the
Field drop-down menu.

5. In the Transforms area, select Upper or Lower from the
Case drop-down menu, depending upon if the
OMR form that is being designed uses all
uppercase or lowercase letters.

6. Click OK.

7. Follow steps 1-3 of the pre-slugging procedure,
selecting the variable name chosen in step 3 in the
Field Name drop-down menu.

If the field name used for pre-slugging is not in the same case as the OMR bubble sequence, one or the
other should be edited so that both cases are identical. A variable field can be created to apply a case
transform to the field name in order to change the case of the data field.

� To enter special characters into the pre-slug edit box
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1. Select Character Map from the Edit menu.

2. Select the same font that is being used for the OMR response.

3. Choose a special character by clicking Select or by double clicking on the special character.

4. Click Copy to copy the special character to the clipboard.

5. Close the character map window by clicking Close.

6. Select the response to be pre-slugged.

7. Select OMR from the Format menu.

8. From the General tab, place the cursor in the pre-slug edit box and paste the special character by typing
<Ctrl> and V at the same time.

Special characters also need to be placed in the response sequence if not already there. See page 307 for
detailed information on response sequences.

Data Driven Pre-Slugging
Database fields can be used for data-driven, pre-slugged responses in Designer. This allows information
like names, addresses, etc. to be automatically pre-filled on each OMR form. This eliminates the need for
the user to slug this information manually. Any data field or variable can be used. Designer is also aware of
bubble shape and direction, and supports response box and column/row skip.

� To create data-driven pre-slugged responses

1. Select the OMR element.

2. Select OMR from the Format menu, or right click and select Format OMR from the context menu.

3. From the General tab of the OMR Properties window, select the database name from the Field Name
drop-down menu in the Pre-Slug area.

A data field must be imported for this feature to be used.
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Response Border
The response border is simply a box drawn around one area of responses. There are a variety of
formatting options available for the response border.

Thickness/Style

Border thicknesses are represented in points from 0-14. Three border styles are available: solid, dotted and
broken.

� To change thickness/style

1. Select the boxed responses to be formatted.

2. To change the border thickness, click the appropriate border thickness button: Increase Border Thickness or
Decrease Border Thickness.

3. Click the Change Border Style button from the Format toolbar to switch between the available line styles.

Color

The border color can also be changed independently of the color of the OMR response box.

� To change border color

1. Select the boxed responses.

2. Select OMR from the Format menu.

3. From the Border and Shading tab, select a color from the border color drop-down menu.

4. Color changes will affect both the OMR response block and the OMR border.

� To change border and response color

1. Select the boxed response(s).

2. To change the border color, click Palette from the Format toolbar.

3. Select the appropriate color.
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Rounded Corners

Rounded Corners can be applied to one or all of the border corners. The amount of roundness can also be
controlled.

� To round corners

1. Select the response(s).

2. Click Round/Square Corner on the Format toolbar.

3. To specify a particular corner to be rounded, click the left mouse button on the corner handle while
holding the <Shift> key. The corner will then be selected.

4. Click Round/Square Corner on the Format toolbar.

To specify the amount of rounding, select Object from the Format menu. From the General Attributes tab, select a
roundness choice from the Roundness drop-down menu.
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Default Border Settings

A default style, color and thickness of OMR responses and their borders can be set. The defaults are set to
solid style, red color, and 1 pt. thickness.

� To change the default settings

1. Select Preferences from the Edit menu.

2. Open the OMR tab.

3. Choose border Style, Color, and Thickness from their respective drop-down menus.

Response Shading

� To shade response

1. Select responses to shade.

2. Click the desired shading button on the Format toolbar to apply shading.

� To specify shading pattern

1. Select responses to shade.

2. Select OMR from the Format menu.

3. From the Border and Shading tab, select shading type from the drop-down menu.
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� To specify fill

1. Select responses to fill.

2. Select OMR from the Format menu.

3. From the Border and Shading tab, select color from the Fill drop-down menu.

� To specify rows/columns to be filled or shaded

1. Select responses to shade.

2. Select OMR from the Format menu.

3. From the Border and Shading tab, select rows or columns to specify which will be shaded.

4. Define the number of rows or columns to be skipped in the Skip Every box.

5. Check Start with Shade/Fill to shade/fill the first row/column.
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Binary OMR
By default, Character OMR is enabled. If the user wishes to enable Binary OMR modes, which includes
Binary Decimal and Binary Litho, they must first be enabled through the Preferences menu prior to drawing
the OMR elements on the form.

� To enable Binary OMR

1. From the Edit menu, select Preferences.

2. Select the OMR tab within the Preferences menu.

3. Select the Enable Binary OMR check box.
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� To draw Binary OMR elements

1. Select the OMR draw button and draw the OMR box on the form.

2. Right click and choose Format OMR.

3. The OMR Properties window will appear. On the General tab, there will be a Mapping area where you can
choose which type of OMR you would like to enable: Character, Binary Decimal, or Binary Litho.

Binary Litho is a 1-dimensional representation of a number, with each bubble having a value of 2 to the
power of n. Being 1-dimensional, it is limited to 1 row if the direction is horizontal, or 1 column if having a
vertical direction. The first bubble starts on the left or top side, having an initial position value of n being 0,
and increments with each bubble to its right or below. The first bubble from the left side has a value of 1 if
filled and 0 if not, while the second bubble has a value of 2 if filled and 0 if not, and the third bubble has a
value of 4 or 0, etc. This is shown in the top OMR in the following image.

Both OMRs in this image are representing a value of 63. The bottom OMR in the image is Binary
Decimal, a 2-dimensional OMR representation. When the direction is horizontal, there must be 4 rows, or
when the direction is vertical, there is a requirement to have 4 columns. Each column can encode a single
digit, with bubble values of 1, 2, 4 and 8, from top to bottom. While the total value if all bubbles are filled
can be 15, it is assumed the slugging of the bubbles will not exceed a value of 9.

Binary OMRs are limited to a total number of 32 columns or rows since the size of an integer is 32 bits.
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Chapter 10

Set Up Auto-Launch

Designer can auto-launch to a variety of VI Compose enabled devices. This chapter outlines how
to properly configure those devices so that the auto-launch feature can be used successfully.

PDF Proofing with Adobe Distiller
Designer can use a VI Compose enabled Adobe Distiller to automatically output jobs to PDF. When saving
a job, simply select Adobe Distiller PDF, and Designer will create the PDF automatically. In order to take
advantage of this feature, VI Compose must be installed on the workstation and a file used by Distiller
must be edited to recognize VI Compose. With only a VI Compose evaluation license, you will be able to
print between 10 and 150 PDF pages, depending upon which version of Distiller and VI Compose you are
using.

After VI Compose is installed and the proper files are edited, it will be possible to output a PDF directly
from the Job mode of Designer.

Loading FreeFlow VI Compose and editing the Adobe start up file is not necessary if FreeFlow VI
eCompose (VIPO) is loaded on the local system.

FreeFlow VI Designer cannot be licensed and installed on the local system prior to installing the FreeFlow
VI Compose and enabling Adobe Distiller to PDF proof VI Compose jobs.
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Install Adobe Distiller and VI Compose

� To set up a VI Compose enabled Adobe Distiller

1. Install Adobe Distiller.

2. Install the FreeFlow VI Compose on the same PC. A license for VI Compose is not necessary. VI
Compose will run in demo mode on the workstation. This will automatically create XGF and XGFC
folders on the C: or otherwise specified drive.

3. Open the Adobe Distiller Startup file in Notepad. The location and file name will vary depending on the
version of Distiller installed.

Adobe Distiller 5.0 C:\Program Files\Adobe\Acrobat 5.0\Distllr\Startup\example.ps

Adobe Distiller 6.0 C:\Program Files\Adobe\Acrobat 6.0\Distllr\Data\distinit.ps

Adobe Distiller 7.0 C:\Program Files\Adobe\Acrobat 7.0\Distllr\Data\distinit.ps

Adobe Distiller 8.1 C:\Program Files\Adobe\Acrobat 8.0\Acrobat\Data\distinit.ps

Adobe Distiller 9.0 C:\Program Files\Adobe\Acrobat 9.0\Acrobat\Data\distinit.ps

Adobe Distiller X C:\Program Files\Adobe\Acrobat 10.0\Acrobat\distinit.ps

Adobe Distiller DC C:\Program Files\Adobe\Acrobat DC\Acrobat\distinit.ps

4. Key in the following lines at the end of the file:

(Loading VIPP from C:\\xgf...) print flush
(C:\\xgf\\src\\xgfdos) run

5. Save the file and close it.

6. Reboot your PC so these changes can take effect.
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Setting Up Click & Print
VI Compose queues and hot folder(s) should be set up at
your FreeFlow Print Server prior to submitting a print job
from Proform Designer.

1. Set Up VI Compose Queue(s) at the FreeFlow Print
Server

� Deploy

� Deploy and Print

� Print and Delete

2. Set Up queue(s) with hot folder(s)

3. Map network drive on workstation

For more information on FreeFlow Print Server queue and
hot folder settings, please refer to the FreeFlow Print
Server documentation or contact your Xerox representative.

It is recommended that short queue names be defined if planning to map the drive through the Windows
network.

Mapping the FreeFlow Print Server hot folder network drive
The DocuSP hot folder should be mapped as a network drive through the workstation to access the
DocuSP Print job submission feature.

� To Map the hot folder

1. Go to My Computer and right-click.

2. Select Map Network Drive.

3. key in the IP address of the print
engine and queue name.
(example:
//100.100.100.197/hotfoldername)
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Set Up Office Printers

The VI Compose Maintenance Window
The VI Compose Maintenance window, accessible from the File menu when no forms are open, serves as
the control center for VI Compose on the office printer. Use this menu to install VI Compose, uninstall VI
Compose, set tray specifications and manage the current VI Compose projects that are stored on the
printer. Any specifications made within this menu will be retained for further use.

Select a Printer

� To select a printer

1. With no forms open, from the File menu, select VI Compose Maintenance.

2. Select which printer you wish to use from the Office Printer drop-down menu. Do not click Add yet.

Select a VI Compose License File

� To select a VI Compose license file

1. Click the VI Compose License File ellipses. Browse to find the appropriate VI Compose License File.

2. Click Open.

3. From the VI Compose Maintenance window, click Add . The chosen printer and license file will be added
simultaneously to the list of selected office printers. You may repeat this process multiple times if
you wish to enable multiple office printers.
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If You Don't Have a VI Compose License

� To Operate VI Compose in Demo Mode

1. From the Office Printer drop-down menu, select which printer you wish to use.

2. Click Add. An alert will pop up, stating that a "License file must be associated with printer before adding to list; Use
evaluation license instead?"

3. Click Yes to choose the evaluation license.

Up to 20 pages will print in using VI Compose evaluation mode (demo mode).

Install VI Compose

After you have specified a printer and license file, VI Compose can be installed.

� To install VI Compose on the printer

1. After the printer and VI Compose license are selected, the buttons at the bottom of the VI Compose
Maintenance window will be enabled.

2. Click the Install… button.

3. The VI Compose Installation window will appear. If you wish to have VI Compose active on the printer
every time it is turned on, make sure that the VI Compose Active on Startup check box is enabled. If you
wish to manually activate VI Compose when it is needed, do not enable this check box.

4. Click Install. This will install VI Compose on the selected office printer(s). Each printer that has just
had VI Compose installed on it will print a VI Compose confirmation page so that you will know VI
Compose has been successfully installed.

Set Up Auto-Launch 325

�



Startup VI Compose

If you do not want VI Compose to be active on the printer every time it is started, you may choose to
submit it manually. A manual submission will activate VI Compose only for the amount of time that the
printer is turned on. After the printer is powered down and restarted, VI Compose will no longer be active
and will have to be submitted again for use.

� To manually activate VI Compose

1. Select the printer and license file and install VI Compose, leaving the VI Compose Active on Startup box
unchecked.

2. Click the Startup VI Compose button. An alert will pop up, notifying you: "VI Compose startup sent to printer."

3. That printer is now VI Compose enabled but will not remain that way after it is powered down.

Uninstall VI Compose

� To uninstall VI Compose from a printer

1. Make sure that only the printer from which you want to uninstall VI Compose is added to the Office
Printer drop-down menu.

2. Select the Uninstall button. An alert will pop up, notifying you that the VI Compose files have been
deleted from the printer.

Manage VI Compose

This button provides a menu from which you can
specify tray settings, check the status of the printer, and
access the VI Compose Active on Startup check box.
The tray settings, however, are not permanent and will
only be active until the printer is powered down.
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Specify Tray settings

You can make tray setting specifications for your networked printers either in the Maintain VI Compose
Office Printer window or through your web browser. Sometimes a printer will not accept the tray setting
specifications when made in the window. If this happens, use the browser option.

� To specify tray settings in the Maintain VI Compose Office Printer window

1. Click the Manage VI Compose button. The Maintain VI Compose Office Printer window will appear.

2. Specify which tray will contain what type of paper, if specialty paper is being used.

3. Uncheck or check the VI Compose Active on Startup check box if necessary.

4. Click Submit to implement changes.

� To specify tray setting through the web browser

1. Enter the printer's IP address into the IP Address line.

2. Click the Display Printer Status link.

3. This will connect you to the networked printer's informational page. It will look similar to the
following:

4. Make the necessary tray specifications from this page.

To find a printer's IP Address, access the Start menu and select Settings: open the Printers option. A list of
your networked printers will appear in the Printers window. Locate the printer in question from the list,
highlight it, and right click. Select Properties from the context menu and access the Ports tab of the new
window. The IP address of the printer is listed here.
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Check Printer Status

The Maintain VI Compose Office Printer window also allows you to easily check on the status of a print
job.

� To check printer status

1. Click the Manage VI Compose button to access the Maintain VI Compose Office Printer window.

2. Type the printer's IP address into the IP Address line.

3. Click the Display Printer Status link.

4. This will open a web browser containing the printer's specific information.

5. You can check the status of the printer from this page.

Manage Projects

This button provides the ability to
delete projects from the printer, to
send projects to the printer, and to
print a list of files on the printer.
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� To print a file list

1. Click the Manage Projects button. The Maintain VI Compose Projects window will appear.

2. From the Print Mask drop-down menu, select which project files you would like to print. If you would
like to print a list of all the files, select the "*" option.

3. Click the Print File Listing button.

� To delete a project on the printer

1. From the Project Name drop-down menu, select which project you wish to delete. This is a list of all the
projects currently in your projects folder. If you delete a project from the printer you will no longer
be able to just send the data if you want to print that project again.

2. Click Add to add it to the list.

3. Repeat this process until all projects that you wish to delete are listed.

4. Click the Delete Project on Printer button.

� To send a project to the printer

Perhaps a company sends out a bill once a month. It is usually printed on the same form, but the billing
information is certainly different each time. Every once in a while the form must be updated as well. After
the form is updated, the company can send the new form files to the printer, and not actually print the
forms yet. This will enable them to, when it is time to print out the bill again, submit only the data to the
printer, since the new form files will already be stored there.

1. Select a project from the Project Name drop-down list.

2. Click Add to add that project to the list.

3. Repeat this process to add all the forms that you wish to send to the printer.

4. Click the Send Project to Printer button. A list of all the files just sent to the printer will automatically be
printed.

Any action performed within the VI Compose Maintenance window will affect all printers included in the
printer list. If you do not want a certain printer to be affected, you must first delete it from the list.
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Set Up the FreeFlow VI eCompose
In order to successfully auto-launch to the FF VI eCompose, you must have a static IP address. If you do
not have a static IP address, you can establish one by enabling the Microsoft Loopback Adapter. If you
already have a static IP address then there is not need to enable the Loopback Adapter..

Enabling the Microsoft Loopback Adapter

1. Go to the Control Panel.

2. Open the Add/Remove Hardware option.

3. Click the Next button to proceed through the wizard.

4. Scroll through the Devices list and select Add a New Device.

5. Click the Next button.

6. Choose the "No, I want to select the hardware from a list" option.
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7. Click the Next button.

8. Select Network Adapters from the Hardware Types list.

9. Click the Next button.

10. Go to the Manufacturers list and choose Microsoft.

11. Select the Microsoft Loopback Adapter option.

12. Click the Next button.

13. Click the Next button again, and then the Finish button.

14. Return to the Control Panel, and open the Network and Dial-up Connections option.

15. Select the Loopback Adapter connection. When a connection is selected, the connection type will be
displayed on the left side of the window. Use this to tell which one is the loopback adapter.
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16. Right click the loopback connection, and select Properties.

17. Select the Internet Protocol (TCP/IP) and click the Properties button.

18. Choose the "Use the following IP address" option.

19 Enter your IP Address, Subnet Mask and Default Gateway. To find these, go to
Start:Programs:Accessories:Command Prompt. Enter ipconfig and press the Enter key.

20. Click OK. If a warning appears, select Yes.

21. Click OK to save the loopback adapter settings and close the window.

22. You now have a static IP address. You must use this static IP address when editing the host file as
described in the next section.

332 Set Up Auto-Launch



Set up FreeFlow VI eCompose (VIPO) for Auto-Launch

1. Install VI eCompose.

2. Go to the Start menu and select Control Panel.

3. Double click the Add/Remove Programs option.

4. Click the Add/Remove Windows Components button, located on the left side of the screen.

5. Enable the Other Network and File Print Services check box.

6. Click Next to install.

7. Click Finish.

8. Return to the Control Panel.

9. Double click to open the Administrative Tools option.
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10. Double click the Services option.

11. Scroll to locate the TCP/IP Print Server listing. Make sure that Started is listed in the Status column.

12. Highlight the TCP/IP Print Server listing. Right click and select Properties from the context menu.

13. Change the Startup Type to Automatic.

14. Click OK.

15. If you have created a static IP address via a loopback adapter, please skip steps 16-18. You will use
this IP Address when editing in the host file in step 21.

16. Go to Start: Programs: Accessories: Command Prompt.
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17. Type ipconfig into the command prompt, and click Enter. This will return the computer's IP Address.

18. Write down the IP Address, and close the Command Prompt window.

19. If you are using Windows 98, ME, or XP, go to C:\Windows\system32\drivers\etc.

If you are using Windows NT or 2000, go to C:\WINNT\system32\drivers\etc.

20. Open the hosts file with WordPad or Notepad.

21. At the bottom of the file, enter the IP Address, insert a tab, and type XVTServer.

22. Save the file, and close the window.

23. The VI eCompose is now properly configured to auto-launch from Proform Designer.
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Xerox FreeFlow VI Design Pro
Xerox FreeFlow VI Design Pro (formerly named FreeFlow VI Designer) is a VI Compose development
environment that can be purchased from Xerox. Designer produced jobs can be loaded to the VI Design
Pro for viewing and/or editing if the user knows the VI Compose coding language. VI Design Pro must
be installed on your system in order to take advantage of the auto-launch feature with Proform Designer. .
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Chapter 11

FreeFlow VI eCompose

Designer supports a PDF workflow with the auto-launch of VI Compose files directly to the VI
eCompose, formerly known as VIPO. Use the Designer interface to create bookmarks to split
PDFs for archiving or reference purposes, or define custom fields and automate email. Once all

the specifications are set, choose VI eCompose from the create drop-down menu and click the Save to VI
Compose button.

Before jobs can be auto-launched, the VI eCompose must be properly configured. If you have not done
this already, please review Chapter 10: Set Up Auto-Launch for complete instructions.

PDF Interactive Features
Designer supports VI Compose PDF Interactive Features (PIF) commands that can be used to create
interactive features such as links or notes when a VI Compose job is converted to a PDF document. There
are seven different interactive features available with the following functions:

Page: Creates a link to another page in the same document.

Destination: Creates a link to a named destination (either an alphanumeric string or a page number).

External Page: Creates a link to a page in another PDF document.

External Destination: Creates a link to a named destination in another PDF document (either an alphanumeric string or page
number).

File: Creates a link to a non-PDF document.

URL: Creates a link to an internet/intranet site or document. These links can then be viewed as html in a browser,
or as additional PDF pages of the same PDF document.

Notes: Creates a pop-up window with a note.
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� To set PDF interactive features

1. Right click on a data area and select Format Data from
the context menu.

2. The Data Properties window will appear.

3. Select the PDF Interactive Feature tab.

4. Select the desired link type from the Type drop-down
menu.

5. Enter text into the Text field.

6. Click the ellipses (...)to browse for a file if using the
External Page, External Destination, or File option. This
field is not applicable for other PIF types.

7. Select page number if applicable.

Create and Submit a Bookmarked Job
Proform Designer can be used to create the proper commands to set up bookmarks within the VI
eCompose produced PDF document. Bookmarks cause the PDF document to be split into smaller
portions according to a user-defined field. Whenever the contents of the designated field change, the PDF
will be split. Use the Job Tree to define on which page the bookmark will occur. Only one bookmark may
be defined per job.

� To define the bookmark

1. Either create or open the job that will be sent to the VI eCompose.

2. Go to the Edit menu and select Form Layout.

3. The Form Layout window will appear.

4. Access the VTP Setup tab.

5. Make sure that the Split PDF check box is enabled.

6. By default, the Bookmark Delimiter will be set to a colon (:). If you would like it to be something
else, enter that value into the Bookmark Delimited field. The Bookmark Delimiter will be used as the
separating character between split PDFs in the resulting list.

7. Go to the Bookmark Field drop-down menu. Select the Field that will be used as the bookmark.

8. Select the color and style in which each PDF's name will appear.

9. Go the Output Filename drop-down menu. Select the Field that will serve as the title for each of the split
PDFs.

10. Click OK.
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After defining the bookmark parameters in the Form Layout window of one page in a job, the bookmark
must then be enabled for the form page in the job tree. The bookmark parameters of only one form page
per job will be recognized.

� To set the bookmark on a page

1. Go to the Job Tree.

2. Expand the Form folder of the form on which the bookmark will be set.

3. Select the Bookmark option.

4. Go to the Edit Information drop-down menu and select Yes.

5. Click the Update button.

6. The PDF will be split whenever the contents of the designated field change on this bookmarked
form.

FreeFlow VI eCompose 339

�



Create an Automated Email Job
Proform Designer can also be used to set up VI eCompose automated email.

� To set up automated email

1. Open or create the job that will be used in the automated email.

2. Go to the Edit menu and select Form Layout.

3. Access the VTP Setup tab.

4. Enable the Automated Email check box.

5. Go to the Bookmark Field drop-down menu and select the field that will denote a split in the PDF.

6. Notice that Designer has automatically populated the first four Field Name fields with ToEmail, From,
Subject and Contents.

7. Use the Field Contents drop-down menus to specify which data fields will be used to populate the ToEmail,
From, Subject and Contents fields. If necessary, additional data fields can be created using the
Concatenated Field function.

8. Click OK.
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Troubleshoot the Auto-Launch
If the auto-launch from Proform Designer does not work, there are several things that you can do to
troubleshoot the problem. Proform Designer auto-launches via LPR. By issuing the LPR command
manually, you can view any errors that are generated and remedy the problem.

1. Go to Start: Programs: Accessories: Command Prompt.

2. Type cd\xgfc\mislib. Press the Enter key.

3. Type LPR -S XVTServer -P XVTPrinter -o l demosample.csv. Press the Enter key.

4. There are several error messages that may appear. Locate your error message from the list below and
proceed accordingly.

Error: host server is unknown

You have not edited the host file correctly: likely there is a capitalization error. Repeat steps 19-21 of
the Set up the VI eCompose for Auto-Launch section. Save the file and resubmit the auto-launch job.

FreeFlow VI eCompose 341



Error: print server did not accept request. Job aborted.

Either the VI eCompose is not installed, or you have renamed it.
Go to Start: Control Panel: Printers. Make sure that XVTPrinter is in the list. If you have renamed it, change
it back to XVTPrinter. If it is not installed then you must install it.

Error: print server unreachable or specified printer does

not exist.

Repeat steps 8-14 of the Set up the VI eCompose for Auto-Launch section. It is likely that you have not started
your TCP/IP Print Server.
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Appendix A

OMR Tips and Tricks

The successful creation of OMR forms relies upon several factors. Alignment of OMR elements is
critical to the scannability of the forms and must be within the tight specifications outlined.
Printers and scanners also play their own role in the process. There are important

recommendations in this appendix in reference to creating OMR forms. Everything from the paper printed
on to printer hardware will contribute to your success.

Form Alignment
Alignment issues have been a major focus of Proform Designer. Procedures are in place to ensure the
proper placement of the critical OMR elements from the tracking bars to the OMR responses themselves.
However, it is best to perform a second manual check before placing a form into production to verify
proper alignment.

Plastic overlays are available upon request from Lytrod Software, Inc. Often times, the scanner
manufacturer will provide these overlays as well. The purpose of the overlays is to assist in determining
proper alignment.

Alignment Checklist
1. Line up plastic overlay with form.

2. Check alignment of Tracking Bars in relation to the scannable form elements (Form Identification
Marks (FIMs) and Responses).

� Form Identification Marks should be both horizontally and vertically centered by scan row and
column.

� Tracking Bars should be vertically centered in responses.

� Tracking Bars should be proper distance from the edge of the paper.
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Individual objects cannot and should not be moved. They are placed in relation to each other and
controlled by Proform Designer. If you believe there is improper alignment of tracking bars and/or Form
Identification Marks to responses, please contact Lytrod Software, Inc.

Xerox Printer Registration (4850 and 4890)
Xerox has taken several steps toward maintaining printer registration for applications such as OMR that
require tight specifications. The following guidelines will help ensure that printer registration variation
remains within specification (+/- .85mm).

Printer Registration Setup
1. Set registration per addition 3-2 in the 4800F Service Manual. Use a sample of XREG11 and fold it

in half. The center line of the form should fall on the folded crease.

2. Verify that there is no skew in the paper path. Use RAP OF 1 located in the last section of the Status
Indicator RAP section of the Service Manual as needed. Use a duplex sample of XREG11. Hold it
up to the light to verify that the centerline from the first side overlays the centerline of the second
side.

3. Print approximately 50 samples of XREG11. Evaluate the copies to determine the two extremes of
variation. Use these two extremes as a reference to centerline the final registration adjustment.

4. Verify there are no problems related to the paper feed trays. Run samples of XREG11 from each tray
to verify they all print the same. It is also recommended to verify that the paper handling drive gears
and idlers are in good conditions.
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Hardware Recommendations
It has been determined that several paper handling reliability improvement parts will help ensure that the
paper registration remains in specification as long as possible.

� 600K54000 Knurled Registration Transport Scuffer Shaft Assy (handles card stock better and has been
reported to help improve registration). Verify that the registration edge guide is square per install
instructions, then skew adjustment can be made.

� 600K53910 Registration Transport Belts (finger tabs and belt have been hardened for longer life).

� 600K59250 Recitation Transport Edge Guide (ceramic dowels provide the guiding surface which do not
cut easily. If for some reason they do cut, they can easily be rotated to provide a new surface).

� 48K42250 Duplex Clutch Assy - Improved Reliability.

� 22K40650 Improved Duplex Scuffer Assy (drive shaft is bearing driven vs bushing driven).

� 30K39911 Duplex magnetic skis (provide the correct tension for paper movement on the vertical
transport which mates to the registration transport).

� 30K47340 Tray 1 magnetic skis.

� 30K39901 Tray 2 magnetic skis.

For maximum reliability effectiveness, it is recommended that the Lead Printer Operator attend ACT
Training.

Ongoing Xerox Service Requirements
� Registration should be checked and verified side to side and top to bottom.

� Skew should be checked and verified.

� Image Density (top to bottom) should be uniform.

� Internal Test Form is within specification.

� Any adjustments or parts replacements related to paper handling require re-evaluating registration and
skew specifications.

Customer Checks
� Ensure form is center lined. Sample 25 prints of the form to be used. Pick out the two samples that vary

from the centerline the most in each direction.

� If variation (float) from the specification (+/- .85mm) is noticed, use the alignment command
(adjustX/adjustY on NPS), when possible, to re-center the form/data until service can rectify the
problem.
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Scanner Specifications

Scanner Service
Prior to running test forms through scanner, verify that the scanner has been properly serviced by the
manufacturer.

Verify Printer Accuracy
Print 1000 to 1500 of internal test form to determine reject rate at the scanner due to inability to detect one
or more alignment marks and the validity of the scanned data. If the results of this test are not satisfactory,
re-check form alignment, printer alignment and scanner service records.

Paper Recommendations

Type of Paper
� Paper weight of 24 lb. is recommended for all OMR forms.

� Brightness should be as high as possible with a target brightness of 87.

Handling & Storage
This application can be affected by paper edge defects such as bent corners, damaged edges and other
similar defects. Changes in humidity and temperature can affect the natural curl and size of the paper which
can also affect printing and scanning registration.
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Appendix B

System Limitations

Form Output Limitations
Proform Designer creates a print format upon form output. Various output formats are available, each
having unique limitations. These limitations affect the operation of Proform Designer in some cases and
restricts features that would produce commands not compatible with destination format. Proform Designer
bases these restrictions on the printer information specified in the Resource Set.

OGL - AFP Source to be compiled with IBM Host-Based Compiler

Lines and Boxes

Line and box borders between 0 and 45 pixels may be defined. Shadings EXTRA LIGHT, LIGHT,
MEDIUM, HEAVY, EXTRA HEAVY and percentage shadings are available.

Text

The following text functions are not supported with an OGL compiler.

� Control of text pitch is not supported.

� Certain text alignments when text is tied to a box is not supported (i.e. Text tied to top-left corner
of box must have a LEFT alignment, while text tied to the top-right corner of a box must have a
RIGHT alignment).

Color

OGL does not support color.

OMR

Since OGL does not support color, OMR functionality is also not supported.

Xerox XES Output

Fonts

The Xerox 4045CP and 2700II XES printers are unable to print more than one font orientation per page.
Proform Designer correctly handles multiple font orientation on a page when the printer is a printer other
than the two named above.
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Most of these printers are restricted to 22 fonts on a page. The exceptions are the 2700 which supports 17
fonts per page, and the 4235 and 4700 which support 32 fonts per page. These numbers are maximums; the
restriction usually exists in the amount of memory available on the printer.

Lines

Dotted and Broken lines from thicknesses Hairline to 3 are drawn using fonts provided with Proform
Designer. Lines greater than a thickness or 3 are drawn using a graphic image for each line. While the line
length is precise, Xerox printers have limits to the number of graphics allowed on a page, as well as the
amount of memory available for graphics in the printer. The number of graphic windows allowed are as
follows:

Printer Model # Graphic Windows

4045, 4197, 4010, 4030, 4213 128

2700, 3700 16

4235, 4700 256

Shadings

All shadings are implemented for XES printers.

Paper Size

Printer Model Maximum Paper Size

2700, 4045, 4197, 4010, 4030, 4213 8.5” X 14”

3700, 4700, 4235 11” X 17”

Color

Color is supported on Xerox 4700 printers. No limitations in color usage.

PCL Output

LaserJet Page Area

The page is defined by the page orientation and the size of the paper. Within the physical page size, there
are other limitations that define the printable page area. These page area limitations are explained below.

PCL printers do not permit printing from one edge of the paper to the other. The feeding and trailing
edges have a 60 dot (1/5”) non-printable area. Although form elements can be placed in this non-printable
area, they will be truncated within these boundaries. Proform Designer will move elements placed within
the non-printable area to an area inside the printable area (if possible).
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On landscape pages, the non-printable areas are defined as 60 dots from the left edge of the page and 60
dots from the right edge of the page. On portrait pages, the non-printable areas are defined as 60 dots from
the top of the page and 60 dots from the bottom of the page.

Another printer limitation is the physical drum width. The printer’s drum width is 8”. Since the feeding
edge of the page is 8.5”, 0.5” is unable to be addressed for printing (50 dots (1/6”) on the left side, and 100
dots (1/3”) on the right). If this area is addressed, the form element will not be printed. Proform Designer
will attempt to place form objects that are located in the non-addressable area as much as possible onto the
addressable page area.

The non-addressable page areas are defined as follows. For landscape pages, the non-addressable areas are
50 dots (1/6”) from the top of the page and 100 dots (1/3”) from the bottom of the page. On portrait
pages, the non-addressable areas are 50 dots from the left edge of the page and 100 dots from the right
edge of the page.

Fonts

Fonts of different orientations on a page are supported on Laserjet Series III and newer printers. Scalable
fonts are also supported on these printers. Proform Designer assumes all PCL printers are Series III or
newer.

Lines

Dotted and Broken lines from thicknesses Hairline to 3 are drawn using a font. Lines greater than a
thickness of 3 are drawn using a graphic image for each line. While line length is precise, this approach uses
significant amounts of internal printer memory and the size of the form file is greatly increased.

Color

Color support is defined for Hewlett-Packard PCL (HighLight Color) and (Color). Only PCL5C printers
support color.

PostScript Output

Print Margins

PostScript is available on many printers, sometimes as the native mode of the printer and other times as an
alternate printer control language. Some of these printers cannot print to all areas of the paper. Proform
Designer is aware of these margin areas when defined in the Resource Set.

Shading Limitations

Proform Designer provides support only for percentage shadings (EXTRA LIGHT, LIGHT, MEDIUM,
HEAVY EXTRA HEAVY, BLACK, percentage).
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Opaque Shadings and Graphic Images

When percentage shading (gray fill) or graphics are laid onto a form, all objects laying at the same position
are cleared (i.e. White filled). Proform Designer tries to minimize the side affects of this operation by
ordering the laying of shades and images onto the page. All shades are first placed onto the page, ordered
from light to dark, followed by all images. After all shadings and graphics are placed, the lines, text, and
logos are placed. In most cases, this should result in the desired affect. If not, try to minimize the amount
and/or placement of shadings and graphics on the form.

Color

Full color is supported on PostScript color printers.

MetaCode Output

Paper Size

Printer Model Paper Size

9700/9790/8700/8790 USLETTER, B4, A4

4050/4450/4090/4650/4850/4890 USLETTER, USLEGAL, B5, A4

3700/4235 USLETTER, USLEGAL, 11 X 17, A3, A4, B4, B5

4135/4635 USLETTER, USLEGAL, 11 X 17, 14 X 17, A3, A4, B4, B5

Shading Limitations

Proform Designer provides support only for a limited range of shadings (LIGHT, MEDIUM, HEAVY,
BLACK).

Color

HighLight color is supported on Xerox HighLight color printers (4850 and 4890). Color is limited to solid
colors (color of toner) in all form objects, except for object fills.
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Appendix C

Reference Information

FDL Grid Formats

FDL Grid Formats for Xerox Printers - US Letter

ID CPI LPI Columns Lines Orientation Origin (Y,X)

FMT1 13.6 8.1 132 66 LANDSCAPE (.18,.66)

FMT2 15 8.1 150 66 LANDSCAPE (.18,.50)

FMT3 13.6 10.7 132 88 LANDSCAPE (.14,.66)

FMT4 15 10.7 150 88 LANDSCAPE (.14,.50)

FMT5 10 6 100 49 LANDSCAPE (.17,.50)

FMT6 13.6 8.1 100 80 PORTRAIT (.57,.58)

FMT7 12 6 90 60 PORTRAIT (.50,.50)

FMT8 10 6 75 60 PORTRAIT (.50,.50)

FMT9 20 10 200 80 LANDSCAPE (.25,.25)

FMT10 17.6 12.5 132 132 PORTRAIT (.22,.51)

FMT11 20 12.5 150 132 PORTRAIT (.22,.50)

FMT12 13.6 8.1 172 66 LANDSCAPE (.18,.66)

FMT13 13.6 8.1 100 104 PORTRAIT (.57,.58)
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FDL Grid Formats for Xerox Printers - A4 Paper

ID CPI LPI Columns Lines Orientation Origin (Y,X)

FMT1A 12.5 8.3 161 68 LANDSCAPE (.18,.57)

FMT2A 14.3 8.3 183 68 LANDSCAPE (.18,.60)

FMT3A 12.5 11.1 161 90 LANDSCAPE (.18,.57)

FMT4A 14.3 11.1 183 90 LANDSCAPE (.18,.60)

FMT5A 10 6.1 123 49 LANDSCAPE (.22,.85)

FMT6A 13.6 8.1 103 99 PORTRAIT (.91,.46)

FMT7A 12 6 91 74 PORTRAIT (.85,.39)

FMT8A 10 6 77 74 PORTRAIT (.85,.39)

FMT9A 20 10 246 82 LANDSCAPE (.14,.85)

FMT10A 17.6 12.5 136 161 PORTRAIT (.57,.39)

FMT11A 20 12.5 155 161 PORTRAIT (.57,.39)
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LaserJet Grid Format

ID CPI LPI Columns Lines Orientation Origin (Y,X)

FMT1 10 6 106 45 LANDSCAPE (.5,.2)

FMT2 12 6 127 45 LANDSCAPE (.5,.2)

FMT3 16.666 6 176 45 LANDSCAPE (.5,.2)

FMT4 10 8 106 60 LANDSCAPE (.5,.2)

FMT5 12 8 127 60 LANDSCAPE (.5,.2)

FMT6 16.666 8 176 60 LANDSCAPE (.5,.2)

FMT7 12 6 98 60 PORTRAIT (.5,.17)

FMT8 16.666 6 136 60 PORTRAIT (.5,.17)

FMT9 10 6 82 60 PORTRAIT (.5,.17)

FMT10 10 8 82 80 PORTRAIT (.5,.17)

FMT11 12 8 98 80 PORTRAIT (.5,.17)

FMT12 16.666 8 136 80 PORTRAIT (.5,.17)
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Standard Grid Format

ID CPI LPI Columns Lines Orientation Origin (Y,X)

FMT1 13.635 8.57 132 66 LANDSCAPE (.40,.66)

FMT2 15 8.57 145 66 LANDSCAPE (.40,.66)

FMT3 12 6 116 46 LANDSCAPE (.40,.66)

FMT4 12.5 9.375 121 72 LANDSCAPE (.40,.66)

FMT5 10 6 96 46 LANDSCAPE (.40,.66)

FMT6 12.5 8.57 121 66 LANDSCAPE (.40,.66)

FMT7 13.635 8.57 105 82 PORTRAIT (.66,.40)

FMT8 12 6 92 58 PORTRAIT (.66,.40)

FMT9 10 6 77 58 PORTRAIT (.66,.40)

FMT10 12.5 9.375 96 90 PORTRAIT (.66,.40)

FMT11 12.5 8.57 96 82 PORTRAIT (.66,.40)

FMT12 15 8.57 115 82 PORTRAIT (.66,.40)
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Appendix D

Form Storage in Printer

VI Compose Forms
Proform Designer is set-up to save VI Compose files in the directories as defined by VI Compose
conventions. This is very convenient if you are using the VI Design Pro as a preview and editing tool since
the files are all in the directories that the VI Design Pro is expecting. In the Resource Set, you define the
location of the VI Compose directory. See page 58 for details.

PostScript forms are saved in the FORMLIB; fonts in the MISLIB; DBMs in the FORMLIB; JDTs in
JDTLIB; data in the MISLIB and the job ticket (to assist in job start) in the MISLIB directory. These files
need to be copied to the same directories on the printer. Typically this is done through an FTP function on
the network. The job ticket file should be pre-appended to the data file before being sent to the printer.

XES Forms
Forms merging on XES printers is done in two different ways, depending on the printer model. On Xerox
3700, 4235 and 4700 printers, forms are stored on the printer’s disk drive. On all other Xerox printers, the
forms are stored in the printer’s memory (temporary merge page store).

In the following data sequences, <ESC> refers to the ASCII escape character (decimal 27 or hexadecimal
1B). If a UDK command is issued at the start of the data stream, <ESC> may be substituted for this
character. The format of the UDK command is: =UDK=<c> where <c> is a printable ASCII character.
<CR> refers to the line ending sequence the printer is expecting.

When the form is in the merge page store, an <ESC>ze command sequence is issued at the start of the
variable data stream to start merging. All pages printed from this point forward will also have the form
printed on it. To terminate the forms merging, issue a <ESC>zd command sequence.

The 3700, 4235 and 4700 printers can handle one to four forms merging on the same page. The printer
must be told which forms to merge. For each form to merge on a page, two escape sequences are to be
called out. The <ESC>+<n><form-name><CR> sequence assigns the form name to a number (<n>)
between 0 and 3 (See your Xerox documentation for further information on this command). After this
command, the sequence <ESC>zb<n> starts the <n>th form merging onto the page. In terminating forms
merging, the user can control each individual form or all forms merging. The sequence <ESC>zh4 stops all
forms merging, while <ESC>zh<n> stops an individual form, where <n> is a number between 0 and 3.

PCL Forms
Proform Designer is designed to take advantage of a capability in the PCL level 4 and 5 escape languages to
allow one or multiple forms (named macros in LaserJet terminology) to be stored in the printer’s
memory. This feature provides for multi-page forms to be cycled without the necessity of downloading the

Form Storage in Printer 355



form for each page printed. A unique macro ID can be assigned. To invoke form merging, a different
method is suggested depending on single page forms, or multiple page forms (i.e. a different form for
multiple pages). For single page forms, the macro should be overlaid (automatic overlaying). Once the
overlay is enabled, every page will automatically print the form along with the variable data until the overlay
is disabled. For multiple page forms, a macro should be called for each page. Called macros will merge the
form with the variable data only a page at a time. The variable data stream will therefore retain control over
which form to invoke for each page.

Before instructing the printer to start variable data merge, a few setup commands must be sent. The printer
must be instructed about the page orientation, paper source and page size. These commands cannot be
embedded into the macro definition because the printer will not allow them. They also cannot be embedded
into the form preceding the macro definition because of the possibility of multiple page forms, or
downloading of a macro for later use causing a change in printer operation.

In the following printer setup escape sequences, ESC should be replaced by the escape character in the
ASCII character set, and # should be replaced by a numeric parameter. All three escape commands are
optional only if your printer defaults to the expected results. The three commands should be sent to the
printer in the order described here and must immediately precede the macro invoking command each time
it’s issued. The first printer setup command is the page orientation command, which may be one of the
following:

ESC&l0O Portrait orientation (escape,ampersand,lower-case L,zero,upper-case O)
ESC&l1O Landscape orientation (escape,ampersand,lower-case L,1,upper-case O)
ESC&l2O Inv-Portrait orientation (escape,ampersand,lower-case L,2,upper-case O)
ESC&l3O Inv-Landscape orientation (escape,ampersand,lower-case L,3,upper-case O)

The second printer setup command is the paper source command. This command is only necessary if an
alternate paper source is required other than the default internal paper tray. This command appears as
follows:

ESC&l#H Paper source (escape,ampersand,lower-case L,user-specified parameter, upper-case
H). The # parameter is a number greater than 0. See your printer’s documentation.

The third printer setup command is different if your printer is (1) HP LaserJet Plus or LaserJet 500
compatible, or (2) LaserJet II, LaserJet 2000, LaserJet III, 4, 5, 6 or compatible. For type (2) printers, a page
size command is issued. For type (1) printers, a sequence of commands centered around a page length
command is issued as these printers do not accept the page size command. The page size command appears
as follows:

ESC&l#A Page size (escape,ampersand,lower-case L,user-specified parameter,
upper-case A). See your printer’s documentation for valid numeric
parameters to replace the # character.

For the LaserJet Plus and LaserJet 500 printers, the page length command consists of a sequence of
commands depending on the page orientation and the paper size. If the form is a landscape legal size paper,
some tricks must be done to select this combination. Instead of selecting a landscape orientation in the first
printer setup command, you should select a portrait orientation. This is necessary because the page height,
which is used to select the paper size, is the same for letter and legal size paper in landscape mode, but not
in portrait orientation. By first defining the page orientation as portrait, selecting the page length (84 lines)
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and then defining the page orientation as landscape, the printer is tricked into selecting the proper page size.
For all other combinations of page orientation and paper size, tricks are not necessary.

The page length command is based on line spacing. In order to guarantee the proper line spacing, it must be
defined before defining the page length. This is accomplished with the line spacing command as follows:

ESC&l6D Line spacing (escape,ampersand,lower-case L,6,upper-case D). Specifies
the line spacing to be 6 lines per inch.

After the line spacing, the page length command can be defined as follows:

ESC&l#P Page length (escape, ampersand, lower-case L, user-specified parameter, upper-case
P). The numeric parameter # can be replaced by a value in the table below:

PAPER SIZE PORTRAIT LANDSCAPE

Letter 66 51

Legal 84 (see text above)

A4 70 49

B5 60 43

Executive 63 43

See your printer’s documentation for paper sizes not listed here.

In the following macro invocation escape sequence examples, ESC should be replaced by the escape
character, and # should be replaced by the macro ID number. The escape sequence to be issued at the start
of the variable data stream to enable macro overlaying is as follows:

ESC&f#y4X Automatic macro overlay (escape, ampersand, lower-case F, user-specified
parameter, lower-case Y, 4, upper-case X). Every page will have this form until disabled.

The escape sequence to be issued at the end of the variable data stream to disable macro overlaying is as
follows:

ESC&f#y5X Disable automatic macro overlay (escape, ampersand, lower-case F,
user-specified parameter, lower-case Y , 5, upper-case X).

To call a macro, the following escape sequence should be sent with the variable data:

ESC&f#y3X Call macro overlay (escape, ampersand, lower-case F, user-specified parameter,
lower-case Y, 3, upper-case X). Only current page will print with this form.

Note: A macro downloaded to the printer is always placed in permanent memory. In order for the macro to
be deleted, either the printer can be powered down, or a delete permanent macro command should be
issued to the printer. This escape sequence is as follows:

ESC&f#y8X Delete macro specified by macro ID # (escape,ampersand,lower-case
F,user-specified parameter,lower-case Y,8,upper-case X). The # should be replaced with the macro
ID.
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Implemented using the provided ESCAPE utility as follows:

ESCAPE \E&f#y8X>PRN: The # should be replaced with the macro ID. The ESCAPE utility
replaces \e or \E with an escape character.

PostScript Forms
Proform Designer is designed to take advantage of a capability in PostScript level 2 (emulated in level 1) to
allow one or multiple forms to be stored in the printer’s memory. This feature provides for multi-page
forms to be cycled without the necessity of downloading the form for each page printed, as well as printing
multiple forms on each page.

When Proform Designer is instructed to produce a form, the internal form name is assigned. The
PostScript commands for this form are encased in a procedure body which must be invoked on each page
printed. To invoke form merging, a suggested method of placing the PostScript form is by adding the
following commands to the end of the form file:

0 0 translate formname EF showpage

The two zeros at the start indicate the X and Y offset to place the form (specified in points (1
72")). The

formname should be replaced with the appropriate form name (note: spelling must be exact, upper and lower
case letters are different). To place multiple forms on a page, a separate sequence is needed (except for the
showpage command, which should only occur once per page) with the offsets specifying locations for each
form placed on the page. It should be noted that for multiple forms per page, the X and Y offsets affect
further forms positioning. After the first form placed, further offsets are based from the last offset position.

Each page printed would need this sequence issued along with any variable data to be merged onto the
page. The last command issued on the page should be a showpage. The file must be terminated with the
PostScript end-of-job character (decimal 4). The PSCOPY utility is provided to add this character to the
file, if you are unable to place this character into the file through your text-editor. No characters can exists
in the form file after the end-of-job character.
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Appendix E

Specialty Imaging

Proform Designer offers advanced variable capabilities that deter fraud by creating distinctive
inimitable protective areas on documents. Specialty Imaging technology allows both numeric and
textual variables that make documents safer by creating hard to duplicate features. Implemented via

Xerox’s VI Suite, Xerox licensed fonts and Lytrod Software Proform Designer; specialty imaging uses
unique algorithms without special inks or post processing to add non-duplicable variable information for
secure documents. With five different variable capabilities to choose from, Specialty Imaging offers a variety
of formatting choices that can add security to personalized documents.
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Specialty Imaging Security Capabilities
Proform Designer offers five specialty imaging capabilities, each offering a different aspect of security.

MicroText Security added through next to invisible text. MicroText prints text so tiny that it can only be read under a
magnifying glass. Any attempt to duplicate the text (copiers, scanners, graphic arts software) produces a
blurred, illegible representation.

Correlation Text Protect sensitive variable text by creating content that is invisible unless superimposed by a “decoder”
transparency. Correlation text hides confidential information that can be quickly and safely viewed when
necessary.
The Two Layer Correlation Text overprints two separate variable messages that can be viewed using a special
double layer transparency.

GlossMark® Text Enhance document text such that the content is not visible in a straight-on view, but becomes visible as gloss
under inclined illumination. The effects of GlossMark® Text cannot be reproduced with even the best copiers
and scanners.

Fluorescent Effect Create a variable whose content is virtually invisible under normal light. Variable information printed with
Proform Designer Fluorescent Effect can only be seen under ultraviolet light.

Infrared Effect The Infrared Effect hides variable information so that it is only viewable using infrared equipment. A shaded
colored box is visible to the eye in normal light.
The Two Layer Infrared Effect allows print providers to print two layers of variable text using overprint. Only
one layer of text is visible at a time. One layer is visible only in normal viewing light, and the other layer is
visible only with infrared equipment.
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Implementing Specialty Imaging
� Have the most current Proform Designer software and Xerox FreeFlow VI Compose.

� If applicable, obtain the Specialty Imaging fonts from Xerox Corporation and place them in the
Proform Designer\Fonts directory on your workstation (not your DFE).

� Run the Proform Designer Help menu, Internet Software Update.

� Edit the Proform Designer Resource Set.

� Edit the xgfcdos.run file on workstation (PDF proofing) and xgfunix.run file on the DFE to enable SI
printing..

� Print the sample SI color palette included with Proform Designer on the recommended paper stock
(Xerox Digital Color Supreme Gloss Paper).

Install Xerox FreeFlow VI Specialty Imaging Fonts
Although the Xerox FreeFlow™ VI Compose Reference Manual directs you to install the Specialty Imaging
fonts onto the FreeFlow Print Server, Proform Designer users should not install these fonts onto the
printer. Instead, save the font files on the local drive of the system Proform Designer is installed on. It is
recommended that these fonts are placed in the Fonts directory mapped by the Resource Set Locations tab.
Proform Designer will access the specific fonts needed for each application and incorporate those fonts
into the VI Compose job files (project folder, container) for the printer. Accessing the fonts in this manner
saves print engine memory and download time.

Editing the Resource Set to enable Specialty Imaging capabilities will allow Proform Designer to access the
appropriate fonts as needed.
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Enabling SI in the Resource Set

Once you have obtained a Specialty Imaging font (if applicable) you must then enable the specialty imaging
capability in the Proform Designer Resource Set(s).

� To Enable Specialty Imaging in the Resource Set

1. Launch Proform Designer.

2. Prior to opening any source files (*.DTD,
*.FSL, or *.PFJ), go to the Edit menu and select
Resource Set.

3. Access the General tab, go to the VI Compose
drop-down menu and select FreeFlow 8.0 or
above.

4. Go to the Xerox Specialty Imaging Availability
section in the General tab, and select one or more Specialty Imaging capability.

For MicroText, Correlation Text, GlossMark® Text selections:

5. If prompted, direct the browser to the location of the Specialty Imaging fonts purchased previously.
It is recommended that these font files are stored on the local hard drive of the system Proform
Designer is installed on.
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Viewing the second layer of a Specialty Imaging Effect in Proform Designer

CorrelationText, FluorescentMark Effect and Infrared
Effect offer 2 layers of imbedded variable security.
Options can be set in the Proform Designer interface
to view this second layer.

� To View Layer 2

1. Go to the View menu.

2. Go to Options.

3. Select Specialty Imaging Layer-2.

Set Up PDF Proofing for SI
If you have set up your workstation to PDF proof
your documents from Proform Designer, you will
need to enable the demo VI Compose license to PDF
proof SI documents.

Adobe Distiller will not be able to emulate many of the SI features (with an exception to MicroText), but
can provide an adequate representation of the overall document design.

� To enable SI PDF proofing

1. Follow the steps in Chapter 10: Set Up Auto-Launch to enable PDF Proofing with Adobe Distiller.

2. Open Windows Explorer and browse the workstation for \xgf\src\xgfdos.run.

3. Open the xgfdos.run file in Notepad.

4. Delete the % before the following line: %(/usr/xgf/src/vippEE.spi) run % run VI Specialty Imaging Module

Completed example: (/usr/xgf/src/vippEE.spi) run % run VI Specialty Imaging Module

5. Save the file and close.

This same edit should also be made to the xgfdos.run file for FreeFlow VI Suite using the Windows operating
system, such as the Xerox FreeFlow VI Designer, which may be used for designing VI Compose
applications. Understand that although the FF VI Designer can be used to code the specialty imaging
feature, the effect (with the exception of MicroText) will only be seen on the printed output. Edit the
following line in xgfdos.run by removing the first %: %(c:\\xgf\\src\\vippEE.spi) run % run VI Specialty Imaging
Module
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Setting Up the Printer for SI
Specialty Imaging capabilities are supported on Xerox printers on all DFE controllers with a licensed
FreeFlow VI Compose. By default, the Specialty Imaging capability is disabled, but can be enabled by
editing the xgfunix.run file.

� To Enable the FreeFlow VI Compose Specialty Imaging module
� Edit the /usr/xgf/src/xgfunix.run file and delete the % to uncomment this line:

%(/usr/xgf/src/vippEE.spi) run % run VI Specialty Imaging Module

When you upgrade the FreeFlow VI Compose software on the DFE, you must edit the /usr/xgf/src/xgfunix.run
file again in order to continue to run Specialty Imaging print jobs.

SPI files

There are three *.spi files: vippDT.spi, vippEE.spi, and vippLN.spi. Only one *.spi file can be enabled at a time.
Because each file provides a different look and feel you may need to experiment by enabling a different *.spi
file. Simply rename the files and make one active. Restart VI Compose after making such a change. The
*.spi files will only effect the Fluorescent Specialty Imaging feature.

DFE Color Settings and Queues

The set up for your DFE controller is of paramount importance when using Specialty Imaging. If the
queue is not set up for VI Compose or the appropriate color settings are not implemented, your application
may not print correctly. For more information about configuring your DFE, refer to the DFE and
FreeFlow VI Compose documentation.

Printing the color palette sample sheet
Lytrod Software provides sample print files that displays each of the SI capabilities. Please contact Lytrod
Software (email: support@lytrod.com, or phone: +1-707-422-9221) and/or go to the Lytrod Software
website (www.lytrod.com) to obtain the appropriate print files.

Paper Recommendation
It is recommended that high gloss paper is used to print GlossMark® Text, Fluorescent Effect, Infrared
Effect, and Correlation Text; such as Xerox Digital Color Supreme Gloss, coated on one side, Color
Copier/Color Laser paper (example US Letter size Xerox product number: 3R11430).
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Designing SI Documents
The use of any of the following Specialty
Imaging capabilities will increase the
security of your documents. Combining
two or more of these features on your
documents significantly increases security.
Don't over do it. Being subtle is the key.

MicroText
The Proform Designer MicroText feature
transforms drawn lines into undersized text
that can only be read clearly under
magnification.

This feature is supported on Monochrome,
HighLight Color and full Color DocuSP
FreeFlow VI engines with the purchase of
Xerox FreeFlow VI Specialty Imaging
MicroText fonts.

� To Apply MicroText™

1. Create or open a variable document you wish to add MicroText to.

2. Select the Line Draw button from the
Drawing toolbar.

3. Draw a Line on the form where you
would like the MicroText to be placed.

4. Select the Select Arrow from the Drawing
toolbar, right-click on the selected line
object, and select Format Line from the
context menu. The Line Properties window
should appear.

5. Go to the bottom of the General tab to the
MicroText section and select the desired text
size from the left-most drop-down menu (choose from Small, Medium, or Large). Once this is selected,
the Bold, Text and Repeat (repetition) options will become enabled.

6. Go to the Text drop-down menu and select a data field, or key in multiple data fields and/or a
combination of data fields and static text.

7. Check Bold if applicable.
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8. Go to the Repeat drop-down menu and select the number of times to repeat the content or select Fit
to Length.

9. Click OK to accept all changes to the Line Properties window.

Conditional MicroText

� To Drive MicroText with Conditional Logic

1. Create or open a variable form document you
wish to add MicroText to.

2. Select the Line Draw button from the Drawing
toolbar.

3. Draw a Line on the form where you would like
the MicroText to be placed.

4. Select the Select Arrow from the Drawing toolbar,
right-click on the selected line object, and select
Format Line from the context menu. The Line
Properties window should appear.

5. Go to the bottom of the General tab to the
MicroText section and select the desired text size
from the left-most drop-down menu (choose
from Small, Medium, or Large). This step will eventually enable MicroText formatting for conditional
logic.

6. Go to the Conditions tab and click the Add button to start the creation of a conditional statement.

7. Once the conditional statement is complete, click the Format button.

8. Check Show Object.

9. To enable MicroText, select the desired text size
from the left-most drop-down menu. You will
then be allowed to select Bold, Text and Repeat
(repetition).

10. Go to the Text drop-down menu and select a data
field, or key in multiple data fields and/or a
combination of data fields and static text.

11. Check Bold if applicable.

12. Go to the Repeat drop-down menu and select the number of times to repeat the content or select Fit
to Length.

13. Click OK to accept all changes in the Line Properties window once all conditional formatting is
complete.
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Correlation Text
The Proform Designer Correlation Text feature allows Variable Data, Conditional Data and Static Text
blocks to be transformed into a shaded box area containing hidden text that is viewable only if
superimposed by a “decoder” transparency. The size of the Correlation Text box adapts to the length of
the variable text for each data item.

This Specialty Imaging feature is supported on Monochrome, HighLight Color and full Color DocuSP
FreeFlow VI engines with the purchase of Xerox FreeFlow VI Specialty Imaging Correlation Text fonts.

� To Apply Correlation Text Formatting to Data and/or Static Text

1. Create or open a variable document you wish to add Correlation Text to.

2. Create or select a data or text object, right-click and choose Format… from the context menu. The
object's Property window should appear.

3. Go to the Specialty Imaging tab.

4. Go to the Specialty Imaging area, Type drop-down menu and select Correlation Text.

5. Select the desired Correlation Text font from the Font drop-down menu. The font name describes the
size and style (normal, bold, italic and bold italic).

6. Go to the Color - GlossText & Correlation Text area Color drop-down menu and select a background shade
color for the Correlation Text box. The previously selected font and length of the variable
information will determine the printed width/height of the background shade color box.

7. Click OK to accept all changes to the Properties window.
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Conditional Correlation Text

� To Drive Correlation Text with Conditional Logic

1. Create or open a variable data document you wish to add Correlation Text to.

2. Select the Conditional Text button located in the Data View Toolbar and draw a condition text block on
the form page. The Data Properties, Conditions tab will automatically open.

3. Create all conditional statements and text actions in the Conditions tab then go to the Specialty Imaging
tab.

4. Go to the Specialty Imaging area, Type drop-down menu and select Correlation Text.

5. Select the desired Correlation Text font from the Font drop-down menu. The font name describes the
size and style (normal, bold, italic and bold italic).

6. Go to the Color - GlossText & Correlation Text area Color drop-down menu and select a background shade
color for the Correlation Text box. The previously selected font and length of the variable
information will determine the printed width/height of the background shade color box.

7. Click OK to accept all changes to the Properties window.
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Double Correlation Text

The Double Correlation Text feature hides two variable
messages in the same shaded box area. Both sides of
the "decoder" transparency are used to see each of the
messages. On one side, the transparency will display
one message, but flip the transparency over and a
different message can appear. The size of the
Correlation Text box adapts to the length of the
variable text for each data item.

� To apply Double Correlation Text formatting to data
and/or static text

1. Create or open a variable document you wish to
add Correlation Text to.

2. Create or select a data or text object, right-click
and choose Format… from the context menu.
The object's Property window should appear.

3. Go to the Specialty Imaging tab.

4. Go to the Specialty Imaging area, Type drop-down menu and select Correlation Text 2 Layer.

5. Go to the Font - GlossText & CorrelationText area and select the desired Correlation Text™ font from the
Font drop-down menu. The font name describes the size and style (normal, bold, italic and bold italic).

6. Go to the Color - GlossText, CorrelationText, Infrared area Color drop-down menu and select a background
color for the Correlation Text box.

� This background color will eventually blend with the color chosen for the second Correlation
Text layer. The numbers to the far right of the color name (50, 75, 100) represent the percentage
of color saturation applied to the area for the particular color chosen.

� Choosing 100% color saturation may sometimes make the message unreadable depending upon
the color combination chosen. It is best to print the Lytrod Software Proform Designer color
palette or run a test print of the desired color combinations/percentages.

7. Go to the Layer 2 area and select a font from the Font drop-down menu. This will be the font used in
the second Correlation message.

8. Go to the Layer 2 area and select a color and saturation percentage from the Color drop-down menu.
This box color will blend with the first Correlation Text layer box color.

9. Go to the Text enter box drop-down and key in text or select a data field. This will be the contents of
the second Correlation message.

� Note that the largest point size of the previously selected fonts and length of the variable
information will determine the printed width/height of the background shade color box.
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10.Click OK to accept all changes to the Properties window.

The numbers to the far right of the color name (50, 75, 100) represent the percentage of color saturation
applied to the area for the particular color chosen. Choosing 100% color saturation may sometimes make
the message unreadable depending upon the color combination chosen. It is best to print the Lytrod
Software Proform Designer color palette or run a test print of the desired color combinations/percentages.

Conditional Double Correlation Text

The first Correlation layer text or data message can be driven by rules (conditional logic). The second
Correlation message is not rule-based, though variable text and static text is still supported.

� To drive Double Correlation Text™ with Conditional Logic

1. Create or open a variable data document you wish to add Correlation Text to.

2. Select the Conditional Text button located in the Data View Toolbar and draw a condition text block on
the form page. The Data Properties, Conditions tab will automatically open.

3. Create all conditional statements and text actions in the Conditions tab then go to the Specialty Imaging
tab.

4. Go to the Specialty Imaging area, Type drop-down menu and select Correlation Text 2 Layer.

5. Go to the Font - GlossText & CorrelationText area and select the desired Correlation Text™ font from the
Font drop-down menu. The font name describes the size and style (normal, bold, italic and bold italic).

6. Go to the Color - GlossText, CorrelationText, Infrared area Color drop-down menu and select a background
color for the Correlation Text box.

� This background color will eventually blend with the color chosen for the second Correlation
Text layer. The numbers to the far right of the color name (50, 75, 100) represent the percentage
of color saturation applied to the area for the particular color chosen.

� Choosing 100% color saturation may sometimes make the message unreadable depending upon
the color combination chosen. It is best to print the Lytrod Software Proform Designer color
palette or run a test print of the desired color combinations.

7. Go to the Layer 2 area and select a font from the Font drop-down menu. This will be the font used in
the second Correlation message.

8. Go to the Layer 2 area and select a color and saturation percentage from the Color drop-down menu.
This box color will blend with the first Correlation Text layer box color.

9. Go to the Text enter box drop-down and key in text or select a data field. This will be the contents of
the second Correlation message.
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� Note that the largest point size of the previously selected fonts and length of the variable
information will determine the printed width/height of the background shade color box.

10.Click OK to accept all changes to the Properties window.

GlossMark® Text
The Proform Designer GlossMark® Text feature creates a color filled box containing static text, variable
data, or conditional data that is viewable under inclined illumination. The size of the GlossMark® Text box
adapts to the length of the variable text for each individual data item.

This feature is supported on full color Xerox DocuSP FreeFlow VI engines with the purchase of Xerox
FreeFlow VI GlossMark® Text fonts.

� To Apply GlossText® formatting to Data
and/or Static Text

1. Create or open a variable data document
you wish to add GlossMark® Text to.

2. Create or select a data or text object,
right-click and choose Format… from
the context menu. The object's Property
window should appear.

3. Go to the Specialty Imaging tab.

4. Go to the Specialty Imaging Type area, Type
drop-down menu and select GlossText.

5. Go to the Font - GlossText & CorrelationText
area and select the desired GlossMark®
Text font from the Font drop-down menu.
The font name describes the size and
style (normal, bold, italic and bold italic).

6. Go to the Color - GlossText, Correlation Text, Infrared area Color drop-down menu and select a background fill
color for the GlossMark® Text box. The font previously selected and length of the variable
information determines the width/height of the background fill color.

7. Click OK to accept all changes to the Properties window.
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Conditional GlossMark® Text

� To Drive GlossMark® Text with Conditional Logic

1. Create or open a variable data document you wish to add GlossMark® Text to.

2. Select the Conditional Text button located in the Data View Toolbar and draw a condition text block on
the form page. The Data Properties, Conditions tab will automatically open.

3. Create all conditional statements and text actions in the Conditions tab, then go to the Specialty Imaging
tab.

4. Go to the Specialty Imaging Type area, Type drop-down menu and select GlossText.

5. Go to the Font - GlossText & CorrelationText area and select the desired GlossMark® Text font from the Font
drop-down menu. The font name describes the size and style (normal, bold, italic and bold italic).

6. Go to the Color - GlossText, Correlation Text, Infrared area Color drop-down menu and select a background fill
color for the GlossMark® Text box. The font previously selected and length of the variable
information determines the width/height of the background fill color.

7. Click OK to accept all changes to the Properties window.
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Fluorescent Effect
The Proform Designer Fluorescent Effect feature allows Variable Data, Conditional Data and Static Text
blocks to be transformed into color filled boxes that contain invisible text, which can only be viewed under
ultraviolet light. The Fluorescent Effect feature is unique from the other Specialty Imaging capabilities in
that it does not require the purchase of a Xerox Corporation® licensed font; it works with any font
available to Proform Designer (TrueType, PostScript Type 1, etc.). Furthermore, the Fluorescent Effect box
area can be stretched to any desired size and will resize to fit the length of a variable.

This feature is supported on full color Xerox FreeFlow VI enabled engines.

� To Apply to Fluorescent Effect Formatting to Data and/or Static Text

1. Create or open a variable data document you wish to add Fluorescent Effect to.

2. Create or select a data or text object, right-click and choose Format… from the context menu. The
object's Property window should appear.

3. Go to the Specialty Imaging tab.

4. Go to the Specialty Imaging Type area, Type drop-down menu and select FluorescentText.

5. Go to the Color - Fluorescent & Infrared Text area, Color Pairs drop-down menu and select a color.

6. Click OK to accept all changes to the Properties window.

7. Resize the text block to the desired size of the color fill box.
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Conditional Fluorescent Effect

� To Drive Fluorescent Effect with Conditional Logic

1. Create or open a variable data document you wish to add Fluorescent Effect to.

2. Select the Conditional Text button located in the Data View Toolbar and draw a condition text block on
the form page. The Data Properties, Conditions tab will automatically open.

3. Create all conditional statements and text actions in the Conditions tab, and then go to the Specialty
Imaging tab.

4. Go to the Specialty Imaging Type area, Type drop-down menu and select FluorescentText.

5. Go to the Color - Fluorescent & Infrared Text area, Color Pairs drop-down menu and select a color.

6. Click OK to accept all changes to the Properties window.

7. Resize the text block to the desired size of the color fill box.
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Infrared Effect
Data and text messages can be hidden within a
shaded area. The message will be visible only to
infrared equipment.

This feature is supported on full color Xerox
FreeFlow VI enabled engines.

� To apply the Infrared Effect to data and/or
static text

1. Create or open a variable data document
you wish to add the Infrared Effect to.

2. Create or select a data or text object,
right-click and choose Format… from the
context menu. The object's Property
window should appear.

3. Go to the Specialty Imaging tab.

4. Go to the Specialty Imaging Type area, Type drop-down menu and select InfraredText.

5. Go to the Color - Fluorescent & Infrared Text section Color Pairs drop-down menu and select a color.

6. Click OK to accept all changes to the Properties window.

Conditional Infrared Effect

� To drive the Infrared Effect with Conditional Logic

1. Create or open a variable data document you wish to add the Infrared Effect to.

2. Select the Conditional Text button located in the Data View Toolbar and draw a condition text block on
the form page. The Data Properties, Conditions tab will automatically open.

3. Create all conditional statements and text actions in the Conditions tab, and then go to the Specialty
Imaging tab.

4. Go to the Specialty Imaging Type area, Type drop-down menu and select InfraredText.

5. Go to the Color - Fluorescent & Infrared Text section Color Pairs drop-down menu and select a color for the
shaded area.

6. Click OK to accept all changes to the Properties window.
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Double Layer Infrared Effect

The double layer Infrared Effect prints one data/text message
that will be visible to the eye, while encrypting a different
data/text message that will be visible only with infrared
equipment.

This feature is supported on full color Xerox FreeFlow VI
enabled engines.

� To apply the Double Infrared Effect to data and/or static text

1. Create or open a variable data document you wish to add
the Infrared Effect to.

2. Create or select a data or text object. This will be the
hidden infrared object.

3. Right-click and choose Format… from the context menu.
The object's Property window should appear.

4. Go to the Specialty Imaging tab.

5. Go to the Specialty Imaging area, Type drop-down menu and select InfraredText 2 Layer.

6. Go to the Color - GlossText, CorrelationText, Infrared area Color drop-down menu and select a color. This will
be the font color of the viewable data and/or text.

7. Go to the Layer 2 area and select a color from the Color drop-down menu. This will be the background
color of the shaded box that will surround the viewable text.

8. Go to the Layer 2 area, Text enter box drop-down and select a data field/key in text and data field
names. This will be the contents of the infrared message. The font will display as black only with
infrared equipment.

9. Click OK to accept all changes to the Properties window.
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Conditional Double Layer Infrared Effect

� To drive the Double Infrared Effect with Conditional Logic

1. Create or open a variable data document you wish to add the Infrared Effect to.

2. Select the Conditional Text button located in the Data View Toolbar and draw a condition text block on
the form page. The Data Properties, Conditions tab will automatically open.

3. Create all conditional statements and text actions in the Conditions tab, and then go to the Specialty
Imaging tab.

4. Go to the Specialty Imaging Type drop-down menu and select InfraredText 2 Layer.

5. Go to the Color - GlossText, CorrelationText, Infrared area Color drop-down menu and select a color. This will
be the font color of the viewable data and/or text.

6. Go to the Layer 2 area and select a color from the Color drop-down menu. This will be the background
color of the shaded box that will surround the viewable text.

7. Go to the Layer 2 area, Text enter box drop-down and select a data field/key in text and data field
names. This will be the contents of the infrared message. The font will display as black only with
infrared equipment.

8. Click OK to accept all changes to the Properties window.

Specialty Imaging Printing
Once the printer set up for Specialty Imaging is complete (referenced earlier in this Appendix), SI
documents generated from Proform Designer are printed like any other VI Compose job. For more
information on printing VI Compose jobs, refer to Chapter 8: Creating Jobs and Saving to VI Compose.

Be sure to use the recommended Xerox Digital Color Supreme Gloss, coated on one side, Color
Copier/Color Laser paper for GlossMark® Text, Fluorescent Effect, Infrared Effect, and Correlation Text.
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Appendix F

Clear Dry Ink

The Xerox Color 800/1000 Presses offer an option to print a light gloss coating with Clear Dry Ink
(CDI). Proform Designer allows you to easily design documents that have this clear coating applied
to text and objects in both static and variable environments. While flooding the entire application

may be a desirable effect in some instances, Proform Designer allows the application of Clear Dry Ink to
select areas on your form. This enables you to make certain areas, whether they are text or objects, stand
out by having a glossy coating.

Create background designs and visually enhancing effects using Clear Dry Ink with Lytrod Software's user
friendly drawing tools such as Box, Circle and Line Draw.

By using the Path Draw tool, portions of images or logos can be enhanced by tracing or outlining the
desired areas and then filling the "path" with the Clear Dry Ink.
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Enabling Clear Dry Ink
Clear Dry Ink can be applied to ANY element on the form, it is as simple as changing one option in the
Color Selection window. Clear Dry Ink can be used to outline or fill elements on your form. The glossy
coating can be applied as is (no coloring, just Clear Dry Ink) or on top of an existing color setting.

Clear Dry Ink is most visible when used alone or over light/pastel colors.

To enable the Color Settings to be defined as only Clear Dry Ink (no color, just a clear gloss coating) make
sure 100% white is selected and 100% Clear Dry Ink is selected. This will not print a white color, but
instead tells the software to ONLY print CDI.

Text

� To apply Clear Dry Ink to Static/Variable Text

1. Select the desired static/variable text block that the Clear Dry Ink will be applied to. If you wish to
only have select text within the text block to appear with Clear Dry Ink, highlight the desired text
within the text block.

2. Right click and choose Font from the context menu.

3. From the Font window, select the color drop-down menu.

4. Choose the button on the bottom of the Color drop-down menu that says Other.

5. The Color Selection window will appear.

6. Select the desired text color from the color wheel, input CMYK/RGB values, or use the color
selector.

7. Enter the desired percentage of Clear Dry Ink to be applied to the text in the Clear Ink % input box.

8. Click OK to accept defined settings in the Color Selection window.

9. Click OK to accept defined settings in the Font window.
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Form Elements
Drawn form elements such as paths, lines, boxes and circles can be outlined or "filled" with Clear Dry Ink.

� To Outline drawn elements with Clear Dry Ink

1. Select the desired form element.

2. Right click and select Format from the Context menu.

3. The Properties window will appear. From the General tab, select the Color drop-down menu.

4. Choose the button on the bottom of the Color drop-down menu that says Other.

5. The Color Selection window will appear.

6. Select the desired outline color from the color wheel, input CMYK/RGB values, or use the color
selector.

7. Enter the desired percentage of Clear Dry Ink to be applied to the element outline in the Clear Ink %
input box.

8. Click OK to accept defined settings in the Color Selection window.

9. Input the desired border Style/Thickness and click OK to accept defined settings.

� To Fill drawn elements with Clear Dry Ink

1. Select the desired form element.

2. Right click and select Format from the Context menu.

3. The Properties window will appear. From the Shading/Fill tab, check the Fill box to enable the Color Fill
options.

4. Select the Color drop-down menu and choose the button on the bottom of the menu that says Other.

5. The Color Selection window will appear.

6. Select the desired fill color from the color wheel, input CMYK/RGB values, or use the color selector.

7. Enter the desired percentage of Clear Dry Ink to be applied to the filled element in the Clear Ink %
input box.

8. Click OK to accept defined settings in the Color Selection window.

9. Click OK to accept defined settings in the Properties window.
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Paths
The Path Draw tool is useful when accenting applications with Clear Dry Ink. The Path Draw tool can be
used to draw or trace individual shapes or elements on the form to be filled with Clear Dry Ink. In order for
the paths to be "filled" with Clear Dry Ink, they must be closed. This means both ends of the path must be
touching to ensure the fill option is enabled.

� To draw a path and fill using Clear Dry Ink

1. Click on the Path Draw tool to begin drawing your path.

2. Draw the desired path by clicking on the form to create different points along the path.

3. When finished, with the drawn path selected, click on the Close/Open Path button to ensure the path is
closed.

4. Right click on the path and choose the Format Path option from the Context menu.

5. The Path Properties window will appear opened to the General tab.

6. If your path was properly closed, the Fill option should be available to select. If the Fill checkbox is
"grayed-out" it means your path needs to be closed before you continue. Check the Fill checkbox to
enable the Path Fill color options.

7. Select the Color drop-down menu and choose the button on the bottom of the menu that says Other.

8. The Color Selection window will appear.

9. Select the desired fill color from the color wheel, input CMYK/RGB values, or use the color selector.

10. Enter the desired percentage of Clear Dry Ink to be applied to the filled path in the Clear Ink % input
box.

11. Click OK to accept defined settings in the Color Selection window.

12. Click OK to accept defined settings in the Properties window.
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Appendix G

Icon Quick Reference

Standard Tool Bar

Icon Function

New Form

Open Form

Create New Resource Set

Save

Proof Print

Preview Form

Import Text

Import Image File

Import Data

Cut
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Copy

Paste

Undo

Redo

What’s This

Help

Text Format Tool Bar

Icon Function

Bold

Underline

Italic

Subscript

Superscript

Left Align Text
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Center Align Text

Right Align Text

Justify Text

Top Align Text

Center Align Text

Bottom Align Text

Correct Word Spellings

Attach to Box/Circle

Position Object to Box/Circle

Toggle Text Margin

Pre-defined Point Sizes

Pre-defined Typefaces

Pre-defined Images
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View Toolbar

Icon Function

Grids

Rulers

Margins

Fit Page to Screen

Enlarge Drawn Area

Magnify Area 25%

Demagnify Area 25%

Pan Mode

View Data

View Line Data

Object Format Toolbar
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Icon Function

Toggle Line Direction

Toggle Diagonal Line

Toggle Circle Segment

Round/Square Corner

Close/Open Path

Add New Point

Continue Path from end

Add Light Shading

Add Medium Shading

Add Heavy Shading

Increase Border Thickness

Decrease Border Thickness

Change Border Style
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Change Border Color

Change Text Image Color

Change Fill Color

Palette

Grouping Toolbar

Icon Function

Left Align Group Items

Right Align Group Items

Center Align Group Items

Top Align Group Items

Bottom Align Group Items

Vertical Center Align Items

Make Same Width
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Make Same Height

Make Same Size

Stretch Left Group Items

Stretch Right Group Items

Stretch Top Group Items

Stretch Bottom Group Items

Repetition Toolbar

Icon Function

Even Repetitions

Exact Repetitions

Staggered Repetitions

Random Repetitions

Break Repetition
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Join Into Repetition

Drawing Toolbar

Icon Function

Select Mode

Select Group Mode

Text Draw

Box Draw

Line Draw

Circle Draw

Path Draw

OMR Bubbles

Current Grids

OMR Toolbar
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Icon Function

Response Direction

Response Shape

Written Response Box

Number OMR

Pre-defined OMR Sequences

Data View Toolbar

Icon Function

Rewind Data

Data Backwards

Data Forwards

Fast Forward Data

Select Field Name

Data Driven Graph
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Conditional Text

Conditional Image

Create New Frame

Attach Relative Object

Data Formula

Edit Job Conditions
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