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About Lytrod Software, Inc.
Established in 1985, Lytrod Software is a privately held company committed to producing high-quality
electronic document design tools. For over 25 years Lytrod has developed software tools that help our
customers get the most out of their production printers.

VisionDP is a standalone variable document design tool and composition engine for all of your Variable
Data Printer (VDP) applications - from personalized to transactional. VisionDP creates optimized PDF in
record time, without the need for a third party composition engine. VisionDP is based on Lytrod
Software’s award winning Designer platform, which supports the most extensive VI composition language
in the industry. It doesn’t end there. In addition to design and composition, VisionDP includes document
workflow features from data driven “lights out” composition, to PDF splitting and job deployment(archive,
email, print).

VisionDP is available in three tiers:

QuickStart: Our most affordable VisionDP product that provides all the design capabilities of VisionDP
Production, but with limited PDF page output.

VisionDP Production: Mid-tier product. Unlimited PDF output. Command Line support.

VisionDP Automate: Unlimited PDF output. Provides full PDF Automation capabilities, including support for
Command Line, Hot-Folders, Reporting/Logging, Versioning, Batch Job Submittal, Automation menuing,
and Email Client support.

Lytrod has extensive knowledge and experience with production printing and continues to exceed industry
expectations with new and innovative products.

Our products are continually refined, and your input is our number one source for product improvements.
Send comments to:

Lytrod Software, Inc.
2573 Clay Bank Road, Suite 4
Fairfield, CA 94533
Phone: 707/422-9221
Fax: 707/429-5179
email: support@lytrod.com
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Lytrod Software Services and Support
Technical support is offered to customers who have purchased a maintenance contract.

Lytrod Support

If you have a current maintenance contract, the following options are available to you:

Telephone Support

1-707-422-9221

Lytrod Software technical support is offered Monday through Friday, 7:30 am to 4:30pm
Pacific Standard Time.

Email Support

support@lytrod.com

Response to email will be within 4 hours during the standard technical support hours.

Web Site

The web address for Lytrod Software products is http://www.lytrod.com. Current product information is
readily available at this site.

Training

Lytrod offers a variety of training options, including web-based training. Please contact sales@lytrod.com
for additional information.

Tutorial Videos

Lytrod Software offers a variety of helpful 1-2 min tutorial videos that demonstrate how to use various
features within the Designer and/or VisionDP software. Browse our play lists to find videos teaching you
how to apply Clear Dry Ink to your documents, create variable QR Codes, define conditional logic, and
much more!

Visit http://www.youtube.com/user/LytrodSoftware
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VisionDP Protection Key (Dongle)
Lytrod Software products are protected via a protection key (also referred to as locking device or dongle)
that is designed to be attached to the USB port of a computer. The protection key retains the software
license of operation. A licensed key must be attached to the USB port of the system that is attempting to
access the software during the entire session of operation.

New Software Licenses

Software protection keys are programmed for operation according to the licensing agreement. A code
(numeric string) and instructions may be issued from Lytrod Software that will enable the protection key
with a license of operation.

Each Lytrod Software product not purchased from Lytrod Software is shipped without a license of
operation. These products can be enabled by contacting Lytrod Software to register each new license.

VisionDP QuickStart purchased directly from Lytrod Software will be shipped without a license of operation.
Lytrod Software will issue a license to enable the software for full operation once contacted by the user that
they are in possession of the product.

VisionDP and VisionDP Automate purchased directly from Lytrod Software will be shipped with a 30 day
temporary license of operation. Once full payment is received within the 30 day grace period, established
in the Lytrod Software purchasing terms, Lytrod Software will issue a license to enable the software for full
operation without an expiration date.

Lost Software Protection Keys (dongles)

Software Protection Keys will not be sold individually if lost or stolen. Full purchase price of the software will be
charged for all dongle replacements, with no exceptions.

Defective Software Protection Keys

If dongles are damaged or fail to perform, there will be a fee to obtain a replacement dongle after the
original dongle has been returned to Lytrod Software, Inc. Replacement dongles will not be shipped until
the original dongle is received.
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Chapter 1

Getting Started with VisionDP

Lytrod Software VisionDP is a user-friendly variable data layout and forms design tool. Sophisticated
one-to-one marketing pieces and transactional/promotional statements can be easily created from
either mainframe, XML, or database delimited data. The Microsoft Windows GUI interface includes

wizards and drop-down menus for easy drag-and-drop data placement. Easily create simple personalized
letters or sophisticated variable documents (conditional rule-based text, images, page designs, slipsheet, etc.)
to be outputted in the PDF format.

VisionDP creates optimized PDF in record time, without the need for a third party composition engine.
VisionDP is based on Lytrod Software’s award winning Designer platform, which supports the most
extensive VI composition language in the industry, but it doesn’t end there. In addition to design and
composition, VisionDP includes document workflow features from data driven “lights out” composition, to
PDF splitting and job deployment (archive, email, print).

VisionDP is available in the entry-level QuickStart version, using a software lease model which has limited
PDF page output. Software upgrades to VisionDP Production or VisionDP Automate are available.

VisionDP Automate LCDS is a tier of the VisionDP Suite that can be used as a migration tool from LCDS
(Metacode resources) to a PDF workflow.
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Lytrod Software's PDF Workflow

Design

The design of Variable Documents is commonly a two step process: (1) creation of the static elements on
the page, and (2) laying out the variable data on the page. The static portion may consist of drawing of
lines, boxes, shadings, and placing of images and text onto the page, or it may just be placing a single full
page image. The second step would be to design the layout of the data, be it conditional items, like data or
images, or formatting text which has variable information embedded within it.

Create PDF

The creation of the PDF permits several actions: (1) changing of the data file, from sample data to
production data; (2) subsetting of the PDF, based on either page or data record ranges; (3) splitting of the
PDF into multiple PDF documents, based on page or data record counts, data conditions, or on each data
set; (4) creation of statistical information, either at the end of the PDF document, or in separate PDF
document, or in a screen dialog; and (5) actions done once the PDF document is produced, either emailing
notifications/PDFs to one or more email accounts, or LPRing the PDF to a printer.

Print

The PDF document can be used for viewing or archival, or it may be printed. VisionDP Production and
Automate versions are available without page limitations.
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Using the Documentation
In addition to the printed documentation, much of VisionDP is documented in an on-line help system.

VisionDP Documentation Set

Online Help Within VisionDP an online help system is available for access during the operation of the program. This
online help can be quickly accessed and the help window can be displayed while you continue your work.

Context-Sensitive Help Integrated within VisionDP is a context-sensitive help system that displays information relevant to the current
task. Context-sensitive help is accessed by clicking What’s This and then clicking on the item for which to
view information.

Fly-by ToolTips Information on icons and buttons will display as you position the cursor over an icon or button within the
toolbars.

User Guide The written documentation you are currently reading provides an in-depth description of VisionDP. There is
also a PDF version of this manual found within the Help Menu.
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Documentation Conventions
The conventions used in this documentation are defined as follows:

Mouse Conventions

The following conventions are used when referring to the mouse:

When you read this… Do this…

Click a button Position mouse over the button and click

Open menu Position mouse over the main menu, depress mouse, position mouse over the requested menu item and click
the mouse button.

Enable check box Click the check box to place an “X” in the box.

Disable a check box Click the check box to remove the “X” in the box.

Select Text Click and hold down the left mouse button at the beginning of the text selection, drag mouse to the end of
the selection and release the mouse key.

Select Object Be sure no other object is selected. Position mouse over object until the mouse pointer changes to the shape
of the object, then click. The object will now have markers at various points on the edge.

Keyboard Conventions

The following conventions are used when referring to keyboard actions:

When you read this… Do this…

Press ENTER Press the Enter key on your keyboard

SHIFT + MOUSE Press the Shift key and click the left mouse button at the same time.

CTRL + MOUSE Press the Control key and click the left mouse button at the same time.

User Guide Conventions

When you see this… It means this…

� A note

� A tip

� An Item of Interest

� Look Here
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Installation
Before beginning, you need to install VisionDP onto your computer. There is a setup program on the
enclosed CD that will lead you through the installation process.

System Requirements

To run VisionDP you will need the following:

� Microsoft Windows operation system XP, Vista, Windows7, Windows8

� PC user rights for periodic access to and editing of system registry during software operation (may
require Admin Rights or that User Account Controls are turned off)

� USB Port (for license dongle)

� 512 MB of RAM

� 1 GB hard disk space

� Pentium IV 2.8 Ghz/AMD Athlon 2800 Mhz or faster processor

� CD-ROM Drive

� Two-button mouse

� 20” high resolution monitor or larger (recommended)

� Internet access and software *.exe download rights for Automatic Software Update Service

Installing VisionDP

Installation of the software requires PC administrative rights that enable the installation of software, access
to the system registry, and installation of a device driver for the dongle.

� To install VisionDP (USB dongle)
� Insert the installation CD into the CD ROM drive. An automatic setup menu will appear. Follow

the directions on the menu.

� Reboot

� Attach the USB dongle and use the Windows New Hardware Device Wizard (Should
automatically appear in WinXP or later O/S) to find a driver for the USB dongle.
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If installing on some 32 bit versions of Windows, the software may default to be installed on the
Program Files (x86)\VisionDP folder. While this is different from previous versions or windows, this will not be a
problem and is recommended as the location for this software.

If the installation wizard does not automatically launch, run the setup.exe program from the CD.

Multiple software licenses are required to run the software on multiple workstation seats.

6 Getting Started with VisionDP
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Automatic Software Updates

This feature is only available to customers who are current on their software maintenance. VisionDP will
automatically check for version updates upon installation and every 7 days thereafter.

� To enable an automatic software update

1. With no forms open, go to the Edit menu and select Preferences.

2. Access the System tab.

3. Check the Enable Internet Based Software Updating check box.

4. Click OK.

� To force an automatic update to occur

1. With no forms open, select Internet Software Update from the Help menu.

2. If your maintenance is current, VisionDP will update your software if a new version is available.

Software downloads are also available on www.lytrod.com for users on current maintenance contracts. A
username and password will need to be obtained from either your Account rep, or Technical Support rep
from support@lytrod.com.

� To download updates from the website

1. Go to http://www.lytrod.com/customer_update/

2. In the English Only Downloads section, click on the button for the VisionDP download.

3. Enter the User Name and Password provided by your Lytrod Software representative.
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Using Help Resources

� To access help topics

1. Select Help topics from the Help menu.

2. Click one of the following tabs:

� Contents tab to browse topics by category.

� Index tab to list index entries. Enter the first
letter(s) of the index entry to jump to that topic.

� Find tab to search for a particular word or phrase.

Accessing Context-Sensitive Help

Context-sensitive help is accessible from anywhere within
VisionDP. When accessing context-sensitive help, use these
guidelines:

To get help on… Click here…

Windows The Context Help button on the toolbar, drag the context help icon to item within the window.

Menu Commands The Context Help button on the toolbar, drag the context help icon to the menu and click.

Tools and dialog controls The Context Help button on the toolbar, drag the context help icon to the item you want help on and click.

Selected object Right-click the object and select the Properties menu item for information on that object's Fly-by ToolTips.

Fly-By ToolTips

Fly-By ToolTips are available for all toolbar buttons and provide a brief description of its operation.
Position the mouse over the toolbar button and wait for a few seconds. The Fly-By ToolTips will appear
below and slightly to the right of the toolbar button.

8 Getting Started with VisionDP



VisionDP Screen Layout

Design Area
The design area is used to display and edit any forms that may be open. More than one form may be open
at a time. The most recently opened form will be displayed. All will be listed in the Window menu. Selecting a
form from this list will cause it to be displayed. Each form is displayed in its own window in the design area
with associated Minimize, Maximize, Restore, and Close buttons. Minimizing or reducing the current
window will allow other open forms to be viewed. Only the active form can be edited. The active form is
designated by clicking in the form’s window or selecting it from the Window menu.

Toolbar Button(s) Screen Item

The view of the design area can be enlarged or decreased using the Zoom buttons on the View
toolbar or by choosing the desired view from the View menu.

Rulers can be displayed at the top and left or the bottom and right of the design area to aid in
placement of form elements. These rulers can be undocked and moved around the design area
by dragging them onto the form. They can be redocked by clicking on them with the right
mouse button and choosing the desired location.

A grid can be displayed on the screen (as well as printed on a proof print) to assist with form
layout and measurement. Grid values are defined in the Form Setup window. See page 50.

Scroll bars are available at the right and bottom of the design area. These are used to move the desired area
of the form into view. Information pertaining to the active form is displayed in the Ribbon bar, which is
beneath the design area.
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Menu Bar

The Menu bar is displayed at the top of the screen and provides access to all menus available in VisionDP.
Each menu contains a list of commands that will be displayed when the user chooses a menu title.
Non-selectable commands will be grayed out. Non-selectable commands are features that are not available
to the user at the time of selection based on the type of form element selected.

Some Menu bar commands are followed by an arrow marker indicating that a cascading menu will appear.
These cascading menus typically request further clarification as to the function being performed. For
example, the Import command from the File menu has a cascading menu. This menu requests further
information regarding the Import function (Font, Image, Text, etc.)

Some Menu bar commands are followed by an ellipses (…) indicating that a pop-up menu will appear.
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Quick Keys

Most commands have their associated quick key listed to the right of the command. Quick keys provide
users with quick access to various functions via the keyboard. Most commands also have a corresponding
button on a toolbar.

Quick Key Command/Action

Ctrl + A Select All

Ctrl + B Background Mode

Ctrl + C Copy

Ctrl + F Find

Ctrl + G Group

Ctrl + H Replace

Ctrl + N File New

Ctrl + O File Open

Ctrl + P File Print

Ctrl + R Rotate

Ctrl + S File Save (Must select Save As from File menu before this command is enabled.)

Ctrl + V Paste

Ctrl + X Cut

Ctrl + Y Edit Redo

Ctrl + Z Edit Undo

Ctrl + (+) Zoom-In

Ctrl + (-) Zoom-Out

Ctrl + 0 View Full Page

DEL Delete

F1 Help

F2 Attach Object, Text Box, Data

F3 Find

F5 Position Object

F6 Next Pane

F7 Format Object (Not Text Box)

F8 Zoom Fit To Page
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F9 Preferences

F10 Refresh Screen

Shift + F1 Context Help

Shift + F6 Previous Pane

Pop-up Menus
Pop-up menus appear when further information is required from the user. Information is requested in the
form of edit boxes, drop-down boxes, spin boxes, radio buttons, and check boxes. Pop-up menus also
contain action buttons.

Radio Buttons

Radio buttons represent a group of choices in which only one option
can be selected. They appear as a set of small circles along with their
associated descriptions. A radio button is set when a dot appears in the
middle of the circle. The circle will be empty if the choice is not
selected.

Check Boxes

Check boxes are similar to radio buttons in that a group of items are listed and can be
set or not. They differ in that check boxes are used for independent or nonexclusive
choices. One or more check boxes can be set as desired.

A check box appears as a square box with accompanying label. When the choice is set, a
check mark appears in the box. The box will be empty if the choice is not selected.

Action Buttons

Each menu has one or more buttons that provide control over the pop-up menu. This control may be to
accept the changes or cancel changes. It may also control the pop-up of additional menus. Action buttons
are OK and CANCEL.

Edit Boxes

Edit Boxes prompt for input of user defined information.
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Drop-Down Menus

A drop-down menu typically displays a list of choices. The choices can
be shown as text, icons or other graphics. The purpose is to display a
collection of choices from which the user can make their selection. The
list is displayed upon demand. In its closed state, the control displays
the current selection. The user opens by clicking the down arrow to the
right of the control to change the selection.

Spin Boxes

Spin boxes are edit boxes that accept a limited set of values. Spin boxes have
up-down control buttons to increment or decrement the value. The user can
also type a value directly into the box by clicking the mouse over the value and
typing the desired value.

Ribbon Bar
The Ribbon bar displayed at the bottom of the design area provides various information to the user. The
left side of the Ribbon bar displays messages based on the current menu field or mouse position. The right
side of the Ribbon bar displays information pertaining to the current form.

The right side of the Ribbon bar contains thirteen fields. From left to right, the purpose of the fields are to
define the following:

� The current Resource Set

� Name of Job

� Job and Data Record Counter

� Number of record being viewed of total records (example shows 1st record of 3 records)

� The X coordinate of the element selected or the cursor if no elements are selected

� The Y coordinate of the element selected or the cursor if no elements are selected

� The ordering position of the selected item on the page. Higher numbers indicate forward
positioning.

� The unit of measure in which the X/Y coordinates are displayed, as defined in the Preferences
menu

� The zoom level of the active form

� The current time or the total amount of time spent on the active form, based on the selection in
the Preferences menu. The 24 hour clock time format is supported for international operating
systems.

� Number Lock

� Scroll Lock

� Insert/Overwrite
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Scroll Bars
Scroll bars are available to maneuver quickly throughout your form. Scroll bars appear whenever the user is
in a view such that their entire form is not able to be displayed in the Design Area. Scroll bars will appear
on the bottom and right sides of the screen. Click and drag the scroll bar to move the form up/down,
left/right as necessary. Page Up and Page Down keys also allow for quick maneuvering. Arrow keys are
located at left/right side of bottom scroll bar and top/bottom of right scroll bar to allow scrolling in
smaller increments.

Toolbars

Various toolbars are available within VisionDP to provide quick access to commonly used functions. Users
are given the ability to organize the commands to suit their needs. You can easily customize the tools on the
toolbar. For example, you can add and remove menus and buttons, create custom toolbars, hide or display
toolbars and re-locate toolbars. Toolbars contain not only buttons, but drop-down menus as well. ToolTips
are available for toolbar buttons to identify their function.

Individual toolbars can be undocked and moved around the design area. This is done by dragging the
toolbar onto the design area. They can be re-docked by dragging them back to the toolbar area.

Display/Hide Toolbars

Toolbars can be removed from the screen if desired. Toolbars buttons are grouped according to
functionality and placed with similar functioning buttons on a single toolbar. For example, all drawing
toolbar buttons can be found on the Drawing toolbar. This not only makes locating buttons simplified, but
assists users in organizing their desktop.

� To display/hide toolbars

1. Select Toolbars from the View menu.

2. Toolbars will be listed by name in the Toolbars list.

3. Check on/off the appropriate Toolbar.
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Change Appearance of Toolbars

Toolbars can be displayed as normal, cool look, and/or large buttons. Toolbars will be displayed in normal
view by default.

� To change toolbar appearance

1. Go to the View menu and select Toolbars.

2. Enable the Large Button and/or Cool Look button as desired.

3. Disable the check boxes to return to normal view.

Enable/Disable ToolTips

ToolTips provide a brief description of the purpose of a toolbar button. They appear automatically when
the mouse is held over a button for a short period of time when the Show ToolTips option is set on.

� To set the Show ToolTips option

1. Go to the View menu and select Toolbars.

2. Check the Show ToolTips button.

16 Getting Started with VisionDP

Normal Cool Look Large Buttons



Customize Toolbars

Toolbars can be tailored to the users needs by removing and adding toolbar buttons to them.

� To customize a toolbar

1. Go to the View menu and select Toolbars.

2. Select the Commands tab to enable toolbar edit mode.

3. Remove and rearrange buttons from toolbars by dragging the buttons off toolbars or to a new
location.

4. Add buttons to toolbars by dragging buttons from the Buttons list in the Commands tab onto the desired
toolbar.

The user can further tailor the toolbars by creating a new custom toolbar.
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Create Custom Toolbar

� To create a custom toolbar

1. Select Toolbars from the View menu.

2. click the New button.

3. An edit box will appear allowing the user to name the toolbar.

4. The new toolbar will now appear in the Toolbar list.

Working with Rulers

Rulers

Rulers are a helpful tool in form measurement. The rulers can be displayed in a variety of units (inches,
centimeters, dots, and grids) and can be docked/re-docked as necessary.

� To display rulers

1. Click Show Ruler on the View toolbar.

<OR>

2. Select Options from the View menu.

3. Select Rulers from the Options menu.

� To define ruler unit

1. Select Preferences from the Edit menu.

2. From the Design tab, check Show Ruler to show/hide rulers.

3. Select unit of measure by choosing desired unit in Ruler Unit drop-down list.

Docking/Re-Docking Rulers

Rulers will be shown on the top and right side of the VisionDP screen when first enabled. The user can
re-dock the rulers to the left and bottom as desired. Rulers may also be undocked to better assist users with
form measurements.

� To undock ruler, drag the ruler to a location within the design area.

� To re-dock ruler, click the right mouse button over the ruler and select location at which to
re-dock the ruler (left/right for vertical ruler or top/bottom for horizontal ruler).
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Welcome Menu
Upon starting up VisionDP, the Welcome Menu will appear. This menu will give you access to the most
commonly used functions and assists in quickly and easily opening up and creating new forms/projects.

Open button After selecting a file (project .pfj or single form .dtd) you can click on Open to open your design
file.

New button The New button will create a new single blank form

Create PDF button After selecting a .pfj or .dtd from the design file list. clicking on Create PDF will automatically
open the PDF Composition menu, surpassing the opening of the design and allowing for quick
PDF creation.

Automate button Clicking on the Automate button will open up the Process Queue Manager. This is a shortcut to
access the PQM. It can also be accessed by going to File > PDF Automate

Template button Clicking on the Template button will open up the Choose Template menu. Templates allow for
easy creation of projects in a few simple steps. Templates are explained in detail on page 237

Show DTD Files check box Selecting ths check box will display all single .dtd forms in the Design Files list.

Design Files List of all available .pfjs/.dtd that are associates with the active Resource Set

Resource Sets List of all resource sets. To edit Resource Set settings, double click on resource set name.
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Design Planes
VisionDP places document objects within three design planes that affect the layering of the objects. Each
plane can be viewed individually or in combination. The order of the planes are as follows from bottom to
top: Background, Static Form, Data Plane.

There is also an optional Secure Plane in which the user can define a secure password that will need to be
provided any time editing to the secure plane is made.

Static Form Plane

All elements that are drawn in VisionDP that do not include a data element are part of the Static Form Plane
by default. Elements in the Static Form Plane will be placed in the form file created upon output.
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Data Plane

Objects that contain, or are produced from, variable data elements will be placed in the Data Plane (except
variable images placed on the Background Plane). This would include text blocks with data, data-driven
images, conditional images or text, variable fields, etc. The Data Plane is the topmost plane, in front of the
Static Form and Background Plane.

Background Plane

The Background Plane can contain a printable image file, or objects that are viewable in the VisionDP
interface but are non-printable. The Background Plane is always below the Static Form and Data Planes.
Objects placed in the Background Plane are locked into the place of import, so they are anchored into place
and cannot be selected when placing or drawing objects in the static or data planes. Background objects can
only be edited or moved in Edit Background mode.

The Background Plane has two main uses:

� Pre-printed stock:

Non-printable background images are useful in emulating pre-printed stock. Drawn objects (lines,
boxes, circles, etc.) can also be placed in the background plane to assist in the design process
(emulating perforated paper, folds, etc.), and will not print.

� Pre-designed pages:

Printable background images are useful in anchoring full page design images that may have data or
static objects drawn on top. Printable backgrounds can be of any supported image format.

� To add static elements to the Background Plane

Select the static element that is to be added to the Background Plane. Right click the mouse and select
Background Plane. The element is now part of the background plane.

Only static form elements can be added to the background plane. Conditional background images can be
created by importing a background image when creating the new form or by importing background images
through the File menu.
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� Working with the Background Plane

Elements in the Background Plane can only be selected for modification (moving, resizing, deleting), if you
select the Background Plane option from the Edit menu. Background elements selected will have a special fly-by
graphic to distinguish them from non-background elements as defined on page 65.

Viewing Document Planes

Each plane can be viewed individually or in combination. To view the various documents, select from the
View menu the Plane Option. The planes currently being viewed will appear with a check mark as shown above.
Select the appropriate plane to either remove or add it to the display.

It is recommended to work with the background plane not activated since it makes it easier to select objects
on the page. To enable/disable the background plane access Background from the Edit menu. If this Edit
Background option has a check mark, then the background plane is activated. When the background plane
is active, it is more difficult to select static form plane elements.
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Secure Plane

VisionDP gives you the option to create a Secure Design Plane within your form that can only be accessed
when an administrator-defined password is provided. All elements created within the other design planes
can be edited while the Secure Plane is selected, but will only be password-protected once they have been
“sent to the Secure Plane”. All elements can be sent to the Secure Plane.

� To Create a Secure Design Plane

1. Access the Form Layout window by either creating a new form or selecting it from the Edit menu.

2. From the Form Setup Tab, enter a password in the Secure Password entry box.

Note: Password can be up to 256 characters.

3. The Verify Password window will appear prompting you to re-enter your desired password.

Click Ok.

� To Change Password of Secure Design Plane

1. Go to the Edit menu, and select Form Layout.

2. From the Form Setup Tab enter in the new desired password.

3. The Verify Password window will appear prompting the user to enter in the old password before a
new password can be defined.

4. Enter the old password and click Ok.

If you cannot remember the original password used, you may send your files to support@lytrod.com and a
Technical Support Representative can recover the original password for you.

� To View elements within the Secure Plane

1. Go to the View menu and select the Plane Option.

2. A drop down list of the planes will appear with check marks next to the planes that are currently
visible.

3. Select Secure Plane from the list to enable the Plane.

4. A prompt will appear requiring the input of the password associated with the secure plane.

� To send selected elements to the Secure Plane

1. Select element you wish to send to Secure Plane.

2. Right click the mouse, and choose the Secure Plane from the Properties menu.
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Chapter 2

Resource Sets

Resource Sets provide an avenue for resource management. The Resource Set contains the locations of
all accessed and created files, all printer font resources, and static mapped image file resources.
Image-to-font conversion and file archiving capabilities are also accessed through the Resource Set

window.

Upon installing VisionDP, the software will generate a Resource Set called “PRO-FORM.” The Resource
Set can be edited and other Resource Sets with custom names can be created.

Multiple Resource Sets can be generated as a means of resource management and output to multiple print
environments. For example, a service bureau or the design department of a large company may want to
keep resources separated based on customer or department. A Resource Set can be defined for each client
containing logos and custom fonts specific to that client's needs, even if all of the forms are eventually
printed on the same printer.

Every new form (page design) generated in VisionDP will be tied to the Resource Set active at the time of
the form’s initial creation, and will be subject to the settings of that Resource Set in future modifications.
When a form is saved, the Resource Set information is stored in the form source file (*.DTD). Therefore,
when the form is opened again, the initial Resource Set will become enabled. The active Resource Set is
displayed in the Ribbon Bar. The last Resource Set that is accessed through the File menu (to create a New
Resource Set) or Edit menu (to change or edit an existing Resource Set) will determine the current Resource
Set assigned to all new forms created.
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Working with Resource Sets

Selecting a Resource Set
The current Resource Set name is displayed in the Ribbon Bar. The Resource Set must be selected before
form design begins and cannot be changed while a form is open. When a form is saved, the Resource Set
information is stored in the form. Therefore, when opening the form in the future, the correct resource set
will be enabled.

� To select a resource set

1. Close all forms.

2. Select Resource Set from the Edit menu.

3. From the Resource Set drop-down menu, select the desired Resource Set. The information in the
window will update to reflect the selection.

� To select a resource set from the Welcome Menu

1. Enable the Welcome menu by going to View > Show Startup Menu

2. Double click on the desired resource set from the list of resource sets at the bottom of the menu.

Creating a Resource Set
Resource sets are meant to be a means to organize the resources used for a particular set of forms/projects.
A new resource set does NOT need to be created for each new form, but you may want to create additional
resource sets when there is a need to separate/organize multiple sets of forms. For example, different
departments within your company should use separate resource sets to keep their forms, fonts, images, and
data separate and organized.

� To create a new resource set

1. Close any open forms.

2. Click the Create Resource Set button from the Standard toolbar.

3. Enter the name of the new Resource Set into the Resource Set field. All existing Resource Sets are listed
in the drop-down so that you can avoid duplicating Resource Set names. You may also choose to use
the name that is generated for you and displayed in the Resource Set field.
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Choose Printer Driver for Font Support (Default Printer Button)
Windows defines PostScript printer fonts by the active PostScript printer driver. The defined Windows
PostScript printer driver is used for the Proof Print function as well as for determining available PostScript
printer fonts.

To ensure that the correct print driver has been selected, it is recommended that users of Windows NT,
2000, XP, Vista and Windows7 go to the Resource Set and select a PostScript printer when updating the
software to a newer release. The printer information will then be stored in the Resource Set and the
available PostScript printer fonts will be gathered.

Installing PostScript Print Driver in Windows

Installing print drivers into the Windows environment is the first step to adding a printer into any software
product. Print drivers can be obtained from disks provided upon purchase of the printer or from printer
manufacturers website.
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Resource Locations
The Resource Set Locations tab retains the path of the directories where VisionDP will create and access its
source files, and output PDF files.

Multiple Resource Sets can be generated as a means of resource management. Individual Resource Sets can
be created to map to specific directory locations for source file input and printer resource output. This
feature is especially useful in Service Bureau environments where resources may need to be managed by
customer account names and not mixed in a general directory.

When editing the default locations to point to a different directory, changing one of the folder locations will
prompt the software to ask you if you would like the rest of the folder locations to be updated to the new
file directory.
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Working with Fonts in the Resource Set

Importing Scalable Fonts

PostScript scalable fonts can be imported into VisionDP. Importing scalable fonts will update VisionDP's
PostScript table, as well as embed the fonts into the PDF. Once the fonts are imported into VisionDP, they
will be displayed with a PS icon in all VisionDP font drop-down menus. Importing scalable fonts is a useful
way to increase the available fonts to your application.

Only the .pfb font should be imported into the resource set.

Before any scalable fonts can be added to the resource set, however, the .pfm must be present in the
Windows Fonts directory. To place a .pfm font in this directory, access the Start menu and select
Control Panel. Open the Fonts folder, go to the File menu and select Install New Font.

� To Import PostScript Scalable
Fonts

1. Select Resource Set from the
Edit menu.

2. Select the Fonts tab from
the Edit Resource Set window.

3. Click Import.

4. The Import Bitmap Font
window will appear. Select
PostScript font (*.fnp, *.pfa,
*.pfb) from the Files of type
drop down.

5. Select a .pfb PostScript Scalable font. Click Open.

6. The Import PostScript Font window will appear. The Internal Name and Style fields will automatically be
populated.

7. Choose the Display Font. This will define how the Font is displayed on-screen.

8. Define the encoding vector to be used for the font. The encoding vector defines the characters that
are available to the font. ISO Latin 1 Encoding and Standard Encoding are available for every font.
Other vectors may be available as well.

9. Click OK.
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Edit the PostScript Table

It is possible to edit VisionDP's PostScript table from within the Fonts tab of the Edit Resource Set menu.

� To edit the postscript table

1. Click the Edit Map Tables button from within the Fonts tab of the Edit Resource Set menu.

2. The Edit Printer Font Mapping Table window will appear.

3. Make necessary font additions or deletions.

4. Click OK.

TrueType Table - TrueType.tbl

VisionDP supports fonts in either TrueType, OpenType or PostScript Type 1 formats. In order to control
how TrueType and OpenType fonts are used in a PDF document, a TrueType table is available for editing
by a user. Maintaining this information can be accomplished from the Edit Resource Set, - Fonts tab, by
clicking on the Edit TrueType Table button. OpenType and TrueType fonts which are not licensed for
inclusion into a document, must be marked without the Embeddable attribute given. Also, these types of
fonts support Code-Pages, a set of predefined character orderings. Any number of Code-Pages may be
designed into these fonts, and the proper one can be chosen by the user in this table.

� To Edit TrueType Table:

1. From the Edit menu, Click on Edit Resource Set.

2. Access the Resource Set Font tab.

3. Click the Edit TrueType Table button.

4. Make the appropriate edits to the Maintain True Table window and click OK to accept changes.
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Font Location

Each Resource Set has an associated default location for fonts. VisionDP uses this location as the output
directory. Any font files created when a form is saved are stored in this location.

� To set font location

1. Close all forms.

2. Select Resource Set from the Edit menu.

3. From the Locations tab, specify a font location in the Font edit box or click to browse in order to locate
the desired location.

Font files are always stored in VisionDP's default font directory, as specified in the Locations tab of the
Edit Resource Set window. Existing fonts can be imported into this directory from anywhere on the system.

Determining PostScript Printer Based Font Selection
Windows defines PostScript printer fonts by the active PostScript print driver. The defined Windows
PostScript print drivers are used for the Proof Print function as well as for determining available PostScript
printer fonts.

Installing Windows Print Drivers

Installing print drivers into the Windows environment is the first step to adding a printer into any software
product. Print drivers can be obtained from disks provided upon purchase of the printer or from the
printer manufacturers website.

� To install windows printer drivers

1. From the Windows Start button, select Settings and then choose Control Panel.

2. Double-click on the printer icon.

3. Double-click on the add printer icon.

4. Follow the Wizard directions to complete the driver installation.
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Determining Printer Fonts in VisionDP

Installing the PostScript print drivers into your Windows environment will enable the specific printer font
information provided by the drivers to be accessible to VisionDP. The PostScript drivers will then need to
be defined within the Resource Set.

� To access the PostScript print driver in VisionDP (enabling PostScript printer based type 1 font
selection)

1. Close all forms.

2. Select Resource Set from the Edit menu.

3. From the General tab of the Edit Resource Set menu, select the Default Printer button.

4. Select the installed PostScript printer from the drop-down menu in the Print Setup window.
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Installing TrueType fonts into Windows

TrueType font files obtained from other sources than the operating system must be installed into the
operating system before it is recognized in the VisionDP software.

� To install TrueType fonts in Windows

1. From the Windows Start button, select Settings and then choose Control Panel.

2. Double-click on the Fonts directory icon.

3. In the File menu select Install New Font.

4. Select the appropriate drive and directory in which the font files are located.

5. Select the font file.

6. Click the OK button to accept.
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Working with Images

Supported Image Formats

VisionDP allows the import of most standard image formats.

Standard Image Formats

(.pcx) Zsoft PC Paintbrush

(.tif) Tagged Image File Format

(.bmp) Windows Bitmap

(.jpg) JPEG File Interchange Format

(.psd) Adobe Photoshop

(.png) Portable Network Graphics

(.tga) TARGA

(.gif) Graphics Interchange Format

(.wmf) Windows Metafile

(.pdf) Portable Document Format

(.eps) Encapsulated Postscript

TIFF, IOCA, FAX compressed or uncompressed using CCITT, with different groups and dimensions
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Adding Images

Once a Resource Set is established, images can be added. Images must be added to the Resource Set for use
within VisionDP. Adding images through this method is a convenient way of adding multiple images to the
resource set in a single pass.

� To add images to the Resource Set

1. Close all forms.

2. Select the Resource Set from the Edit menu.

3. From the Images tab, click the Import button.

4. An open menu will appear allowing file selection. Click on the File of type drop-down menu to choose
the file type.

5. Select image to be imported and click Open. Multiple images may be selected by holding down the
<SHIFT> or <CTRL> keys.

6. The Image List will now reflect the imported image(s).
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Importing Images

Importing of images is the method of choice while a form is active in VisionDP. It is convenient while
designing a form and coming across an image that requires importing. An imported image will be added to
the Resource Set automatically. The imported image will also be placed onto the current form and displayed
in the Image List drop-down on the toolbar.

� To import images while a form is active

1. Click on the Import Image button from the Drawing toolbar, or go to the File menu and choose Import and
then Image…

2. An open menu will appear allowing file selection. Click on the Files of type drop-down menu to set file
type.

3. Select the file to be imported and then click the Open button.

4. Click on the location in the form where the image should be placed.

Image Location

Each Resource Set has an associated default location for images. This is where VisionDP will automatically
look for images.
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� To set the image location

1. Close all forms.

2. Select Resource Set from the Edit menu.

3. From the Locations tab, specify an image location in the Images edit box or click to browse in order to
locate the desired location.

While new image files are always stored in the default directory, existing images can be imported from
anywhere. The location of the original image is displayed in the Images tab of the Resource Set menu. If an
image file is no longer found in this location when a form is opened, the Missing Resources menu will
appear. The image can then be imported from its new location.

Removing Images

Images can be removed from a resource set if necessary. Removing images from a resource set simply
removes the reference to that image in the Resource Set. It does not delete the actual image file.

1. Close all forms.

2. Select Resource Set from the Edit menu.

3. From the Images tab, select image(s) to be removed.

4. Click the Remove button.
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Working with Data Files
The types of data that can be imported are database (delimited), line data (print ready ASCII files) and
XML. In the Resource Set you can define the default data directory.

Supported Data Formats

Delimited Data typically generated from a database where each line represents a record and field information for each
record is delimited with a common character, such as a comma. If the delimiter is used within a data field,
then single or double quotes must surround the data field to act as a text qualifier. The first record must
define the field names delimited. Non-printable characters are restricted from existing in field names.

Line data Line data is data that is a flat ASCII file in a “print ready” format. This type of data is typically generated
from a mainframe computer for printing on line printers. The record is now defined as the data relating to
one source. For example, a phone bill. Each record may contain several pages of data which varies based on
the customer call usage. It now is critical to define the record break as well as the maximum number of lines
that can be printed on each page.

XML Data XML is a grammatical system for constructing custom mark-up languages, where the data is organized into a
tree structure. VisionDP will treat XML data fields in the same manner as delimited data fields. After the
data file is imported, all of the data fields will be listed in the data drop-down menu.

Line Data Record Breaks

Fixed length Fixed length records have the same number of lines in each record.

PCC PCC (print carriage control) is examined in the first byte of each line. ASCII PCC bytes are supported.

ASCII Character A single character can be defined as the record break. For example a Form Feed.

Text String In records that have varying length, a common text string can break the record before or including the line
which contains the text.
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Archive Resources
VisionDP can archive all the files contained in a
resource-sets entirety into a single file for easy
backup/archiving purposes. Any resource set that is
archived can also be un-archived with the simple click
of a button.

There are two types of archives that can be done; one
that will archive ALL files contained within the resource
folders, or a archive that will only contain the resources
that are currently being utilized by the forms.

� To archive resources

1. With no forms open, select Edit > Resource Set. The
Edit Resource Set menu will appear.

2. Access the Archive tab of the Edit Resource Set menu.

3. Select the resource set that you want to archive
from the Resource Set drop-down menu.

4. By default, the archived resources will be placed in C:\Program Files\VisionDP\ARCHIVE.

Click the browse (...) button to designate a different location for the archive to be stored.

5. A default file name will be entered into the Archive File Name field. To change the default name to a
custom name, delete the default name and enter the desired name into the field.

6. Create a password if desired. The password will be required whenever the archive is opened.

7. To include ALL files that are contained within each individual resource folder, enable or disable the
check boxes for the Forms, Fonts, Images, Data and Output folders. By default, the Keep directory structure
check box will be enabled.
To include only the resources that are being utilized by the forms within the resource set, check the
box that says Archive resources based on form references. This will disable the Forms, Fonts, Images, Data and
Output folders because the archiving process will by default look for only the resources being used in
all the folders.

8. Click the Archive button to archive the resources.

To un-archive resources, specify the information in the same manner as described above, and click the
Unarchive button.
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Change the Resource Set used by a Form
Once a form has been created, the resource set that is associated with it can be changed. The new resource
set that the form will be exported to must be created first.

� To change resource sets

1. Go to the File menu of an open form and select Export.

2. Select either Form… or Job…

3. Click the Options button.

4. Select the new resource set with which the form will be associated.

5. Make sure to change the location of where the form will be exported to (the new resource set's Form
folder).

6. Select OK within the Export Form Options window.

7. Click Save within the Export Form window.

View Form Resources
When designing print applications, it may be necessary to identify resources associated with the job. This
tool will list all fonts, logos, images and data that are used within the current form.

� To View Form Resources

1. Select Form Resources from the View menu of an Open form.

2. The View Resources menu will appear
listing fonts, logos and images used
in the current form.

3. To print the View Resources menu,
click Print. To close the menu, click
Close.
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Chapter 3

Opening, Creating and Saving Forms

There are three different files types that VisionDP supports on input. Supported file formats are:
Single Form (.DTD), Project File (.PFJ), and Command Sets (.COS). A project, also known as Job, is
a collection of one or more forms, along with specifications of how they interact. A Command Set

refers to a job, and also provides PDF creation information.

A form file (.dtd) will contain the design for a single page. Duplex applications will need separate .dtd's
created for both the front and back sides. Projects (grouping multiple forms together) are discussed further
in Chapter 8.

Opening Forms
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� To open a form from the Welcome Menu

1. Select the desired Resource Set from the bottom list on the Welcome Menu, this will display the
Project files (.pfj's) associated with the selected resource set.

To display single page .dtd files, click on the Show DTD files check box.

2. Double-click the form, or select it and click Open.

� To open a form from the File Menu

1. Click Open Form from the Standard toolbar or select Open from the File menu.

2. Browse for the form that you wish to open.

3. Double-click the form, or select it and click Open.

To open a recently used document, click the appropriate file name from the history list at the bottom of the
File drop-down menu.

� To show/hide recent file list

1. Select Preferences from the Edit menu.

2. From the System Preference tab, use arrow keys in the Recent File List field to specify number of recently
used files (if any) to be displayed in the File menu.

� To open a backup file

1. Locate Backup File, stored in VisionDP's Forms folder. (will have a .BAK extension)

2. Rename the file to have the .DTD form extension.

3. Click Open Form from the Standard toolbar or select Open from the File menu.

4. In the Look in box, click the drive or folder location that contains the form.

5. In the folder list, browse to the folder containing the form to be opened.

6. Double-click the form you want to open.

The backup file will have the same name as the form with a .BAK extension. It will also be located in the
same folder as the form.
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Multiple Document Interface
VisionDP uses a Multiple Document Interface (MDI). This allows multiple forms to be active/open within
VisionDP at the same time.

� To switch between forms

1. Select the Window menu.

2. Select the desired form (.dtd) from the list at the bottom of the Window menu.

3. If multiple forms are already open, the user can minimize and maximize forms to switch between
them.

Missing Resources
Upon opening forms in VisionDP, a check will be made to verify that all of the resources (forms, fonts,
images, and data) are found within the resource folders that are defined within the current Resource-Set. A
menu will appear allowing users to correct any missing resource issues. If for some reason a resource is
removed or changed within one of these folders, it may cause the Missing Resources Menu to appear.

� Missing resources can be handled in one of five ways:

1. Locate the resource file and import it into the Resource Set.

2. Select a resource to substitute for the missing resource permanently.

3. Modify the current form to use a new resource.

4. Make a temporary substitution in order to simply view the form.

5. Images/Data can be removed from the form to allow the form to be displayed.

In most cases it is best to import the resource that is missing. Any resource that is substituted will probably
not be identical to the original. Therefore, some redesigning of the form may be required, resizing or
repositioning text blocks, re-wrapping text, etc.

If the original resource is no longer available, a permanent substitution may be made. This is done by
importing a similar resource or by choosing a font from the Substitute font list. The Substitute font list
contains all of the fonts in the current Resource Set along with the list of available TrueType and Postscript
fonts. A permanent substitution affects all forms that may contain the missing resource. Once the
substitution is made any readjustments needed to account for the substitution can be made to the form.

There is also the option to modify only the current form. This is done by choosing a substitute resource
and disabling the Permanent check box. The resource reference in the current form will be permanently
changed to reflect the substitution, but this in no way affects other forms opened in the future. This
method also allows a temporary substitution to be made for the purpose of viewing a form, because the
form is not actually modified until it is saved. This means, however, that no changes can be made to the
form unless the substitution is to be permanent.
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� To import a missing resource

1. Select the font, image or data name to be assigned.

2. Click browse button (...) adjacent to the Import file field.

3. A Select File window will appear.

4. In the Look in box, click the drive or folder location that contains the resource.

5. In the folder list, double click folders until you open the folder containing the missing resource.

6. Double click the resource you want to import, or highlight it and click Open.
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� To substitute missing resources

1. Select the font or image name to be substituted.

2. Select a substitute resource from Substitute drop-down menu.

3. When a scalable font is selected, an Assign Font window will appear.

4. Select Font, Style, Point Size and Orientation from corresponding list boxes in the Assign Font window.

Temporary font substitution will only affect the form being opened.

� To make a permanent resource substitution

1. Check the Permanent check box to indicate permanent substitution.

2. Select font/image name to be used as the substitution.

3. Select a substitute resource from the Substitute drop-down menu.

4. When a scalable font is selected, an Assign Font window will appear.

5. Select Font, Style, Point Size and Orientation from corresponding list boxes in the Assign Font window.

Permanent font substitution will make a reference of the substitution for all forms which reference the
missing resource.
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Creating New Forms
When creating a new form, the user will be prompted to setup the form in the Form Layout window. The form
setup information defines the basis of the form layout. Initial setup is accomplished in the Form Layout
window by defining many form basics such as name, measurement, sizes and orientation.

� To create a new form

1. Click New Form on the Standard toolbar, or select New from the File menu, or click on the New Form button
within the Welcome Menu.

2. The Form Layout menu will appear, prompting form setup.

Form creation using the Template Manager is discussed in Chapter 8.

Form Layout
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Form Name
The Form Name defines the name of the .dtd file that will be produced.

� To specify a form name

1. Open the Form Setup tab from the Form Layout properties window.

2. Indicate the Form Name in the edit box provided.

Form Title
Form title provides the ability to provide comment information regarding the form. It can be used to
indicate form title, clarify form usage, track revisions, etc.

� To specify a form title

1. Open the Form Setup tab from the Form Layout properties window.

2. Indicate a Title in the edit box provided.

Secure Password
Defines the global password for the secure plane. Once defined, one or more elements on the page can be
switched to the secure plane.
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Paper Size
This selection defines the size of the physical paper. VisionDP supports various predefined paper sizes, as
well as custom paper sizes by defining the Width and Height in the appropriate fields.

Supported Default Paper Sizes:

8.5 x 11" (letter) 14 x 17" 14.33 x 26.0"
8.65 x 11.67" 17 x 17" A3 (297 mm x 420 mm)
8.5 x 13.7 12 x 18" A4 (210mm x 297mm)
8.5 x 14" (legal) 12.6 x 19.2" B4 (257mm x 364mm)
11 x 17" 14.33 x 20.5" B5 (182mm x 257mm)

14.33 x 22.5" SRA3 (320mm x 450mm)
26 x 26" SRA4 (225mm x 320mm)

� To specify paper size

1. Open the Paper Size tab from the Form Layout window.

2. Select paper size from the Paper Size drop-down list.

� To specify default paper size

1. Select Preferences from the Edit menu.

2. Select the paper size from the Paper Size drop-down list.

48 Opening, Creating and Saving Forms



Form Orientation
Form orientation determines which way the page faces. Form orientation is either portrait (shortest edge of
the page at the top), or landscape (longest edge of the page on top), or inverse of portrait or landscape.

� To specify form orientation

1. Open the Paper Size tab from the Form Layout properties window.

2. Select orientation.

� To specify default form orientation

1. Select Preferences from the Edit menu.

2. Select orientation.

View Design in Different Orientation

Form/Pages need to be created using the orientation in which they will be printed. This may, however, be a
different orientation than how the design is laid out. For example, if a multi-up postcard has a portrait
design, but will be printed landscape, the form orientation will initially need to be defined as landscape. To
alleviate the hassle of having to design the document on its side, the page can be viewed in 90 degree
increments.

� To Rotate Page View

1. With your design open (.dtd/.pfj)
select View > Rotate Design, and then
select the appropriate degree of
rotation.
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Grid Settings
The grid is a user-defined measurement in
the X and Y direction as well as an origin
from which all measurements are distanced.
This is convenient when designing a form
around variable data. A grid can be defined
that matches the spacing of the variable data
font to be used with the form. Multiple grids
can be defined in a single form.

Predefined grid formats (FMT1 - FMT13
and FMT1A-FMT9A) are available for use
within VisionDP. In addition to these
formats, users can create custom grids to be
used with the current form or add a custom
grid format to the current Resource Set for
future use.

The origin value is the point from which all placements are measured. Changing the origin will cause form
elements to be moved in relation to the new origin. This is a convenient way to assure alignment with
variable data.

If the A4 paper size is selected in Paper Size tab of the Form Layout menu, the FMT1A-11A grid settings will
automatically appear in the Pre-defined drop-down menu.

� To add a custom grid format:

1. Select Edit and click on Form Layout to access the Form Layout window.

2. Click on the Grid Settings tab.

3. Specify Grid settings (width/height and origin) in the Grid Size/Form Origin section.

4. Click the Save button. The new custom Grid Format will be added to the Custom list and is
automatically named. A user-defined name can also be defined before saving to make it easier to
remember the grid settings in the future.

� To select a grid format

1. Open the Grid Settings tab from the Form Layout properties window.

2. Specify Grid Size Width and Height values along with Form Origin

<OR> Select a Pre-defined Grid Format

<OR> Select Custom Grid Format
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3. Click Update in the Define Grid List.

� To specify form origin

1. Open the Grid Settings tab from the Form Layout properties window.

2. Specify origin in the Left (X coordinate) and Top (Y coordinate) fields.

Current unit of measure is shown in the Unit drop-down menu. Units of measure available are inches,
centimeters and dots.

� To display grid

1. Click the Show Grid button on the View toolbar.

<OR>

1. Select Options from the View menu.

2. Select Grid from the Options menu.

Grid Exchange
Use the Grid Exchange to change the grid
used by the form if you do not want to affect
the positioning of objects on the form. This
may be handy if the form was not originally
designed using a grid. This is a convenient
option if the size of the variable data font
used with the form has changed.

� To exchange the form grid

1. Select Grid Exchange from the Tools menu.

2. Select the grid you wish to change from
the Defined Grid List.

3. To change the Grid Size and Form Origin, select a Predefined grid format, or select a Custom Grid Format.

4. Click the OK button to perform the grid exchange and close the window.
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Multiple Grids
Multiple grids are handy if large sections of a form will be drawn around variable data using different fonts.
When designing a form using more than one grid, it is best to place all objects associated with the current
grid before switching to the next grid.

� To define multiple grids

1. Select Form Layout from the Edit menu.

2. Specify Grid Size Width and Height values along with Form Origin

� <OR> Select a Pre-defined Grid Format

� <OR> Select Custom Grid Format

3. Click the Add button in the Defined Grid List to add a grid format to the list.

4. Click the Delete button in the Defined Grid List to remove a grid format.

� To use multiple grids

1. Add the desired grids to the Defined Grids List in the Grid Settings tab of the Form Layout window.

2. Choose the desired grid from the Defined Grids drop-down menu from the View toolbar.

3. Draw form objects that are based on the selected grid.

4. Select another grid from the Defined Grids drop-down menu in the View toolbar.

5. Draw form objects that are based on the selected grid.

OMR elements are drawn based on predefined OMR grids. These grids are displayed in the Defined Grids
drop-down so that they are available when adding other elements to an OMR form.
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Margins
Page Margins can assist when designing for applications that allow for bleed when printing. These margins
will be used as guides for containing design within the specified printable page. Once a margin has been
defined, a non-printable pink border will be displayed on your design screen.

� To specify page margins

1. Select Edit and click on Form Layout to access the Form Layout window.

2. Open the Margins tab from the Form Layout window.

3. Use arrow keys to specify margins in Left, Right, Top and Bottom fields.

� To view page margins

1. To display Page Margins, click Margins on the View toolbar.

<OR>

1. Select Options from the View menu.

2. Select Margins from the Options menu.

OMR Form Layout
Please refer to Chapter 9 - OMR Form Creation for detailed information regarding OMR form creation.
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Import a Background or Document Style
When creating a new form, the layout of the form can be borrowed or created from existing forms or
documents. By importing a background or style, the creation of forms with similar size/layout settings is
much easier than starting from scratch each time.

Importing Background

The Import Background option allows you to choose an image that the newly created form will be based
upon. The selected image will define the page size and orientation. The image will be placed in the
background plane, and will be assumed to be a printable background. To change this assumption, enable
Background mode in the Edit menu drop-down, select the image and from the properties menu, remove
the Print Image name.

Importing Document Style

Any existing form can be chosen to borrow it’s “Document Style”, including form name, title, page size,
orientation, grids, margins and data settings. A substantial time savings can be achieved when developing
multiple pages for the same application.

54 Opening, Creating and Saving Forms



� To import a Background Image

1. From the file menu, select New Design... or select the New Form button.

2. The Form Layout menu will appear. Name your new form.

3. At the bottom of the menu, select the Import Background button.

4. Browse and select the desired imaged to be used as the background for your form. The new form will
automatically be sized to fit the dimensions of the selected image.

5. Click OK to create the new form with background image.

� To import a Document Style

1. From the file menu, select New Design... or select the New Form button.

2. The Form Layout menu will appear. Name your new form.

3. At the bottom of the menu, select the Import Style button.

4. Browse for the desired form that would like to copy the "document style" from. This will create a
new form with the same dimensions and data file used from the form you selected. Any images, text,
and drawn form items will not be copied onto this new form.

5. Click OK to create a form with a borrowed Document Style.

The Background/Document Style import buttons will only appear when creating a new form.
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Saving Forms
You can save the active form you are working on, whether it is a new or a previously existing form. Active
forms can be saved with a different name or in a different location than they were previously saved.

Supported Form Formats:

(.DTD) VisionDP, Proform Designer, DeskTopDesigner

� To save new form

1. Click Save on the Standard toolbar or select Save As from the File menu.

2. To save the document in a different folder other than the default, click a different drive in the Save in
box, or double-click a different folder in the folder list.

3. To save the document in a new folder, click Create New Folder.

4. In the File name box, type a name for the form. The internal name of the form will by default appear
in the File name box.

5. Click the Save button.

� To save an existing form

1. Click the Save button on the Standard toolbar or select Save from the File menu.

2. The form will be saved in the same folder by the same name.

Auto-Save
You can protect your work by using the Auto-Save feature. Auto-Save will save your form as a VisionDP
form periodically as you work. The Auto-Save will save at user-defined intervals. A form file must be named
before Auto-Save will be activated.

� To activate auto-save

1. Select Preferences from the Edit menu.

2. From the System tab, check Auto-Save.

3. Use arrow keys to indicate interval time in minutes.

Take caution when setting the Auto-Save interval. Setting the interval too short can cause unwanted
over-saving of files.
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Create Backup Files
You can protect your work by using the Backup File feature. By activating this feature, the previous copy of
the form will be renamed to form.BAK every time you save a form. It will also be located in the same
folder as the form.

� To create backup files

1. Select Preferences from the Edit menu.

2. From the System tab, check Create Backup File.

Embed Resources in .DTD File
Resources (data, fonts, and images) can be embedded in the .dtd form file in order to contain all resources
into a single file for transfer.

� To embed resources in .dtd file

1. Open the form that will be saved as a .dtd file.

2. Go to the File menu and select Save As.

3. Go to the Save as type drop-down menu and select VisionDP Form (*.dtd).

4. Enable the Embed Resources check box.
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� To open a .dtd file with embedded resources

1. Go to the File menu and select Open. Highlight the .dtd form that you want to open, and click Open.

2. The embedded resources are automatically placed in the appropriate Font, Image, and Data folders.

3. The form will be displayed using the embedded resources.

This option should only be used when archiving the form or transferring the form to another system.

Close a Form

� To close a form

1. Select Close from the File menu.

� If the file has not been saved, you will be prompted to do so.

� If the file has been saved, the form will be closed.

VisionDP has a Multiple Document Interface. Therefore, multiple forms can be open at one time,
eliminating the need to close a form in order to open or start a second.
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File Transfer
Once a form has been completed, it can be transferred to another PC. VisionDP provides the ability to
gather all resources associated with the form and place into a folder or zip file to ease the transfer process.

Send Form to Folder
VisionDP can send a form and all its resources to a specified folder.

� Send Form to folder

1. Open the form that you want to send to the folder.

2. Select Send Form To from the File menu and choose Folder.

3. The Browse for Folder menu will appear.

4. Select the folder to which you will send the form and all its resources.

5. Click OK.
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Send Files To Archive
When needing to gather ALL resources associated with a form/job, VisionDP has the option to Archive all
necessary files. VisionDP will determine all resources of a form or application (.pfj), zip all of these files
together and save a zip file in the Archive folder. This is a useful function when wanting to transfer all the
files and resources needed for an entire job.

� To send files to archive

1. Open the form (.dtd) or job (.pfj) that you want to send to archive along with all its resources.

2. Select Send Form To from the File menu and choose Archive.

Export Form
The Export Form function allows you to export the desired form to a different location. The Export Form
function will only export the form., not the accompanying resources used in the form (Data, Fonts,
Images).

� To Export a Form to a different location

1. Open the form (.dtd) that you want to send to export.

2. Select Export from the File menu and choose Form…

Export Job
The Export Job function can be used to change the defined Resource Set for a Job. The Export Job
function allows you to choose a different resource set than what is currently being used by the project file
and the accompanying forms.

For example, you would use this feature if you accidentally created a PFJ under the wrong Resource Set, or
if you later decide that you'd like a .pfj to be referenced by a different resource set than the one that it was
originally created with. Remember that Resource-Sets define the folder locations where all the project's
resources are located.

� To Export a job to a different Resource Set

1. Open the desired .pfj

2. Go to File > Export > Job The Export Job menu will appear.

3. In the bottom right hand corner of the menu, use the drop-down menu to select the desired Resource
Set. If the newly chosen resource set points to a different directory of folders than the .pfj's current
resource set, all forms, fonts, images, and data will be exported to the new resource set folders.

4. Click OK to save the changes.
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Chapter 4

Basic Form Drawing

All form elements can be drawn using the mouse. To draw an element, select the appropriate draw
mode and place the mouse where you want to start the element. To create an element, you must drag
the mouse and release to end. Paths require that you drag and click at each point location.

Drawing Form Elements

Drawing Lines, Boxes, Circles, OMR Responses, and Paths

Icon Draw Mode

Line Draw

Box Draw

Circle Draw

OMR Response Draw

Path Draw

� To draw lines, boxes, circles and OMR responses

1. From the Drawing toolbar, click the appropriate draw tool.

2. Position mouse where the element should begin, press and hold the left mouse key to begin drawing.

3. Drag to draw the element and release the mouse key to end.
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MicroData Line
The MicroData line feature transforms drawn lines into undersized text that can only be read clearly
under magnification. No extra fonts are needed to use this feature.

MicroData is created by using the line draw tool and defining the static and/or variable text that will
appear in place of the line.

� To create MicroData

1. Create or open a variable document you
wish to add MicroData to.

2. Select the Line Draw button from the Drawing
toolbar.

3. Draw a Line on the form where you would
like the MicroData to be placed.

4. Select the Select Arrow from the Drawing toolbar, right-click on the selected line object, and choose
Format Line from the context menu. The Line Properties window should appear.

5. Go to the bottom of the General tab to the MicroData section and select the desired text size from
the left-most drop-down menu (choose from Small, Medium, or Large). Once this is selected, the
Bold, Text and Repeat (repetition) options will become enabled.

6. Go to the Text drop-down menu and select a data field, or type in multiple data fields and/or a
combination of data fields and static text.

7. Go to the Repeat drop-down menu and select the number of times to repeat the content or select
Fit to Length.

8. Click OK to accept all changes to the Line Properties window.
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Conditional MicroData

� To define conditional MicroData

1. Create or open a variable form document you wish to add MicroData to.

2. Select the Line Draw button from the Drawing toolbar.

3. Draw a Line on the form where you would like the MicroData to be placed.

4. Select the Select Arrow from the Drawing toolbar, right-click on the selected line object, and choose
Format Line from the context menu. The Line Properties window will appear.

5. Go to the bottom of the General tab to the MicroData section and select the desired text size from the
left-most drop-down menu (choose from Small, Medium, or Large). This step will eventually enable
MicroData formatting for conditional logic.

6. Go to the Conditions tab and click the Add button to start the creation of a conditional statement.

7. Once the conditional statement is complete, click the Format button. The Conditional MicroData
Format menu will appear.

8. Check Show Object.

9. To enable MicroData, select
the desired text size from the
left-most drop-down menu.
You will then be allowed to
select Size, Text, Repeat
(repetition, and color).

10. Go to the Text drop-down
menu and select a data field, or
key in multiple data fields
and/or a combination of data
fields and static text.

11. Go to the Repeat drop-down
menu and select the number
of times to repeat the content
or select Fit to Length.

12. Click OK to accept all changes
in the Line Properties window once all conditional formatting is complete.
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Drawing Paths

� To draw paths

1. From the Drawing toolbar, click the Path Draw button to enable path draw mode.

2. Position mouse where the path should begin and press and hold the left mouse key to begin drawing.

3. Click the left mouse button to indicate each point of the path and continue drawing.

4. Double click the left mouse button to end drawing or single click the right mouse button.

� To close a path

1. Select path(s) to close.

2. Click Close/Open Path on the Format toolbar to toggle between closed and opened path.

� To continue a path from the ending point

1. Select path(s) to continue.

2. Click Continue Path from End on the Format toolbar.

� To add a point to a path

1. Select path.

2. Select point to the right of the location of the new point to be added. To select a point, click the left
mouse button on the point handle while holding the <SHIFT> key.

3. Click Add New Point on the Format toolbar to add a new point to the left of the point selected.

Grid Snap
Grid Snap is an important design feature when
drawing, resizing and moving form elements. The
grid snap option ensures the user that all form
elements will fall on ¼ grid, ½ grid or full grid unit
and not on any other fractional values thereof. This
guarantees creation of lines that intersect and eases
alignment.

� To define grid snap interval

1. Select Preferences from the Edit menu.

2. From the Design tab, specify Mouse Snap increment.
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Selecting Form Elements
In order to manipulate a drawing element, it must first be selected.

It is often difficult to tell if you are positioned properly over a particular form element. VisionDP’s cursor
will change to indicate proper positioning. The various cursor shapes indicate the type of element over
which the cursor is positioned. The mouse must be positioned over the border of an element in order to
select it except in the case of shaded or filled boxes, circles and path. In these cases, any position over the
element will be sufficient for selection.

Cursor Background Object Cursor Selected Object

Horizontal Line

Vertical Line

Diagonal Line

Box

Circle

Path

Text

� To select a form element

1. From the Drawing toolbar, click Select Mode.

2. Position the mouse over the element to be selected and click the left mouse key.

Selected items will be displayed with selection handles. To select overlapping objects, it may be necessary to de-select all objects
prior to making selection.
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� To select multiple elements

1. From the Drawing toolbar, click Select Mode.

2. Position your mouse over the element and hold the
<SHIFT> key while clicking the left mouse key over the
desired elements.

<OR>

3. Click Group Mode from the Drawing toolbar, and draw a box
around the elements to be selected. The <SHIFT> key
in combination with the left mouse key can be used to
add or remove individual elements from the group.

� To select all elements

1. Choose Select All from the Edit menu.

2. All elements on the form will be selected. The <SHIFT> key in combination with the left mouse key
can be used to remove individual elements from the selection.

When multiple items are selected, a group is automatically created. Elements will be shown in blue with one
round selection marker per element. A group box will surround the elements.

Moving and Copying Form Elements

� To move using the mouse

1. Select the element(s) to be moved.

2. Position the mouse over the element(s) and drag element(s) to a new location.

� To copy using the mouse

1. Select the element(s) to be copied.

2. Position the mouse over the element(s)and drag element(s) to a new location while holding down the
<CTRL> key.

When moving and copying elements using the mouse, grid snap will affect the interval in which an element
is moved or copied. Grid Snapping is described in detail on page 64.
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� To position an element through the Properties window

1. Select the element.

2. Select Object from the Format menu or click the right mouse button and select Format from the context
menu.

3. From the Size and Position tab of the Properties window, use the arrow keys to specify position (X and Y
coordinates).

� The X/Y coordinates for lines represent the starting point and ending point. Both values need to
be changed to re-position a line rather than resize a line.

� The X/Y coordinate for boxes represent the origin or top left corner.

� The X/Y coordinate for circles represent the center point.

� The X/Y coordinates for paths represent the individual points in the path. All point coordinates
would need to be modified by the same amount to affect overall Path position.

� To position a group of elements

1. Group form elements to be formatted.

2. Select Group from the Format menu or click the right mouse button and select Format from the
context menu.

3. From the Size and Position tab of the Group Properties window use the arrow keys to specify X/Y values
for the group origin (top left corner).

Current unit of measure is shown in the Unit drop-down. Units of measure available are grids, inches,
centimeters and dots.

Keyboard Snap for repositioning

Keyboard Snap is an important design feature when moving form elements using the keyboard (grid
stepping). The keyboard snap option ensures the user that all form elements will fall on a pixel, ¼ grid, ½
grid or full grid unit and not on any other fractional values thereof. This guarantees creation of lines that
intersect and eases alignment.
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� To set keyboard snap

1. Select Edit, and then choose Preferences.

2. From the Design tab, specify Keyboard Snap increment.

� To move using the keyboard (grid stepping)

1. Select the element(s) to be moved.

2. Hold the <SHIFT> key in combination with the arrow key representing the direction in which to
move.

Horizontal/Vertical Hold

When drawing, moving or copying form elements, either the horizontal or vertical placements can be held.
Once the position of an element is correctly placed in one direction, the position in the opposite direction
can be changed without altering the held placement.

� To hold vertical position (move horizontally)

1. Select form element(s) in which the vertical position is to be held.

2. Hold the left or right arrow keys while performing draw, move or copy operation.

� To hold horizontal position (move vertically)

1. Select form element(s) in which the horizontal position is to be held.

2. Hold the up or down arrow keys while performing draw, move or copy operation.

Resizing Form Elements

� To resize using the mouse

1. Select the element(s) to be resized.

2. Position mouse over appropriate handle and drag to new size.

When resizing boxes, corner handles resize both width and height proportionally. Center handles resize
width or height respectively. When resizing circles, the center point will remain constant as the radius is
increased or decreased.

When resizing elements using the mouse, grid snap will affect interval in which element is resized. Grid
Snapping is described in detail on page 64.
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� To resize through the Properties window

1. Select element(s).

2. Select Object from the Format menu or click the right mouse button and select Format from the context
menu.

3. From the Size and Position tab of the Properties window use the arrow keys to specify size.

Paths are not resized through the Properties window in the same fashion as other elements. The X/Y
coordinates in the Size and Position tab of the Path Properties window represent the individual point locations.

Group Scaling

� To scale a group of elements

1. Group form elements.

2. Select Group from the Format menu or click the right mouse button and select Format from the context
menu.

3. From the Size and Position tab of the Group Properties window use the arrow keys to specify width/height
values for the group or percentage to scale.
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Grid Settings

Changing the grid for a form element or a group of form elements can be
done. By doing so, the element or group of elements will realign with the
new grid. Therefore, the element(s) will be resized accordingly and the
position may be affected based on a new grid origin.

� To change the grid of a form element or group of elements

1. Select an element or a group of form elements.

2. Choose the new grid from the Defined Grids drop-down menu in the Drawing toolbar.

In the previous example: The grid setting for the box has been changed. The width and height of the box
remain the same (20 grids by 10 grids). However, because the grid size is different, the width and height
values are now based on the new grid size causing the box to be resized accordingly.

OMR objects are drawn based on predefined OMR grids. All grids used on the form are displayed in the
Defined Grids drop-down. The grid for the entire form can be set to the OMR grid if the OMR element is
drawn before any other element is placed on the form.

Current unit of measure is shown in the Unit drop-down. Units of measure available are grids, inches,
centimeters and dots.
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Keyboard Snap for resizing

� To resize using the keyboard (grid stepping)

1. Select the element to be resized.

2. Hold the <CTRL> key in combination with the arrow key representing the direction in which to
resize.

Stepping can be used when fine movement or resizing is difficult to achieve through mouse movements.
Detailed information on setting keyboard snap interval is described on page 67.

Moving, Copying and Resizing Summary

Cursor Shape Operation

Move

Move holding vertical position

Move holding horizontal position

Copy

Copy holding vertical position

Copy holding horizontal position

Resize width

Resize height

Resize width and height respectively

Deleting Form Elements

� To delete a Form Element

1. Select the element(s) to be deleted.

2. Click the <DELETE> key on the keyboard.
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Form Element Repetitions
Repetitions are useful when there are multiple elements to be drawn that are the same size and share the
same attributes. There are two different types of repetitions available: even and exact. Even Repetitions
allow users to create a group of items evenly spaced at a user-defined interval, and can be vertical,
horizontal, or staggered. Exact Repetitions allow users to create a group of items in which each item is
placed at varying user-defined intervals, and can be vertical, horizontal, or random. Repetitions not only
save time when initially designing forms, but also when making modifications later. Line, box, circle and
path repetitions can be created.

Icon Repetition Mode

Even Repetitions

Exact Repetitions

Staggered Repetitions

Random Repetitions

Creating Even Repetitions

� To create even repetitions using the mouse

1. Select element to be repeated.

2. Click the appropriate repetition button from the Repetition toolbar.

� Click Even Repetition to create evenly spaced horizontal/vertical repetitions

� Click Staggered Repetition to create evenly spaced staggered repetitions.

3. Click left mouse button at the appropriate distance and direction (on the first repetition) from
original item to set interval.

4. Continue to click left mouse button to add additional repetitions.
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� To create even repetition through the repetition window

1. Select the element to be repeated.

2. Select Object from the Format menu.

3. Open the Repetition tab from the Properties window.

4. Choose the appropriate radio button indicating repetition direction (horizontal, vertical or random).

5. Specify the number of repetitions in the Number of Repetitions edit box or by using the spin arrows.

6. Check the Evenly Spaced checkbox.

7. Specify the interval in the appropriate X/Y edit box. Specify X value if creating horizontal
repetitions and a Y value if creating vertical repetitions. Specify both if creating staggered repetitions.

� To change interval through mouse

1. Select the repetition group to modify.

2. Click the Even Repetition or Staggered Repetition tool as appropriate on the Repetition toolbar.

3. Position the mouse over an individual element in the group.

4. Drag element to new location to change interval.
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� To change interval through repetition window

1. Select the repetition group to modify.

2. Select Object from the Format menu.

3. Open the Repetition tab of the Properties window.

4. Modify appropriate X/Y value(s).

Creating Exact Repetitions

� To create exact repetitions using the mouse

1. Select the element to be repeated.

2. Click the appropriate repetition button from the Repetition toolbar

� Click Exact Repetition to create horizontal/vertical repetitions.

� Click Random Repetition to create random repetitions.

3. Click the mouse pointer at the location of each desired repetition.
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� To create exact repetitions through the Repetitions window

1. Select an element to be repeated.

2. Select Object from the Format menu.

3. Open the Repetition tab from the Properties window.

4. Choose appropriate radio button indicating repetition direction (horizontal, vertical or random).

5. Specify number of repetitions in the Number of Repetitions edit box or by using the spin arrows.

6. Specify repetition locations in X/Y edit boxes.

� To reposition individual elements using the mouse

1. Select a repetition group to modify.

2. Click Exact Repetition or Random Repetition as appropriate on the Repetition toolbar.

3. Position the mouse pointer over an individual element in the group.

4. Drag the element to a new location.

� To reposition individual elements through the repetition window

1. Select a repetition group to modify.

2. Select Object from the Format menu.

3. Open the Repetition tab of the Properties window.

4. Modify X/Y location of the individual repetition to re-position by clicking on a value in the list and
then editing the value in the corresponding edit boxes.
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Adding Elements to Repetitions

� To add an element to a repetition using the mouse

1. Select a repetition group to modify.

2. Click the appropriate Repetition Mode button on the Repetition toolbar.

3. Click the left mouse button to add items to the group.

� For Even and Staggered repetitions, added elements will be placed at the end of the group.

� For Exact and Random repetitions, added elements will be placed at the location where the mouse
is positioned.

� To add an element to a repetition through the Properties window

1. Select a repetition group to modify

2. Select Object from the Format menu.

3. Open the Repetition tab of the Properties window.

4. Increase the number in the Number of Repetitions edit box.

5. Specify the location of the added repetition in corresponding X/Y edit boxes.

Deleting Elements from Repetitions

� To delete an element from a repetition

1. Select repetition group to modify.

2. Click on appropriate Repetition Mode button on the Repetition toolbar.

3. While holding down the <SHIFT> key, select the element you wish to remove.

4. Once selected, press the <DELETE> key to delete the element.
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Breaking Elements from Repetition Groups
All elements in a repetition group must have the same attributes applied and be the same size. There may be
times in which an individual element requires unique traits. In this case, the element must be broken away
from the rest of the repetition group. Once broken, it will no longer be associated with the group and will
be seen as an individual form element.

� To break an element from a repetition

1. Select a repetition group.

2. Click on the appropriate Repetition Mode button on the Repetition toolbar.

3. While holding down the <SHIFT> key, click left mouse button over the element you wish to break
way from group.

4. Click Break on the Repetition toolbar.

The “broken” item will not be deleted. It will only be removed from the repetition group.

Form Element Joining
Line, Box, Circle, and Path elements can be joined together and can be repeated together. However, only
like elements can be joined (e.g. path elements to path elements, circles to circles, etc), and the elements
must be the same size. Text blocks can also be joined into a single block.

� To join form elements

1. Click the Select Group Mode button from the Drawing toolbar.

2. Click the left mouse button to begin drawing. Drag a grouping box around the form elements and
release the mouse key to end.

3. Click the Join into Repetition button on the Repetition toolbar.
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Formatting Elements
Several attributes can be defined for form elements. These attributes are the same whether formatting an
individual element or a repetition.

Some of the formatting attributes can be applied to all of the different form elements (lines, boxes, circles
and paths), while a few may only be applicable to certain form elements.

Several formatting options are available to a group of elements. These options are similar to those found
when formatting individual lines, boxes, circles and paths. The group formatting tool allows universal
formatting of different form elements simultaneously. Some formatting options will not affect all of the
elements in a particular group if not applicable to that element. For example, shading will not affect any
lines just as line direction will not affect anything other than lines. The pointer icon will identify attributes
that can be applied to a group of elements.

Formatting tools unique to groups will be described in detail at the end of this chapter.

Detailed information regarding the formatting of OMR responses can be found in Chapter 9 - Creating
OMR Forms.

Thickness and Style

Line/Border thicknesses are represented in POINTS from 0 - 14. Three styles are available including solid,
dotted and broken. Thickness and style will affect lines of all directions along with box, circle and path
borders. It will also affect diagonal lines within boxes and circles.

This attribute can also be applied to a group of elements.

� To define line and border thickness and style

1. Select the element to be formatted.

2. To change the thickness, click the appropriate thickness button (Increase Border
Thickness/Decrease Border Thickness) from the Format toolbar.

� To increase border thickness, click Increase Border Thickness.

� To decrease border thickness, click Decrease Border Thickness.

3. To change the style, click the Change Border Style button from the Format toolbar to rotate through
available styles.
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Zero Thickness Lines/Borders

Line/Border thicknesses can be set to 0. These lines/borders will be invisible and will not print. The
benefit of using zero lines is the ability to create invisible boxes or circles so that text, data, data graphs, and
images can be placed within them and positioned using the attach and position functions. Invisible lines can
also be used to complete a box for this same purpose.

This attribute can also be applied to a group of elements.

� To create a zero line object

1. Right click the object, and select Format from the context menu.

2. Access the General tab.

3. Go to the Thickness field and use the spin buttons to set the thickness to 0.

4. Click OK.

� To view zero lines

1. Select Options from the View menu.

2. Select Zero Lines from the Options menu.

Color

Color changes will affect lines of all directions along with box, circle and path borders. It will also affect
diagonal lines within boxes and circles, and shadings within boxes, circles and closed paths. It will not affect
fill within boxes, circles and closed paths. Please see page 82 for information on color fill.

� To change line/border color

1. Select the item(s).

2. To change the color of a selected item(s), click Palette or Border Color from the Format toolbar.

3. Select the appropriate color.

The availability of colors is dependent on whether the form has been defined as monochrome, highlight
color or full color.

When applying color to a group of elements there are additional capabilities implemented to specify type of
coloration. Please see page 93 for more information on applying color to a group of elements.
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Adding Diagonal Lines

Diagonal lines can be added to boxes and circles. The attributes of the diagonal lines will match the border
attributes.

This attribute can also be applied to a group of elements.

� To add diagonal lines

1. Select the box or circle to which you will add the diagonal lines.

2. Click the Toggle Diagonal Lines button on the Format toolbar. Two diagonal lines will be toggled on or off.

3. To specify a particular diagonal line to be added/removed, click the left mouse button on the corner
handle, while holding down the <SHIFT> key. The corners will then be selected.

4. To add/remove only one diagonal line in a specific direction, select Object from the Format menu or
click the right mouse button and select Format from the context menu.

� From the General Attributes tab, check the appropriate button (Top-Left to Bottom/Bottom-Left to Top) to
enable/disable diagonal lines.

� To add diagonal lines to a group of elements
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1. Click the Toggle Lines button on the Format toolbar. Two diagonal lines will be toggled on or off.

2. To add/remove only one diagonal line in a specific direction, select Group from the Format menu or
click the right mouse button and select Format Group from the context menu.

� From the Lines and Borders tab, check the appropriate button (Top-Left to Bottom/Bottom-Left to
Top) to enable/disable diagonal lines.

Shading Form Elements
Shading can be applied to boxes, circles and closed paths.

This attribute can also be applied to a group of elements.

� To shade element

1. Select element(s).

2. Click the appropriate shading button on the Format toolbar to apply shading.

� To specify shading pattern

1. Select element(s).

2. Select Object from the Format menu.

3. From the Shading/Fill tab select a shading type from the drop-down menu.

� To specify shading pattern for a group of elements

1. Group elements.

2. Select Group from the Format menu.

3. From the Shading tab select a shading type from the drop-down menu.

Shading with diagonal lines

When shading boxes/circles with diagonal lines, the user
has control over which areas are shaded and not shaded
and what type of shading is applied to each area. Each area
is considered separate and can have its own type of
shading.

� To shade elements with diagonal lines

1. Select box/circle(s) with diagonal lines to be shaded.

2. Select Object from the Format menu.
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3. Access the Shading/Fill tab. Use the Area and Shading/Percentage drop-down menus to select the area to
be shaded and which type of shading, if any, will be applied.

Color Fill

Color fill is available for boxes, whole circles and closed paths. Color fill will flood fill
the element with the selected ink. When using fill, it is not advised to use box shading
unless a solid color is chosen for the fill. Box shading combined with a patterned fill
may produce undesirable results. Diagonal lines do not affect the fill, unlike shading.

� To fill an element

1. Select element(s) to fill.

2. Select the Color Fill button or right click and choose Format.

3. Check Fill to enable fill.

4. From the Shading/Fill tab select color from the Fill drop-down.

When applying color to a group of elements there are additional capabilities implemented to specify type of
coloration. Please see page 93 for more information on applying color to a group of elements.

Rounded Corners

Rounded corners can be applied to boxes and paths. The amount of roundness can also be controlled.

This attribute can also be applied to a group of elements.

� To round corners

1. Select the element(s).

2. Click Round/Square Corner on the Format toolbar to toggle between rounded corners and square corners.

3. To specify a particular corner(s) to be rounded, click the left mouse button on the corner handle
while holding the <SHIFT> key. The corners will then be selected.

4. Click Round/Square Corner on the Format toolbar to toggle between rounded and square corners.

� To specify amount of corner rounding

1. Select the element(s).

2. Go to the Format menu and select Object, or right click and choose Format from the context menu..

3. For boxes, select roundness from the General Attributes tab of the Properties window. If the predefined
values are not precise enough, a value (radius of corner) can be specified in dots.

4. For paths, select roundness on a point by point basis in the Size and Position tab of the Properties window.
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Roundness options include SMALL, MEDIUM, LARGE, HALF and MAXIMUM. A value in dots may
also be specified. SMALL is equivalent to 12 dots, MEDIUM is equivalent to 25 dots, and LARGE is
equivalent to 37 dots. HALF and MAX are the same for boxes (half the distance of the smaller of the two
sides), while a MAX corner length for a path extends the arc as far as possible on both path segments.

� To specify amount of corner rounding for a group of elements

1. Group the elements.

2. Go to the Format menu and select Group.

3. For boxes, select roundness from the Lines and Borders tab of the Properties window.
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Line Direction

The three line directions available are horizontal, vertical and diagonal. Diagonal lines will initially be drawn
at a 45 degree angle. When changing between the three line directions, the starting point (X/Y coordinate)
will remain the same while the ending point will change accordingly to accommodate the new line direction.

This attribute can also be applied to a group of elements.

� To change line direction

1. Select the line(s).

2. To change the line direction, click Toggle Line Direction from the Format toolbar.

The angle of diagonal lines can be rotated by holding down the <CTRL> key and positioning the mouse
over a line endpoint handle and rotating as needed.

Diagonal lines within boxes and circles cannot have their angle changed. They always begin and end at
corner points.

Quarter/Half/Three-Quarter Circles

Circle segments can be selected and removed to create quarter, half and three-quarter circles.

This attribute can also be applied to a group of elements.

� To create quarter/half/three-quarter circles

1. Select circle(s).

2. While holding the <SHIFT> key, click the left mouse button over desired segment handle(s).

3. Click Toggle Circle Segment on the Format toolbar to toggle indicated circle segment on and off.

Quarter/Half/Three-Quarter circles can also be defined in the circle's
property menu.

1. Right click on the circle.

2. Select Format Circle.

3. Select the check boxes of the quadrants that you would like to be drawn.

When filling quarter, half or three quarter circles, the entire circle will be filled.
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Path Ends

The path end specifications determine the look of the start and end points of a non-closed path.

� To format path ends

1. Select path.

2. Select Object from the Format menu.

3. From the General tab of the Properties window, select path start and endpoint style as trimmed, square or
rounded.

Square will draw the endpoint as a rectangle. Trimmed will draw the endpoint trimmed to the horizontal and
vertical. Round will draw the endpoint with a semicircle, where the center point is the path endpoint.

Default Formatting
The default setting is available to set the default attributes of a particular type of form element (line, box,
circle, response etc.). There is a default set of attributes for each type of element. These attributes include
border thickness, style, color, shading options, diagonal lines, etc. When set, attributes will affect the current
element selected as well as each new element drawn until the default is changed.

� To set Formatting options as Default

1. Select element.

2. Select Object from the Format menu or click the right mouse button and select Format from the context
menu.

3. From the General Tab or the Shading/Fill tab of the Format Properties menu, select the desired attributes and
check Set as Default.

The Set as Default check box will appear in both the General and Shading/Fill tabs in order to give more
flexibility in choosing default attributes. Setting the default option in one tab and not the other only sets the
attributes in the chosen tab as the default.
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Aligning Objects
Alignment guides will appear when designing if they are enabled through your preferences menu. These
are lines that appear to assist in positioning items based on a nearby items center, top, or bottom
positioning.

� To enable alignment guides

1. From the Edit drop-down, select Preferences.

2. The Preferences menu will appear.

3. From the Design tab, select the Show Alignment Guides check box.
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Group Formatting Tools
When multiple items are selected, a group is created. In addition to the standard formatting that can be
applied to form elements, groups have unique formatting tools available. They are only available when
working with a group of elements.

Keep Only Grouping

The Keep Only grouping function allows the selection of specific form elements in a group. After grouping
several elements or applying the Select All function (go to the Edit menu and choose Select All), the Keep Only
function is useful in keeping only the elements of one particular type within the group. This provides an
efficient way to format one type of form element.

� To apply keep only grouping

1. Group elements on the form by selecting the Group icon and then left clicking and dragging a box over
the desired form elements, or by using the Select All function.

2. Right-click and select Keep Only from the context menu.

3. Select one element that will be maintained within the created group.
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Individual form elements can be selected one at a time by holding down the <Shift> key and using the left
mouse button to click over the desired element.
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Remembered Grouping
The grouping of form elements can be remembered for future group formatting. After remembered
grouping is applied to a set of elements, whenever one form element in the group is selected, the entire
group becomes selected. Multiple groups can be remembered, and elements can also be ungrouped.
Remembered grouping however is not saved when a form is closed.

� To apply remembered grouping

1. Click the Select Group Mode button on the Drawing toolbar.

2. Click and drag a box around the form elements to be grouped.

3. Right click in the selected area to show the context menu

4. Select Group from the Grouping cascading menu.

� To ungroup form elements

1. Click on any element of a previously remembered group.

2. Right click in the selected area.

3. Select Ungroup from the Grouping cascading menu.

The Keep Only function cannot be used with form elements with remembered grouping applied to them,
since they are no longer considered individual form elements.
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Aligning Group Elements
The alignment tools allow quick alignment of a group of elements. When using the alignment tools a
“master” element is defined as the element for all other elements to be aligned to.

Toolbar Button Alignment

Left Align

Right Align

Center Align

Top Align

Bottom Align

� To define the “master” element

1. Group the elements to be aligned. The default “master” element will be identified with a round, pink
handle.

2. While holding the Shift key, click the left mouse button over the special round handle of the element
you wish to define as the “master” element. The rounded handle will turn pink to indicate selection.

� To align elements

1. Group objects to be aligned.

2. Define a “master” element if different from the defaulted “master”.

3. Click appropriate button on the Tools toolbar to align objects.
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Resizing/Stretching Group Elements

Resizing Group Elements

The resizing tools allow quick resizing of a group of elements. When using the resizing tools a “master”
element is defined as the element for all other elements to be resized to.

Toolbar Button Resize Operation

Make Same Width

Make Same Height

Make Same Size (both width and height)

� To resize elements

1. Group objects to be resized.

2. Define a “master” element if different from the defaulted “master”.

3. Click appropriate button on the Tools toolbar to resize objects.

Some functions are not able to affect certain objects in the group. For example: When using the Make Same
Height function with a group that contains horizontal lines, the horizontal lines will not be modified.
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Stretching Group Elements

Stretching tools are available for groups of elements. It combines the alignment and resizing tools to
provide a different approach to resizing elements within a group. There is again a “master” element by
which to measure. With stretching, the items will be stretched to align with the “master” element.

Toolbar Button Stretch Operation

Stretch Left

Stretch Right

Stretch Top

Stretch Bottom

� To stretch elements

1. Group objects to be stretched.

2. Define a “master” element if different from the defaulted “master”.

3. Click appropriate button on the Tools toolbar to stretch objects.

When performing resizing and stretching operations to groups that contain circles, it is important to note
that circles are measured in terms of radius rather than width and/or height. Therefore, by increasing the
width or stretching larger (as in the above example) the overall circle size will be increased by a greater
amount than non-circles.
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Applying Color to a Group of Elements

Color changes can be applied to a group of elements in various ways. Special tools have been included to
specify the type of coloration to be applied to a group of elements.

Changing Border Color

Border color will affect lines of all directions along with box, circle and path borders within a group. It will
also affect diagonal lines within boxes and circles, as well as shadings within boxes, circles and closed paths.

� To change line/border color

1. Group objects.

2. Click the Border Color button on the Grouping toolbar.

3. Select appropriate color.

Fill Color

Fill color will affect boxes, circles and paths fill color within the group.

� To change fill color

1. Group objects

2. Click the Fill Color button on the Grouping toolbar.

3. Select appropriate color.

Text Color

Text color will affect text within the group.

� To change text color

1. Group objects

2. Click the Text Color button on the Grouping toolbar.

3. Select appropriate color.

Available colors are dependent on whether the form has been defined as monochrome, highlight color or
full color.
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Chapter 5

Working with Text

VisionDP has an extensive text editor that allows you to enter and manipulate text much as you would
in a word processor. The text cursor is represented by an upper and lower bracket that encases the
area where text is being entered.

The text editor allows text to be quickly placed onto forms. Text boxes can be drawn for insertion of text
or VisionDP will automatically create a block for text insertion. Formatting of text is done on a text block
basis and through the text editor allowing character by character formatting. Advanced text functions
include justification, spell checking, search and replace, and font changes on a character by character basis.

VisionDP can import and export ASCII text (.TXT), Rich Text Format (.RTF), and Microsoft Word
(.DOCX). This allows users to transfer large amounts of text to and from VisionDP with little effort and
without losing all formatting when using .RTF/.DOCX format.

Text from the Windows Clipboard is also available to be pasted into VisionDP allowing users to copy/cut
text from other Windows applications.

Text Placement
In order to place text onto a form, a text block must first be defined. There are two ways to create a text
block. Each method creates a different type of text block.

� To create a text block

1. Click the Text Draw button on the Drawing toolbar to enable text mode.

2. Click the left mouse button where a text block should be drawn.

3. Type the desired text when the cursor appears.

This method should be used when entering titles or short lines of text. There will be no column width
associated with these text blocks. Text will not automatically word wrap.
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� To draw a text block

1. Click Text Draw on the Drawing toolbar to enable text mode.

2. Click the left mouse button and drag to draw a rectangular text block.

3. Type the desired text when cursor appears.

This method should be used when entering a paragraph of text. It will create a columnar block of text that
will be the column width of the block drawn. As a result, text will word wrap at the end of each line
accordingly.

X/Y location is indicated on the ribbon bar location at the bottom of the screen to assist in placing
elements in the desired location. More precise size and positioning can be accomplished in the Size and
Position tab of the Text Properties window.

Selecting Text Blocks
In order to manipulate a text block, it must first be selected.

It is often difficult to tell if you are positioned properly over a particular form element. VisionDP’s cursor
will change to indicate proper positioning. The various cursor shapes indicate the type of element that the
cursor is positioned over.

� To select a text block

1. From the Drawing toolbar, click Select Mode.

2. Position your mouse over the text block to be selected and click the left mouse key.

Selected text blocks will be displayed with selection handles. To select overlapping objects, it may be necessary to de-select all
objects prior to making selection.
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Moving/Copying Text Blocks

� To move using the mouse

1. Select the text block(s) to be moved.

2. Position the mouse over the element(s) and drag element(s) to a new location.

� To copy using the mouse

1. Select the text block(s) to be copied.

2. Position the mouse over the element(s)and drag element(s) to a new location while holding down the
<CTRL> key.

� To move using the keyboard (grid stepping)

1. Select the text block(s) to be moved.

2. Hold the <SHIFT> key in combination with the arrow key representing the direction in which to
move.

� To position element through the Properties window

1. Select the text block.

2. Select Text from the Format menu or click the right mouse button and select Format from the context
menu.

3. From the Size and Position tab of the Properties window use the spin arrow to specify position (X and Y
coordinate) or type values in the respective edit boxes.

The current unit of measure is shown in the Unit drop-down. Units of measure available are grids, inches,
centimeters and dots.

Resizing Text Blocks
When resizing width, column width specification will be changed causing text to word-wrap to new column
width. When resizing vertically, line spacing will change to accommodate new text box size.

� To resize using the mouse

1. Select a text block to be resized.

2. Position the mouse pointer over a resize handle and drag to new size.
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When resizing text blocks, corner handles resize both width and height proportionally. Center handles resize
width or height respectively.

� To resize using the keyboard (grid stepping)

1. Select the text block to be resized.

2. Hold the <CTRL> key in combination with the arrow key representing the direction in which to
resize.

� To define grid step interval (for moving and resizing)

1. Select Preferences from the Edit menu.

2. Open the Design tab.

3. Indicate the Keyboard Snap by selecting the appropriate radio button (Pixel, ¼ grid, ½ grid or full grid).

Stepping can be used when fine movement or resizing is difficult to achieve through mouse movements.
Moving an element to an exact X and Y coordinate or defining a specific element size is available in the Size
and Position tab of the drawing element’s respective Properties window.

� To resize through the properties window

1. Select the text block to be resized.

2. Select Text from the Format menu.

3. From the Size and Position tab, specify width and height values to resize text block.
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Text Block Formatting
Several attributes can be defined for text blocks.

Several text formatting options are available to a group of elements. These options are similar to
those found when formatting individual text blocks. The group formatting tool allows universal
formatting of multiple text blocks simultaneously. The pointer will identify attributes that can be
applied to a group of elements.

Text Direction

VisionDP supports both horizontal and vertical text. Horizontal text reads left to right, while vertical text
reads top to bottom, placing characters below the previous. Text can also be made to flow from right to left.
This feature is intended for use with Arabic fonts, and will be enabled as a default if Arabic is defined as the
language when starting up VisionDP. However, the option is always available, and any font can be made to
flow from right to left if desired.

This attribute can be applied to a group of text blocks.

� To orient text vertically or horizontally

1. Select text block.

2. Select Text from the Format menu, or right click and choose Format Text from the context menu.

3. From the General tab, select the desired text direction (vertical or horizontal).

� To orient a group of text blocks vertically or horizontally

1. Group text.

2. Select Group from the Format menu, or right click and choose Format Text from the context menu.

3. From the Text and Images tab, select the desired text direction (vertical or horizontal).

When editing vertical text, text will appear horizontally.

Text can also be rotated by angle. Please see Rotate/Flip Images on page 133 for additional information.
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� To enable text flow from right to left

1. Select that text to be edited and right click the selection.

2. Choose Format Text from the context menu.

3. The Text Properties window will appear. Access the General tab.

4. Enable the Right to Left Direction check box.

5. Click OK to save this specification and return to the form.

Font Selection

When working with text blocks, font changes applied will affect the entire block of text.

This attribute can be applied to a group of text blocks.

� To select text block font

1. Select text block(s).

2. Choose font typeface and point size from the Text Format toolbar as follows:

� Choose typeface from the Typeface drop-down.

� Choose point size from the Point Size drop-down.

<OR>

� Press <ALT>< F10> keys together to make font selection from the typefaces and point sizes
listed.

More detailed font information can be found in the Text Editing section of this chapter.

Underline, Bold and Italic Styles

When working with text blocks, all style changes applied will affect the entire block of text. To apply style
changes on a character-by-character basis, please refer to Text Editing later in this chapter.

Icon Style

Underline

Bold

Italic
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� To apply character styles

1. Select a text block to be modified.

2. Click Bold, Underline and/or Italic as desired.

Underline Style

There is one underline style associated with each text block. If more than one style is required in a single
text block, the block must be broken into multiple text blocks as described on page 108.

� To define underline style

1. Select the text block to be formatted.

2. Select Text from the Format menu.

3. From the Underline Style tab of the Properties window:

� Click Single or Double to choose underline type.

� Choose style (solid, broken, dotted) from Style drop-down.

� Define underline thickness (0-14, hairline) using the spin arrows.

� Choose underline color from Color drop-down.

� Use arrow keys to specify Distance value of underline below text baseline.

Text Color

When working with text blocks, color changes will affect the entire block of text.

This attribute can also be applied to a group of text blocks.

� To change the text color

1. Select text block(s).

2. Click the Palette button on the Format toolbar to select text color or select Font from the Format menu to
choose color.
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Bullets

Bullets can be applied to text blocks by selecting the Bullet button.

� To apply bullets to text and edit bullet styles

1. Select the desired text block.

2. Click on the bullet button to enable bullets at each carriage return within the text block.

3. Right click and choose Bullets from the context menu to access options for other types of bullets.

Select a different bullet type if desired.

� To define default bullet settings

1. Access the Preferences menu by selecting Edit > Preferences from the top menu bar within VisionDP.

2. Click on the Bullet Definitions tab within the Preferences menu.

3. Select the radio button below the icon that you wish to be the default bullet character. To edit the
bullet character, use the font and size drop-down menus.
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Text Block Spacing

Line Spacing

Predefined line spacing options include single, 1.5 and double line spacing. The Custom option allows other
line spacings to be defined in the Custom Line edit box.

� To define line spacing

1. Select text to be formatted.

2. Select Text from the Format menu, or right click and choose Format Text from the context menu.

3. From the General tab of the Properties window, choose line spacing from the Line drop-down.

Character Spacing

Character spacing controls the width of each character. By defining a character spacing, proportionally
spaced fonts will appear fixed pitch.

� To define character spacing

1. Select text to be formatted.

2. Select Text from the Format menu, or right click and choose Format Text from the context menu..

3. From the General tab of the Properties window, specify character spacing (pitch) using the spin arrows
or by typing in the Character edit box.

The value shown in the Custom and Character fields are represented in the unit selected in the Unit drop-down.
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Alignment
There are seven different alignment options available depending on text direction. The alignment affects the
entire text box formatted.

Icon Alignment

Left Align Text

Center Align Text

Right Align Text

Justify Text

Top Align Vertical Text

Bottom Align Vertical Text

Center Align Vertical Text

This attribute can be applied to a group of text blocks.

� To define alignment

1. Select text block(s).

2. Click appropriate alignment button on the Text Format toolbar to apply justification style.

Interword Spacing

If working with justified text, there is an additional option to modify the width of the space in between the
characters in order to adjust the number of words that will fit on each line.

� To modify text interword spacing

1. Select the text block containing the justified text.

2. Right click, and select Format Text from the context menu.

3. Access the General tab of the Text Properties window.

4. Make sure that the text alignment is set as Justified. Select a percentage value for the interword spacing.
This is a percentage of the normal interword spacing. To make the spacing smaller, select a number
that is less than 100%.
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Alignment to Character

Characters within a text box can be vertically aligned to the first occurrence of a user-defined character.
The characters in each line of text thereafter will line up, forming columns depending on the occurrence of
the user defined character to be aligned to.

� To enable character alignment

1. Right click the text to be aligned and select Format Text from the context menu.

2. Access the General tab of the Text Properties window.

3. Select Character from the Alignment drop-down menu.

4. Define the single character that will be used for alignment. A period is commonly used to align a
column of numbers.

5. Click OK to apply the alignment and return to the form.

Working with Text 105

Alignment to CharacterInterword Spacing



Attach to Box/Circle
Text blocks can be attached to boxes and circles. By attaching text to a box or circle, the user simplifies later
form modifications. The text block will remain attached during moving and resizing operations. The text
cannot be moved out of the box or circle unless it is detached first.

This attribute can be applied to a group of text blocks.

� To attach/detach text

1. Select text block.

2. Click Attach to Box/Circle on the Text Format toolbar to toggle between attached and detached.

Attach to Artificial Box

VisionDP is able to automatically create an artificial box to which text, data, or an image can be tied.

� To tie to an artificial box

1. Select the form element, either text, data or an image, that will be attached to the artificial box.

2. Right click the form element, and select Format Text, Format Data, or Format Image from the context menu.

3. Access the General tab of the Properties window.

4. Enable the Attach to Box/Circle check box.

5. A pop-up box will appear, asking if a box should be created. Click Yes.

6. Click OK.

Positioning Text in Boxes/Circles
Text can be positioned in boxes and circles once they have been attached. The same procedure can be used
for repositioning text.

� To position text in box/circle

1. Select element.

2. Click Position in Box/Circle on the Text Format toolbar.

3. A matrix will appear showing the nine locations available for positioning.
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4. Click the mouse pointer within one of the nine boxes to select a location.

There are nine positions available for positioning: Top-Left, Top-Center, Top-Right, Center-Left,
Center-Center, Center-Right, Bottom-Left, Bottom-Center and Bottom-Right.

Positioning Margins

When positioning within circles, or rounded corner boxes, there are two different types of margins
available: squared and rounded.

� To select positioning margin
� Click Toggle Text Margins on the Text Format toolbar to toggle between squared and rounded margins.

Attach Element to Center Page
If there is no box defined, an element can be tied to the center of a page.

� To attach element to center of page

1. Select the element that will be attached to the center of the page.

2. Go to the Text Format toolbar and click the Attach to Box/Circle button, or go to the Format menu and choose
Tie Object.
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Breaking Text Blocks
Certain text attributes can only be applied to an entire text block; for example: underlining style, column
width, text direction, justification, etc. There are times in which multiple attributes need to be applied to
different sections of a text block. In these cases, it is necessary to break a text block into multiple text
blocks.

� To break a text block

1. Double click the text block to open the text block.

2. Highlight the text to be removed from the text block.

3. Click Cut to Clipboard from the Standard toolbar to remove the text.

4. Click Text Mode from the Drawing toolbar to invoke text mode.

5. Click left mouse button and drag to draw text region.

6. Click Paste from Clipboard from the Standard toolbar to paste text.

Default Text Setting
The default setting is available to set the default attributes of text blocks. There is a default set of attributes
for each form element. For text, this includes alignment, text direction, spacing, attached status, etc. Setting
default text attributes causes future text blocks to have these default attributes.

� To set attribute defaults for a single form/job

1. Select Text from the Format menu or click the right mouse key and select Format from the context menu.

2. From the General tab of the Text Properties window, select the desired attributes and check the Set as
Default button.

� To set default font and size for all new designs

1. Select Preferences from the Edit menu.

2. Select the Design tab.

3. Set the default font and font size newly created forms.
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Text Flow
Static or conditional text can be made to flow from one text block to another when the amount of text
exceeds the dimensions of the frame in which it is located. Text flow can be implemented before or after a
text block has been filled to capacity, but it must first contain some amount of text. Use the Create New Frame
button, located on the Data View toolbar, to define additional, linked frames.

Frames will be linked in sequential order, based off of the frame that is selected when the new linked frame
is created. If the original frame is selected, the next box will be numbered 1. If a second linked frame is
created, but the original box is still selected, the second box will be numbered 1, and the previous box will
be bumped to number 2.

However, if the first linked frame is selected when the second frame is created, the new frame will be
numbered 2, and the first one will retain its position as frame 1. This convention makes it possible to easily
insert frames into the flow order without having to rearrange what is currently on the page.

� To apply text flow

1. Select a text box containing text that exceeds the dimension of the frame.

2. Click the Create New Frame button.

3. Click the left mouse button to drag a new frame onto the page of the desired proportions.

4. Overflow text will flow into this new frame.

5. Define as many frames as necessary to accommodate and shape the text.

Text contained within linked text boxes can only be edited from the original box. All linked text boxes will
appear with a number on the upper left corner. This number denotes which place the box holds in the order
of linking. This number will be displayed when the original box is selected.
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Text Editing

Editing Text
Text editing can occur from within the text editor. This includes the ability to insert and/or remove
characters.

� To open the editor and edit text

1. Double click on the text block to be modified to invoke the text editor.

2. A cursor will appear to indicate edit mode. Scroll through the text using the keyboard or mouse as
necessary to make modifications.

3. Edit text as desired.

There are two edit modes: Insert and Overtype. To invoke Insert mode, press the <INSERT> key. Edit mode
will be indicated on the far right corner of the ribbon bar located at the bottom of the screen by the OVR
symbol.

Edit Commands to scroll through Text (Keyboard)

Command Keystroke

Scroll up or down a line, or left or right one character Up, Down, Left and Right arrow keys

Position at the beginning of the current line <HOME>

Position at the beginning of a text block <CTRL-PAGEUP>

Position at the end of a text block <CTRL-PAGEDOWN>

Position on the previous word. <CTRL-Left Arrow Key>

Position on the next word <CTRL-Right Arrow Key>
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Text Formatting

Font Selection

The font selection list of the Text Format toolbar will contain a list with access to Windows TrueType,
OpenType, PostScript fonts and the fonts that are being used in the active form.

TrueType fonts can be distinguished in the list by the symbols to the left of the font name.

“TT graphic” = Windows TrueType font

"PS graphic"= PostScript fonts that are provided by the print-driver defined within the Resource Set

� To make a font selection from the toolbar

1. Double click on text block to be modified to invoke the text editor.

2. Cursor will appear to indicate edit mode.

3. Using the mouse, highlight the character(s) to be modified.

4. Choose font typeface and point size from the Text Format toolbar as follows:

� Choose typeface from the Typeface drop-down.

� Choose point size from the Point Size drop-down.

<OR>

� Press <ALT>< F10> keys together to make font selection from the typefaces and point sizes
listed.

� To make a font selection from the Format Font window

1. Select Font from the Format menu.

2. Select Font, Style and Point Size from the respective drop-down lists.
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Restrict TrueType Fonts

If there is no desire to use TrueType fonts in your application, they can be removed from the font list so
that they are not used accidentally. This is done by enabling the Restrict TrueType Fonts check box in the
Preferences window.

� To set restrict truetype flag

1. Select Preferences from the Edit menu.

2. From the Systems tab, check the Restrict TrueType Fonts check box.

Font Exchange

The font exchange tool allows users to quickly change the font of multiple text blocks in a form. It allows a
font substitution of a particular font for another font. For example, in a document in which Arial-12 was
used, Tahoma-17 Portrait can be substituted for Arial-12 Portrait. All text referencing Arial-12 would then
change to Tahoma-17.

� To exchange fonts

1. Select Font Exchange from the Tools menu.

2. Select the font to be exchanged in the Select Font drop-down.

3. Choose new font typeface, size, style and orientation from the corresponding menus. The font chosen
from these menus will now be reflected in the Change To edit box.

4. Click OK to accept font exchange operation.

The orientation change will only occur if the font being exchanged is the only font used in the text.
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Underlining, Bolding and Italicizing

From within the text editor, style changes can be made on a character-by-character basis. The style changes
available include underline, bold and italic.

Icon Style

Underline

Bold

Italic

� To make a style change

1. Double-click on text block to be modified to invoke the text editor.

2. Cursor will appear to indicate edit mode.

3. Select character(s) to be modified.

4. Click Bold, Underline and/or Italic as desired.

Underline Style

There is one underline style associated with each text block. If more than one style is required in a single
text block, the block must be broken into multiple text blocks as described in detail on page 108. Underline
style is further discussed on page 101.

Subscript and Superscript

Subscript or superscript can be applied to text on an individual character basis.

� To apply subscript or superscript

1. Highlight the character(s) to which you will apply the formatting.

2. Click either the subscript or superscript button from the Text Format toolbar.
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Text Color

Within the text editor, color changes can be made on a character by character basis.

� To change the text color

1. Double-click on text block to be modified to invoke the text editor.

2. The cursor will appear to indicate edit mode.

3. Select character(s) to be modified.

4. Click Palette on the Format toolbar to select text color or select Font from the Format menu to choose
color.

Color Exchange

The color exchange tool allows users to quickly change the color of multiple items in a form. It allows a
color substitution of one color to another. In other words, in a form in which red was used, red can be
substituted for blue. All selected items would then change to blue.

� To perform a color exchange

1. Select Color Exchange from the Tools menu.

2. Select the color to be exchanged in the Original Color drop-down.

3. Choose whether you wish to exchange the object color or fill color.

4. Select new color from the Change To Color drop-down.

5. Click OK to accept color exchange operation.
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Paragraph Indentation

Paragraph indentation may be specified for both data and text. The user may define a specific amount of
indentation for the data or text block, including negative indentation.

� To define paragraph indentation

1. Right click the text to which the indent will be applied, and select Format Text from the context menu.

2. Access the General tab of the Text Properties window.

3. Select the unit in which the indentation will be specified from the Unit drop-down in the Indentation
section of this tab.

4. Enter an indentation amount into the Indentation edit box. Entering a negative number will create a
hanging indent.
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Tabbing

VisionDP's tabbing support allows users to define relative and absolute positioning of tabs. Absolute
tabbing allows you to define different length tabs, each based upon the left margin of the text block.
Relative tabs will space the sequence at even intervals, as defined in the Tab Every edit box.

� To define absolute tabs

1. Enter the string of numbers, letters or words that will be separated by tabs onto the form. Do not
include spaces between the items that will be separated by tabs: this will cause the tabbing to be off.

2. Right click the text string and select Format Text from the context menu.

3. Access the Tabs tab of the Text Properties window.

4. Choose the tabbing unit from the Unit drop-down menu.

5. Enter the distance that the first tab will cover into the Tab Stop edit box. Click the Add button to add this
value to the Tab Stop list.

6. Repeat this process to add the additional tab stop values into the list.

7. Click OK to save the settings and return to the form.

8. Once the tab stops are set, they must be inserted into the text string. Enable the text editor, and insert
the tab stops at the appropriate locations throughout the text string.

� To define relative tabs

1. Enter the string of numbers, letters or words that will be separated by tabs onto the form. Do not
include spaces between the items that will be separated by tabs: this will cause the tabbing to be off.

2. Right click the text string and select Format Text from the context menu.

3. Access the Tabs tab of the Text Properties window.

4. Choose the tabbing unit from the Unit drop-down menu.

5. Enter the tab distance into the Tab Every edit box.

6. Click OK to save the setting and return to the form.

7. Insert the tabs into the text string at the necessary locations.
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Dot Leadering

Up to two dot leadering sequences can be applied to a text string. Enabling dot leaders disables tabbing.

� To define dot leadering

1. Type the string of numbers, letters or words that will be separated by dot leaders onto the form. Do
not include spaces between the items that will be separated by leaders: this will cause the spacing to
be off.

2. Right click the text string and select Format Text from the context menu.

3. Access the Tabs tab of the Text Properties window.

4. Enable the Leadered check box.

5. Type the character(s) that will be used for the leadering into the Character edit box.

6. Select the unit in which the column width will be defined from the Unit drop-down menu.

7. Enter a value into the Column Width edit box.

8. Choose a color from the Color drop-down menu.

9. Click OK to save the leadering settings and return to the form.

10. Invoke the text editor, and insert a tab into the text sequence where the dot leadering should appear.
Up to two dot leaders can be inserted per one line of text.
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Access the Tabs tab from the Text Properties window to specify dot
leadering requirements.

VisionDP supports double and single dot leadering.



Find and Replace

Find Word or Phrase

� To find a specific word or phase

1. Select Find from the Edit menu.

2. Type the word or phrase to be located in the Find what edit box.

3. Click the Find Next button.

Find and Replace Word or Phrase

� To find and replace a specific word or phrase

1. Select Replace from the Edit menu.

2. Type the word or phrase to be replaced in the Find what edit box.

3. Type the replacement word or phrase in the Replace with edit box.

4. Click Find Next, Replace, or Replace All as follows:

� Find Next will search for the text in the Find what edit box.

� Replace will search for the text in the Find what edit box and replace upon user confirmation of each
case.

� Replace All will simply search for the text and replace it in all cases with the replacement text.
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To cancel a search in progress, click the CANCEL button.

Match Whole Word Only

To match only whole words during find and replace operations, the match whole word option must be set.
If it is not set, matches will be found that contain the word even if within another word.

� To set match whole word option

1. Select Find or Replace from the Edit menu.

2. Check Match Whole Word Only.

3. Continue with Find and Replace operation.

Match Case

To match case during find and replace operations, the match case option must be set. If this option is not
set, upper and lower case differences will be ignored during find and replace operations.

� To set match case option

1. Select Find or Replace from the Edit menu.

2. Check the Match Case checkbox.

3. Continue with the Find and Replace operation.
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Special Characters
A character map is available and allows you to quickly see which characters are in a specified font. You can
insert special characters, international characters, and symbols with the help of the character map. You can
also view the character code assigned to a character or symbol in the character map. That character code
can later be typed out on the numeric keypad to insert the character or symbol it represents.

VisionDP uses the Windows tool Charmap.exe to display the character map. If this tool has not been
installed, you will need to install this tool from your Windows Installation CD.

View the Character Map
In order to insert special characters, the user must first view the character map.

� To view the character map

1. Select Character Map from the Edit menu.

2. The character map for the current font will be displayed.

Change Font to be Viewed

� To change the font being viewed in the character map

1. Select Character Map from the Edit menu.

2. Select the font to be viewed from the Font drop-down menu.
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Insert Special Characters
The main purpose of the character map is to allow quick insertion of special characters and symbols.

� To insert special characters

1. Select Character Map from the Edit menu.

2. Choose font from the Font drop-down menu.

3. Double click character or select character(s) and press Select.

4. Press Copy to copy character(s) to the clipboard.

5. Press Close to close character map.

6. Select Paste from the Edit menu to paste the character(s) from the clipboard.

� To insert special character using character codes

1. Select Character Map from the Edit menu.

2. Choose font from the Font drop-down menu.

3. Highlight the character to be inserted.

4. Note keyboard code listed in the Keystroke field.

5. Press Close to close character map.

6. Type out keyboard code for character to be inserted; for example Alt+ 0173, on the numeric keypad.
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Importing and Exporting Text

Importing Text Files

If any formatting has been applied to text in another program, text should be imported as RTF or .DOCX.
While not all parts of these files will be imported like embedded pictures, text with formatting will be
maintained.

� To import a text file

1. Click Import Text from the Drawing toolbar.

2. To import a text file from a different folder other than the default, click a different drive in the Look in
box, or double-click a different folder in the folder list.

3. Select the text file format of text to be imported from Files of type drop-down. Available formats
include .TXT (ASCII Text), .RTF (Rich Text Format), and .DOCX (Microsoft Word).

4. Select the file to be imported and click Open.

5. Click the location on the form where text should be inserted.



Exporting Text Files
Text blocks can be exported from VisionDP.

� To export a text file

1. Select the text block to be exported.

2. Select Export from the File menu.

3. Select Text from the Export menu.

4. To save the text in a different folder other than the default,
click a different drive in the Save in box, or double-click a
different folder in the folder list.

5. To save the document in a new folder, click Create New Folder.

6. In the File name box, type a file name for text.

7. Select text file format from Files of type drop-down. Available formats include .TXT (ASCII Text),
.RTF (Rich Text Format), and .DOCX (Microsoft Word).

8. Click the Save button.

If you would like to export multiple text blocks, join blocks together and then proceed with export
operation.

Spell Checking
A spell checker is available to spell check the text on an individual form basis. It will look for spelling
mistakes, capitalization errors, and duplicate words. The user can spell check an individual text block, a
group of text blocks, or an entire form. If a text block(s) is not selected, the entire form will be checked
when running the spell checker.

� To run the spell checker

1. Click Correct Word Spellings button or select Spell Checker from the Tools menu.

2. Unknown words will appear in the Not in Dictionary field. The user then has several options involving
the unknown word. The additional options are all outlined on the following page.

3. Click the Done button to end spell checking.
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Change Word

1. Click the Correct Word Spellings button or select Spell Checker from the Tools menu.

2. The unknown word will appear in the Not in Dictionary field.

3. Suggested replacements will appear in the Suggestions list. The closest match to the unknown word will
be placed in the Change To field.

4. Change the word to one of the suggested replacements as follows:

� To change the word to the word in the Change To field, click the Change button.

� To change the word to a word in the Suggestions list, select the word from the list so that it is
defined in the Change To field. Click the Change button.

5. Change the word if not found in the suggested replace as follows:

� Click on the Change To field, and type in the corrected word.

� Click on the Change button.

Ignore Word

1. Click Correct Word Spellings or select Spell Checker from the Tools menu.

2. The unknown word will appear in the Not in Dictionary field.

3. Suggested replacements will appear in the Suggestions list. The closest match to the unknown word will
be placed in the Change To field.

4. Click the Ignore button to ignore the unknown word.

5. Click the Ignore All button to ignore the unknown
word throughout the form.

Add Word to Dictionary

� To add a word to the custom dictionary

1. Click Correct Word Spellings or select Spell Checker from
the Tools menu.

2. The unknown word will appear in the Not in
Dictionary field.

3. Suggested replacements will appear in the Suggestions list. The closest match to the unknown word will
be placed in the Change To field.

4. Click the Add button to add the unknown word to the custom dictionary. The Spell Checker will
continue looking for misspellings without reporting this word as misspelled again. Words in the
custom dictionary can be viewed or edited by clicking the Options button and selecting the Custom
Dictionary tab.
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Spell Checking Options

Custom Dictionary

� To use a custom dictionary

1. Click Correct Word Spellings or select Spell Checker from the Tools menu.

2. Click Options to define spell checking options.

3. From the Spelling Options dialog, check the Custom Dictionary box to activate the custom dictionary.

Select Language Dictionary

There are ten different language dictionaries currently available, including English, French, UK-English,
German, Spanish, Italian, Swedish, Danish, Dutch, and Norwegian.

� To select a language dictionary

1. Click Correct Word Spellings or select Spell Checker from the Tools menu.

2. Click Options to define spell checking options.

3. From the Spelling Options tab, select Language Dictionary from the Language drop-down.

Ignore Capitalized Words

Many words that begin with a capital letter may be names or places that are not included in a standard
spelling dictionary. When using the spell checker, you have the option of bypassing all words that contain a
capital letter. This optional setting will save you time in the spell checking text that contains capitalized
names whose spelling can be ignored.

� To ignore capitalized words

1. Click Correct Word Spellings or select Spell Checker from the Tools menu.

2. Click Options to define spell checking options.

3. From the Spelling Options tab, check Ignore Capitalized Words to ignore all words containing capital letters.
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Modify Custom Dictionary

� To modify custom dictionary

1. Click Correct Word Spellings or select Spell Checker from the Tools menu.

2. Click Options to define spell checking options.

3. From the Custom Dictionary tab, the user can add or remove words from the custom dictionary.

� To Add words, type word to be added in the Add Word edit box and click the Add button.

� To Remove words, select word from the dictionary list and click the Delete button.
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Chapter 6

Working with Images

VisionDP allows the import of most image formats. File formats supported include Zsoft PC
Paintbrush (.pcx), Tagged Image File Format (.tif), JPEG (.jpg), Windows Bitmap (.bmp), Raster PDF
uncompressed (.pdf), Compuserve GIF (.gif), Windows Metafile (.wmf), enhanced Metafile (.emf),

Adobe Photoshop (.psd), Portable Network Graphics (.png), Encapsulated Postscript Images (.eps), and
TARGA (.tga).

VisionDP can import images using either RGB or CYMK color values.

Placing Images on a Form
Images that have already been imported into the current resource set are available from the image
drop-down list on the text format toolbar.

� To use a previously imported image

1. Click Image List drop-down on the toolbar.

2. A list of image files in the resource set will be listed.

3. Select an image.

4. Click the location on the form where the image should be placed.
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Importing Images

Additional images can be imported while a form is open by choosing Import from the File menu. Upon
importing an image, the image will automatically be added to the resource set and be displayed in the Image

List drop-down on the toolbar.

� To import an image:

1. Click Import Image from the Drawing toolbar or select Import and Image from the File menu.

2. An open window will appear allowing file selection. Click the Files of type drop-down menu to set the
file type mask.

3. Select the file to be imported and click the Open button.

4. Click on the location where the image should be placed.

Multi-Page PDF Images

PDF files that are multiple pages can be imaged and imported into VisionDP. Once imported, the pages can
be scrolled through and the desired page can be placed on the form. The image will be placed on the form
with the same dimensions as the original PDF page, but it can be resized and rotated once on the form.

� To Choose a page of a multi-page PDF

1. Click the Import Image button on the Drawing toolbar, or select Import and choose Image from the File
menu.

2. Choose a PDF file with two or more pages.
Import the file.

3. Click on the form to place the PDF image.

4. Right click and choose Change Page from the
context menu.

5. An Extract Image from Multiple Pages window will
appear. The window will show the name of the
PDF file and the current page. The Previous Image
and the Next Image buttons can be used to move
backward and forward through the pages of the
PDF.

6. After choosing the desired page, click Close to
close the window. The page selected will be
imaged.

Multi-page PDFs can be directly imported in a VI job and automatically split into separate form files
(*.DTD). Refer to Chapter 8: Creating Print Jobs.
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Selecting Images

In order to manipulate an image, it must first be selected.

It is often difficult to tell if you are positioned properly over a particular form element. VisionDP’s cursor
will change to indicate proper positioning. The various cursor shapes indicate the type of element that the
cursor is positioned over.

� To select an image

1. From the Drawing toolbar, click Select Mode.

2. Position your mouse over the element to be selected and click the
left mouse key. The cursor will change according to the current
object being selected.

Selected images will be displayed with selection handles. To select
overlapping objects, it may be necessary to de-select all objects prior to making selection.

Moving/Copying Images

� To move using the mouse

1. Select the image(s) to be moved.

2. Position the mouse over the element(s) and drag element(s) to a new location.

� To copy using the mouse

1. Select the image(s) to be copied.

2. Position the mouse over the element(s)and drag element(s) to a new location while holding down the
<CTRL> key.

� To position element through the properties window

1. Select the image.

2. Select Image from the Format menu or click the right mouse button and select Format Image from the
context menu.

3. From the Size and Position tab of the Properties window, specify X and Y coordinates of the image
(Top Left Corner).
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Images, like text, can be attached to a box/circle. If an image is attached it must be detached before
moving. See Attaching to Box/Circle on page 106 for more information.

Resizing Images

� To resize using the mouse

1. Select the image to be resized.

2. Position the mouse pointer over the appropriate handle and drag to new size.

When resizing images, corner handles resize both width and height proportionally. Center handles resize
width or height respectively. Holding down the Alt key while resizing will preserve the aspect ratio.

� To resize through the Properties window

1. Select an image.

2. Select Image from the Format menu or click the
right mouse button and select Format Image
from the context menu.

3. From the Size and Position tab of the Properties
window use the arrow keys to specify width
and height.

� To scale through the Properties window

1. Select an image.

2. Select Image from the Format menu or click
right mouse key and select Format Image from
the context menu.

3. From the Size and Position tab of the Format
menu use the spin arrows to specify scaling
percentages.

4. Check the Maintain Aspect Ratio box to scale
proportionally.
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Cropping Images

After importing an image into VisionDP, it is possible to crop it to a desired size.

� To crop an imported image

1. Right click the image and select Format Image from the context menu, or select Image from the Format
menu in the menu bar.

2. Access the Appearance tab of the Image Properties window.

3. Select which unit you would like to use when making the crop specifications: inches, centimeters, dots
or grids.

4. Enter the amount that you want to crop from each side of the image into the Crop From Edge fields.

5. Click OK to apply the crop specifications and return to the form.
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Editing Image Appearance

It is possible to modify the brightness and contrast levels, as well as to sharpen the look of an image.

� To edit the appearance of an image

1. Right click the image and select Format Image from the context menu, or select Image from the Format
menu in the menu bar.

2. Access the Appearance tab of the Image Properties window.

3. Use the Brightness, Contrast and Sharpen sliders to choose new levels for the selected image, or enter a
value into the field to the right of the sliders.

4. Click OK to apply the changes and return to the form.

Image Borders

Image borders can be defined in the Properties window. The border will be automatically resized with the
image if the image is resized.

� To define an image border

1. Select and right click the image to which the border will be applied.

2. Select Format Image from the context menu.

3. Access the General tab of the Image Properties window.

4. Go to the Border section, at the bottom of the window.

5. Define a Border Type, Thickness and Color.

6. Click OK.
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Rotate/Flip Images

Images can be rotated by any user defined angle
through the image properties window, or to a
pre-defined angle by using the Flip/Rotate
window. Images can also be flipped horizontally or
vertically.

� To rotate an image to a pre-defined angle

1. Select an image to be rotated.

2. Select Rotate from the Tools menu

3. Mark the rotation angle (0,90,180,270) radio button.
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� To flip an image

1. Select image to be flipped.

2. Select Rotate from the Tools menu

3. Check appropriate flip option (horizontal/vertical).

� To rotate an image to a user-defined angle

1. Select the image that will be rotated. There are several menus from which you can rotate the image:

� Right click the image and select Rotate in Degrees from the context menu.

� Right click the image and select Format Image from the context menu. Access the Appearance tab.

� Select Image from the Format menu in the menu bar. Access the Appearance Tab.

2. Enter a rotation angle into the Rotation field.

3. Click OK to apply the rotation and return to the form.
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Working with Background Images
Backgrounds can be imported into VisionDP to be used as visual aid in the design process. Many times the
background images will represent preprinted stock, and will only be viewed on screen and not printed.
However, the option always exists to define a background printing image as well, to be printed with the final
application. VisionDP has the ability to import backgrounds from other design packages, such as Quark,
PageMaker, InDesign, etc.

Importing Background Images
Images can either be set to the background plane or initially imported as a background.

� To import a background image file

1. Create a new form or open an existing form

2. In the File menu, go to Import and then select Background.

3. In the Images directory, choose the appropriate image file to set as a background and click the Open
button to accept.

4. The image will appear on the form at the origin point (top left).
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Setting an Image to the Background Plane
Images already placed on the form can be set to the background plane.

� To set an image as a background

1. Select the image that is to be added to the background plane.

2. Right-click the mouse and select Background Plane.

Editing Background Images
Images placed on the background plane can be selected
for modification (moving, resizing, deleting, calling
printing image) once the Background Plane option is
selected from the Edit menu. Background images can
be set to just be viewable for design purposes, such as
designing for a pre-printed stock, or they can be
printable.

Reference a printing image from an image already set to
the background plane

Background images can be edited to reference any
supported image format.

� To reference a printing image

1. Make sure that the View menu Plane option for
Background is selected.

2. From the Edit menu select the Background Plane
option.

3. Select the desired background image.

4. Right-click and select Format Image.

5. In the General tab of the Image Properties window, key in the printing image file name in the Printing Image
edit box or browse for the image file by clicking the ellipses (...). Click the OK button to accept.
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Working with Path Art
The Path Art capability in VisionDP allows form objects (circles, boxes, lines, paths, text and images) to be
grouped and saved as an *.art image file. The *.art file can then be imported into the form, replicating the
grouped elements that were saved. This capability is especially useful when patterning formatted objects or
when a group of drawn elements is needed for later use.

Alternatively, if there is a common form design that you would like to use on multiple forms - you could
save the original form (.dtd) as a copy and make the appropriate changes. The Path Art method allows you
to save only the elements that need to be repeated. This copy of the grouped elements is then able to be
imported into new or existing forms.

Although *.art files are imported using the Import Images feature within VisionDP, Path Art files are NOT
images. Once imported onto the form, they retain their formatting as form elements.

� How to create Path Art

1. Select desired element(s) on the form. To select multiple elements use the Grouping button OR hold
down the <SHIFT> key while selecting multiple elements.

2. Right click on the selected element(s) and choose Save as Path Art File... from the context menu.

3. Define a name for the *.art file in the Export Path Art window and click Save.

Once the Path Art file has been saved, it can then be re-imported into the same form or used in other
forms for later use.

� Import Path Art

1. With your form open, select the Import Image button.

2. From the Image Type drop-down in the Import Image menu, select Path Art File *.art.

3. Select the desired *.art file and select OK.

4. The Path Art will be placed on the form. All elements in the Path Art will be selected so that it may be
easily moved.

VisionDP provides pre-defined Path Art shapes that are available to be imported onto your form. Each of
these shapes were created using VisionDP's Path Draw tool and are formatted to be filled with Clear Dry
Ink. More information on Page 357
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Chapter 7

Personalized Documents

V ariable data can be placed on documents and formatted in VisionDP. User created variables may be
defined for counters or created from data to modify their values. These new variables can either be
placed on the form in a text box or used in Conditional Logic to add variable text, images, lines, boxes

or paths onto the form.

Importing Data
Data can be imported from any ASCII file. The data import function will invoke a wizard that will walk you
through the various parameters required to use the data file (the wizard is explained in full in this section).
The data file is used by VisionDP in order to define the data design layout.

Simple numerical data files can be created in VisionDP using the Create CSV Data Files menu. This feature is
useful when creating applications that require a numerical counter to be placed on the page, but you do not
have an existing data file with these values.

� To import a data file

1. Click the Import Data button from the Drawing toolbar, or go to the File menu and choose Import and then
Data.

2. Browse for the folder location that contains the data.

3. Select the file to be imported. Either double-click the file or select a file and click the Open button.

4. The Data Wizard will assist in defining the data formats.

Only a single data file can be imported per design.
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Data File Types
VisionDP accepts line (host-based),
delimited (database), and XML data files.
VisionDP will attempt to auto-detect most
of the attributes of a data file, but the
settings should always be checked for
accuracy.

Data File Type

The preview window allows the data to be
previewed in order to assist in the selection
of either database, line, or XML data file
types. Once the data file type has been
selected, click on the Next button to
continue through the Import Data Wizard.

� Data Base (Delimited) - Is created
from database programs. Each
data record is composed of a fixed number of data fields. The data fields are determined by a
delimiter, which is a special character that defines one field from the next. The field names of the
delimited file must be 127 characters or less. All field names must be regular alphabetic text or
alphanumeric (with at least one alphabetic character). It is recommended that the first letter be
capitalized, and the remainder of the field name should be lowercase. A common file type is .CSV.

� Line Data (Print Ready) - Is typically found on the mainframe. Since line data files are flat text files, a
record break must be defined. VisionDP supports fixed length records with either a user defined
record length, Printer Carriage Control (PCC) bytes, user defined hex characters, or a user defined
text string.

� XML - Is a grammatical system for constructing custom mark-up languages. This type of data is
organized into a tree structure, and is often used to describe and organize genealogical,
mathematical, chemical or business data. VisionDP treats XML in the same manner as a
delimited data file. Each field is defined and will appear in the data drop-down menu after the
data file is imported.
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Create CSV Data Files
The ability to create simple numerical CSV (Comma Separated Value) data is available within your
software. This ability is usually used to create data files that are used for numerical counter sequences. For
example, when creating a ticketing application where each ticket needs to be uniquely numbered with a
consecutive value, but you do not currently have a data file that contains these values.

� To Create a CSV Data file

1. With no forms open, select the Edit button and choose Create CSV Data… from the drop-down menu.

2. The Create Delimited Data File menu will open.

3. Name your new data file, the *.csv extension will automatically be added upon output.

4. Define the number of data records to be created.

5. To begin creating field names, start by typing the name of the new field.

� Initial Value: Define the initial value (beginning value).

� Increment: Define the increment value. Default value will be "1".

� Length: Entering a value will create a fixed length value, adding preceding 0's to the initial value.

For example: If the Initial value entered was '100' and the Length was defined as '6', the first
value in the sequence would be "000100"

6. Click ADD to add this new field to the data file.

7. Continue defining fields in the same manner, if desired.

8. Click Build File to create your data file. It will automatically be saved in the Data folder that is defined
in the current Resource Set.
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Importing Database Data
Database data must be further defined by specifying the field delimiter, text qualifier, or maximum record
length. By clicking the View Data button from the first window in the Import Data Wizard, it is possible to
view the entire data record while it is being imported. This makes it much easier to define the correct data
parameters during import.

Field Delimiters

� If the delimiter is a Tab, Colon, Semi - Colon, or Comma, then select the appropriate radio button.

� If the delimiter is another character, then that single character should be entered in the Other field.

� If the delimiter is a non-printable character, then enter a slash ‘/’ followed by the decimal value of the
character in the edit field to the right of the Other radio button.
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Database Delimited Parameters

� A Text Qualifier is used if any of the data has double or single quotes surrounding it. By selecting a text
qualifier, the quotes will not appear when your data is printed. By setting the text qualifier to (none), any
quotes in the data will remain intact.

� The Maximum Record Length must be set to at least the number of characters of the longest line in your data
file.

Importing Database Data without Field Names
If the delimited data file (e.g. csv) does not contain a header record of Field Names, this data can still be
handled by defining the names manually.

� To define Delimited data Field Names

1. Click the Import Data button, or go to the File menu and choose Import and then Data.

2. Select the desired data file.

3. The Data Wizard will appear. Select Data Base (Delimited) as the data type to be imported. Click Next.

4. In the Data Base Delimiter menu, select Comma as the delimiter.

5. Still in the Data Base Delimiter menu, select the Define Field Names button.

6. In the Data Base Field Names Definition menu:

� Add each field names by typing the field names one by one, clicking Add each time. Field names
must be entered in the order that they will appear within the data file. If you are unsure of the
correct order, click the View Data to see a preview of your data file.

� Remove field names by selecting the field name in the list and clicking the Delete button.

� To arrange field names that have already been entered, use the Up and Down arrows.



Importing Line/LCDS Data
Because line data files are flat text files, a
record break must be defined. VisionDP
supports fixed length record breaks,
Printer Carriage Control (PCC) byte
record breaks, user defined hex character
record breaks, user defined text string
record breaks, and search area record
breaks. If the page being designed is part
of a multi-page job, then further job
properties must be defined.

Define a Record Break Type

� Fixed Length - Records have a fixed Lines
Per Page value that can be specified to
denote the size of the record breaks.

� ASCII Value -The record break may be any single character except a null byte.

� Text String - A specific string of text reoccurs throughout the data to signal a record change. The text
string must be specified in the Text String field.

� PCC Bytes - The first column is reserved for printer codes such as page breaks, etc. Custom printer
controls can be assigned using the VFU (vertical form unit).

� Channel 1 On - A text match at the beginning of a line causes a skip to channel 1. This record break is
similar in function as a multi-byte PCC, where the PCC column can still be accessed for the document
design.

� Search Area - a text match found within the designated search area will serve as the record break. This is
similar in function to the text string record break. However, applying the search area function will cause
VisionDP to only use the defined text when it is found within the specified Search Area, even if that text
is found in other locations on the page. This method is only available once data has been defined and a
search area has been created. Then, the record break can be edited.

Unicode Data Support

If your Delimited or Line Data is in a Unicode encoding, VisionDP supports this with a Unicode check box
in the Import Data menu.

Without selecting this option, Unicode encoded data does not show and cannot be processed properly.
Unicode is a double byte character encoding, while not frequently used in some parts of the world (e.g.
USA), it is required in many places where the number of characters exceeds the limits of 256 in a single
byte character encoding.
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Job Properties

� If a multiple page job is being defined, and the same data record will be printed over multiple pages,
then you must define a starting record to indicate which page this will be in the job. For example, if you
are creating a 4 page job, and this is going to be page 3, then the Starting Record is 3.

� Define the Record Interval (typically the number of records for each set). For example, if the job contains
4 pages, then the record interval is 4.

Working with Printer Carriage Controls (PCC bytes)

PCC bytes can be assigned to a particular channel or to relative skips. VisionDP supports ANSI, IBM1403,
IBM1403A, and user defined PCC bytes.

Predefined (non-modifiable) PCC bytes are as follows: 0 (skip 2 lines), 1 (new page), + (same line),
- (skip 3 lines) and space (skip 1 line). These preassigned PCC bytes can not be reassigned.

If Channel Assignments are used, then defining line data fields is not allowed. Only a full record can be
placed on a page. Formatting of line data fields must be applied using the search area conditions as defined
on page 217. Database fields can still be defined and used even if VFUs have been assigned.
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Page Break

If the line data file has an ASCII Value or Text
String as the record separator, the Page Break
Options will need to be defined.

� Page break is on - Choose whether the page
break is on the first line of a record or the last
line of a record.

� Print portion of line - Choose which portion of
the line contains the page break to print. The
options are:

� Left if not empty

� Left

� Right

� Entire line

� None

� Multiple Breaks per Line - Select either Yes or No to define whether there will be more than one break per line.

� The Page Break Code is generated automatically by the page separator choices made or may be entered
manually.

Line Data Parameters

� Maximum eRecord Size should be entered in terms of Characters Per Line and Lines Per Page. A maximum record
size is assumed by VisionDP. If working with a sample of data rather than a complete data file, or if
using Fixed Length as a record separator, it is important to verify these values.

� Fixed Record Length (no cr/lf) -VisionDP supports data files that do not contain carriage returns or line feeds.
These files often appear to be a continuous line of data in a text editor. By selecting Fixed Record
Length (no cr/lf)when importing line data, VisionDP will display carriage return/line feeds at the
maximum character position. The characters per line must be set accurately.

� Prefix Data is data that contains a group of characters in the same column of every line that is used to set
formatting and positions. Prefixes are useful for data that has transactional information which does not
end on a fixed line number. If prefixes are used in the data file, then check the Prefix box and specify
the starting column and length of the prefix.

� The Data Overprint option allows interpretation of a carriage return as just a carriage return. If this option
is not selected, then a carriage return is interpreted as a carriage return, line feed.

� The Tab Spacing option allows the use of fixed increment tabs and the expansion of tabs to spaces in line
mode display. The tab interval must be specified.
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Data Definition Summary Window

The Summary window provides a list of the parameters given. Changes in parameters can be made by
clicking the Back button until the desired window is displayed. The Back button will not affect the other
previously set parameters which are saved unless re-entered. Click the Finish button if the information in
the Summary window is correct.

Search Area Record Breaks
Once the data file is imported and a search area is
defined (search areas are covered later in this chapter, on
page 158) you can edit the record break parameters to
create a search area record break.

� To define a search area record break

1. You will not be able to define this type of record
break during the initial import process. When the
wizard asks for a record break, define a text string
to serve as a placeholder.

2. Finish defining the data import specifications using
the data wizard.

3. Go to the data view window and define a Search
Area.

4. Go the Edit menu and select Data Settings.

5. Enable the Condition radio button.

6. Select the Search Area from the drop-down menu, and enter the search value into the equals field.

7. The data will now break whenever the defined text is found within the search area.
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Importing XML Data
XML data can be imported into VisionDP as well. The data wizard will display an outline of the tree, and
allow you to select where the data break will occur. Once the data is imported onto the form, it will be
displayed in the same data view interface as a delimited data file.

� To import an xml data file

1. Go to the File menu and select Import and then Data.

2. Choose the xml file that you want to import.

3. Select the appropriate record to serve as data break from the XML Data Record Break window.

4. Click Next to proceed through the data import wizard.

5. The Summary window will appear before the data file is imported into the form. This outlines all of the
previously defined specifications. Review the definitions for accuracy. If something needs to be
modified, click Back until the necessary information is displayed. Make changes, and click Next to
proceed through the remainder of the wizard. When everything is correct, click Finish to import the
data file.
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Working with Delimited or XML Data
VisionDP displays the current data record of either delimited or XML data in the Data View window on
the right side of the screen.

The Data View window can be closed to provide a full-screen view of the form. To open and close the data
view window, click the Toggle View Data Window button, located in the View toolbar.
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Delimited Field Definitions
When importing delimited data, the field names are extracted from the first line (or lines) of a data file. The
header record is used to identify individual fields of data. For example, if the data record appeared as
follows:

The first record would define the field names: Fname, Lname, Street, Secondline, City, State and Zip.

XML Field Definitions
When importing an XML data file, the field names will be defined from the data tree. These will then be
used as the individual data records when the data file is imported into VisionDP. Each data record will be
displayed on the right side of the screen, as well as in the data drop-down menu, in the same manner as a

delimited data file.
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Data Layout

Data Placement on Form

Placing data onto a static form is the initial
step in formatting data. Placement onto the
form is done on an individual field basis.
Individual data fields can be used multiple
times on a single page. All fields in the data
file do not need to be used.

� To place a data field onto the form

1. Select the field to be placed onto the
form from the data drop-down on the
Data View toolbar.

2. Click the left mouse key at the desired location on the form.

Combining Text and Data

Data and text can easily be combined in the text
editor to take advantage of word-wrapping,
alignments and other features.

� To place a data field into a text block

1. Enable the text editor by either creating a
new text block or double clicking the left
mouse button on an existing text block.

2. Position the cursor where the data field should be entered.

3. Select the field to be entered from the data drop-down menu on the Data View toolbar. The field name
will be entered into text preceded by $$ and with a trailing period. Once the editor is closed, the field
name will change to the actual data values.

When formatting a data field be sure to select the entire data field (preceding $$ and trailing .), or the
format change will not take affect.

When data fields are inserted in a text block, word-wrapping will occur dynamically upon merging the data
into the text.
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Viewing Data

By default the data view will be active, meaning that the actual data will be seen on the form rather than the
field name. The view can be toggled to view the field names or actual data.

� To toggle data view

� Click View Data from the View toolbar.

� To Preview Data Records

Tools are available to scroll through data records for preview purposes. To scroll through data records click
appropriate scroll key to scroll through data as follows:

Key Action

Rewind data to the first record

Scroll backward one record

Scroll forward one record

Fast forward data to the last record

In order to preview data records, Data View must be enabled.
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Working with Line Data
Line data is typically found on a mainframe and consists of data that has been formatted to print on a static
background. Line data was originally designed to be printed on line printers, which are limited in their
formatting capabilities. Page position, in many cases, was limited to vertical paper movement and affective
use of “spaces.”

VisionDP takes advantage of these line data file formats in its WYSIWYG interface. By using cut and paste
data placement techniques, data field definitions, and other functions, line data can easily be formatted and
integrated into the form design.

In the case of line data, the data drop-down menu will fill-in with “Entire Record” signaling proper
importation of the data. In the case of delimited data, the data drop-down menu on the data toolbar will
list the field names as explained in the previous section. In either case, user-defined variables will also
appear in this drop-down, following the field names.

View Line Data Window
In this view, a split-screen will
appear showing the static form in
one window and a record of the
line data in the other. The data side
of the window will show a grid in
the background denoting individual
characters.

� To view line data

1. Click View Line Data button
from the View toolbar.

2. Resize the data window as
needed by placing the cursor
over the left edge of the window and stretching to a new size. As the data window size increases the
form window will decrease.

When the entire record cannot be seen due to the size limitations of the data window, then use the scroll
bars to navigate the data record. The size of the window and the zoom percentage will be remembered
when a form is closed. Line data fields can also be defined so that the data window may be closed and data
placed using the data drop-down by field name. See page 155 for more detailed information.

Personalized Documents 153

�

View Line Data Example:

�



Line Data Placement
Placing data onto the static form is the initial step to formatting data. There are three ways line data can be
placed onto the form.

� Entire data record placement: The entire data record can be placed at the origin of the form in its
original format. In this case, all of the data would be in the same font and color.

� Selective data placement: Placing data onto the form is done by dragging areas of data from the data
window to the form window.

� Named data placement: Areas of data may be defined as a support type (area, database field, search
area, delimited field) and named. The field names may be placed onto the form the same way as
with a delimited data file.

� To place line data

1. Hold down the left mouse key while dragging the mouse over the area of data to be selected. The
selected data will appear highlighted.

2. Position the mouse over the selected data region. Hold the left mouse key down while dragging the
data to the form side of the window.

3. The data area will be placed at the top left corner of the data cursor.
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Defining Line Data Areas and Fields
When working with line data, there is an option to set-up areas of line data as “fields” similar to how one
would work with a delimited data file. This is helpful when creating a data-intensive document in which the
same piece of data is used in multiple places throughout the document. The user can then close the line
data window and continue working with data as they would with a delimited data file.

� To define line data areas and fields

1. Within the Data View window, (to the right of the screen) click and drag the mouse over the area of
data to be selected. The selected data will appear highlighted.

2. Right Click.

3. Select which type of data field will be defined from the context menu as follows:

� Define Data Area - Used to segment data area (can contain more than one line) for placement

� Define Database Field - Used to define a portion of a single line for conditional processing, data
driven graphics, or for placement.

� Define Search Area - Used to define line by line search conditions (defined later in this chapter).

� Define Delimited Fields - Used to extract information out of a single line of data.

� Define AutoSum Area - Used to define rows or columns of data for addition.

� Define Conditional Field - Used to search an area of line data for a condition to be true.

� Define Variable - Used to define custom fields and counters (discussed later in this chapter).

� Edit Fields - Used to edit defined fields
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Data Areas

More than one line of data can be defined as a Data Area. Entire Data areas can have a single font style and
color defined.

� To define a data area

1. Within the Data View window, highlight the desired area of data.

2. Right Click and select Define Data Area.

3. The Data Area window will appear. Enter the data area
name in the Name field.

4. Edit the data area parameters in the Starting and Ending fields
to change the field size (if different than what is drawn in
the Line Data Window).

5. Define any necessary field extractions.

� Enable the Extract check box.

� Define a separator. This will be
the character that VisionDP
looks for to split one field from
another, such as a space or dash.

� Enter the number of the field
that should be separated. If the
field contains the name, Jane
Jones, and you want to separate
Jane from Jones, you would
select field number 1. Jones
would be field number 2.

� This feature also allows you to
separate fields from columns of
data. By creating a multi-line data
area and defining a separator and
field, you can create a new data
area that contains only a portion
of the selected section.

6. Click OK to accept the defined
settings. The new field will now be available in the Field Name drop-down on your toolbar.
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Defining Database Fields

Only one line of data can be defined as a database field. Line data is defined as a database field for use with
conditional text and image functions, custom variable fields, and data driven graph creation.

The defined field name must be 127 characters or less. All field names must be regular alphabetic text or
alphanumeric (with at least one alphabetic character).

� To define a database field

1. Within the Data View window, highlight the desired area of data.

2. Right Click and select Define Database Field.

3. Enter the data area name in the Name field.

4. Edit the Database Field contents through the Starting Column, Ending Column and Line Number fields.
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Define Search Area Columns

Search area columns can be defined for line-by-line conditional formatting functions explained later in this
chapter.

� To define a search area

1. Enter the search area name in the Name field.

2. Edit the columns through the Start Column and
End Column fields. Each row will be searched.
The use of the search area is further defined
later in this chapter.

Define Delimited Fields

The define delimited fields feature is used to define fields from a single line contained in a line data file.
This is similar to the way that data is defined in a database file. Individual lines in the line data file can be
separated by delimiters, and defined into fields like a database file.

� To Define Delimited Fields

1. With the mouse pointer, select the desired
row of line data from the data window.

2. Right click the mouse, and select Define
Delimited Fields from the context menu.

3. Select the Field Delimiter type. The Field Delimiter
can be a tab, colon, semi-colon, comma, or
other specified delimiter.

4. Name the data field(s). The Add New Field icon
is the dotted box in the top-right corner.
The Delete icon is the red X in the top-right
corner. If the Named Fields is checked, you
must add one or more field names to this
list.

5. Click the OK button to accept the changes.
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AutoSum Variable

The AutoSum feature can be used in line data mode to add the contents of selected areas of data and store
them as a variable.

� To define AutoSum area

1. Highlight the desired area of line data.

2. Right click and choose Define AutoSum Area from the context menu.

4. The AutoSum Area window will appear.

5. Define the variable name, and starting and ending coordinates if different from the highlighted area.

If the contents selected for the AutoSum field are not numbers, the job will error out at this occurrence.

Commas and dollar signs cannot be included in an area defined for addition; decimals are allowed.
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Conditional Field Variable

Conditional field variables can be used in line data mode to search a defined area of line data for a
condition to be true and then assign that information to a variable. This operates in much the same way as
Define Search Area, but in this case a condition can be applied to obtain a value that is stored in a variable.

� To create a conditional field variable

1. Define a Search Area.

2. Highlight an area of line data.

3. Right click and select Define Conditional Field from the context menu.

4. The Conditional Field window will appear.

5. Assign a Name to the variable.

6. Verify that the Start and End column values are correct.

7. Select the Data Row Offset value. This is an offset from the row where the condition is first true. For
example, a value of -1 will assign the information from the previous row to the variable.

8. Define a condition.

9. Click OK.
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End Data Area

A Data Area End can be conditionally defined by using a Search Area to find a marker defining the point
where the Data Area is to end. A Data Area is defined by selecting an area in the data window. By
conditionally changing the number of lines in each data record for a Data Area field, more control is
possible over your line-mode data. In the following menu, you can see that the End Data Area checkbox is
the sole action possible when checked.

� How to define an End Data Area

1. Right click on the data area that has been placed on your form.

2. Select Format Data...from the context menu. The Data Properties menu will appear.

3. Click on the Set Condition tab.

4. Click the Add button to start defining a condition.

5. Once your condition has been defined, click on the Format button.

6. The Set Conditional Font window will appear. Check the box that says End Data Area.
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Edit Line Data Fields

Once areas of line data have been defined as
fields, there is an option to edit the defined
fields. The name of the field and the area
included in the field can be modified. Data
fields can also be deleted if not currently in
use in your form.

� To edit line data fields

1. Right click on the Data View window.

2. Select Edit Variables from the context
menu.

3. Select the data field to modify from the
Fields/Variables list by clicking the desired
name.

4. To change the name, double click on
the name and type the new name.

5. To change the item's positions, edit the
Start Position and End Positions fields.

6. Click the OK button.

� To delete a line data field

1. Right click over the line data window.

2. Select Edit Variables from the context menu.

3. Select the field to delete in the Fields/Variables list by clicking on the desired name.

4. Click the Delete icon (red X) in the top-right corner of the list.

5. Click the OK button
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Formatting Data
Formatting the data can be done once the data has been placed onto the static form. All operations are
done by selecting data from the form window and formatting as described.

Selecting Data Fields
In order to manipulate a data element, it must first be selected. VisionDP’s cursor will change to indicate
proper positioning in order to make it easier to select form elements. The various cursor shapes indicate the
type of element that the cursor is positioned over.

� To select data

1. Go to the Drawing toolbar and click Select Mode.

2. Position your mouse over the data to be selected and click the left mouse key.

Selected data will be displayed with selection handles. To select overlapping objects, it may be necessary to unselect all objects
prior to making selection.

Moving and Copying Data
It may be necessary to relocate a data element or copy a data field to another location once it has been
placed onto the form.

� To move a data element using the mouse

1. Select the data element(s) to be moved.

2. Position the mouse over the data and drag to a new location.

� To copy a data element using the mouse

1. Select the data element(s) to be copied.

2. Position the mouse over the data and drag to a new location while holding down the <CTRL> key.
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When moving and copying using the mouse, grid snap will affect the interval in which the element is moved
or copied. Grid Snapping is described in detail on page 64.

� To position data through the properties window

1. Select the data.

2. Select Data from the Format menu or click the right mouse button and select Format Data from the
context menu.

3. From the Size and Position tab of the Data Properties menu use the arrow keys to specify position (X and
Y coordinate). The X/Y coordinate for data represents the origin or top left corner.

The current unit of measure is shown in the Unit drop-down menu. Units of measure available are grids,
inches, centimeters and dots.

Deleting Data

� To delete data

1. Select the data element(s) to be deleted.

2. Press the <DELETE> key on the keyboard or right-click the mouse and select the Delete option.

Data Rotation
Data elements can be rotated by 90 degree increments.

Please see Rotate/Flip Images for additional information 133.

Font Selection
Multiple data fonts can be specified on each page with one font used for each data element. In the case of
delimited data, where multiple data fields are included in a text block, each individual field can be formatted.
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� To select data font

1. Select the data.

2. Choose font typeface and point size from the Text Format toolbar as follows:

� Choose typeface from the Typeface drop-down.

� Choose point size from the Point Size drop-down.

Icon Style

Underline

Bold

Italic

� To apply character styles

1. Select the data.

2. Click the Bold, Underline, and/or Italic buttons as desired.

Data Color

� To change the data color

1. Select the data.

2. Click the Palette button on the Format toolbar to select text color, or select Font from the Format menu
to choose color.

Line Spacing
Predefined line spacing options include single, 1.5 and double line spacing. The custom option allows other
line spacings to be defined in the Custom Line area.

� To define line spacing

1. Select the data to be formatted.

2. Select Data from the Format menu.

3. From the General tab of the Data Properties window, choose line spacing from the Line drop-down or
specify Custom line spacing.

The value shown in the Custom field is represented in the unit selected in the Unit drop-down box.
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Attach Data to Box/Circle/Center of Page
Data can be attached to boxes and circles on the static form. By attaching data to a box or circle, the user
simplifies later form modifications. This feature can be used to center data directly in the middle of a page,
as well. The data will remain attached during moving and resizing operations. The data cannot be moved
out of the box or circle unless it is detached first.

� To attach/detach data to existing box or circle

1. Draw a box or circle on the form where you want the data to be attached.

2. Select the data.

3. Click the Attach to Box/Circle button on the Text Format toolbar to toggle between attached and detached.

� To attach/detach data to an artificial box

1. Place the data in the desired location on the form.

2. Select Data Object from the Format menu, or right click
the data and select Format Data from the context
menu.

3. Enable the Attach to Box/Circle check box, located
under the General tab of the Data Properties window.

4. The following message will appear. Click Yes to have
VisionDP create a box for you.

5. Select the placement location and margin
specifications from the Placement and Margin
drop-down menus.

6. Click OK.

� To attach data to the center of a page

1. Select the data that you will attach to the page.

2. Either right click the data and select Tie Object from the context menu, select Tie Object from the Format
menu, or click the Attach to Box/Circle button from the Text Format toolbar.

3. If there is no box defined for the data to be attached to, the data will be attached to the center of the
page.
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Positioning Data in Boxes/Circles
Data can be positioned in boxes and circles once it has been attached. Data can also be repositioned using
the same procedure.

� To position data in box/circle

1. Select the data.

2. Click the Position in Box/Circle button on the Text Format toolbar.

3. A matrix will appear showing the nine locations available for positioning.

4. Click the left mouse button in the location where the data will be placed.

There are nine positions available for positioning: Top-Left, Top-Center, Top-Right, Center-Left,
Center-Center, Center-Right, Bottom-Left, Bottom-Center and Bottom-Right.

Positioning Margins

When positioning within circles, or rounded corner boxes, there are two different types of margins
available: squared and rounded.

� To select positioning margin
� Click Toggle Text Margins on the Text Format toolbar to toggle between squared and rounded margins.

There is a default set of attributes for each data element. For data this includes alignment, line spacing,
attached status, etc. Setting default data attributes causes future data elements to have these default
attributes.
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Scale to Fit Data in Box
When a data area is attached to a box, this feature allows the data font to be scaled down automatically if
the data cannot fit in the box using the defined font size. When this feature is enabled, the data will be
placed in the top-left corner of the box and scaled down to fit within the parameters of the box. This
feature greatly simplifies the design process for multi-up applications.

Resizing will only occur if the data needs to be reduced in width. If the data exceeds the height of the box,
scaling down will not result.

� To apply a data scale-down

1. Create a data area on the form.

2. Draw a box around the data area. The borders of the box can be set to zero line thickness to make the
box invisible.

3. Attach the data area to the box using the Attach to Box/Circle button. Or, select the data, right click, and
select Tie Object from the context menu.

4. Select the data, right click, and select Format Data from the context menu.

5. Access the General tab of the Data Properties window.

6. Enable the Reduce to Fit in Box check box.
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Data Border
Data border and fill can be defined in the Border/Fill tab of the Data Properties window. The border style,
thickness and color can be selected, corners can be rounded to user defined levels, and fill/shading can be
defined.

� To set a data border

1. Right click in the data area and select Format Data.

2. Select the Border/Fill tab from the Data Properties window.

3. Select desired border and corner styles. Selecting a border style of None will create a blue box on the
page that will not print.

All corners must have the same degree of roundness.

Data Alignment within a text block
When data is defined within a word-wrapped text block, empty lines are automatically removed, causing
non-empty data lines to move up higher in the text block. While this is a common need, sometimes Right
or Center alignment of the data block is needed without empty text lines disappearing. In order to use
these alignment settings in a text block where word-wrapping is removed, the column width of the data
block needs to be defined.

� Setting a Data Column for use with Alignments

1. Right click on the data block containing the data to be aligned.

2. Select Format Data. The Data Properties menu will appear.

3. Select the Size and Position tab.

4. Select the Use for alignments check box. When this checkbox is checked, the Column field may be edited
with a value depending on the current Unit. When the data block is word-wrapped, the Use for

alignments checkbox is not shown and the Column field shows the width of the column, but is not
allowed to be edited. Data alignments are only enabled when this checkbox is checked or when the
data block is word-wrapped.
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PDF Interactive Features
A PDF produced by VisionDP has the ability to have links and notes, using variable data or images as its
hot-spot. There are several different PDF Interactive Features available, named as follows:

� Page: Creates a link to another page in the same document.

� Destination: Creates a link to a named destination.

� External Page: Creates a link to a page in another PDF document.

� External Destination: Creates a link to a named destination in another PDF document.

� File: Creates a link to a non-PDF document.

� URL: Creates a link to internet or email address. Internet addresses must begin with http:\\ and
finish with a \. Email addresses must begin with mailto:.

� Notes:An note annotation is created. When the image or data is clicked in the PDF document,
a pop-up window appears with the specified note.

� To set PDF Interactive Features

1. Right click on the selected data (or the selected image) and select Format Data/Image from the context
menu.

2. The Data/Image Properties window will appear.

3. Select the PDF Interactive Feature tab.

4. Select the desired link type from the Type drop-down menu.

5. Each type has it’s own set of fields available. Fill all available fields with the appropriate information.

6. Click the ellipses (…) to browse for a file if the type is External Page, External Destination or the File option.

7. Select page number if applicable. Page numbering starts at 1.

Another PDF Interactive Feature is a Bookmark. Different than the previous listed items in that it is not
establishing any effects to be clicked on, but defines a Table of Contents type of listing within the PDF
document, with page locations, and control over the text, style and color of each entry in this listing. The
text may include variable information, using the $$field_name. structure. A hierarchical listing, the level
amount allows for defining sub-entries in the listing, when the level increases from the previous bookmark.
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Show Data as 2D Barcode
VisionDP allows you to format your data as six different types of 2D barcodes: PDF417, MaxiCode,
DataMatrix, Intelligent Mail Barcode, Aztec and QR Code.

2D PDF417 BarCodes

VisionDP can be used to create 2D PDF417 BarCodes. PDF417 BarCodes store a large amount of data
(around 2000 characters) in a symbol, which can be read and decoded by a 2D scanner. PDF417 BarCodes
are an industry standard for encoding data and are supported by every printer. In VisionDP, data can be
dropped onto a form and converted to a 2D BarCode. Compression, error level, row, column and aspect
can then be set to user-defined levels.

Data converted to a 2D BarCode will appear as a shaded data area within VisionDP, but it will print as a 2D
BarCode.

� To show data as a 2D BarCode

1. Select data on form.

2. Right click on data and select Format Data from the context menu, or from the Format menu select Data
Object.

3. From the Data Properties dialog box, select the 2D Barcodes tab.

4. Choose 2D BarCode (PDF417) from the Show Data As drop-down menu.

5. Set the Compression, Error Level, Rows, Columns and Aspect as desired.
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Show Data as MaxiCode 2D Barcode
Data can be encoded as a MaxiCode 2D BarCode. MaxiCode is an international standard symbol used for
package sorting and tracking, most importantly as the standard shipping barcode for UPS. The symbol
consists of two messages: the primary message, which encodes the postal code, country code, and the class
of service number and the secondary message, which encodes address data or some other information.

� To show data as MaxiCode

1. Select data area on form that is to be transformed into a 2D BarCode.

2. Right click on data and select Format Data from the context menu, or from the
Format menu select Data Object.

3. From the Data Properties window, select the 2D Barcodes tab.

4. Choose MaxiCode from the Show Data As drop-down menu.

5. In the MaxiCode Options area, select a Mode form the drop-down menu. The seven
modes have the following functions:

Mode 0 - The primary message is a Structured Carrier Message and the secondary encodes up to 84
uppercase characters, numeric or punctuation.

Mode 1- The primary and secondary messages together encode up to 93 uppercase characters, numeric
or punctuation.

The functionality of Modes 0 and 1 has been taken over by Modes 2 and 3. Modes 0 and 1 should only be
used by existing MaxiCode users with only Mode 0 and 1 capability.

Mode 2 (US Carrier)- The primary message encodes numeric postal codes up to nine digits in length, and
the secondary message encodes up to 84 characters.

Mode 3 (International Carrier)- The primary message encodes alpha-numeric postal codes up to six digits
long, and the secondary message encodes up to 84 characters.

Mode 4 (Standard Symbol)- The primary and secondary messages combined can be used to encode up to
93 characters. This useful for encoding information for applications other than shipping.

Mode 5 (Secure Symbol)- The primary and secondary messages combined encode up to 77 characters with
more error correction than Mode 4.

Mode 6 (Reader Program)- The primary and secondary messages combined encode up to 93 characters for
the purpose of programming barcode readers.
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DataMatrix
DataMatrix is a two-dimensional barcode that can store from one to about 2,000 characters. The square
symbol can range from .001 inch per side up to 14 inches per side, and about 500 characters can be encoded
in a 1 inch square. DataMatrix is often used to encode product and serial information and to identify items
during manufacturing.

� To show data as a DataMatrix BarCode

1. Select the data on the form to which the DataMatrix barcode will
be applied.

2. Right click the data and select Format Data from the context menu,
or from the Format menu select Data Object.

3. From the Data Properties window, select the 2D Barcodes tab.

4. Choose DataMatrix from the Show Data As drop-down menu.

5. Enable the Square Symbol check box to create a square barcode. If you leave the box unchecked, a
rectangular barcode will be created.

6. Use the Scale % box to adjust the size of the BarCode.

7. Click OK to apply the specification.

AZTEC
AZTEC is a type of two-dimensional barcode, named because the center of the code resembles an Aztec
pyramid. This type of barcode has the ability to use less space to encode information than other matrix

barcodes because it does not require a surrounding blank “quiet zone” area.

Two options that are supported are (1) Binary mode: which encodes non-ASCII characters (in range
128-255) more efficiently; and (2) Correction level, in range 0 to 35, which provides for increased recovering

of scan errors by using a less density of encoding.

� To show data as an Aztec BarCode

1. Select the data on the form to which the AZTEC barcode will be applied.

2. Right click the data and select Format Data... from the context menu.

3. From the Data Properties window, select 2D Barcodes tab.

4. Choose Aztec from the Show Data As drop-down menu.

5. From your knowledge of the data that will be encoded, determine the

Binary mode and Correction level.

6. Click OK to apply the specification.
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Intelligent Mail Barcode
The USPS 4-State barcode is the next generation barcode used by the U.S. Postal Service, replacing PostNet
barcoding. It consists of a field placed on the page containing tracking data, as well as the zip code (routing
code) information defined within the 2-D Barcode dialog box. The tracking data must have 20 digits of
information, defined as: 2 digit Barcode Identifier, 3 digit Service Type Identifier, 6 digit Mailer Identifier,
and a 9 digit Serial Number. The zip code is supported in the following formats: (1) empty, (2) 5 digit ZIP
code, (3) 9 digit ZIP+4 code, or (4) 11 digit ZIP+4 + 2 digit DPC.

An alternate format for the data is supported, used when a data field contains 65 characters ready for direct
placement onto the page using a USPS 4-State barcode font. By checking the USPS 65 Characters checkbox,
VisionDP will bypass the use of a font and draw this barcode onto the page using this processed
information.

� To show data as an Intelligent Mail Barcode

1. Select the data on the form to which the Intelligent Mail Barcode will be applied. This may either be
a 20 digit tracking-code (supplied by the Post Office), or a 31 digit tracking-code and zip-code.

2. Right click on the data and select Format Data from the context menu, or from the Format menu select
Data Object.

3. Access the 2D BarCodes tab on the Data Properties menu.

4. Choose Intelligent Mail BarCode from the Show Data As drop-down menu.

5. Define Routing Code and Alignment options from their drop-down menus in the Intelligent Mail BarCode
Options. In the case of 31 digits, click on Routing-Code is last 11 digits of Tracking-Code. Otherwise, use the
drop-down menu to select the select the zip code data field.

6. Click OK to apply the specifications.

Intelligent Mail, QR Codes, MaxiCodes, and Aztec Barcodes can be mirrored (flipped horizontal/vertical)
by going to Tools > Rotate > and then choosing either Horizontal or Vertical.
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QR Codes
QR Codes are two-dimensional barcodes that store more information than traditional barcodes and can
include URLs or PURLs that are accessed quickly using a webcam or camera phone with a QR Code Reader
application. VisionDP provides easy to use templates to create variable QR Codes. These templates include:
Web Site, Bookmark, Phone Call, Send SMS, Send Email, vCard, Geographical Coordinates, Calendar, and
meCard.

� To create a QR Code

1. Select data on the form.

2. Right click the data, and select Format Data from the context menu.

3. Access the 2D BarCodes tab of the Data Properties menu.

4. Choose QR Code from the Show Data As drop-down menu.

5. Click on the QR Code Templates button and choose a template from the
drop-down menu. Enter information in the appropriate fields as necessary.

� Web Site: Add a website.

� Bookmark: Add a website that will be bookmarked for later reference.

� Phone Call: Enter a phone number to initiate a phone call.

� Send SMS: Enter a phone number and a message to be sent through Text message.

� Send Email: Enter an email address along with a subject and message to be sent
through email.

� vCard: Enter business card information.

� Geographical Coordinates: Enter geographical coordinates to initiate Google Maps.

� meCard: Enter personal information.

� Calendar: Enter subject and date/time for an event.

6. In the QR Code Options section, define (Optional):

� Scale: Define the size of the QR code by %.

� Version: Specify version of QR Code (1-40)

� Error Correction: Highest, Least, Medium, Medium-High

� Mask Pattern: Specify which mask patterns to be used (1-8 available).

7. Click OK to apply the specifications.

When creating simple QR Codes that are limited to black and white with minimal scaling, a faster method
of composition can be used by going to Edit > Preferences > and selecting the Use Alternate QR Code Encoder in PDF
option.
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Data Flow
A data area (e.g. a frame) can be made to transfer data from one frame to another. When data is too large to
fit in the frame, the excess will dynamically flow into the next defined frame. One or more frames can be
attached to the primary data area, and all linked frames will be displayed with a number in the top left
corner to show the order in which they are linked. Using this feature, data can be made to form columns or
to wrap around an image.

� To activate data flow

1. Select the area of data that will flow into the next frame.

2. Click the Create New Frame button.

3. Click the left mouse button and drag to create a new frame of the desired size and position for the
data to flow into.

4. Release the mouse to conclude the drawing of the frame.

Relative Form Object Placement
Form items can vertically float to accommodate differently sized images and data blocks to which they are
attached. Element 1 must be a variable image or data/text block.

� To attach a relative form item

1. Select the item, such as a conditional text block or a conditional or data-driven image, to which the
relative item will be attached.

2. Click the Attach Relative Item button.

3. Select the item that will be attached as a Relative Form Item.

4. Notice that a purple number will appear in the top left corner of the attached items. This number
denotes the order in which the items are attached.

5. Multiple relative form items can be attached, either one at a time or by selecting the group, naming a
master object, and clicking the Attach Relative Item button. The selected items will be relatively attached
to the master item.
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Edit Data File
The Edit Data window allows the ability to change the attributes of the data file that was initially imported
into the form or to re-import a new data file without deleting or changing the defined fields already
implemented. There are two sets of data windows, one is for line data and the other one is for database
data.

Edit Line Data Parameters

� To set data parameters

1. Select Data Settings from the Edit menu to open the Data Edit window.

2. Select the Data Parameters tab on the Data Edit window.

3. To import a new data file click the ellipsis button (...) adjacent to the Data File field, and select a new
data file from the Choose Data File window.

4. Edit the record separator by selecting either Fixed Length, ASCII Value (enter a character, or a decimal value
of an ASCII character preceded by a slash (e.g. /62)), Text String (enter text in the adjacent box), or PCC
Bytes (specify VFUs for user specified channel assignment).

5. To change the maximum record size edit the Characters Per Line and Lines Per Page fields.

6. Check or uncheck the Prefix check box as desired. When the prefix box is checked the Start and Length
of the prefix must be specified.
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When changing data files, all aspects of the new data file are expected to be the same as the original data. If
they are not, re-import a data file through the Import Data toolbar button.

� To edit the page break

1. Select Data Settings from the Edit menu and then open the Data Edit window.

2. Open the Page Options tab of the Data Edit menu.

3. If working with an ASCII Value or Text String as the record separator, set the Page Break options as follows:

� Page break is on -Choose whether page break is on first line of record or last line of record.

� Print portion of line -Choose whether to print information left of page break, right of page break,
entire line or none.

� End Portion of Page Break Line - Choose whether to ignore multiple page breaks per line or to start a
new page with each page break.

� The Page Break Code is generated automatically by the page separator choices made or may be
entered manually.

4. Set the Starting Record of the data file to be displayed in VisionDP.

5. Set the Record Interval in which the records will skip.

6. Set the Tab Spacing option as desired. Tab Spacing allows the use of fixed increment tabs and the
expansion of tabs to spaces in line mode display. The increment of spaces for each tab must be
specified.

7. Click the OK button to accept the changes.
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Edit Delimited Data Parameters

� To edit delimited data file parameters

1. Go to the Edit menu and select Data Settings.

2. To select a new data file click the ellipsis button (...) adjacent to the Data File field. Select the new file
from the Choose Data File window.

3. To change the field delimiter, enter a character or a decimal value of an ASCII character preceded by
a slash (e.g. /62) in the Delimiter field.

When changing data files, all aspects of the new data file are expected to be the same as the original data. If
it is not, re-import a data file through the Import Data toolbar button.

4. Edit the Text Qualifier from the drop-down menu.

5. To edit the Maximum Record Length, enter a new value.

6. Click the OK button to accept the changes.
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Edit XML Data Parameters

� To edit XML data parameters

1. Go to the Edit menu and select Data Settings.

2. The Data Parameters window will appear.

3. If necessary, use the Data File ellipses (...) button to browse for a new data file.

4. If necessary, select a new record break from the XML data tree.

5. Click OK.
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Microsoft Mail Merge
Microsoft Word mail merge documents can be instantly converted to VisionDP fields using the Change
«Names» to Fields function.

� To convert «Names» to VisionDP fields

1. Import the data file.

2. Import the document in a .TXT, .RTF, .DOCX format.

3. Right-click and select Change «Names» to Fields from the context menu.

All «Names» will be converted to the VisionDP field name format ($$names.) in the selected data block.
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Conditional Logic
VisionDP supports complex conditional logic functions, and allows users to create conditional text, images,
form objects (lines, circles, boxes and paths) and background images. Conditional text and images are
created by drawing a conditional area onto the form and then defining the necessary conditions.
Conditional form objects and background images are created by drawing the static image onto the form or
importing the background image, and then applying conditions to those elements.

“If ” logic is used to create conditions, and text, images or form objects are defined as a result. If a
condition is met, the result is displayed. “Else” logic, nested conditions and AND/OR conditions can also
be used to further drive conditional logic.

Conditional Text and Images

Creating Conditional Text or Graphic Areas

A conditional text or graphic area must be drawn to specify the placement and size of the text or graphic
on the form.

� To draw a conditional text area

1. Select the Conditional Text button.

2. Click the left mouse button and drag the mouse to draw the text field box.

3. The Format Image window will appear. Access the Conditions tab.

4. Define a text condition.

� To draw a conditional image area

1. Select the Conditional Image button.

2. Click the left mouse button and drag the mouse to draw the area of the graphic.

3. The Format Image window will appear. Access the Conditions tab.

4. Define an image condition.
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Conditional Background Images
Conditional background images are created in a slightly different manner than a regular conditional image.
You must first import the background image onto the form, and then define the conditions from within the
Image Properties window.

� To create a conditional background image

1. Import one of the images that will be used as a conditional background image onto the form. If you
would like to use a low resolution image for viewing and a high resolution image for printing, define
those images now.

2. Right click the image. You will have to enable background mode from the Edit menu in order to select
the background image.

3. Select Format Image from the context menu.

4. The Image Properties window will appear. Access the Conditions tab.

5. Define the necessary conditions and click OK to save the conditions and return to the form.

Conditional background images cannot be resized once they are on the form. All background images must
be the correct size before they are imported.

Conditional Form Objects
A conditional form object must first be drawn on the form. Conditions can then be specified through the
Line, Box, Circle or Path window.

� To create a conditional form object

1. Draw a form object (box, circle, line or paths).

2. Right click the form object, and select Format Box, Circle, Line or Path from the context menu.

3. Access the Conditions tab.

4. Click Add to begin creating conditions.

5. Click the Format button to define thickness, color, or box roundness.

6. When all conditions are created, click OK to save the tree and return to the form.

Detailed instructions for creating conditional logic are defined in the following pages.
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Building Conditional Logic
A conditional statement must be formulated by a true or false statement, resulting in a designated output,
based upon that condition.

� To add conditional logic statements

1. Click the Add button to open the Add Condition window.

2. Select from the Field drop-down if applicable. This conditional variable classification drop-down menu
allows variables to be sorted as either Field, Variable, System Variable, Page Overflow (line mode only) or Job
Conditions. Selecting one of these classifications from the menu predefines only those variables of the
specified classification in the If: drop-down menu.

� Field: The variable field names defined in the data record.

� Variable: Customized variable fields (concatenated, incrementing, etc.)

� System Variable: One of the built-in System variables pre-defined in the drop-down menu. (These
variables will only be available in the drop-down menu if the Include System Keywords in Field List is
checked on the Data tab of the Preferences window.)

� Page Overflow (line mode only): This can be used for line mode applications (like a billing statement)
where a data record can flow for a variable number of pages before the next record break.

� Job Conditions: Job conditions can be set in order to apply special formatting at the end of sets or at
the end of the entire job.

3. Choose to create either an If or an If Not statement by enabling the appropriate radio button.
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4. Choose a field from the If/If Not edit box.

5. Choose a function (=, >, <, >, <, not equal to, contains).

6. Choose a field or enter a value into the drop-down menu to set the condition.

7. Specify whether the variable that sets the condition is a Number, Text, or Logical.

8. Click the OK button to accept.

Key Function

equal to

greater than

less than

greater than or equal to

less than or equal to

not equal to

contains
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AND/OR Conditions
AND/OR conditions can be used as a simplified alternative to nested conditions. The AND condition is
the equivalent of a simple nested condition, and the OR condition is the equivalent of an else-if statement.

� To add AND or OR conditions

1. After adding the primary condition in the Conditions tab of the Data Properties window, click the Add AND
or Add OR button to open the Add Condition window. The order of the AND/OR conditions is important to
the logic, since they will be evaluated in sequential order.

2. In the Add Condition window, set the condition by selecting whether to create an If or an If Not statement
and choosing a field, function, and variable value. For a complete description of what each variable is
specifically for, please see page 184.

3. Choose number or text for the variable type.

4. Click OK to accept the conditions.

To aid in the design process, AND conditions will always be displayed with a red diamond, and OR
conditions will always be displayed with a green diamond.
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Nested Conditions
Nested conditions are used in circumstances where a condition is set after a primary condition. This
primary (parent) condition can have nested conditions (children) that will be evaluated when the primary
condition is true.

� To add a nested condition

1. After adding the primary condition in the Conditions tab of the Data Properties window, click the Add Nested
Condition button to open the Add Condition window.

2. In the Add Condition window, set the condition by selecting whether to create an If or an If Not statement
and choosing a field, function, and variable value.

3. Choose number or text for the variable type.

4. Click OK to accept the conditions.
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Final Else Conditions
Setting the Final Else condition allows text or images to appear when the prior conditions set are not met.
Without a final else condition, nothing displays if all conditions are not met.

� To add an else or nested else condition

1. Select a statement on the conditional tree in the Conditions tab of the Properties window.

2. Click the Add Condition button.

3. Select the Final Else check box at the top of the window.

4. Click OK to accept.

Editing Conditional Statements
Once defined, conditional statements can easily be edited.

� To edit a conditional statement

1. Right click the conditional image and select Format Image from the context menu.

2. Select the conditional statement from the Conditions Tree.

3. Click the Edit button.

4. Edit the statement and click OK to save the changes.
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Use the up and down arrows located at the bottom right of the Properties window to shift conditions
around within a condition tree.

Copying and Pasting Condition Trees
It is possible to copy an entire condition tree and paste it into another location on the form. This is a great
time-saving feature, and also reduces the amount of error that could occur when trying to duplicate a
condition tree exactly.

� To copy and paste an entire condition tree

1. Select the conditional area on the form.

2. Right click and select Copy from the context menu.

3. Select a data field, or a conditional image/data field.

4. Right click again and select Paste from the context menu.

5. The currently displayed conditional element will be copied. Move it to where you want it on the form.
It will be an exact duplicate of the original.

Displaying Conditions

You can display all the conditions currently defined on a page in the View Conditions window.

� To view conditions

1. Go to the View menu and select Data Conditions.

2. The View Conditions window will appear. All the conditions used on the page will be listed here.
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Conditional Text Blocks
When creating conditional text statements, the
text will only appear if the logic statement is
true. Text can also be imported from other
applications, such as MS Word, to be used in the
conditional statements.

� To create a conditional text block

1. Select the Conditional Text button and draw an
area on the form where the conditional
text is to be placed.

2. Click Add to start adding conditional
statements

3. Highlight the conditional statement to
which you will add the conditional text.

4. Click the Text button.

5. Type in the text, import text, and insert
database fields as necessary.

6. Click OK to save the conditional text.

Text imported into the conditional text window will replace any pre-existing text. It is recommended to
import the text file first, then add any additional text or database fields.

Format Text
Font formatting can be applied to conditional text. The font type, style, point size, color and underline can

be specified. The entire text block can be changed, or just a particular portion selected and specially
formatted.

� To format the conditional text

1. Right click on the conditional text block and select Format Data Condition.

2. Highlight the area of the text that you want to format.

3. Use the text formatting buttons at the top of the conditional text window to format the text.

4. Click OK to save the formatting and return to the form.
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Conditional Text Mail Merge
Conditional text that has been imported from a Word document can be mail merged within a conditional
text block.

� To perform a conditional text mail merge

1. Create a conditional statement.

2. Import a .txt, .docx, or .rtf mail merge document into the Conditional Text window by clicking the Import Text
button.

3. Highlight the text within the Conditional Text window.

4. Click the Change Names to Fields button.

Editing Conditional Text
Conditional text can be quickly edited on screen using the text editor. The changes made on screen will be
reflected in the text displayed in the Conditional Text window as well. Only the conditional text that is
currently displayed can be edited from the screen. To edit the other conditional text, scroll through the data
and edit each as it is displayed, or open up the Conditional Text window and make necessary edits from
within that menu.

� To edit conditional text on screen

1. Double click the conditional text that is displayed on the form, or right click and select Edit Text from
the context menu. This will open up the text editor.

2. Make necessary text edits.

3. Exit out of the text editor by clicking elsewhere on the form.

4. Click Save to save the changes.

� To edit conditional text using the conditional text window

1. Right click the conditional text box.

2. Go to the Conditions tab.

3. Expand the conditional statement that you want to edit.

4. Select the conditional text.

5. Click the Edit button.

6. Make necessary edits to the conditional text and click OK.

7. Click OK again to save the edits and return to the form.
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Conditional Images

Conditional images can be imported through the Image Properties window.

� To Create Conditional Images

1. Click on the Conditional Images button and draw an area on your form where the image is to be placed.

2. The Image Properties menu will open up to the Conditions tab. Click Add to start defining conditions.

3. Select the defined condition, and then click the Image button to select the appropriate image files.
There will be options for a display image, and also a printing image.

4. The image selections will be listed under the qualifying condition in the condition tree.

5. To define additional conditional images, select the first conditional statement, and then click Add to
repeat this process.

It is not required to select both a viewing and a printing image. If there is only one version of the image
and you would like to use it for viewing and printing, then there is no need to specify a particular printing
image. It is more efficient, however, if you are working with large image files, to specify a low res .jpg for
viewing and a high res .jpg for printing.
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Conditional Data Driven Images

Conditional data driven images can be defined in the Image Properties window. The Conditional Data Driven
Image Name window allows the concatenation of a field name with an image extension, which results in a
conditional image that will appear based upon a field definition in the data.

� To create a conditional data driven image

1. After defining a conditional image statement, click the Image Field button.

2. Select the field that contains the data-driven images.

3. Type in the file extension if the data file does not already contain the file extension. Make sure that
the concatenated field is formatted to read $$data..extension. There must be a complete file extension
and a complete field included for the conditional data driven image to work.

4. Click OK to return to the form.
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Search Areas and Conditional Line Data Formatting
A line data area that has been placed onto the form can be conditionally formatted. The condition will
affect the entire line of data where the condition is found true. The line of data can be conditionally
formatted to undergo both font and color changes.

Defining Search Area Fields
A Search Area Field must be defined before a line by line conditional statement can be created. The Search
Area Field defines the columns that will be evaluated in the conditional statement. VisionDP will use the
column(s) defined by the Search Area Field to evaluate the conditional logic statement. If the conditional
logic statement is true, then the entire line of data containing the condition will be affected. The Search
Area Field will not be displayed in the data drop-down menu on the data view toolbar since it is only used

for setting line by line search conditions.

� To define a search area field

1. Select the starting and ending column of data in the line data view window, located on the right side
of the screen.

2. Multiple lines can be selected, but despite row selections all lines in the data record will be searched.
Only the column values are used.

3. Enter the Search Area field name and verify or change the starting or ending column values.

4. Click OK to accept.
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Applying a Search Area Condition
Line by line formatting can be applied by using the
Search Area Field and conditional logic. The search area
field must be specified after the If condition. The
second value/field can not be a search area field name.

� To apply a search area condition for line by line
formatting

1. Right click on the Data View window and select Define Search Area Field.

2. The search area will become highlighted within the Data View window. Select the search area and drag
it onto the design.

3. Select the data that has been placed onto the form, right click, and select Format Data from the context
menu.

4. Access the Set Conditions tab, and click Add.

5. The Add Condition window will appear.

6. Choose a field to begin the If statement. Only fields set as Search Area Fields will be displayed in this
drop-down menu.

7. Select the function: =, <, >, etc.

8. Enter a value or database field to search for. Click OK to save the statement.

9. Add AND and OR conditions as necessary to properly define the condition.

10. Click the Format button. This will cause the Set Conditional Font window to appear.

11. Choose how the data line will be displayed when the condition is met.

12. If you would like the data to always be displayed in the same font as defined in the preceding
condition, enable the Use Current Font check box.

13. If you want the line on which the search condition is found true to not print, enable the Do Not Print
check box. This will cause the line to not print, and the following lines to be shifted up so that there
is no blank space.
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14. Click OK to save the conditional formatting.

Custom Variable Fields
VisionDP allows the user to create variable fields, based off of information in the data record. These
variable fields can be used to perform concatenations, calculations and transforms and to create conditional
variables.
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Concatenated Fields
Concatenated fields are made up of text
and/or data fields, and may contain multiple
data fields. One use of the concatenated field
is to call data-driven images form the Images
directory. Use the image's suffix (e.g. .jpg) and
the field name that contains the image names
in the data file, to create one variable field that,
when placed on the form, will cause the
defined image to appear. See more about
data-driven images on the following page.

� To create a concatenated field

1. Import a delimited data file, or, if using
line data, define database fields.

2. Select Field Settings and choose Define
Variable from the Edit menu.

3. Select Concatenated Field from the Type
drop-down menu.

4. Name the field. This name will be listed in the data drop-down menu.

5. Add the desired data fields by selecting them from the Field drop-down menu.

6. Add any necessary text.

7. Define extractions and transforms if desired. The following pages outline in detail how to perform
these functions.

8. Click OK to return to the form.
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Data-Driven Images
If the data file contains the name of an image file, this data
can be dropped onto the page and treated as an image. If
the data file contains just a partial name, you can use the
concatenated variable field to add on the missing part of
the name, usually the suffix (e.g. .tif or .jpg). Once the
image name field is placed onto the form, VisionDP will
query the user as to whether the field is an image name or
just a regular data field. Answer that it is an image name
and the image will be shown. This is known as a data-driven image. As the contents of the field changes
from record to record, the image will also change. Be sure that all possible image files are added to the
Additional Resources node in your job tree, allowing an archive to be created with these files stored in the
zip file.

� To format Data-Driven Images

1. Ensure your data file has the correct names of the images to be called onto your form, and all image
names referenced in the data file are located in the Images folder that is defined in your resource set.

2. Use the Select Field Name drop-down menu to select the defined field that contains the image names and
place it on the form.

3. VisionDP will ask you to verify that the variable field placed on the form is an image file, select Yes.

Data-Driven Text
If a field within your data contains text file names, this field can be dropped onto the form and the contents
of this text file will be shown. If the data field contains a partial file name, you may modify this field by
creating a concatenated variable with the complete text file name formatted. When this text file field is
placed onto the form, VisionDP will notice that the field contents matches a file that exists in the Data
folder. The user will be asked to verify that the field contents is a text file name or if it is just a normal data
file. Once verified, the contents of this text file is displayed on the form. Other than the column width,
font, size and style being defined, no other formatting is permitted on this text. This is known as a
Data-Driven Text.

� To format Data-Driven Text

1. Ensure your data file has the correct names of the text files to be called in and all text files referenced
in the data file are located in the Data folder that is defined in your resource set.

2. Use the Select Field Name drop-down menu to select the defined field that contains the text file names
and place it on the form.

3. VisionDP will ask you to verify that the variable field placed on the form is an external text file, select
Yes.
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Incrementing Variable
The Incrementing Variable function (counter) counts the data records, using a user defined increment, and
displays an optional prefix and suffix along with the numeric value of the incrementing variable.

This function can be used to generate page numbers as well. The prefix "Page" could be set with a defined
increment of "1" to display one page number on the form per data record.

� To create an incrementing numeric variable

1. From the Edit menu, select Field Settings and choose Define Variable. If using line data, it as also possible to
right click the data and choose Define Variable Field from the context menu.

2. Create a Name for the variable field.

3. Select Incrementing Variable from the Type drop-down menu.

4. In the Start box, indicate which number to start the count with.

5. Define the Increment by which the counter will increase.

6. Add the desired Prefix and/or Suffix.

7. Define Transforms as necessary.

8. Click OK.
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Incrementing Text Variable
The Incrementing Text Variable function will count each
data record using a set increment and then add zeroes to
the left of the variable number to create a number with a
defined character length. This is useful when creating serial
numbers based upon a record count and starting numeric
value. A prefix or suffix can also be added to the variable.
The added prefix or suffix will not be recognized as part of
the defined record length and will not affect the variable or
preceding zero values.

� To create an incrementing text variable

1. Import a delimited file or define a database field from
a line data file.

2. From the Edit menu, select Field Settings and choose
Define Variable.

3. Enter a name for the new variable field. This name
will appear in the data drop-down menu.

4. Choose Incrementing Text Variable from the Type drop-down menu.

5. In the Start box, specify the number with which the counting
will begin.

6. Define the increment by which the numbers will progress.

7. Add the desired Prefix and/or Suffix if necessary.

8. Specify the character length of the desired counter. If you
choose a length of 3, and the counting begins with the
number 1, your counter will look like 001, 002, 003...100, 101
etc.

9. Define transforms as necessary.

10. Click OK.
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Variable
The Variable function allows new fields to be created from information already existing in the data file. This
function can be used to apply case and barcode transforms, as well as to extract portions of pre-defined
fields.

� To create a variable

1. Import a delimited data file or define a database field from a line data file.

2. From the Edit menu, select Field Settings and choose Define Variable.

3. Select a name for the variable.

4. Choose Variable from the Type drop-down menu.

5. Select which pre-existing field will be modified to create the new variable. Select this field from the
Field drop-down menu.

6. If performing a data extraction, define the type of extraction (by length or by separator). If by length,
define the beginning position and the length. If by separator, define the character that will serve as
the separator and which field will be separated.

� For example, you have a name field that is made up of a person's first and last name:

Jimmy Smith

� You want to extract the first name to make a field called Fname, containing only the name
"Jimmy".

� You set the separator as the space (actually use the space bar and type a space into the separator
field), and, since you want the first portion of the name, you set the field to be 1. If you were to
want the part that comes after the separator, "Smith", the field would be 2.

7. If performing a case transform (upper, title, or lower case), select which case you desire from the Case
drop down menu.

8. If performing a barcode transform, select the barcode type from the Barcode drop-down menu.

9. Click OK to save the new variable and return to the form. The new variable will now be listed in the
data drop-down menu.

User-defined variables created are available for use on the page that is active when the variable is defined.
For information on synchronizing variables on all pages within a project, see page: 244
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Barcode Transforms

1D traditional barcodes can be created by transforming the data into characters recognized as a barcode,
and then applying the desired barcode front. Barcode fonts come free with VisionDP and are readily
available for you to use. The following barcode transforms are available and can be performed by creating a
new variable: 2OF5, CODE39, CODE128, EAN128, EAN8, EAN13, POSTNET, UPCA.

2OF5 2OF5 transforms are available with checksum information encoded in the barcode and without.

Standard Code 39 Standard Code 39 is limited to upper case letters, numbers, and characters: space * - $ % . / +

Full ASCII Code 39 Full ASCII Code 39 has no character limits, but creates larger barcodes. Choose the appropriate barcode
transform expected by your barcode scanner.

� To perform a barcode transform

1. Right-click on the Data View window and choose Define Variable.

2. Name the new variable.

3. Select Variable from the Type
drop-down menu.

4. Select the field to be transformed
from the Field drop-down menu.

5. Choose the desired barcode type
from the Barcode drop-down
menu.

6. Click OK to save the variable and
return to the form.

7. Select the newly defined variable
from the Field Name drop-down
and place it on your form. With
the variable selected, choose the
appropriate barcode font. You
must apply a barcode font to the
variable in order for the barcode
to be correctly displayed.
VisionDP includes a WASP
barcode library, containing fonts
for 2of5, Code39, Code128, and EAN 1D barcodes.
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Character Removal Transform

The following removal transforms are available:

� Leading and Trailing Spaces

� Leading, Trailing and Duplicate Spaces

� First and Last Characters

� First and Last Matching Characters.

The difference between the first two transforms is when adjacent spaces occur within the text, the 2nd

transform will replace multiple spaces with a single space. The difference between the last two transforms
is transform (3) blindly removes the first and last character, whatever they are, while transform (4) only
removes the first and last character is they are single/double quotes and if they are the same quote
character.
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Text Variable
The purpose of defining a Text Variable is to convert a
variable recognized as binary (numeric or decimal) into a
variable recognized as textual. Defined Calculation Variables
using only decimal values (no text) and System Variables
can be used to create a Text Variable. Though other fields
can be selected in the Field drop-down menu (containing text
and are non-decimal/binary), the proper application of this
function is achieved only with a predefined binary variable
(Calculation value or Variable not seen as text).

Numeric decimal variables offer a 32 bit limit to the variable
string and can be utilized to produce highly accurate
calculations. Converting a decimal binary value into a text
variable will limit the variable string to 7 digits and simple
textual (small numbers) calculations (not as precise).

� To create a text variable

1. Import a delimited or XML data file, or define a
database field from a line data file.

2. From the Edit menu, select Field Settings and Define Variable Field.

3. Establish a name for the variable field.

4. Under Type, specify Text Variable.

5. Go to the Field drop-down menu and select either a pre-defined Calculation variable or a binary
System Variable.

6. Specify the Length of characters.

7. Click OK to accept.

When defining a Text variable, a maximum text length must be defined. Text Variable content exceeding the
maximum length may halt the print job with errors.

The following System Variables are recognized as Binary: FRLEFT, FRCOUNT, LSP, VDISP, HDISP, SVPOS, SHPOS, RPLEFT,
RPCOUNT, PPCOUNT, LPICOUNT, LPCOUNT, CPCOUNT, COLW, PGCOUNT, DTCOUNT.
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Calculation Variable
The calculation variable allows a variety of functions to
be applied to a variable. Math, text and boolean
expressions can be added to data fields to create the
calculation variable. A formula editor is available to
apply VisionDP functions to fields or variables.

Math

� +, -, *, /, unary + -, ()

� Number is [<sign>]<number>, ([...] indicated
optional)

� Real Number is [<sign>]<number>.<number>

� [<sign>] indicates optional + or -

Text Boolean

+ (concatenation) >, >=, <, <=, =, != (not equal)

'text' false, true

� To create a calculation variable

1. Select Field Settings from the Edit menu. Choose Define Variable.

2. Enter a name in the Name edit box.

3. Select Calculation from the Type drop-down menu.

4. Click the Edit button. The Formula Editor will appear. All
database fields previously imported or defined will be
available in the Field drop-down menu.

� If a different field name is to be used, select a Field Name
from the drop-down menu. Highlight the Field Name in the Formula area.

� Select the desired Function from the drop-down menu. The syntax will appear in the Formula: edit
box.

� Click OK to return to the Define Variable window.

5. Additional Transforms can be applied if necessary.

6. Click OK.
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Data Functions
VisionDP's Formula Editor provides the user with access to 21 VisionDP transforms/functions and 18
PDF functions, each having 0, 1, or 2 parameters. These functions can be applied to data during the design
process. The Formula Editor is useful for applying functions to data for one time use.

� To implement data functions

1. On a form that contains a data file, click the Data Formula button on the Data View toolbar.

2. Draw a box where the data is to be placed.

3. The Data Properties window will appear, displaying the Formula Editor tab. The variable field defined in the
data field drop-down menu will already be listed in the Field Name drop-down menu and the Formula
edit box.

4. If a different field name is to be used, select a Field Name from the drop-down menu. Highlight the Field
Name in the formula area.

5. Select the desired Function from the drop-down menu. The syntax will appear in the Formula edit box.

6. Click OK to return to the form. The data will be placed onto the form.

Function descriptions listed on page 208
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Conditional Variable
The Conditional Variable function allows users to create a custom variable that is true only when a specified
condition in the data field is met, and is false otherwise. For example, a user might create a conditional
variable called CommonName. CommonName would be true if a person's last name was Jones or Smith.
Therefore, if the last name was not Jones or Smith, CommonName would be false and would not be used.

� To create a conditional variable

1. Right click on the Data View window and choose Define Variable.

2. Enter a name for the conditional variable in the Name field.

3. Select Conditional Variable from the Type drop-down menu.

4. Click the Edit button to open the Conditions window.

5. Click Add to access the Add Condition window.

6. Create the condition and click OK to save. Add AND/OR conditions as necessary.

7. Click OK to save the defined conditions and return to the Define Variable window.

8. The condition will be displayed in the Condition area.

9. Click OK to save.
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VisionDP Functions

BarCode Transforms

These transforms prepare data for properly displaying a barcode, by determining transforms, checksums,
start and end sequences.

2OF5(data)

2OF5 is to be used with an Interleaved 2 of 5 barcode font. Cannot accept space or alphabetic
characters.

Example: 2OF5($$BarcodeData.)

If BarcodeData contains 123456 the results of this transform would be —“³ÉÝ˜

CODE39(data)

CODE39 is to be used with a Code-39 barcode font. Only alphabetic and numeric characters are
acceptable in the input data.

Example: CODE39($$BarcodeData.)

If BarcodeData contains 123456 the results of this transform would be `123456~

CODE128(data)

EAN128(data)

CODE128 and EAN128 are to be used with a Code-128 barcode font. Accepts characters in the full
ASCII range (0..127) in its input data. Uses code-set C when possible to compress sequence of digits.

Example: CODE128($$BarcodeData.)

If BarcodeData contains 123456 the results of this transform would be é-CY¬ê

EAN8(data)

EAN13(data)

EAN8 and EAN13 are to be used with an EAN barcode font. EAN8 accepts only 7 digit character
sequences, and EAN13 accepts only 12 digit character sequences as its input data.

Example: EAN8($$BarcodeData.)

If BarcodeData contains 1234567 the results of this transform would be _~1234IFGHA*_

POSTNET(data)

POSTNET is to be used with a PostNet barcode font. Accepts only 5, 9 or 11 digits, or 10 or 12
characters with a dash character in the 6th position, as its input data.

Example: POSTNET($$BarcodeData.)

If BarcodeData contains 12345-6789 the results of this transform would be *1234567895*
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UPCA(data)

UPCA is to be used with a UPC version A barcode font. Accepts only 11 digit numbers in its input
data.

Example: UPCA($$BarcodeData.)

If BarcodeData contains 12345678901 the results of this transform would be ~v23456IHIJABM*-

Case Transforms

These transforms change the letter case of the input data to these functions, returning the transformed
text.

CASEUP(data)

CASEUP will convert every lower case character in the input data to upper case, without modifying any
non-alphabetic character.

Example: CASEUP($$FullName.)

If FullName contains ‘John Smith’ the results of this transform would be ‘JOHN SMITH’

CASELOW(data)

CASELOW will convert every upper case character in the input data to lower case, without modifying
any non-alphabetic character.

Example: CASELOW($$FullName.)

If FullName contains ‘JOHN SMITH’ the results of this transform would be ‘john smith’

CASETITLE(data)

CASETITLE will convert the first alphabetic character (and every first alphabetic character after a space)
to an upper case character, and all other upper case characters to lower case in the input data, without
modifying any non-alphabetic character.

Example: CASETITLE($$FullName.)

If FullName contains ‘JOHN SMITH’ the results of this transform would be ‘John Smith’
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Data Transforms/Functions

BCOUNT(data)

BCOUNT will determine the number of space characters in the input data, returning an integer number.

Example: BCOUNT($$Paragraph1.)

If Paragraph1 contains ‘Our company is proud to announce our latest product’ the results of this
function would be the value 8

BSTRIP(data)

BSTRIP will remove any leading and trailing space characters from input data.

Example: BSTRIP($$Data1.)

If Data1 contains ‘ The winning entry belongs to: John Smith ’ the results of this transform would
be ‘The winning entry belongs to: John Smith’

BTRIM(data)

BTRIM will remove any leading, trailing and any duplicate space characters from input data.

Example: BTRIM($$Data1.)

If Data1 contains ‘ The winning entry belongs to: John Smith ’ the results of this transform would
be ‘The winning entry belongs to: John Smith’

CS(data1,data2)

CS will merge two text fields into a single text field. data1 and data2 can be either data fields or
quoted text.

Example: CS($$ZipCode.,’-0109’)

If ZipCode contains ‘94533’ the results of this function would be ‘94533-0109’

CVI(data)

CVI will convert the text field into an integer value.

Example: CVI($$ZipCode.)

If ZipCode contains the text ‘94533’ the results of this function would be the number 94533

CVR(data)

CVR will convert the text field into a real number.

Example: CVR($$TotalPrice.)

If TotalPrice contains the text ‘1234.56’ the results of this function would be the number 1234.56
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Extract(text,position,length)

Extract(text,position,delimiter)

Extract will extract characters from a text based on position and length of the substring, or by field
number position (starting with 0) and a single character delimiter search, returning a subset of the
original text parameter.

Example: Extract($$DataLine.,3,’,’)

If DataLine contains ‘John,Smith,123 Main Street,New York,NY,00200’ the results of this function
would be ‘New York’

FORMAT(number,control)

FORMAT will format a number into a text based on a control string.

control is text that can be defined with:

- negative sign shown only if number is negative.

+ positive sign shown only if number is positive.

@ represents a formatting placeholder.

# represents a digit that is kept as it, or is filled with 0s if digit did not exist.

, thousand separator (not shown with leading 0s represented with @).

. decimal delimiter.

Any other character in the control text will be shown.

Example: FORMAT($$TotalValue.,’$-@,@@@,@@#.##’)

If TotalValue contains the value 12345.67 the results of this function would be ‘$ 12,345.67’

HMS(number)

HMS will convert time defined in seconds to a format of HH:MM:SS (24 hour), where HH is a value
of 0 to 23, MM is a value of 0 to 59, and SS is a value of 0 to 59.

Example: HMS($$TimeInSeconds.

If TimeInSeconds contains 12345 the results of this transform would be ‘3:25:45’

Maximum(number1,number2)

Maximum will determine the larger of two numbers. Either of the two parameters may be an integer,
real, variable or text number.

Example: Maximum($$Qty1.,$$Qty2.)

If Qty1 contains 12345 and Qty2 contains 12432 the results of this function would be 12432
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QSTRIP(data)

QSTRIP will remove the first and last characters from the text.

Example: QSTRIP($$QuotedName.)

If QuotedName contains ‘”John Smith”’ the results of this transform would be ‘John Smith’

Quotient(number1,number2)

Quotient will divide number1 by number2, where either parameter can be an integer, real, variable or a
text number.

Example: Quotient($$Qty1.,4)

If Qty1 contains ‘12345’ the results of this function would be 3086.25

REPLACE(data,find,replace)

REPLACE will search the data parameter for any number of occurrences of the find parameter and
replace each one with the replace parameter.

Example: REPLACE($$SSN.,’-‘,’’)

If SSN contains ‘123-45-6789’ the results of this function would be ‘123456789’

Remainder(number1,number2)

Remainder will determine the remainder of dividing the number1 parameter from the number2
parameter. Either of the two parameters can be an integer, real, variable or a text number.

Example: Remainder($$Qty1.,4)

If Qty1 contains ‘12345’ the results of this function would be 1

ROUND(number,position)

ROUND will round the real number parameter to the nearest digit at a given position to the left
(negative position) or right (positive position) of the decimal point.

Example: ROUND($$Number.,2)

If Number contains '12345.6789' the results of this function would be "12345.68'

NUMBER2WORDS(number)

NUMBER2WORDS will return the English words created from the number. The number field could be a
static or variable field.

If the value in the Amount field was: 12345, this would return "twelve thousand three hundred forty
five".

Supports large numbers (up to 60+ digits).

Fractions are also supported with this function. "and xx/100" will return if any fractions exist.
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Size Functions

IHEIGHT(image_name)

IHEIGHT will provide the height of the named image in pixels.

Example: IHEIGHT($$ImageName.)

If ImagedName contains ‘CompanyLogo.jpg’ the results of this function would be 624 if this image
has a height of 624 pixels.

IWIDTH(image_name)

IWIDTH will provide the width of the named image in pixels.

Example: IWIDTH($$ImageName.)

If ImageName contains ‘CompanyLogo.jpg’ the results of this function would be 264 if this image
has a width of 264 pixels.

SLENGTH(data)

SLENGTH will determine the number of characters in the text parameter.

Example: SLENGTH($$Paragraph1.)

If Paragraph1 contains ‘Our company is proud to announce our latest product’ the results of this
function would be 51

SSIZE(data,font_name)

SSIZE will determine the width in dots of the input text using the specified font.

Example: SSIZE($$FullName.,’Helvetica12-P’)

If FullName contains ‘John Smith’ the results of this function would be 266 dots in width using a 12
pt. Helvetica Portrait font.
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Date Functions

Dates are manipulated in a textual format, and will be accepted in any of the following: ‘YYYY-MM-DD’,
‘YYYY/MM/DD’, ‘YY-MM-DD’ or ‘YY/MM/DD’. Any of the date functions that return a date will
always be in the first of these supported formats (YYYY-MM-DD). Date parameters in any of these
functions may either be quoted (single or double) text, or the name of a variable surrounded by $$ and ..

DAYS(year,month,day)

DAYS will take the provided year, month and day parameters and return with the number of days since
January 1st, 1970.

Example: DAYS($$Year.,$$Month.,$$Day.)

If Year has the value 2013, month has value of 1 and day has the value 27 (01/27/2013) the results of
this function would be 15732

SETDATE(year,month,day)

SETDATE will take the year, month and day parameter information and set the current system clock to
this date.

Example: SETDATE($$Year.,$$Month.,$$Day.)

The three parameters are used to set the system clock to the specified date. There is no returned
information from this function.

SETDAYS(days)

SETDAYS will take the days parameter and add that to the date of January 1st, 1970 to determine the
date that is set into the current system clock.

Example: SETDAYS($$DaysSince1970.)

If DaysSince1970 has the value of 15732, the system clock will be set to the date of January 27, 2013.
There is nothing returned from this function.

CONVERT_DATE: Converts international date DD/MM/YY to YY-MM-DD

CONVERT_DATE(intl_date) returns a date

Example: CONVERT_DATE(’02/01/2013’) returns “2013-01-02”

CONVERT_US_DATE: Converts U.S. date MM/DD/YY to YY-MM-DD

CONVERT_US_DATE(us_date) returns a date

Example: CONVERT_US_DATE(’01/02/2013’) returns “2013-01-02”

CURDATE: Get the current date. Reevaluated on every page.

CURDATE() returns a date

Example: CURDATE() returns “2013-01-02”

214 Personalized Documents



DATE_ADD_DAYS: Add a number of days to a date.

DATE_ADD_DAYS(date,days) returns a date

date is any valid date text.

days is a positive or negative number.

Example: DATE_ADD_DAYS(“2013-01-02”,31) returns “2013-02-02”

DATE_ADD_MONTHS: Add a number of months to a date.

DATE_ADD_MONTHS(date,months) returns date

date is any valid date text.

months is a positive or negative number.

Example: DATE_ADD_MONTHS(“2013-01-02”,1) returns “2013-02-02”

DATE_ADD_YEARS: Add a number of years to a date.

DATE_ADD_YEARS(date,years) returns a date

date is any valid date text.years is a positive or negative number.

Example: DATE_ADD_YEARS(“2013-01-02”,2) returns “2015-01-02”

DATE_SUB_DAYS: Subtracts a number of days from a date.

DATE_SUB_DAYS(date,days) returns a date

date is any valid date text.

days is a positive or negative number.

Example: DATE_SUB_DAYS(“2013-02-02”,31) returns “2013-01-02”

DATE_SUB_MONTHS: Subtracts a number of months from a date.

DATE_SUB_MONTHS(date,months) returns a date.

date is any valid date text

months is a positive or negative number.

Example DATE_SUB_MONTHS(“2013-02-02”,31) returns “2013-01-02”

DATE_SUB_YEARS: Subtracts a number of years from a date.

DATE_SUB_YEARS(date,years) returns a date

date is any valid date text.

years is a positive or negative number

Example: DATE_SUB_YEARS(“2015-01-02”,2) returns “2013-01-02”
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DATEDIFF: Subtracts a date from another date, giving the number of days in difference.

DATEDIFF(date1,date2) returns a number

date1 is any valid date text.

date2 is any valid date text.

Example: DATEDIFF(“2013-02-02”,”2013-01-02”) returns 31

DAYNAME: Determines the name of the day of the week for the date.

DAYNAME(date) returns one of: ‘Sunday’, ‘Monday’, ‘Tuesday’, ‘Wednesday’, ‘Thursday’, ‘Friday’,
‘Saturday’

date is any valid date text.

Example: DAYNAME(“2013-01-02”) returns “Wednesday”

DAYNAME3: Determines the 3 character abbreviated name of the day of the week for the date.

DAYNAME3(date) returns on of: ‘Sun’, ‘Mon’, ‘Tue’, ‘Wed’, ‘Thu’, ‘Fri’, ‘Sat’

date is any valid date text.

Example: DAYNAME3(“2013-01-02”) returns “Wed”

DAYOFMONTH: Extracts the day number from a date.

DAYOFMONTH(date) returns a number in range: 1..31

date is any valid date text.

Example: DAYOFMONTH(“2013-01-02”) returns 2

DAYOFWEEK: Determines the number of the day of the week for the date.

DAYOFWEEK(date) returns a number in range: 1..7, where 1 corresponds to Sunday, 2 to Monday, … and
7 corresponds to Saturday.

date is any valid date text.

Example: DAYOFWEEK(“2013-01-02”) returns 4

DAYOFYEAR: Extracts the day number starting from the beginning of the year in a date.

DAYOFYEAR(date) returns a number in range: 1..366

date is any valid date text.

Example: DAYOFYEAR(“2013-01-02”) returns 2
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FROM_DAYS: Determines a date based on the number of days since the year 0.

FROM_DAYS(days) returns a date

days is any positive number of days.

Example: FROM_DAYS(730669) -> ‘2007-07-03’

MAKEDATE: Creates a date by defining a year and day number within the year.

MAKEDATE(year,dayofyear) returns a date

year is any positive number.

dayofyear is any number in the range 1..366

Example: MAKEDATE(2013,2) returns “2013-01-02”

MONTH: Extracts a month number from a date.

MONTH(date) returns a number in range: 1..12

date is any valid date text.

Example: MONTH(“2013-01-02”) returns 1

MONTHNAME: Determines the name of the month from a date.

MONTHNAME(date) returns one of: ‘January’, ‘February’, ‘March’, ‘April’, ‘May’, ‘June’, ‘July’, ‘August’,
‘September’, ‘October’, ‘November’, ‘December’

date is any valid date text.

Example: MONTHNAME(“2013-01-02”) returns “January”

MONTHNAME3: Determines the 3 character abbreviated name of the month from a date.

MONTHNAME3(date) returns one of: ‘Jan’, ‘Feb’, ‘Mar’, ‘Apr’, ‘May’, ‘Jun’, ‘Jul’, ‘Aug’, ‘Sep’, ‘Oct’, ‘Nov’,
‘Dec’

date is any valid date text.

Example: MONTHNAME3(“2013-01-02”) returns “Jan”

TO_DAYS: Determines the number of days from year 0 of a date.

TO_DAYS(date) returns a number of days

date is any valid date text.

Example: TO_DAYS(“2007-07-03”) returns 730669
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WEEKDAY: Determines the number of the day of the week for the date.

WEEKDAY(date) returns a number in range: 0..6, where 0 corresponds to Sunday, 1 to Monday, … and 6
corresponds to Saturday.

date is any valid date text.

Example: WEEKDAY(“2013-01-02”) returns 3

WEEKOFYEAR: Determines the week number of a date, from the start of the year, based on Sunday being the first day of a week.

WEEKOFYEAR(date) returns a number in range: 1..53

date is any valid date text.

Example: WEEKOFYEAR(“2013-01-02”) returns 1

YEAR: Extracts a year number from a date.

YEAR(date) returns a positive number

date is any valid date text.

Example: YEAR(“2013-01-02”) returns 2013

FORMAT_DATE: Allows date and time to be formatted in any desired way

FORMAT_DATE(date,time,format) returns formatted text

date is ‘’ (empty) or any value date text.

time is ‘’ (empty) or any value time text.

format is any value format text, described below.

Example: FORMAT_DATE(“2013-01-02”,”09:15:10”,” %W %M %D, %Y”) returns
‘Monday January 2nd, 2013’

Specifier Description

%a Abbreviated weekday name (Sun..Sat)

%b Abbreviated month name (Jan..Dec)

%c Month, numeric (0..12)

%D Day of the month with English suffix (0th, 1st, 2nd, 3rd, …)
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%d Day of the month, numeric (00..31)

%e Day of the month, numeric (0..31)

%f Microseconds (000000..999999)

%H Hour (00..23)

%h Hour (01..12)

%I Hour (01..12)

%I Minutes, numeric (00..59)

%j Day of year (001..366)

%k Hour (0..23)

%l Hour (1..12)

%M Month name (January..December)

%m Month, numeric (00..12)

%p AM or PM

%r Time, 12-hour (hh:mm:ss followed by AM or PM)

%S Seconds (00..59)

%s Seconds (00..59)

%T Time, 24-hour (hh:mm:ss)

%U Week (00..53), where Sunday is the first day of the week

%W Weekday name (Sunday..Saturday)

%w Day of the week (0=Sunday..6=Saturday)

%Y Year, numeric, four digits

%y Year, numeric (two digits)

%% A literal % character
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Time Functions

Times are manipulated in a textual format, and will be accepted in one of the following: ‘HH’, ‘HH:MM’,
‘HH:MM:SS’ or ‘HH:MM:SS.MMMM’, where MMMM represents 4 micro-second digits. An optional ‘AM’,
‘PM’, ‘a.m.’ or ‘p.m.’ may also appear at the end of the time. Any of the time functions that return a time
will always be in the first of these supported formats (HH:MM:SS). If any of the input parameters to a
function are defined in a 12 hour clock, the result will be returned in a 12 hour clock. A time span is
sometimes referenced below and refers to a period of time, as opposed to a time of day. Time parameters
in any of these functions may either be quoted (single or double) text, or the name of a variable surrounded
by $$ and ..

ADDTIME: Adds 2 times together, where one of the times should be a time-span.

ADDTIME(time1,time2) returns a time.

time1 is a valid time or time-span text

time2 is a valid time or time-span text

Example: ADDTIME(’09:00:10’,’00:15.10’) returns ‘09:15:10’

CURTIME: Returns the current time.

CURTIME() returns a time

Example: CURTIME() returns ‘09:15:10’

HOUR: Extracts the hour number from a time.

HOUR(time) returns the hour in range 1..24

time is a valid time text

Example: HOUR(’09:15:10’) -> 9

MAKETIME: Takes the specified hour, minute and second values and creates a time.

MAKETIME(hour,minute,second) returns a time

hour is a value in range 0..23

minute is a value in range 0..59

second is a value in range 0..59

Example: MAKETIME(9,15,10) -> ’09:15:10’

MICROSECOND: Extracts the micro-second value from a time.

MICROSECOND(time) returns the micro-second value; 0 if a micro-second is not defined.

time is a valid time text

Example: MICROSECOND(’09:15:10.1234’) -> 1234
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MINUTE: Extracts the minute value from a time.

MINUTE(time) returns the minute value in range 0..59

time is a valid time text

Example: MINUTE’09:15:10’) -> 15

SECOND: Extracts the second value from a time.

SECOND(time) -> second

time is a valid time text

Example: SECOND(’09:15:10’) -> 10

SEC_TO_TIME: Determines a time from the number of seconds since midnight.

SEC_TO_TIME(seconds) returns a time

seconds is a value in seconds since midnight

Example: SEC_TO_TIME(2378) -> ’00:39:38’

SUBTIME: Subtracts a time from another time, where the subtracted time should be a time-span.

SUBTIME(time1,time2) returns a time

time1 is a valid time text

time2 is a valid time or time span text

Example: SUBTIME(’09:15:10’,’09:00:10’) -> ’00:15:00’

TIME_ADD_HOURS: Adds a value of hours to a time.

TIME_ADD_HOURS(time,hours) returns a time

time is a valid time text

hours is a number of hours

Example: TIME_ADD_HOURS(’09:15:10’,2) returns ‘11:15:10’

TIME_ADD_MINUTES: Adds a value of minutes to a time.

TIME_ADD_MINUTES(time,minutes) returns a time

time is a valid time text

minutes is a number of minutes

Example: TIME_ADD_MINUTES(’09:15:10’,30) returns ‘09:45:10’
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TIME_ADD_SECONDS: Adds a value of seconds to a time.

TIME_ADD_SECONDS(time,seconds) returns a time

time is a valid time text

seconds is a number of seconds

Example: TIME_ADD_SECONDS(’09:15:10’,20) returns ‘09:15:30’

TIME_SUB_HOURS: Subtracts a value of hours from a time.

TIME_SUB_HOURS(time,hours) returns a time

time is a valid time text

hours is a number of hours

Example: TIME_SUB_HOURS(’09:15:10’,2) returns ‘07:15:10’

TIME_SUB_MINUTES: Subtracts a value of minutes from a time.

TIME_SUB_MINUTES(time,minutes) returns a time

time is a valid time text

minutes is a number of minutes

Example: TIME_SUB_MINUTES(’09:15:10’,30) returns ‘08:45:10’

TIME_SUB_SECONDS: Subtracts a value of seconds from a time.

TIME_SUB_SECONDS(time,seconds) returns a time

time is a valid time text

seconds is a number of seconds

Example: TIME_SUB_SECONDS(’09:15:10’,20) returns ‘09:14:50’

TIMEDIFF: Subtracts a time from another time.

TIMEDIFF(time1,time2) returns a time

time1 is a valid time text

time2 is a valid time or time span text

Example: TIMEDIFF(’09:15:10’,’09:00.10’) returns ‘00:15:00’

TIME_TO_SEC: Converts a time into the number of seconds.

TIME_TO_SEC(time) returns the number of seconds

time is a valid time text

Example: TIME_TO_SEC (’00:39:38’) -> 2378
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Math Functions

Various useful functions available in the PostScript engine.

abs(number)

abs will take the absolute value of the input parameter.

Example: abs($$CurrentValue.)

If CurrentValue has the value of -1234 the results of this function would be 1234

atan(numerator,denominator)

atanwill determine the arc tangent angle in degrees from the input parameters.

Example: atan($$Numerator.,$$Denominator.)

If Numerator has the value 1 and Denominator has the value 0 the results of this function would be
the angle 90.0

ceiling(number)

ceiling will determine the least integer value >= to the real number parameter.

Example: abs($$TotalAmount.)

If TotalAmount has the value of 3.2 the results of this function would be 4

cos(angle)

cos will determine the cosine of an angle parameter.

Example: cos($$Angle.)

If Angle has the value of 90 the results of this function would be 0.0

floor(number)

floor will determine the greatest integer value <= to the real number parameter.

Example: floor($$TotalAmount.)

If TotalAmount has the value of 3.2 the results of this function would be 3.0

length(text)

length will determine the number of characters in the text parameter.

Example: length($$Field.)

If Field has the contents of ‘John Smith’ the results of this function would be 10
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ln(number)

ln will determine the natural logarithm (base e) of the integer parameter, returning a real value.

Example: ln($$Value.)

If Value has the value of 100 the results of this function would be 4.60517

log(number)

log will determine the common logarithm (base 10) of the integer parameter, returning a real value.

Example: log($$Value.)

If Value has the value of 100 the results of this function would be 2.0

mod(number1,number2)

mod will determine the remainder that results from dividing number1 by number2, returning an
integer value.

Example: mod($$TotalQuantity.,12)

If TotalQuantity has the value of 148 the results of this function would be 4

rand()

rand will provide a random integer number in the range of 0 to 2147483647.

Example: rand()

Every page will have a new random number.

round(number)

round will determine the integer value closest to the real number parameter.

Example: round($$TotalAmount.)

If TotalAmount has the value of 3.2 the results of this function would be 3

sin(angle)

sin will determine the sine of the angle parameter, returning a real number.

Example: sin($$Angle.)

If Angle has the value of 90 the results of this function would be 1.0

sqrt(number)

sqrt will determine the square root of the positive number parameter, returning a real umber.

Example: sqrt($$Value.)

If Value has the value of 144 the results of this function would be 12.0
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cvs(data)

cvs will convert a number to a text. The number may be either an integer or a real.

Example: cvs(rand())

If the random number returns 12345, the results of this function would be ‘12345’.

truncate(number)

truncate will truncate the number towards 0, removing it’s fractional part.

Example: truncate($$TotalAmount.)

If TotalAmount has the value of 3.2 the results of this function would be 3

Logical Functions

Various logical functions are available in the PostScript engine.

and(number1,number2)

and will determine the bitwise-and of their binary values of the two parameters. If bits in he same
position of both numbers are 1, the result is 1 for this bit position, otherwise 0.

Example: and($$PageNumber.,31)

If PageNumber has the value of 35 the results of this function would be 3

bitshift(number,shift)

bitshft will shift the binary number left by the shift amount, shifting in 0 bit values. Bits shifted out of
the number are lost. A negative shift will shift the binary number right by the negative shift amount.

Example: bitshift($$PageNumber.,2)

If PageNumber has the value of 35 the results of this function would be 140

not(number)

not will determine the ones-complement of the integer parameter. Bits with value of 0 will be 1, while
values of 1 will be 0.

Example: not($$Number.)

If Number has the value of 35 the results of this function would be -36

or(number1,number2)

or will determine the bitwise-or of their binary values of the two parameters. If bits in the same
position of either number are 1, the result is 1 for this bit position, otherwise 0.

Example: or($$PageNumber.,31)

If PageNumber has the value of 35 the results of this function would be 63

xor(number1,number2)
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xor will determine the bitwise-exclusive-or of the binary values of the two parameters. If bits in the
same position of both numbers are the same, the result is 1 for this bit position, otherwise 0.

Example: xor($$PageNumber.,31)

If PageNumber has the value of 35 the results of this function would be 60

System Variables
System variables are predefined variables. System variables provide information about a form, Job, or PDF
details such as time and date. System variables can be used in a variety of ways in VisionDP. The variables
are available in the Field drop down menus within the Variable, Text Variable, Calculation Variable and
Concatenated Variable windows. They can be used to populate the second field when creating conditional
logic statements. They can also be typed directly onto a form as a System field (Ex. $$BACK.), where they
will be converted to a number, boolean value (e.g. "false" ) or a text string. System variables fall into several
categories: boolean, numeric, text, time, or date. When building conditional logic statements, if a System
Variable is selected, the type will be automatically selected from the Variables are: drop down menu. If the
variable is boolean, Variables are: Logical will be selected, and "true" and "false" will be added to the drop
down menu.

Line Mode Only

YINIT YINIT is a numeric variable that provides the current vertical position as defined by SETGRID.
This variable will produce a numeric value representing vertical position measured in the current
form unit. If used in conditional logic statements, this variable is applicable to Image and Data
Conditions.

LNCOUNT LNCOUNT is a numeric variable that gives the number of lines of data on the current record. The variable will
produce a numeric value representing a number of lines.

GRIDSKIP GRIDSKIP is a new built-in VisionDP boolean variable to determine how a page break occurred in line mode.
It is true if the lines-per-page (as defined by SETGRID) was exceeded, or false otherwise (PCC, SETPBRK, or
SETSKIP condition has occurred).

Database Mode Only

FRLEFT FRLEFT is a numeric variable used for text or data flow. It gives the amount of vertical space from the
current print position to the bottom of the current frame on the stack. The variable will produce a numeric
value in the units being used.

FRCOUNT FRCOUNT is a numeric variable that provides the current frame number.

Line and Database Modes

LSP LSP provides information about the line spacing of data. If used in conditional logic statements, this variable
can only be used for Data Conditions, and the value be an number in dots.

DATAFILE Returns name of the data file that is currently being used by the form/project.

PROJECTNAME Returns name of the project currently being used (*.pfj).
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VDISP VDISP is a numeric variable that gives the displacement between a saved print position and the current
position. This is used when, for example, a form contains paragraphs of variable lengths and a box will be
inserted between them. VDISP provides the displacement between the current vertical position, where the
second paragraph will begin and print position, where the first paragraph ended. VDISP produces a numeric
value representing a number of form units between these two positions.

HDISP HDISP is the same as VDISP, except that it deals with horizontal rather than vertical position.

SVPOS SVPOS is a numeric variable that provides the vertical print position for a form element that is determined by
the saved print position of some other element. The variable produces a numeric value representing a
number of units between these two positions.

SHPOS SHPOS is a numeric variable that provides the horizontal print position for a form element that is determined
by the saved print position of some other element. The variable produces a numeric value representing a
number of units between these two positions.

RPLEFT RPLEFT is a numeric variable used when repeating a portion of a page, a page, or a sequence of pages that
determines the number of times the procedure will occur, i.e. the number of repetitions plus the first
iteration. The variable produces an integer representing the number of times a procedure will occur. This
could be used, for example, as a job condition in a job where pages are being repeated.

RPCOUNT RPCOUNT is a numeric variable that provides the current iteration (beginning with 1) of a procedure that is
being repeated. The variable will produce a numeric value representing an iteration. This variable can be
used in a condition to customize one or more pages in a series of repetitions or for a variety of other
purposes.

PPCOUNT PPCOUNT is a numeric variable that provides the number of the physical page in a job. The variable will
produce an integer representing a page number.

PGCOUNT PGCOUNT is numeric variable that provides a virtual page number for each data record.

LPICOUNT LPICOUNT is a numeric variable that represents one of the logical pages on a multi-up page. If this variable
is used to produce an action, this action will be applied to the logical page, not the physical page. The
variable will produce an integer representing a logical page number (1-the number of rows times columns
defined in the multi-up section of the Job Options. Note: This can be used in conjunction with Z-Sort only in
Database Mode.

DTCOUNT DTCOUNT is a numeric variable that provides a data record number.

LPCOUNT LPCOUNT is a numeric variable representing the number of the current logical page number in a multi-up
job. Note: LPCOUNT begins from 0. The variable will produce a an integer representing a logical page
number (1 - the number of rows times columns defined in the multi-up section of the Job Options.)

BACK BACK is a boolean variable that can be used to create conditions based on whether the current page is on
the front or back side of a physical page in a duplexed job. The variable will produce a value that is either
"true" or "false."

CPCOUNT CPCOUNT is a numeric variable that provides the current number of a copy (the logical number of a page
within cycle). E.g., if there are two forms, and Form A is being repeated in the job but the second is not, the
copy number of Form B is 3. The variable will produce an integer representing the copy number.

TEMPLATENAME TEMPLATENAME returns name of the template used to create the project.
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COLW COLW is a numeric variable that stores the column width of a form element. The variable produces a number
in the current unit.

PDFDEVICE PDFDEVICE is a boolean variable. If the device being used to print the job produces PDFs, PDFDEVICE can be
used to conditionally yield printed documents, PDF documents, or both. The value to be compared to must
either be the text "true" or "false."

PAGEH PAGEH provides the height of the current logical page.

PAGEW PAGEW provides the width of the current logical page.

SHEETH SHEETH provides the height of the current physical page.

SHEETW SHEETW provides the width of the current physical page.

SHEETCOUNT SHEETCOUNT is a numeric variable that provides the paper count. For Simplex output, it's the page number,
for Duplex output, the front and back sides have the same value, with each sheet incrememing.

Time and Date Variables

Time and Date Variables refer to the current time/date when the Job initializes on your PC's internal clock.

D_DD D_DD is the day of the current month in a two digit format. Ex. 21.

D_DOY D_DOY is the day of year represented as a number between 1 and 365.

D_DWL D_DWL is the day of the week written out in full. Ex. Friday.

D_DWS D_DWS is the day of the week abbreviated to three letters. Ex. Fri.

D_MO D_MO is the number representing a month. Ex. 9 for September.

D_MOL D_MOL is the name of a month written out in full. Ex. December.

D_MOS D_MOS is the name of the month abbreviated to three letters. Ex. Sep

D_YY D_YY is the year abbreviated to 1 or two digits (leading zeros are omitted). Ex. 3 for 2003

D_YYYY D_YYYY is the full year. Ex. 2003

T_AmPm T_AmPm is either a.m. or p.m.

T_HH T_HH is the current hour in the 24 hour clock format. Ex. 13 for one o'clock pm.

T_HH2 T_HH2 is the current hour abbreviated to 1 or two digits (leading zeros are omitted). Ex. 1 for
one o'clock

T_MM T_MM is the current minute. Ex. 35.

T_SS T_SS is the current second. Ex. 6.

T_TZN T_TZN is a text variable representing the time zone. Ex. Pacific Daylight Time or Central Standard Time.

System Variable Keywords are accessible in the field list if enabled through the Preferences window (Edit
menu / Preferences / Data tab).
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Data Driven Graphs
The Data Driven Graphs wizard helps you to create a graph using values in a data file.

If using a line data file, the data fields must be predefined.

� To create a data-driven graph

1. Click the data-driven graph icon on the Standard toolbar, or go to the Edit menu, select Draw Mode and
choose Graph Draw.

2. Draw the graph outline.

3. Once the Data Driven Graph wizard is displayed, select a Graph Type of either Curve, Bar, Pareto, Radar or Pie. If
you select Pie. Depending on the graph type selected, the wizard will guide you through the
appropriate menus to choose the customized look of your graph.

4. Continue through the wizard to make additional graph appearance selections. If you select Labels, the
labels will appear on the graph itself. If you select Legend, the labels will be color coded and displayed
to the right of the graph.

5. Select either a Flat appearance or 3-Dimensional.

6. Define Graph Fields by clicking the Add Field button and defining a label and value. Enable the Stacked Bar
Chart check box to create a stacked bar.

7. Fields can be deleted by clicking the Delete Field button. Several fields can be added, and their order
can be changed by using the Up or Down buttons. Graphs created with line data records can only use
defined fields that are created with one line each.

8. The Summary window presents all of the define graph information. If the information needs to be
edited, use the Back button to scroll through the Graph Wizard and make appropriate changes.

9. Click the Finish button in the Summary window to accept the parameters and return to the form.
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Format Graph
After creating a graph with the graph wizard, you can add additional attributes or edit changes in the Graph
Properties window. First, select the graph and right click to select Format Graph, or go to the Format menu
and select Data Object.

General Graph Style

� To format graph style

1. Right click the graph and select Format Graph from the context
menu.

2. Access the General tab. Form this tab, multiple specifications
can be made that will determine the final look of the graph.

� Graph Type: Select the graph type (bar, curve or pie) from
this drop-down menu.

� 3 Dimensional: Enabling this check box will produce a 3
dimensional graph. Un-check the box to produce a 2
dimensional graph.

� Rotation: The graph can be rotated to any 90 degree angle.

� Reverse Order: Enabling the Reverse Order check box will
cause the graph labels and values to be listed from right to left and top to bottom along the X and
Y axis. Un-checking this box will cause the labels and values to be listed in traditional left to right
and bottom to top order.

� Attach to Box/Circle: Graphs can be attached to boxes and circles. Enable the Attach to Box/Circle
check box. If this box is enabled and there is no box or circle currently defined on the page to
which the graph can be attached, VisionDP will ask if one should be created. Click Yes and
VisionDP will create a zero line box and attach the graph to it.

� Placement: Select from the Placement drop-down menu where you want the graph placed within
the box or circle that it is attached to.

� Margin: The Margin drop-down menu allows you to choose between square or rounded margins. If
attaching the graph to a circle, selecting the rounded margin option will provide more placement
options for the graph within the circle.

� Set a Default: If you want VisionDP to default to these parameters every time a graph is created,
enable the Set as Default check box.

3. Click OK to apply the settings and return to the form.
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Graph Attributes

The Graph Attributes tab of the Graph
Properties window provides further graph
formatting options. Select graph segment
colors, 3D thickness, label width, label
location, and if these parameters should
serve as graph defaults.

� To define segment colors

1. Enable either the Default radio button
or the Choose Colors radio button.

� Default: VisionDP will supply the
colors for the graph segments
based upon default settings.

� Choose Colors: The user specifies
which colors will be used for the
graph segments.

2. If you will use the default colors, there is no more color definition necessary. If you will choose the
segment colors, click the Add Color Button. The Color Selection window will appear.

3. Select a color from the display, type in a specific RGB or CMYK value, or select a Pantone color from the
Pantone drop-down menu.

4. VisionDP also has the ability to pick up a color from anywhere on the screen and use that color in the
segment definitions. Left click the Select button, and drag the eyedropper tool to the on-screen color
that you would like to use. Let go of the mouse to select the color.

5. Click OK to save the segment color definition. Repeat this process until all necessary colors are defined.

� To edit segment colors

1. Select the defined color that you wish to edit.

2. Click the Edit Color button in the Segment Colors area.

3. The Color Selection menu will appear. Choose a new color and click OK to replace the old color with the
new color.

� To delete a segment color

1. Select the defined color that you want to delete.

2. Click the Delete Color button.

3. The color will be deleted from the Segment Colors area.
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� To move a color up or down in the color order

1. Select the color that will be moved to a different position.

2. Use the up and down buttons to position the color in a new place in the line-up.

� To specify the 3D thickness of the graph

1. Select whether the thickness will be based upon the Radius or Bar/Segment width or 1/5 of Graph Width.

2. Define a 3D Thickness percentage, based on the above settings.

� To specify the label location and width

1. Specify a width percentage.

2. Choose a Label Location from the drop-down menu: no label, X axis, end of bars.
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Graph Values

� To format graph values

1. Open the Graph Properties
window.

2. Select the Graph Values tab.

� Outline Color and Line
Width: Choose an
outline color from
the drop-down menu
and enter the width
of the line in the
Width edit box.

� Background Color:
Choose a
background color
from the
Background Color
drop-down menu.

� Labels on Legend: Enter the spot size percentage based on the font size of the graph, and enter the
Distance of the spots from the graph in the percentage value based on one half of the graph
width.

� Display the Scale or Values on the Graph: The Scale check box is selected by default. Uncheck this box to
disable the x-axis scale of the graph and check the Value box to display the values of the
segments on the graph.

� Format a Pie Graph: The Pie Section drop-down menu provides a choice between a whole pie, the top
half, or the bottom half, to be used in the design of a pie chart.

� Slice Burst: Determine the distance between each pie segment. The value entered will be based on a
percentage of the radius.

� Labels on Graph: Enables label formatting for a pie chart. The formatting options are presented in
the Pie Labels window that is accessed by clicking the Labels button.

� Label Offset: This value determines the distance of the labels from the pie.

� Label Dash Width: Determines the dash line width. The color of the dash line can be changed by
selecting a color from the Label Dash Color drop-down palette.

� Space Between Bars: Enter the Space Between Bars as a percentage of the bar width.

� Format: Choose a format from one of the available selections in the drop-down menu or define a
custom format.

� Set as Default: Enable this check box to instruct VisionDP to use the current settings in the future
when creating graphs.
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Graph Fields

� To add graph fields

1. Open the Graph Properties window. Select the Graph Fields tab.

2. Click Add Field.

3. The Graph Fields window will appear. Select a Label and Value from the drop-down menus.

4. Click OK.

� To edit graph fields

1. Select the graph field to be edited.

2. Click the Edit Field button.

3. Make necessary edits from the Graph Field window.

4. Click OK.

Merge Data Values

If you want to bundle together two or more data fields into one,
label the fields with the same name and select the Merge Data Values
box. The accumulated totals of all the combined fields will appear as one field.

� To merge data values

1. Check Merge Data Values.

2. Click OK to accept.

Size and Position
You can specify an exact location for the graph to be placed on the
form, as well as an exact size, through the Size and Position tab.
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Chapter 8

Creating Print Jobs and Saving to PDF

VisionDP can create PDFs for single page forms as well as create Print Jobs for multiple page variable
documents. Creating a Print Job project (.pfj) is useful and necessary when you have multiple forms
that need to be combined together in a variety of configurations and contained in one job. Multi-up

and Z-Sort formatting options can be defined, crop marks can be added to your application, and job
conditions can be defined to call in different pages depending on specified page logic, among many other
things.

Saving a Single Form to PDF
Single forms can be saved to PDF without having to take the additional step of building a job. All necessary
resources will be created automatically and the PDF document will be placed in the output directory.

� To save a single form to PDF

1. From the open form, select File > Save As > PDF.

2. Choose the location of where the PDF document is to be saved to. Also choose the name of the PDF
document.

3. Click Save.

4. The PDF Creation window will appear. The Following options will become available:

� Choose the desired data file (If different from data file used in design)

� Define security password (Optional)

� Choose Page Range settings

� Choose PDF Splitting properties (Optional)

� Select PDF Demographics options (Optional)

� Choose PDF Completion Action (Optional)

� Choose PDF Quality Options

� Select View PDF When Finished option (Optional)

� Choose Stop If Error Occurs option (Recommended)

5. Click OK to start the data merging process.
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Creating Jobs
Creating a Job is useful and necessary when you have multiple forms that need to be combined together in a
variety of configurations and contained in one job. Since forms are created as single files(.dtd), a Job must
be created in order to combine multiple forms together.

The user must create at least one form and have data on the page, unless using No Data Mode in order for a
Job to be created manually. Once the New Job option is selected from the File menu, the Job Tree will appear.

The Job Menu is organized into a tree structure. The tree
structure can be expanded to reveal forms contained in the
job, as well as all specified job parameters. Each job option is
listed next to a blue circle. To change the setting of each
option, double click the option. The job menu drop-downs
will re-populate depending upon the option selected. You
will know which option you are editing because the circle
next to an active option will be yellow.
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Creating New Jobs
Jobs can be created by either opening a single form and then creating a job based off of the single form, or
pre-defined templates can be used that will create blank forms and all necessary project settings in just a few
simple steps. The easiest method is to use a template so that all forms and project settings are defined at
once, but manually creating a job may also be necessary in some circumstances. The following directions
will go over the process of how to use the Template Manager, and then will go over how to create a Job
manually.

Creating a Job using the Template Manager

Many pre-defined Templates are available for Labels, Cards (business and postcards), Letters and PDF
documents. Templates are separated by general categories, and once the template is selected from a list, you
will be guided through various menus showing which Multi-Up settings, Paper and Form Sizes, Cut Marks,
and images to be used as backgrounds are pre-selected. Any of these settings may be changed along the
way. If changed, the last menu gives you the option to save overwrite the existing template, or create a new
one..

� To create a job using a Template

1. Templates can be accessed three different ways:

� Select File, and then choose Template Design.

� Select the Start Template Wizard button from the Standard toolbar.

� Select the Template button from the Welcome Menu.

2. The Choose Template menu will appear. Use the Template Type drop-down menu to select the type of
templates you would like to display. Selecting a specific paper size using the Paper Size drop-down will
narrow down the list of supported templates.

3. Select the desired template, or click Custom Template and click Next. The following menus will display the
default settings that have been defined for the template. If desired, these settings can be changed
before continuing onto the next menu.

4. The Template Identify Pages menu has drop-downs that allow you to choose existing forms to be used
within the template. If no forms are chosen, new forms will be created.
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4. Once all the settings have been reviewed, click Finish. If any settings have been altered from the default
settings and you would like to keep them for later use within the template, click the Save Template
button to either save the current template or create a new one.

5. The Import Data menu will appear. Browse and select the desired data file to be used, or select the
No-Data button if creating a simple application that does not require a data file. Continue through the
Data Import Wizard to define the data settings.

6. Once the all settings have been defined, the project will open with a blank form(s) and is ready for
images and data to be placed onto the design.

Creating a job based off a Form

The first step in the job creation process is to define a new job and give it a name. Creating a job based off
a form can be done two ways; with the form open or using the Welcome Menu without the form open.

� To create a new job with a form open

1. Open the form that will appear first in the job sequence.

2. Go to the File menu and select New Job.

3. The Job Menu will appear on the left hand side of your screen.

4. Enter a Name for the job into the Job Name field. Notice that the information entered into this field is
also reflected in the name of the job folder in the tree structure below.

� To create a new job from the Welcome menu

1. With the Welcome menu open, select the Show .DTD Files check box.

2. Select the desired .dtd file and then click the Create Project button.

3. Name your new project.
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Specify a Data File

The data file that is currently imported into the form will automatically be defined in the Data File Name field.
If this is not the data file that you want to use when printing, you will need to define a different data file to
be contained in the job.

� Specify a data file for printing

1. Click the ellipses next to the Data File Name field.

2. Browse to locate the needed data file.

3. Highlight the file and click Open.

4. The new data file will be displayed in the Data File Name field.

No Data

If you are creating a PDF Print job that does not use data, such as a lottery ticket that simply uses a
counter, you must enable the No Data check box. You must also tell VisionDP how many records to
create, since there will be no data file included from which this information can be obtained. The number
of records to create must match the number initially defined when the form was created. i.e. If your
ticketing application was designed to produce 1000 tickets, then 1000 records must be defined.

� To set "No Data" mode

1. With your form open (.dtd), select the Import Data button.

2. From the Import Data menu, select the No-Data button.
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3. The Data Parameters menu will appear. Define how many "records" to create and then click Close.

You will now be able to create a new job and have access to the job tree options by going to File > New
Job.

Job Sets
Forms within a Job can be grouped into Job Sets. Job sets contain lists of pages to be named as separate
sets within a job, all of which must use the same data file. Creating job sets is a highly flexible and efficient
way of building and managing complicated variable data documents allowing groups of pages to be
conditionally inserted into the document. Once defined, job sets can be manipulated using job conditions to
create highly sophisticated PDF jobs.

� To create a job set

1. After creating a job, double click on the job folder, listed within the job tree (This will usually be the
first folder). A drop-down menu will appear, select Add Job Set.

2. The Job Set Name menu will appear prompting you to name your new job set. Once named, press OK.

3. A confirmation menu will appear asking if you'd like to create this new Job Set, click Yes.

4. You may now continue creating additional job sets, or adding new/existing forms to your job sets.
Instructions on adding forms can be found on the next page.
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Managing Forms
An unlimited number of forms can be added to a job or job set. The form that was open when you created
the job will already be contained in the job tree.

Adding Existing Forms

Forms that have already been created can be added to a job or job set.

� To add an existing form to a job

1. Double click on the job folder that contains the existing form. From the drop-down menu, select Add
New Page.

2. The Add New Page menu will appear. Click on the browse button to browse for the existing .dtd.

3. Once a .dtd file is selected, click OK and it will be added to the project.
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Adding New Pages

New, blank pages can also be added to a project. A new page added to the project through the job tree will
automatically use the same data file as the rest of the project. Once the new page is added to your project,
you can add images, text and form elements as necessary.

� To add a new page

1. Double click on the job folder that you would like to add a new form to.

2. From the drop-down menu, select Add New Page.

3. The Add New Page menu will appear. Name the new .DTD file and click OK.

4. The new page will be added to the job.

Selecting the Blank Form check box will create a blank uneditable form that will act as a placeholder. Blank
forms can be used for multi-page duplex applications.

5. When new pages are added to your project, any variables that have previously been defined will
automatically be carried over to the new .dtd. If a previously created .dtd is being added to your
project, select the Synchronize Variables item in the Tools menu drop-down to make all defined variables
on every page of the project synchronized with each other.
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Changing File Names

Pages that have been added to a project can have their file names changed within the job tree.

� To change a page name

1. Double click on the page to which the name change will be applied.

2. The file name can be changed by either typing the new name into the edit box, or using the
drop-down menu to select Edit Page Name.

3. If Edit Page Name is selected, an edit menu will appear where you can update the file name.

Removing Pages

Pages can be removed from the project.

� To remove pages from the project

1. Double click on the page that is to be removed.

2. Select Delete from the drop-down menu.

Ordering Forms in a Project

Pages can be reordered once they've been added to a job.

� To reorder pages in a project

1. Double click on the page to moved.

2. From the drop down menu, you may either select Move Page Up, or Move Page Down.
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Synchronizing Variables Within a Project

When creating custom variables (calculation, concatenated, etc.), they are only available for use within the
page that was active when the variables were defined. For example, if you have a project that contains both
a front and backside page, and you define variables while designing the front page, they will not
automatically be available for use on the backside page. The Synchronize Variables tool will look at all pages
in your project and add any variables missing to each of the pages. Any variable of the same name is left
untouched, even if the variable is of a different type.

� To Synchronizing Variables Within a Project:

1. With your project open, select Tools > Synchronize Variables

2. All user-defined variables will now be available for use within any page of the project. If additional
variables are added to any page within the project, the synchronizing process will need to be repeated.
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Defining Form Options
Once a form has been added to a job, additional options such as job conditions can be defined. These
options will only affect the form on which they are defined, and may be used to modify the behavior of a
job on a form by form basis. For example, use the Plex Control to define one form to print simplex, while
the rest of the job is printed duplex.

Add Background

Backgrounds images can be added to forms or can be
called in without a form (a blank sheet). Background
images that are defined within the job tree will be added
to the design automatically and cannot be edited through
the design screen. Also, background images defined in
the job tree will be default be printable images. To define
a background image that is for display purposes only, see
page 135.

� X Origin: Define the X location for the top, left
corner of the image.

� Y Origin: Define the Y location for the top, left
corner of the image.

� Orientation: Define the orientation of the
background image. Choose from Landscape,
Portrait, Inverse Landscape and Inverse
Portrait. This information is critical so that
VisionDP will place the background image in
the correct location on the form.
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� To add a background

1. Double click on the form folder for which a background will be defined, this will expand additional
options.

2. Double click on the Background option. If you have not previously defined a background for this form,
it will be listed as <None>.

3. The drop-down menu will be populated with a list of images. Choose the appropriate image to serve
as the background for the form, or click the browse button to browse elsewhere for an image.

4. Once selected, the image file will be listed in your job tree and appear on your design.
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Plex Control

Defining a Plex control for a particular form will override the Plex control that is set for the job as a whole.
This allows you, for example, to print a simplex form in the middle of a duplex job. Set the Plex control for
the form by enabling the Plex Control option and choosing either simplex or duplex from the drop-down
menu. Note that the Page Format for the job must be set to duplex in order for these options to be
available.
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Green Bar

Applying this feature will cause alternating white and colored stripes to be printed on the form. This can
make it easier to read forms that contain many lines of data, such as financial statements. Define the Green
Bar function by double clicking on the option and selecting Yes from the drop-down menu. This will enable
the feature and provide a list of additional Green Bar options that can be defined.

� Color: This will define the stripe color. Select an option from the drop-down menu.

� Lines in Stripe: Choose how many lines will appear in the stripe. Enter the number into the Edit Box.

� Lines in White: Choose how many lines will appear in the white. Enter the number into the Edit Box.
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Job Conditions

Multiple conditions can be defined on each page of a job. A job condition is created in much the same way
as a conditional text or image statement. Job conditions, however, require actions to be defined, rather than
text or images. Actions determine how the job is printed and can be used to control things such as the
sequence of forms and the use of job sets.

� To define job conditions

1. Expand the form folder from which the Job Condition
will be defined.

2. Double click on the Job Conditions option and click
Yes to enable additional settings.

3. The Job Condition window will appear. Click Add.

4. The Add Condition window will appear. It is from this window that the conditions can be defined.
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5. Conditions are added in the same manner used when specifying conditional logic statements. Specify
the Field/Variable that the condition will be based off of, the Function, and value that the condition is
being compared to.

In addition, there is a variable type called Job Conditions. The job conditions variable includes End of
Set and End of Job.

� End of Set: Define special formatting to occur at the end of each set.

� End of Job: Define special formatting to occur at the end of each job.

Job Conditions have an additional function, called "Changed", that is not available with data conditions.
This function is used to test if the contents of a field have changed from those of the previous data record.
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6. Specify Job Condition Actions by clicking the Action button after the Job Condition has been defined.

Additional Pages

If job conditions are set that require extra pages to be inserted, such as Insert Form or Replace Form, they will be
placed in a new folder called Additional Pages. This folder will automatically be created when a job condition
that requires an additional form is defined. The additional forms will be automatically added to and deleted
from this folder as necessary. Users are not able to manually include or delete forms from this folder.

Job Condition Actions

Once job conditions have been established, various actions can be defined to direct what happens when the
conditions are met. Actions can be used to control the sequence and number of forms in a job, as well as
job sets and the use of the data record. The function of each available action is defined below.

Form Actions:

Next Form: This is the default setting. The current form will be printed, and then the next form defined in the
job will be printed.

Replace Form: The Replace Form Action will replace the form on which this condition is set with another
form specified in the Forms drop-down menu.

Repeat Form: This action will print the form on which it is defined for the number of times specified in the
Repeat Count drop-down menu, then continue to print the next forms in the job. The Repeat condition will
not be reevaluated on the repeated forms. All other conditions, however, will be evaluated on all repeat
forms.

Skip to Form: This action will skip to another form within the same job set, as designated in the Form
drop-down menu. It will not print the current form.
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Insert Form: This action can be used to insert any desired form into the series of forms in the job set. The
form, however, must use the same data file. After the inserted form prints, the current forms in the job will
continue to print.

Escape From Job Set: This action will end printing after the current form and resume printing from the
beginning of the job set, automatically advancing the data record. This is a convenient way to create subsets
within a job set or to eliminate forms conditionally from within a job set.

Restart Job Set: This action can be used to skip out of the current data record at any point during printing and
move on to the next data record. The job set will restart without printing the current form. This is similar
to the Escape from Job Set action, yet the Escape from Job Set action will print the form on which the
condition is located. The data record will be advanced automatically.

Ignore Data Record: This action will exclude an entire data record from printing, and the job will proceed to
print the next data record. The job set will not be restarted.

New Job Set: This action provides a means of moving from one job set to another. If more than one job set
has been established, the New Job Set action can be used to manipulate the flow of the sets. (The only
other way to manipulate multiple job sets is to use the Insert Job Set action) New Job Set can be used at any
point in the job set. The form on which the condition is set will not print, and the job set specified in the
Job Set field will begin to print.

Insert Job Set: This action will print the entire contents of a specified job set before the form on which this
condition is set. For example, if the condition is met on form 5, Job Set 2 will print after form 4, and then
Job Set 1 will continue to print. This is very useful in cases where more than one form is to be inserted into
a job set. If only one form is to be added, it is best to use the Insert Form action. Insert Job Set can only be
used with one level of insertion. A job set can't be inserted into a second job set, which will in turn be
inserted into the third job set.

Control Actions:

The following Control Actions can also be applied from within the Job Condition Action window.

Advance Page To: Choose from Next Side, Back Side, or Front Side. Next Side will print the current page on
the next physical page. Front Side will print the current page on the next front of a new sheet. Back Side
will print the current page on the next available back side of a sheet. This feature is only available if
duplexing is enabled.

Advance Data Record: If this box is enabled, every page will use a different data record. Advancing the data
record is the default setting for applications using database or xml data, whereas holding the data record is
the default setting for applications using line mode data.

Job Set: Allows list of pages to be named as separate sets within a job, if these sets will use a single data
record.

Repeat Count: If Repeat Form is defined as the form action, the Repeat Count option will be enabled. Repeat
Count allows the user to define how many times the form will be repeated.
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Page Format: Define if the action will include a page format change. Choose between No Change, Simplex,
Duplex, or Tumble Duplex.

Orientation: Choose from No Change, Landscape, Inverse landscape, Portrait, or Inverse Portrait.

Slip Sheet: When this box is enabled, it is possible to select one of the forms in the job to serve as a slip
sheet. Define a paper type, color and weight.

Change Variable: Enabling the Change Variable check box makes it possible to replace the value of a variable
with another. Select the variable that will be replaced from the Change Variable drop-down menu, and
either select a replacement variable or enter a replacement value into the To Value drop-down menu.

Ordering Forms in a Job

The order that the forms appear in a job can be easily edited one at a time.

� To change the order of forms in a job

1. Double click on the form that needs to be moved.

2. Using the drop-down menu. select either Move Up Page or Move Down Page to move the form.

Delete a Form from a Job

� To delete a form from a job

1. Double click on the form to be deleted.

2. Using the drop-down menu, select Delete Page.
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Import Multi-page PDF
Multi-page PDFs can be directly imported into a job, creating the same number of forms (.dtds) as there
are PDF pages. Each form will display a different page from the PDF file and variable data can be applied
to each form in the job. Multi-page PDFS can be imported into an existing job, or a "PDF Document"
template can be used to import the multi-page pdf automatically. Using the PDF Document template is the
easiest method.

� To create a job based off of a multi-page PDF using a Template

1. Select File and choose Template Design…

2. From the Template Type drop-down, select PDF Document.

3. Select the applicable template for your document (simplex/duplex and orientation). Click Next.

4. Click Next after confirming Project settings in the Page & Paper Size menu of the template wizard.

5. From the Import PDF Document/Background Images menu, browse for your PDF and define the
page range you would like to use (if something other than the entire PDF). Click Finish.

6. The Data Import wizard will appear. Select a data file to import.

7. You project will now automatically be created with the PDF pages as background images to each form
in the project.

8. Double click on a page within the job tree to edit the page. Objects and data can be added to the page
design. Be sure to press the Save All button on the toolbar to save all pages.

� To import a multi-page PDF into an existing job

1. Create a New form and import a data file (or create a variable to work in No Data Mode).

2. Go to the File menu and choose New Job.

3. Within the job tree, double click on the existing form.

4. Select Add Page After from the drop-down menu

5. The Add New Page menu will appear, select the browse
button to browse for the desired PDF and click OK to
add the selected PDF to the job.

5. This will create new editable forms for each page of
the PDF.

If there is no need for any additional pages in your job aside from the ones created when importing your
multi-page PDF, then the initial page that was created can be deleted.
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Merging a PDF Document into Output Stream

Each page in a VisionDP application may be designed to have a unique static PDF document merged into
the PDF output stream. This may be a static PDF document file, or the PDF file chosen could be named
based on a variable name (e.g. $$PDF_Name.). The user controls where this PDF document is to be
inserted by defining the PDF to be placed: (1) after the current page, (2) before the current page, or (3)
replace the current page.

� To define a PDF to be merged into the Job output:

1. From within the job tree, expand the form folder to enable additional options.

2. Double click on the Merge PDF option and either select
a PDF file from the drop-down menu, or browse for
the desired file by selecting Search for file....

3. Once this PDF file is defined, the Merge PDF option
will now be enabled with additional options:

� Action: This option will allow you to define if you'd
like the PDF to be Merged or Inserted.

� Place: In reference to the form that has the Merged
PDF defined under, select from Before Page, After
Page, or Remove Page.

4. Any page may be defined with a unique Merge PDF
document.
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Print Job Options

There is a selection of job options available from within the Options folder in the job tree. Double click the
options folder to expand its contents and reveal the list of job options. Job options effect the entire job
unless a form option and/or job condition is applied to a particular page.

� To define job options

1. Select the option for which you would like to make a specification.

2. The drop-down menu will be automatically populated with options, depending upon the selection.
Choose from the drop-down list which selection you would like to use.

3. The options are defined as follows:

� Page Format: This option describes how the forms will be printed. Choose from simplex, duplex, or
tumble-duplex.

� Abort on Missing Resources: VisionDP can behave in two different ways when coming across missing
resources: abort or no display. By choosing Abort on Missing Resources, the job will be stopped if
resources are missing. By choosing No Display on Missing Resources, the job will still be processed, but
the missing resources will not be displayed.

� Advance Record: The data record can be advanced at job or page break. Jobs containing multiple
pages commonly have this option set to No so that each record of data will be applied to each
page in the job. This option must be enabled for jobs using line mode data if page conditions are
being used.

Output Paper Size
The output paper size defines the physical size of the substrate the application will print on. This differs
from the paper size of the form when Multi-up is defined. The Output Paper Size should be defined prior
to enabling Multi-Up options.

� To update paper size

1. Double click the Output Paper Size folder and select Yes to enable more options.

2. By default, the Output Paper Size will be defined with the same dimensions as the form size. To
change this, double click on the two options within the Output Paper Size folder to change the
Orientation and Size dimensions. The paper size can be chosen from a pre-defined list in the drop-down
menu, or if Custom is selected, custom values can be entered.
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Multiple-Up Jobs
Multi-up forms contain two or more logical pages on a single page
and are a useful way of creating postcards, labels, lists, or any
application where there is a need to have multiple forms, records
of data, or a single data record printed multiple times, on a single
page. Simplex, duplex, and tumble-duplex multi-up jobs can be
created using line, delimited and XML data files. The VisionDP
Z-Sort capability makes it possible to match data records on the
front and back sides of a multi-up application, and is available in
both delimited and XML data modes.

Multi-Up Jobs can be easily created using a variety of pre-defined
templates within the the Template Manager. Starting a project from
a template will define all the job tree settings automatically for you.
See Page: 237

� To create multi-up jobs

1. Double click the Multiple Up folder and select Yes from the drop-down menu to enable additional
options.

2. Edit the sub-options in the multi-up folder by double clicking on each node to change the settings, or
double click on the Multi-Up folder and select Edit Multi-Up Settings to display an easy-to-use Edit menu.

3. A list will appear, containing the following options:

Repeat Direction: Choose from rows, columns, or custom. Selecting custom will allow the user to define the
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exact (x, y) location, as well as the rotation, of each form on the multi-up page. This makes it
possible to specify a dutch cut layout in order to utilize leftover space on the paper.

Rows: Specify how many rows will be on each multi-up page.

Columns: Specify how many columns will be on each multi-up page.

Data Repeat: Specify how many times, if any, the data record should be repeated on one page.

Offset-X: If necessary, enter an offset value. This will shift the application along the X-axis.

Offset-Y: If necessary, enter an offset value. This will shift the application along the Y-axis.

Z-sort: To enable z-sort (to be used when the data on the back of a multi-up application needs to match
the front) enter a stack size number. A z-sort with a value of '0' will denote no z-sort.

Background: This option allows you to select a non-multi-up background to be printed behind a multi-up
application. This is an excellent way to implement crop marks.
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Stacked Z-Sort

Z-sort can be used for two different functions that can work
independently or in conjunction with one another. When
z-sort is enabled, it can be used to match record locations on
duplexed forms. Z-sort will perform the caching that is
necessary to place the data record on the back of the form to
match that which is on the front. Z-sort can also be used to
create stacks so that the job can be cut and placed into piles,
while the original order of the data file is preserved. This
unique function requires that the user set the stack size to the
number of forms that will be placed in each stack.

The stack size is displayed as a numeric value next to the
Z-Sort option. This value will, by default, be set to '0' before
any z-sort functions are defined. A stack size of '0' cannot
exist. By defining a realistic stack size, you also enable the
z-sort option.

� To create a multi-up job using z-sort

1. Create a job, adding only the form that will be used for the front of the application.

2. If multi-up has not yet been enabled, double click on the multi-up folder and select Yes from the
drop-down menu.

3. Select the Z-Sort node and double click and choose Yes to enable additional option.

4. The Z-Sort option will now be populated with additional options: stack size, shorten last stack and slipsheet
form.

� Shorten Last Stack: Enabling Yes for this option will allow the last stack to consist of fewer forms than
what is defined as the stack size. This prevents the last stack from being filled with blank pages to
compensate for an uneven number of data records.
Selecting No for this option will make the last stack the same size as all the other stacks, filling in
with blank pages what is not filled with forms.

� Slipsheet Form: Choose a form to be used as the slipsheet. Double click to choose a form from the
drop-down list, manually enter a form name, or click the ellipses button to browse in other
locations for the desired form.
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To define a backside form for your z-sort application

To finish setting up the multi-up, z-sort job, you must define a page condition that will call in the
appropriate form for the back of the application. Follow the directions below to implement the necessary
page condition.

� To create a z-sort job condition

1. Click the + next to the form folder to expand and display its contents.

2. Select the Job Condition option.

3. Click the Add button.

4. The Job Conditions window will appear.
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5. Click the Add button from within the Job Conditions box. The Add Condition window will appear.

6. Define the following condition:

If Variable BACK = true
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7. Click OK. You will be returned to the Add Job Condition window. The condition that you just defined will
be listed here. To define the action that will take place when the condition is met, click the Action
button.

8. The Job Condition Action window will appear. Select Replace Form from the Form Action drop-down menu.

9. Use the ellipses '...' button to browse for the desired form.

10. Click OK in the Job Condition Action window, the Add Job Condition box, and the Job Conditions box to save the
new condition.

11. The new job condition will be listed in the job tree.
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Stacked Rows/Columns

When using a single sheet cutter, Stacked ordering can be defined by either Rows or Columns. In order to
maintain ordering, cut pieces are stacked onto each other as they are cut until the project is finished being
processed. The data ordering will travel across the page until the end of column/row, continuing this
sequence onto the same column/row on the next page until the stack size is met. The Stack size should be
defined as the total number of data records divided by the number of columns/rows. So with a 2 x 2
Multi-Up application, the stack size should be set to half the number of data records.

� To define Stacked Columns/Rows for Multi-Up Projects

1. With your multi-up project opened (instructions for defining multi-up options for both simplex and
duplex projects are defined on previous pages) expand the Multi-Up folder in the job tree.

2. Double click on the Stacked bullet and select either Columns or
Rows. The options of Columns or Rows will be displayed
based upon the setting defined for Repeat Direction.

3. Next, the Stack Size needs to be defined. Stack size is
determined by taking the number of records in your data
file and dividing it by the number of Rows/Columns used
in your project. If Stacked is set to Columns, use the # of
Columns, or vice versa if it's set to Rows.

Creating Print Jobs and Saving to PDF 263



Dutch-Cut (Custom positioning)

Multi-up applications can have additional rows/columns added that are positioned in a different orientation
than the rest to allow for the most use out of the substrate that is being printed on. This type of
positioning is refered to as a dutch-cut layout and is commonly used when printing smaller applications
such as postcards or tickets onto a larger substrate.

� To define Dutch-Cut positioning for your multi-up application

1. With your project open, define the number of rows and columns that will fill the majority of your
substrate. Instructions on page: 257.

2. Enable Imposition Mode to see the layout of your multi-up document by clicking on the Imposition
Mode button.

264 Creating Print Jobs and Saving to PDF



3. To allow for the addition of rotated designs to your multi-up document, the positioning of the
columns can be changed manually or by adjusting the specific position X and Y coordinates within
the job tree.

To Adjust Position Manually: Select the top most design of the column/row you would like to position,
and drag it to another area using your mouse, or select the top most design and move using the arrow
keys on your keyboard.

To Adjust Position by X and Y Coordinates: Within the Job Tree, expand the Multiple Up folder by clicking on the
+ icon. Double click on the Repeat Direction drop-down menu and select Custom. The Custom Position
Menu will appear. Use the X and Y fields to adjust the positioning of the designs that are currently
defined on your multi-up application.
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4. If the repositioning of your pages was done by manually selecting and dragging to a new location,
ensure the Multiple Up setting is defined as Custom, described in the previous step. Enabling the
Custom option allows for single pages to be added to the design instead of full rows/columns. The
Multi-Up Positioning and Rotation menu will appear and display the positioning of the current pages.
Click OK to accept this menu.

5. Click on the Add Page button to add another page to your multi-up application. A new page will be
added in the orientation that matches the rest of your pages. In the image below, the new page was
added in the bottom right hand corner. Select the new page and drag to the desired location.

6. To change the orientation of the page that has been added, select the page and then click on the Rotate
Page 90 button until it is in the desired orientation.

7. Once the desired positioning is complete, click on the Create PDF button to compose your project.

266 Creating Print Jobs and Saving to PDF



Preview Multi-Up Positioning

Once multi-up settings have been defined within your project, Imposition Mode can be enabled to preview
the multi-up positioning of your documents. This feature is especially useful if dutch-cut positioning is
defined. While in Imposition Mode, the individual design cannot be edited, as it is intended to be used for
verifying the correct positioning of your documents prior to PDF composition.

� To view your multi-up application in Imposition Mode

1. With your project (.pfj) open, select the Imposition Mode button.

2. Your multi-up project will now be viewed in Imposition Mode, showing a preview of the imposed
layout. While in Imposition Mode, the Data View window will not be visible, the data will be
displayed as field names (not live preview of the data contents) and no edits to the individual designs
can be made (i.e. editing text, imagery, etc.).

While in Imposition Mode, margin and gutter values are displayed in red. These values can be
changed manually within the job tree or by selecting the individual designs and dragging them to
adjust positioning.

3. To return to design mode, select the Imposition Mode button again.
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Page Numbering
You can choose to include a page number on applications. VisionDP allows you to select from four
different locations for that page number: bottom center, bottom right, top center, or top right.

� To apply a page number

1. Double click the Page Numbering folder and select Yes from the drop-down menu to enable more
options.

2. Double click on any of the options listed within the Page Numbering folder to define settings other
than the default.
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Crop Marks
Crop marks can be added to any project needing to be trimmed. Crop marks can be added to either the
output paper, which is defined as Physical, or to each individual multi-up page, which is defined as Virtual.
Setting crop marks to accommodate for bleed can be done by adjusting the OffSet setting, described below.

� To add crop marks

1. Double click on the Crop Marks folder and select Yes from the drop-down menu to enable more options.

2. The following options will be available and can be edited
by double clicking to enable applicable drop-down menus
and edit boxes.

� Page: The Page setting will automatically be defined as
Physical, which will place crop marks on the outter
edge of the output paper that is being printed on. The
Virtual setting will place crop marks on each individual
multi-up design within the application.

� Format: The Format setting will be set to Standard by
default. If changed to Custom, additional options for
Mark Length and Edge Offset can be changed.

� Horizontal/Vertical Lines: Define the number of cut marks
that will appear. Max 6.

� Color: Define crop mark color

� Thickness: Define crop mark thickness
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� To edit crop mark length and position

1. Within your job tree, double click on the Crop Marks folder to enable more options.

2. To change the formatting of the crop marks, double click on the Format: Standard node. This will enable
additional options.

3. Double click on Mark Length to change the length of the crop marks. An edit box will appear where
you can change the value. Press the Enter key on your keyboard when finished.

4. Double click on Edge Offset to change the positioning of the crop marks. This setting is especially useful
when designing for applications with bleed. An edit box will appear where you can change the value.
Press the Enter key on your keyboard when finished.

Annotated Stamps

Annotated stamps can be added to the PDF on output. Double click on the Annotated Stamps node and click
Yes to enable additional options. Any of the sub-options may be edited by double clicking to access the
applicable drop-down menu or edit boxes.
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Additional Resources
Data-driven images(page 198) are not automatically included when VisionDP generates PDF resource files.
Adding these images will ensure that the project contains all the needed resources, which may be important
when archiving.

� To add additional resources

1. Double click on the Additional Resources folder and use the drop-down menu to select an image already
contained within your Images folder, or browse for the desired file(s) by selecting Search For File…

2. Once selected, the image file will be added to the Additional Resources folder list. Resources can only
be added one file at a time. To add more files, repeat the proses by double clicking on the Additional
Resources folder to access the drop-down menu.

Editing Jobs
Once a job is created it can be edited.

� To edit a job

1. Open the .pfj file of the job to be edited. This file is stored in the Forms folder, within VisionDP.

2. Make any necessary changes to the job in the Job Tree.

3. Click the Create PDF Job button to output the new files.
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Manage Job Source File Resources
All job source files are saved by default in the locations mapped in the Resource Set.

� Form (project files *.pfj, form files *.dtd, command-set files *.cos, and batch command-set files *.bcs)

� Font (PostScript Type 1 *.pfb)

� Images

� Data

Individual print job source files can also be archived in a single directory or *.zip file. Most of the files
required to open the job will be included except fonts and data-driven images that were not added as
Additional Resources to the job. Windows TrueType fonts and PostScript Type 1 display files (*.pfm, *.pfb)
will not be included in most cases.

Copy Single Job Source to Folder

� To Send Job Files to Folder

1. Create a directory to house the job files (using Windows Explorer, etc.).

2. Launch Lytrod VisionDP and create a New Job or Open a job (*.pfj).

3. Go to the File menu, choose Send To and Folder.

4. Browse for the folder created in step #1 and click Open to send the job source files to the directory.

Zip a Single Job Source (Send To Archive)
When contacting Lytrod Technical Support, you may be asked to provide an "Archive" of your job so that
the tech support person assisting you can emulate the same environment that you're in by using your files.

� To ZIP Job Source Files

1. Create a New Job or Open a job (*.pfj).

2. Go to the File menu, choose Send To and Archive.

3. Click OK to create zip file of job in the \VisionDP\archive directory displayed. A *.zip file with the
job name will be created in the \archive folder.
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Chapter 9

Creating OMR Forms

OMR forms are special forms that allow high speed capturing of hand input data. These forms are
distinguishable by the bubble shapes that are used to capture information; therefore, they are
frequently referred to as bubble forms or scannable forms. This type of form is commonly used in

standardized testing, surveys, payroll data collection, and other applications where a limited number of
responses are required.

OMR is an acronym for Optical Mark Reader. Optical Mark Readers are LED scanning devices that
interpret the black marks strategically placed on a page. The OMR scanner initially detects a tracking bar
placed on the edge of a sheet and is then triggered to scan that row for black marks. These black marks
must be placed exactly in relation to the tracking bars as dictated by the density (even placement of the
LEDs) of the scanning device. In order to get the user to place the marks at the exact position, a
circle/oval/rectangle/square is drawn precisely where the scanner will look for a mark.

A total of three OMR modes are supported in Lytrod Software:

(1) Character, which is the normal type of OMR

(2) Binary Decimal

(3) Binary Litho

By default, Character OMR will be automatically enabled. Binary Decimal and Binary Litho modes can be
enabled through the Preferences menu.

It is optimum if the bubbles, and the text within the bubbles, are designed in a color other than black. If
OMR elements are placed on a monochrome form, the text within the bubbles is not drawn. If it were, it
would cause scanning problems since the black toner would appear to the scanner to be a filled in mark in
the middle of each bubble.
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OMR Form Setup

Scanner Type
VisionDP supports two types of OMR scanners: 40 channel and 48 channel. Typically, 40 channel scanners
are used outside of the United States, and 48 channel scanners are used primarily within the United States.
It is important to identify the type of scanner that will be used in order to create the OMR form properly.

� To select a scanner type

1. Select Form Layout from the Edit menu.

2. Access the OMR Settings tab.

3. Mark the appropriate radio button to indicate the scanner type.

� To set default scanner type

1. Select Preferences from the Edit menu.

2. Access the OMR tab.

3. Select the default scanner type, either 40 or 48 channel, from the Channel drop-down.
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Tracking Mark Placement

Tracking bars are used to notify the scanner that responses lie in a particular row/column. Their placement
is critical in creating a scannable form. VisionDP will automatically place tracking bars at the correct
distance relative to the edge of the paper and spaced at the column/rows per inch specified. VisionDP also
assures that the tracking bars that are placed on the form are accurately aligned with the responses.
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� To define tracking bars

1. Select Form Layout from the Edit menu.

2. From the OMR Settings tab, select the desired tracking bar location. (left/right for portrait forms, or
top/bottom for landscape forms)

3. Choose columns per inch or rows per inch based on form orientation, from the respective drop-down menus.
Support for 5, 6, or 8 columns/rows per inch is available (along long edge of paper).

This sets the default spacing for the form. Spacing can be different for each set of responses as long as all
of the responses associated with the individual tracking bar use the same spacing. Specific response spacing
is done in the OMR Response Properties window. Tracking bar spacing will automatically be adjusted,
based on the response spacing.

Tracking Bar Size

The default tracking bar size is 15. This size is measured in dots (300/inch) and refers to the thickness of
the tracking mark. Users can modify this size in order to increase the scanning area of each scan row. This
helps to insure that the form is able to be scanned.

� To set default tracking bar size

1. Select Preferences from the Edit menu.

2. Open the OMR tab.

3. From the Tracking Bar Size drop-down, choose one of the predefined sizes.

Selective Tracking Bars

Tracking bars are not necessary for rows/columns that do not contain responses to be scanned. The
Selective Tracking Bars option automatically places tracking marks in relation to responses on the page and
updates them as responses are moved or deleted, etc. Individual tracking bars can also be turned off and
on as desired with the mouse.

� To enable selective tracking bars

1. Select Preferences from the Edit menu.

2. From the OMR tab of the Preferences window, click Selective Tracking Bar Drawing.
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� To add/remove individual tracking bars

1. Click the left mouse button over the tracking bar to be added/removed. The mouse pointer shape
will change over valid positions on the screen where tracking bars are allowed. Clicking the left
mouse button will toggle the tracking bar on and off.

Form Identification Marks (FIM)
Form Identification Marks are used to identify each scanner form. These marks can be located on the
bottom or top of a landscape OMR form, or along the right or left side of a portrait OMR form.

Form Identification Mark Setup

� To define form identification marks

1. Select Form Layout from the Edit menu.

2. From the OMR Settings tab, check the appropriate FIM locations.

3. Choose individual FIM mark locations by clicking on the appropriate column locations on the form.
Chosen column locations will be blackened on the form, indicating selection.

Removing Form Identification Marks

� To add/remove form identification marks

1. Position the mouse over the area of the form where the FIMs are defined. The mouse pointer shape
will change when over a position on the screen where FIMs are allowed. Clicking the left mouse
button will toggle each individual FIM off or on.

Form Identification Marks are commonly referred to as Skunk Marks.
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Working with OMR Elements

Drawing Response Blocks
The main element of the OMR form is the response block. These blocks are defined using the OMR
response drawing tool.

� To draw response blocks

1. From the Drawing toolbar, click OMR Response to enable OMR response draw mode.

2. Position the mouse where the response block should begin and press the left mouse key to begin
drawing.

3. Drag to draw the response block and release to mouse key to end drawing.

More precise positioning and sizing can be accomplished in the size and position tab of the OMR
Properties window. The OMR response block will snap to the closest OMR grid position as the box is
drawn.

� To select an OMR response

1. From the Drawing toolbar, click Select Mode.

2. Position the mouse over the element to be selected and click the left mouse button. The cursor will
change according to the object being selected.

Selected items will be displayed with selection handles. To select overlapping objects, it may be necessary to
de-select all objects prior to making the selection.
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Response Spacing

� To specify response spacing

1. Select the responses to be formatted.

2. Select OMR from the Format menu.

3. From the Size and Position tab, choose the spacing in either LPI or CPI, as applicable.

Only certain spacing options are available, based upon the orientation of the form. This helps to maintain
compliance with the OMR specifications set in the OMR Properties window. For example, on a portrait
form, the CPI of a response block cannot be modified.

� To skip rows/columns

1. Select the responses to be formatted.

2. Select OMR from the Format menu.

3. From the General tab of the OMR Properties window, select spacing by specifying the number of
rows/columns to be skipped between each scan row/column.
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Response Formatting

Response Shape

� To change response shape

1. Select the responses to be formatted.

2. Click Response Shape from the OMR toolbar to toggle through shape options.

Response shapes include circles, horizontal/vertical ovals, horizontal/vertical rectangles, horizontal/vertical
rounded rectangles, and square boxes. To improve scanner detection, response shapes will be limited based
on form orientation and default OMR LPI/CPI.

Response Shapes

Circle (not available in 8 LPI/CPI)

Horizontal Oval (portrait page only)

Vertical Oval (landscape page only)

Rounded Horizontal Rectangle (portrait page only)

Rounded Vertical Rectangle (landscape page only)

Horizontal Rectangle (portrait page only)

Vertical Rectangle (landscape page only)

Square (not available in 8 LPI/CPI)
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Response Shape and Text Defaults

� To set default response shape

1. Select Preferences from the Edit menu.

2. From the OMR tab, select the desired bubble shape from the Shape drop-down menu.

� To set default response text size

1. Select Preferences from the Edit menu.

2. From the OMR tab, select text size in points from the drop-down menu.

Response Direction

� To change response direction

1. Select the responses to be formatted.

2. Click Response Direction from the OMR toolbar to toggle between horizontal/vertical responses.
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Response Sequence

Support for common response sequences, as well as user defined sequences, is available.

� To select predefined response sequences

1. Select the responses to be formatted.

2. Open the Sequence drop-down from the OMR toolbar and select a response sequence.

Pre-Defined Response Sequences

A-Z Uppercase Alphabet

a-z Lowercase Alphabet

0-9 Numeric

A-Z, 0-9 Uppercase Alphabet followed by Numeric

a-z, 0-9 Lowercase Alphabet followed by Numeric

TF True/False

YN Yes/No

� To define custom response sequences

1. Select the response to be formatted.

2. Choose OMR from the Format menu.

3. Access the General tab of the OMR Properties window and type the desired OMR sequence into the
Sequence edit box. For temporary or blank responses, use the space bar. The length of the response
sequence is not limited to the size of the edit box. The edit box can scroll left to right to handle
more text than is visible.

The custom sequence tool can be used to create responses in reverse order. For example, a response
sequence of 9876543210 can be defined instead of the standard 0123456789.
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� To place a special character in a custom response sequence

1. Select Character Map from the Edit menu.

2. Select the font that is being used for the OMR sequence. You want the special character's font to be
the same font that is already being used on the form.

3. Choose the special character by highlighting the character and clicking Select, or by double clicking on
the special character.

4. Click Copy to copy the special character to the clipboard.

5. Close the Character Map window by clicking Close.

6. Select the OMR form.

7. Select OMR from the Format menu.

8. From the General tab, place the cursor in the Sequence edit box and paste the special character by typing
<Ctrl> and V at the same time.

Persistent OMR Sequences

A commonly used custom OMR sequence can be saved for later use. This saved sequence will appear in
the Sequence drop-down menu when future OMR forms are defined.

� To save a custom OMR sequence

1. Right click the desired OMR form, and select Format OMR from the context menu.

2. Access the General tab of the OMR Properties window.

3. Define the custom sequence.

4. Click Remember.

5. The custom sequence will be saved in the Sequence drop-down menu for future selection.
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Two Character Bubbles

OMR forms can contain 2 different characters within each bubble. The top drop-down menu allows the
user to select the characters that will be contained within the bubble. The bottom drop-down menu tells
VisionDP which single character will be represented by the double characters in the bubbles.

For example:

A user defines the double character sequence to read A B C D E F and so on. Each bubble would contain
two characters: a letter and a space. However, when pre-slugging data, such as a name, VisionDP will slug
for single letters, as specified in the data file. By defining which single character to look for, VisionDP will
be able to recognize that the pre-slug for the letter S will go in the bubble that contains the S and the space.

� To define two character OMR sequences

1. Right click the OMR block that you wish to format.

2. Select Format OMR from the context menu.

3. Access the General tab of the OMR Properties window.

4. Enable the 2 Characters in Bubble check box. This will cause the second sequence drop-down menu to
appear.

5. From the first drop-down menu, select the sequence of letters and/or numbers that you want to
appear in the bubbles.

6. From the second drop-down menu, select the single character series that will be defined by the double
characters.
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Response Numbering

Initiating Response Numbering

� To activate response numbering

1. Select the responses to be formatted.

2. Click Numbered from the OMR toolbar to number response rows/columns.

Numbering Interval

When numbering OMR responses, the default number interval is 1. The user can specify any number
interval to be used when numbering.

� To set numbering interval

1. Select the responses to be formatted.

2. Select OMR from the Format menu.

3. From the general tab, specify the interval in the Interval edit box or by using the spin arrows.
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Starting Number

When numbering OMR responses, the default starting number of the sequence will be 1. However, the
user can specify any starting number. This is particularly helpful in situations where there are columns of
continuing responses.

� To set starting number for response numbering

1. Select the response to be formatted.

2. Select OMR from the Format menu.

3. From the General tab, specify the start number in the Start edit box, or by using the spin arrows.

Trailer

Trailers are available when numbering responses. Trailers can be defined as a character(s) that will follow
the numbers. Common trailers include periods "1." and parenthesis "1)".

� To set trailer

1. Select the responses.

2. Choose OMR from the Format menu.

3. From the General tab, define the trailer character(s) in the Trailer edit box.
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Written Response Boxes
Written response boxes are a unique feature that allows for a space on the OMR form in which answers can
be written. The written response box will be indicated to the scanner by a corresponding OMR mark. Any
formatting applied to the OMR border will also be applied to the written response box.

� To draw written response boxes

1. Select the responses to be boxed.

2. Click Written Response Boxes from the OMR toolbar to toggle boxes on and off.

Response Title

� To create a response title

1. Select the responses to which a title should be added.

2. Select OMR from the Format menu.

3. From the General tab, type the title text into the Title edit box.

4. Add a box around the title by checking Title Box. It is not necessary to have a box around title text.

Change the font of the title by selecting the title and choosing Font from the Format menu.
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OMR Pre-Slugging

� To pre-slug an OMR response

1. Select the response to be pre-slugged.

2. Select OMR from the Format menu.

3. From the General tab, type the characters to be pre-slugged into the Pre-Slug edit
box. For empty or blank responses, use the space bar. The length of the
pre-slug is not limited to the size of the edit box. The edit box can scroll left
to right to handle more text than in visible.

� To create a variable for pre-slugging

1. Select Define Variable from the Field Settings
cascading menu on the Edit menu.

2. Select Variable from the Type drop-down
menu.

3. Name the variable.

4. Select the field name to be pre-slugged
from the Field drop-down menu.

5. In the Transforms area, select Upper or Lower
from the Case drop-down menu,
depending upon if the OMR form that is
being designed uses all uppercase or
lowercase letters.

6. Click OK.

7. Follow steps 1-3 of the pre-slugging procedure, selecting the variable name chosen in step 3 in the
Field Name drop-down menu.

If the field name used for pre-slugging is not in the same case as the OMR bubble sequence, one or the
other should be edited so that both cases are identical. A variable field can be created to apply a case
transform to the field name in order to change the case of the data field.
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� To enter special characters into the pre-slug edit box

1. Select Character Map from the Edit menu.

2. Select the same font that is being used for the OMR response.

3. Choose a special character by clicking Select or by double clicking on the special character.

4. Click Copy to copy the special character to the clipboard.

5. Close the character map window by clicking Close.

6. Select the response to be pre-slugged.

7. Select OMR from the Format menu.

8. From the General tab, place the cursor in the pre-slug edit box and paste the special character by typing
<Ctrl> and V at the same time.

Special characters also need to be placed in the response sequence if not already there. See page 283 for
detailed information on response sequences.

Data Driven Pre-Slugging
Database fields can be used for data-driven, pre-slugged responses in VisionDP. This allows information
like names, addresses, etc. to be automatically pre-filled on each OMR form. This eliminates the need for
the user to slug this information manually. Any data field or variable can be used. VisionDP is also aware
of bubble shape and direction, and supports response box and column/row skip.

� To create data-driven pre-slugged responses

1. Select the OMR element.

2. Select OMR from the Format menu, or right click and select Format OMR from the context menu.

3. From the General tab of the OMR Properties window, select the database name from the Field Name
drop-down menu in the Pre-Slug area.

A data field must be imported for this feature to be used.
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Response Border
The response border is simply a box drawn around one area of responses. There are a variety of
formatting options available for the response border.

Thickness/Style

Border thicknesses are represented in points from 0-14. Three border styles are available: solid, dotted and
broken.

� To change thickness/style

1. Select the boxed responses to be formatted.

2. To change the border thickness, click the appropriate border thickness button: Increase Border Thickness or
Decrease Border Thickness.

3. Click the Change Border Style button from the Format toolbar to switch between the available line styles.

Color

The border color can also be changed independently of the color of the OMR response box.

� To change border color

1. Select the boxed responses.

2. Select OMR from the Format menu.

3. From the Border and Shading tab, select a color from the border color drop-down menu.

4. Color changes will affect both the OMR response block and the OMR border.

� To change border and response color

1. Select the boxed response(s).

2. To change the border color, click Palette from the Format toolbar.

3. Select the appropriate color.
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Rounded Corners

Rounded Corners can be applied to one or all of the border corners. The amount of roundness can also be
controlled.

� To round corners

1. Select the response(s).

2. Click Round/Square Corner on the Format toolbar.

3. To specify a particular corner to be rounded, click the left mouse button on the corner handle while
holding the <Shift> key. The corner will then be selected.

4. Click Round/Square Corner on the Format toolbar.

To specify the amount of rounding, select Object from the Format menu. From the General Attributes tab, select a
roundness choice from the Roundness drop-down menu.

Creating OMR Forms 291

�



Default Border Settings

A default style, color and thickness of OMR responses and their borders can be set. The defaults are set to
solid style, red color, and 1 pt. thickness.

� To change the default settings

1. Select Preferences from the Edit menu.

2. Open the OMR tab.

3. Choose border Style, Color, and Thickness from their respective drop-down menus.

Response Shading

� To shade response

1. Select responses to shade.

2. Click the desired shading button on the Format toolbar to apply shading.

� To specify shading pattern

1. Select responses to shade.

2. Select OMR from the Format menu.

3. From the Border and Shading tab, select shading type from the drop-down menu.
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� To specify fill

1. Select responses to fill.

2. Select OMR from the Format menu.

3. From the Border and Shading tab, select color from the Fill drop-down menu.

� To specify rows/columns to be filled or shaded

1. Select responses to shade.

2. Right click and select Format OMR.

3. From the Border and Shading tab, select rows or columns to specify which will be shaded.

4. Define the number of rows or columns to be skipped in the Skip Every box.

5. Check Start with Shade/Fill to shade/fill the first row/column.

Creating OMR Forms 293

Border and Shading tab of the OMR Properties window

Every other shading



Binary OMR
By default, Character OMR is enabled. If the user wishes to enable Binary OMR modes, which includes
Binary Decimal and Binary Litho, they must first be enabled through the Preferences menu prior to drawing
the OMR elements on the form.

� To enable Binary OMR

1. From the Edit menu, select Preferences.

2. Select the OMR tab within the Preferences menu.

3. Select the Enable Binary OMR check box.
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� To draw Binary OMR elements

1. Select the OMR draw button and draw the OMR box on the form.

2. Right click and choose Format OMR.

3. The OMR Properties window will appear. On the General tab, there will be a Mapping area where you can
choose which type of OMR you would like to enable: Character, Binary Decimal, or Binary Litho.

Binary Litho is a 1-dimensional representation of a number, with each bubble having a value of 2 to the
power of n. Being 1-dimensional, it is limited to 1 row if the direction is horizontal, or 1 column if having a
vertical direction. The first bubble starts on the left or top side, having an initial position value of n being 0,
and increments with each bubble to its right or below. The first bubble from the left side has a value of 1 if
filled and 0 if not, while the second bubble has a value of 2 if filled and 0 if not, and the third bubble has a
value of 4 or 0, etc. This is shown in the top OMR in the following image.

Both OMRs in this image are representing a value of 63. The bottom OMR in the image is Binary
Decimal, a 2-dimensional OMR representation. When the direction is horizontal, there must be 4 rows, or
when the direction is vertical, there is a requirement to have 4 columns. Each column can encode a single
digit, with bubble values of 1, 2, 4 and 8, from top to bottom. While the total value if all bubbles are filled
can be 15, it is assumed the slugging of the bubbles will not exceed a value of 9.

Binary OMRs are limited to a total number of 32 columns or rows since the size of an integer is 32 bits.
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Chapter 10

Creating PDF Documents

Portable Document Format (PDF) is an open standard for document exchange that was originally
created by Adobe Systems Inc. The PDF file format is a small, highly efficient, self contained format,
that includes all text, drawn items like lines, boxes, circles and paths, and font and image resources

within the produced document.

VisionDP has the capability to output your print jobs without any additional software components. Design
your document, merge your data and output to PDF all using Lytrod Software VisionDP.

When a PDF job is created in VisionDP, resources like fonts, images and forms, are classified as either static
or dynamic, and placed into the PDF document in the most efficient way possible, and is thus able to create
a highly compact PDF file.

A production “lights out” ability is provided to:

� Change the data file

� Subset the data

� Split the PDF in various ways

� On completion of each PDF, you may schedule:

1) Email notifications with the PDF attached, and/or

2) LPR the PDF to a printer.

3) Print the PDF to a local printer.

� Create a “Demographics” resource statistics page to be included at the end of your PDF job, in a
separate PDF, or on-screen.
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PDF Set-up

Font Defaults

When the PDF document is being created, if any fonts referenced cannot be added to the PDF, from
licensing issues, or unable to be located in the proper format, the Default Font in the Preferences menu will
be automatically substituted, using the same size and style as the original font.

For TrueType fonts, a TrueType.tbl file exists which defines the default CodePage character mapping and if
the font is embeddable into the PDF document. If a referenced TrueType font is used which is not defined
in the TrueType.tbl file, the defined Default Code Page in this menu will be used. The Code Page
drop-down lists common Code Page mappings, but is not limited to this list.

Setting up Font Substitution when using Bitmapped Fonts

If migrating from a Legacy Environment using families of bitmapped fonts, font substitution information
may be defined. With Designer naming bitmapped fonts using the FDL font naming convention, a two
character family name, information can be extracted from these six character font names. By defining which
TrueType or PostScript Type 1 font is to be associated with the 2 character family name, style and weight, a
font substitution can occur when it is realized that a font is neither a TrueType or PostScript Type 1 font.
If a font substitution is not found, a default font substitution will be used. The default font substitution
uses the Arial TrueType font. Any number of associations may be defined, as long as the two character
family name, along with the style/weight, is unique in the table.

� Set up Font Substitution tables

1. From the Edit drop down, select Preferences.

2. Select the PDF Font Mapping tab on the Preferences menu.

3. From the Default Font drop-down, choose a font to be
used in the event that a substitution has not been
defined for a bitmapped font that is being used on your
form. Arial will be used is nothing is chosen.

4. Use the Bitmap Font drop-down to select the bitmap font
that you would like to define a substitution for. When a
font is picked from the drop-down and matches (one
of) the Xerox FDL font naming convention(s), the Font
Identifier and Style information is populated with this
information.

5. Once the bitmap font is chosen, use the Map To Font
drop-down menu to select the desired Postscript or
TrueType Font.

6. Click Add to add this font substitution to the list.
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PDF Output Location

By default, the PDF output location will be C:\Program Files\VisionDP\Output. This means that every time a PDF
job is created, it will automatically be saved to the designated folder defined in the Resource Set Locations
tab. The user may change the PDF output location in each defined Resource Set.

� To edit the PDF output location

1. Close any open forms/projects.

2. From the Edit menu, select Edit Resource Set.

3. Select the Locations tab.

4. Use the ellipses button to browse for the desired folder location.
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Creating the PDF

Single Page Design

For simple single page applications, you may create the PDF output by selecting Save As PDF from the file
menu.

� Output single page design to PDF

1. With your form open, select Save As PDF... from the File menu.

2. Choose the output PDF file name if different from the form name.

3. If the PDF is to be split into multiple files, the output PDF file name may be built from variable
information. By surrounding the variable name with $$ and ., variable information will be inserted
into the output name. The data record used will be the first data record of the split PDF document.
Example: AcmeApplication$$Account_Number..pdf will create a file name of:
AcmeApplication13526.pdf if the variable Account_Number contained the value 13526 on the first
data record.
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Multiple Page Job

When multiple page or more complex applications are designed having the Job menu, the Create PDF Job…
button may be selected.

� Outputting your Print Job to PDF

1. With your project file open, select the Create PDF Job... button at the bottom of the Job Tree.

2. The Create Print File window will appear. Name your PDF and select the location where the file is to be
saved. Click Save.

3. If the PDF is to be split into multiple files, the output PDF file name may be built from variable
information. By surrounding the variable name with $$ and ., variable information will be inserted
into the output name. The data record used will be the first data record of the split PDF document.
Example: AcmeApplication$$Account_Number..pdf will create a file name of:
AcmeApplication13526.pdf if the variable Account_Number contained the value 13526 on the first
data record.

4. The PDF Creation window will appear. The following options will become available:

� Choose the desired data file (If different from data file used in design)

� Define security password

� Choose Page/ Data Record Range settings

� Select your PDF Splitting properties

� To have a resource usage report
created, choose PDF Demographics
option

� Define PDF Completion Action

� Specify your desired PDF Quality options

� To view the last created PDF at the
end of this process, click on the View

PDF When Finished

� Selecting the Stop If Error Occurs option is
recommended

� If Clear Dry Ink is defined in your
application, a Suppress Clear Dry Ink
button is available

� If splitting is defined, the Booklet
Imposition option will become available.

� If your document needs to be rotated to a different orientation when output to PDF, select the
Rotate Page 90 check box

5. Click OK to start the data merging process.
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Password Protected PDF

PDFs have the ability to be password protected. By clicking on the Edit Permissions, a menu is shown which
allows Open and Permissions passwords to be defined. Defining the Password in the PDF Creation menu, you are
defining the Open password. Also in the PDF Permissions menu, control over what level of permissions a
password protected file is allowed to the viewer of the PDF document. Additional Encryptions levels can
be set if desired. When the password defined PDF is opened in Adobe’s Acrobat software, the permission
settings are enforced.

Subsetting the PDF Document

A PDF may be created using the complete data file, or a range of pages may be defined to subset the PDF
produced. This subset may be defined by data record ranges, or by page numbers. If a data record is used
on multiple pages, these ranges are different from one another. The first page/data record starts at a value
of 1. When a data file is not defined, this range may be used to increase/decrease the defined initial record
count when the No-Data mode was defined.

Demographics

Enabling this option will produce a Demographics report at the end of PDF creation. This report will
detail the resources referenced in the job, as well as total page count. This report can be added to the end
of your PDF document, created as a separate PDF, or simply appear on screen at the end of PDF creation

What happens if a problem is found in the data?

In the PDF Creation menu, the checkbox “Stop If Error Occurs” controls whether the user is queried if an error
occurs during the creation of the PDF file. If not checked, all error messages are gathered and shown in a
View Errors menu after the PDF is finished being created. If checked, a dialog box is displayed every time an
error occurs, allowing the user to decide whether to continue with the creation of the PDF, or to quit the
process. The status of this checkbox is remembered from the last time that this menu was seen.

Page Splitting Options

Within the PDF Creation menu you are able to define the point at which you would like your print job to be
split into multiple PDF files. These settings will be remembered by default.

� Page Number: Define the number of pages for the PDF to be split at.

� Data Record: Define the number of data records for the PDF to be split at.

� Time Limit: Define the number of hours at which the PDF will be split at. This number can be fractional.

� End of Set: When this option is selected, the PDF will be split at each Job Set.

� Condition: When this option is selected, you are able to define a condition to have the PDF Split
dependent on variable information found within the data or based on system-defined variables.
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When splitting a PDF into separate PDF documents, the user can control what actions are to be applied to
each PDF document.

These actions may be:

� Emailing

� LPRing to a printer

� emailing & LPRing

� printing

� emailing & printing

� conditionally doing any of these actions. Also, a condition may specify that the PDF is to be
deleted after the action occurs.

Example: A common scenario for a conditional PDF Completion action permits the emailing of the PDF if
the email address is available in the data, otherwise printing the PDF to send through the mail, as shown in
the example below.

Clicking on the Set Condition button brings up a Conditions menu, as shown below. This example shows the
condition menu determining if an email address is defined, and defining the action to email the PDF.
Otherwise the PDF is sent to a printer. If a "final else" was not specified, no Completion Action would
have been taken on a PDF when all conditions evaluate to a false result.
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Print/ Print & Email

Once your variable job design is complete, you may print the PDF to
any printer attached to your PC through ports or defined networks.
Select either Print to: or Email and Print to: in the PDF Completion Action
section. Setting this option will still create the PDF file in the Output
folder.

A Printer drop-down and Printer Settings… fields will appear, with the
drop-down containing a list of all printers known to this PC. The first printer will automatically be chosen.
The appropriate printer must be selected before clicking on Printer Settings… as information in this menu
changes for each printer.

When the Printer Settings button is selected the following options will become available:

Job Title: Allows for a short description of the
job that may appear on the printer’s display
when the application is printing.

Scaling: None, Fit to paper or Shrink large
pages.

Paper Size: Standard paper sizes are defined in
the Paper Size drop-down field, and is based on
settings defined in the active resource-set. A
custom paper size may be defined by defining
the Width and Height fields.

Copies: Defines the number of copies of the
entire job to be printed.

Collate: When this option is checked, the entire
document will be printed before the next copy.

Quality: High, Medium, Low or Draft is
available.

Duplex: Setting will be copied from the Options –

Page Format setting in the application’s Job-Tree.
You may change it here to override it for this
print.
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Orientation: Settings will be copied from the application's Paper-Size setting in the application’s Job-Tree, if
defined; or it is taken from the application’s first defined page. You may override this setting for this
printer.

Paper Trays: Information is retrieved from the print driver, and should be accurate for what Trays/Bins are
available for this printer.

If Print to file is checked, a file name must be defined in the field immediately to its right. When checked,
this document will not be sent to the defined printer.

Email Notification

Once your PDF job is done being created, an email notification of job completion and/or PDF delivery
can be sent to static or variable email addresses.

When sending email notifications, the user must have an email program active for email notifications to
function properly. Since VisionDP QuickStart and VisionDP Production do NOT have an internal email
server, they rely on a SMTP email client like Outlook, Outlook Express, Windows Live Mail, etc. to actually
send out the email notifications.
VisionDP Automate customers: Emails can be sent with customer's Email Client, or using VDP Automate
Internal Email Client. Settings on page:

� To send notification to email address(es)

1. Once your job design is complete, select the Create PDF Job button on the Job Tree.

2. Define the name of the PDF in the Create Print File menu and select Save when done.

3. In the PDF Creation menu, select Email To: from the Do: drop-down menu in the PDF Completion Action
section.

4. Enter the desired email address(es) in the text input box to the right of the Do: drop-down menu. If
entering more than one email address, separate using semicolons (;). To send emails to variable email
addresses, use the drop-down menu to select the Field Name that contains the variable email
addresses.

5. Select the Attach PDF to Email option if desired.

If the Attach PDF to Email option is selected, the email notification will happen after every PDF is created,
in the case of PDF splitting.
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6. Select the Email Settings button to define additional formatting options for the email notification.

� From

� To

� CC

� Subject

� Message

� HTML Message

� Attach PDF to Email

If no email settings are defined other than a
"To:" address, a generic time stamp for the PDF
created will be included in the body of the email.

VisionDP Automate: If the "From:" address is not
defined, the email defined in the Preferences
menu will be used. See Page:

7. Finish defining PDF creation settings in the PDF Creation menu and Click OK when done.

8. The PDF Action Display menu will appear, listing all emails that were sent. To save this information, click
on the Save to File checkbox on the bottom of the menu.
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Emailing without Queries using Windows Default Email
The default action of email programs like Outlook, Outlook Express and Windows Live Mail is to query
the user before sending out an email which originates from another program, like VisionDP. To prevent
this from happening, we will show how this can be disabled in each email client program.

Outlook Express

From the Tools drop-down on the menu bar, click on Options… In the Security tab, you will see in the
Virus Protection area: “Warn me when other applications try to send mail as me”. By resetting this option,
Outlook Express will no longer request confirmation when VisionDP is emailing PDF completion
notifications.

Windows Live Mail

Click on the Menus button on the right side of the top menu bar, and click on Safety Options… In the
Security tab, you will see in the Virus Protection area: “Warn me when other applications try to send mail as
me”. By resetting this option, Windows Live Mail will no longer request confirmation when VisionDP is
emailing PDF completion notifications.

Outlook

To prevent queries from happening in Microsoft Outlook, you can make it permanent if your computer is
not managed by Microsoft Exchange administrator, by clicking on the Tools menu and then click on Trust
Center. Click on Programmatic Access and change the security settings. If you do not want or cannot do
this, a temporary setting is possible when the first query comes from Outlook requesting permission to
send an email generated by the VisionDP software, click on Allow. If you are prompted to allow access to
recipient information, select the Allow access for check box. You can now select an amount of time to
prevent Outlook from further queries.
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PDF Proof
VisionDP has an option to Proof your variable document, creating a watermarked PDF. This option is
especially useful if you are using VisionDP QuickStart, where the allowed number of PDF pages to be
created is limited. This option allows you to define all PDF formatting options as you would the final PDF,
except the PDF will be watermarked and not counted toward the total page count that you are limited to.
The PDF Proof option differs from the Print Proof option available within the File menu, which will only produce
the static elements on your document.

The PDF Proof option places a "Lytrod Proof" background image on every page of the PDF document.

� To create a PDF Proof of your document

1. Once your job design is complete, select the Create PDF Job button on the Job Tree.

2. Define the name of the PDF in the Create Print File menu and select Save when done.

3. Select desired formatting options with the PDF Creation menu.

4. Select the Proof PDF button.
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Chapter 11

PDF Automation

This chapter documents enhancements for the VisionDP Automate tier. A version of VisionDP that
provides a much greater level of capability to handle a “lights-out” mode of operation. You can determine
if your software is at this tier by viewing the About VisionDP menu (drop-down Help and click on About
VisionDP...). You will notice Automate displayed in the center of this menu. If you are not at this tier, and
you determine that these enhancements documented in this chapter would greatly benefit your usage of
VisionDP, contact sales@lytrod.com to get a quote for upgrading your current product.

Once an application is designed, PDF output may be produced many times using different data files in an
automated process. Our definition of PDF Automation is the process of producing PDF documents with
as little user involvement as possible. VisionDP Automate's unique use of Command-Set Files allows the user to
create command line functions through an easy to use menu and save these functions to a Command-Set
file (.cos).

VisionDP Automate can process variable applications into PDF in three ways:

(1) With a single form open, select Save As PDF from the file menu or with a job open (.pfj), click on the
Create PDF Job... button.

(2) With no forms open, select PDF Automate from the File drop-down and select one or more
Command-Sets or Batch Command-Sets into the Queue.

(3) Run VisionDP from a command prompt, or called from another program, passing a Command-Set,
Batch Command-Set, Project or Form file as parameters to control the processing of the application.
There is no need to understand the structure of a Command-Set file as menuing exists which will
create these files for you.
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Automation Capabilities
VisionDP Automate allows you to automate the production and distribution of variable PDFs. VisionDP
Automate contains several product features, not available in VisionDP QuickStart and VisionDP
Production, to enhance PDF automation. From Hot Folder mode, in which VisionDP Automate is waiting
for data to be dropped into a "hot folder" for immediate processing; to the Activity module which allows
processing of multiple print jobs to be defined, controlled and viewed; to Versioning in which variables
defined in the application can have new initial values overridden; as well as the creation of log data files to
complement the split PDFs produced, so that downstream processes understand the correlation of the
PDF files to the data used in each PDF document. VisionDP Automate separates the design of
applications from the creation of PDF documents.

Command Set Files
The automation workflow can be simplified through the use of Command Set Files. Command Set files are
files (.cos) that contain command line values that can be created through easy to use menus. A .cos file is
basically the creation of instructions for the automation of your variable PDF job.

� Creating Command Set Files (Defining Automation Specifications)

Once your design is complete, you can define the automation settings for your variable PDF by creating a
command set file.

1. With your design job open (.pfj) select the Automate
button from within the job tree.

2. The Command Set Definition window will open,
allowing you to define the optional automation
settings. These settings are explained in detail on the

following page.

3. Once all the desired automation options have been
defined, click OK to create your Command Set
File. Select a file location in the Export Command Set
File menu. The first time that this menu is used
for this application, you will be asked to name the
Command-Set file.
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Command Set Definition Menu settings

Resources: The Command Name application, resource set, and data file will automatically be populated
with the files defined in your variable print job. Any of these can be edited.

Hot Folder: If the use of a hot folder is desired, the file location can be changed within the data file input
menu and a Hot Folder check box can be enabled.

� To define a “Hot Folder”

1. Click on the Hot Folder check box.

2. Define the Hot-Folder location in the Data File edit box. The default folder is named "HotFolder", and
will be assumed if a folder is not defined as part of this name. Further examples below:

� If a specific data file is defined (e.g. C:\Program Files\VisionDP\HotFolder\DailyReports.csv), VisionDP
Automate will then only process this file when placed in the Hot-Folder

� A data file name with wildcard characters (* or ?). This can be something like: *.* (any file placed
in the hot-folder will be processed as data for this application)

� *.csv (any file with a .csv extension will be processed as data for this application)
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� DailyReports*.csv (just files with names starting with "DailyReports" and having a .csv extension). It
should be noted that it is highly recommended that this name be as specific as possible to the
actual name, with *.* NOT recommended.

Password: Defining a password will require the viewer to enter a password to open the PDF document.
Clicking on the Edit Permissions button will allow a separate password to be defined to control the user
specified permissions.

Versioning: When processing a print application, VisionDP Automate permits variables defined within the
application to be assigned new initial values without modifying the design. By clicking on the Edit
Assignments button in the Command Set Definition menu, one or more variables can be assigned a new initial
value. The Variable and Value drop-down will contain all fields and variables defined on the current
page of the job. Select one of these variables and type in the new initial value. Choosing the
Remember Final Value checkbox will remember the final value of this variable at the end of processing
the PDF document. Therefore, the next time that this application is run, the Versioning initial value
for this variable will be this last value plus increment. This permits a continuation of the
incrementing from the last run. Clicking on the Add button adds this assignment into the
Assignments table. Any number of assignments can be defined. Selecting any of the entries in this
table allows for deletion or modification.

Pages: Select pages/data records to limit the range, allowing subsets of applications to be created into a
PDF document.

Splitting: If you need your PDF Job to be split, choose the splitting method using the Create Separate PDFs at:
menu. A complete PDF file is also created, named without a number at the end of the file-name.

Report: If you would like a Demographics Report to be created once your variable PDF job is complete,
select the Create Usage Report option and choose where you would like this report to appear: at the end
of your PDF, or in a separate PDF. This report will outline Pages Referenced, Fonts Referenced,
Page Counts, PDF Total Creation Time, etc.

Email/LPR/Print: Select a PDF Completion action if necessary. This option allows you to define static or
variable email addresses to be defined if you would like to email a notification of job completion or
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have the PDFs emailed. This option also allows you to define LPR Settings so that PDFs can be sent
to the printer.

Instead of LPR, you may also send the document to a printer connected to your PC. Click on Printer
Settings to control how the document is to print.

Quality: Select a PDF quality.

Highest - Images are used as provided. Fonts, Images and PDF pages are compressed to reduce their
size within the PDF document.

PDF/A-1b - The PDF is created to the ISO standard for this type of PDF. According to Wikipedia:
“PDF/A-1b has the objective of ensuring reliable reproduction of the visual appearance of the
document. PDF/A-1a includes all the requirements of PDF/A-1b and additionally requires that
document structure be included (also known as being ”tagged"/"Tagged PDF"), with the objective of
ensuring that document content can be searched and repurposed. PDF/A-1a also requires Unicode
character maps."

Monochrome - Images that have greater than 8 bits/pixel of color information are reduced to an 8 bit
gray scale image. The effect of this image conversion is to create smaller and more efficient PDFs to
print on monochrome printers.

Fastest - No compression of images, fonts and pages to permit the greatest speed when creating the
PDF document.

Miscellaneous Settings

� Suppress Clear Dry Ink - Removes any item drawn in Clear Dry Ink.

� Quiet Mode - If any error occurred, they will be written to the file VisionDP.err.

� Create Log File - Creates a log.csv file with an entry for each split PDF file created; detailing
Name, Size, Creation Time, Number of Records used, Number of Pages created, etc. for use by
downstream processing.

� Booklet Imposition - Every PDF created will be imposed into a booklet ordering.

� Create a Master PDF containing the contents of all split PDF documents

� Invoke the Update Service to download any available software updates

� Visualize the running of the command line using the Process Queue Manager
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Using Online Data Repositories as VisionDP/Automate Hot Folders
If you use www.dropbox.com (or One Drive, Google Drive, etc.) for your clients to provide you with data
files to process through your VisionDP/Automate software to generate PDF documents, you can use the
folder on your PC where these data repository services sync to your PC as a VisionDP/Automate Hot
Folder. To define a Dropbox folder to be a VisionDP Hot Folder on your PC, right click on the Dropbox icon
on your taskbar. Click on the settings icon in the top-right corner and choose Preferences…

On the Account tab, you will notice the Location defined for the sync folder. You can either continue to
use this default Location, or define your own by clicking on the Move… button. Dropbox does not allow
this syncing folder to be defined within the \Program Files or \Program Files (x86) folders. In the above
screen shot, I choose C:\Hot Folder\ and Dropbox added a Dropbox folder within this folder. Define this
folder as your Hot Folder in the Command Set Definition dialog (VisionDP/Automate only) for each of
your applications.

When a data file is uploaded to your dropbox account by your client, Dropbox automatically downloads this
file to this sync folder on your PC. Once the file is finished downloading, VisionDP/Automate will detect
it and start processing the application waiting for it, producing one or more PDFs. The VisionDP
application can also be defined to LPR or email the completed PDF(s). You may also have the PDF output
assigned to the Dropbox sync folder for automatic uploading back to the Dropbox folder in the cloud,
allowing your client to retrieve the results in a lights out fashion.
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Booklet Imposition

To select the Booklet Imposition option in the PDF Creation menu, you must have Page Splitting options defined
within the PDF Creation menu.

When the PDF is about to be saved to a file, this post-processing function will take over and perform the
following:

1) Determine number of pages in the original PDF document. If not a multiple of 4, blank pages will
be added to the end to make it a multiple of 4.

2) A new PDF document will be created with the same page height, but twice the width of each page.

3) The appropriate pages (1/n, 2/–1, ...) are gathered from the original PDF document and two pages
are then placed on each page in the new document, one on the left side and another on the right side
of the page.

4) Once the pages are all copied to the new PDF document, the imposed PDF document is written to
disk, while the original PDF document is removed and not saved.

Create Log Files

When splitting PDFs, VisionDP Automate can create a log CSV data file which provides information
describing each PDF produced. This file has a data record for each PDF, with at a minimum contains the
name of the PDF file and folder where it is stored, time and date of creation, number of pages in the
document, a sequence number starting from zero of the PDFs produced during this process, and the
contents of a bookmark, if defined. Bookmarks may be defined in the application’s job-tree for one of the
pages, or it may be conditionally defined using a Conditionally Set Variable. If the PDFs were emailed,
additional information stored in each data record will be following using standard email fields: To, From,
CC, BCC, Subject and Content. A final field will indicate if the PDF was attached to the email, having a
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value of 1 if attached, and 0 if not. If the PDFs were LPRed, the data record will indicate the Server and
Printer fields.

In the PDF Creation menu, once the PDF splitting is defined, a check-box titled: Create log file will appear
in the bottom right corner of the dialog. If checked, the log file will be created using the name of the
application, with -log.csv added to the end to create it’s file name.

A partial sample of a CSV log file is shown below:

“FileName”,"OutputFolder","SplitTime","SplitDate","NumberPages","Sequence","Bookmark"

“VTP_DEMO0.pdf ”,"C:\Program Files\VisionDP\Output\","07:40:47","2012-05-23","2","0",""
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Automating Your Variable PDF Job
Once you are ready to automate your variable PDF job, you can do so without opening the design.
Automating your job allows you to submit new data files to an existing VisionDP variable form design by
simply selecting an existing form design, or selecting a pre-defined command set file.

� To Automate Your Variable PDF Job

1. With no forms/jobs open, select File and then choose PDF
Automate or select the Automate button from the Welcome Menu.

2. The Process Queue Manager window opens up to the current
resource set. With the resource set containing all the locations
of the resources, this effects the Command-Sets and Batch
Command-Sets that are shown as available. A different
resource-set may be chosen within the Process Queue
Manager.

3. The Command-Sets list will contain all existing Command-Sets (.cos) and Batch Command-Set (.bcs)
files. By clicking on the check-box to the left of the file names, you can then click on Add Checked Items
to Queue button, which adds the selected jobs to the Queue display. Selecting a Batch Command-Set,
which typically contains multiple Command-Sets, will add each of the .cos files to the Queue display.

4. Press Resume to begin PDF Creation.
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Process Queue Menu
The current resource set is used to determine which Forms folder to look into for Command-Set (.cos) and
Batch-Command-Set (.bcs) files to show in the Command Sets list.

Selecting any one of the items listed by clicking on its name will allow this item to have the Edit COS and
Remove COS buttons available. With a Command-Set selected, Edit Selected Item will open the Command Set
Definition menu to allow editing of the Command Set; or when a Batch-Command-Set is selected, the
Batch PDF Application menu will open to edit the Command-Sets defined in the .bcs file.

Changing the order within this list is possible by clicking on the Move Selected Item Up and Move Selected Item Down
buttons.

To the left of each name is a check box for final selection. This allows one or more items to be dropped
into the queue by clicking on the Add Checked Items to Queue

Batch-Command-Sets can also be created by selecting multiple .cos files and then clicking on the
Batch-Command-Set button. Batch-Command-Sets (.bcs files) are useful when you have multiple .cos files
that are ran in conjunction with each other on a regular basis. They allow you to automatically run a set of
jobs, without having to repeatedly select individual .cos files.
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Processing jobs in the Queue

Once one or more .cos files have been added to the Queue, the buttons above the Queue list become
available to allow for job processing.

The Run button starts the processing of non-finished/non-terminated applications in the queue. Status will
change to Initializing, Processing, and then to Finished. While Processing, the button will change to a Pause
symbol to allow the user to pause all active applications that are running.

The Stop button terminates the currently selected application in the queue. Status will change to Stopped for
the selected application. Once an application is stopped, it cannot be restarted, although a Rerun is possible.

The Rerun button will resubmit the selected item in the Queue list for processing again. Equivalent to
selecting a .cos file in the Command Sets list and clicking the Add to Queue button. You will see your job listed
a second time in the Queue list.

The Scroll Up button allows the Queue list to scroll upward by a page of entries when more entries are listed
in the Queue than can be display at one time.

The Scroll Down button allows the Queue List to scroll upward by a page of entries when more entries are
listed in the Queue than can be displayed at one time.

The Remove button removes the selected entry from the Queue list. The selected .cos file must be in a
Finished/Terminated/Stopped state for it to be removed.

The Move Up and Move Down buttons change the ordering of the entries in the Queue.

If an error occurs during the processing of a job, the View Errors button will become available. Click on this
button to see a report of the error(s) that occurred.
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Each of the processes in the Process Queue will be in one of the following states:

� Paused – When Paused, all processes in the Ready and Processing states are temporarily stopped from
continuing. If a process was in a Processing state at the time that the Pause button was clicked, the
application will be paused once the current page is finished being created in the PDF document. The
button changes to a Resume icon. Clicking on this button will resume the processing of the application
from where it was when paused.

� Ready – This process is ready to be started. This process will start up after any current processing
application finishes or is stopped and when it is next in line to run, or when a data file for this process is
placed in the HotFolder and no other processes are in a Processing state.

� Hold – This process is temporarily stopped from entering the Processing state. Selecting this process and
clicking on the Resume button will change the state back to Ready. Once a process enters the Processing
state, it cannot be placed into the Hold state.

� Processing – One process at any time may be in this state, creating a PDF document.

� Stopped – Permanently in this state. Process did not finish processing the application before it was
stopped. This process must be added again to the Queue for it to be run again.

� Finished – Process is finished processing the application. This process must be added again to the Queue
for it to be run again.

� Failed - Process is finished processing the application with errors that prevented the PDF document from
being created.

Auto Starting Variable PDF Jobs

Creating a Batch Command-Set with the name AutoStart.bcs has special meaning to VisionDP/Automate.
Once this BCS file is defined, opening up the Process Queue Manager will import the Command-Sets defined
within this Batch Command-Set file, and automatically start running these jobs. If you ever want to stop
this from happening, remove the AutoStart.bcs file from the current resource set's Forms folder.
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VisionDP Automate Command Line Interface
In the following diagram, a choice of items is available when these items are on top of one another.
Bracketed items indicate optional settings. While the diagram indicates that most parameters start with a
minus (-) character, they may also start with a slash (/) character. Only the final parameter, which is
required, does not have a minus or slash
character preceding it. No spaces are
permitted in a parameter unless the
parameter is quoted (‘ or “). To have
spaces, or any character which would
conflict in the parameter, you can use the
notation: %hh where h is a hexadecimal
character. For example, a space has a value
of hex 20, so %20 would be used within a
parameter anywhere a space is necessary.
Single or double quote marks can also be
used for any parameter or sub-parameter.
It should be noted that on some versions
of Window’s Command Prompt, quotes
are not allowed within a parameter, and
you may need to use the %20 notation for
spaces. The @command_set_file method
can also be used, and does not have this limitation with quotes. A command_set_file is an external file
which contains these parameters and application name.

Hot Folder Name:

-Hdata_file
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To specify a Hot-Folder where VisionDP Automate is waiting for a data file to be placed into, use the -H
parameter. If this parameter specifies just the name of a folder, VisionDP Automate will wait for ANY file
placed in this hot-folder, and use it as the data file for the current application specified. This is equivalent
to specifying *.* as the data file name. This “lack of a data file name” option is permitted if this is the only
-H hot-folder parameter defined on the entire command-line. Once the application is processed, the data
file in the hot-folder is removed. If this parameter specifies a file name with optional wildcard characters *
and/or ?, VisionDP Automate will wait for any matching files to be placed into this hot-folder. Once there,
VisionDP Automate will process the application when the hot-folder specification matches the data file
found, then remove the data file, and wait again for any matching data files to be placed in this hot-folder.
The data file must use the same data format as what the application was originally designed for. The default
hot-folder is named HotFolder and is expected to be located in the VisionDP folder. The data file name
may specify a complete path location so that an alternate hot-folder may be used. It is critical that this
folder be empty if the name-less method is used, as VisionDP Automate will grab each file in the folder,
process it and delete it after it’s done.

With the ability to have multiple applications being defined on a single command-line, with each referencing
a different application, and each can be defined with a hot-folder for it’s data file, you must ensure that each
hot-folder specification is unique and the same data file cannot satisfy more than one application.

Miscellaneous Settings:

-CA

Setting this option will use Asynchronous Email queuing, if the internal Email Client is being used, and if
the SMTP settings are defined, and if the ChilKat Smtp Queue service is active.

-CB

An application that imports PDF documents and also needs to be imposed into a booklet can enable the
Booklet parameter. The imposition is accomplished after the document is composed but before it is written
to a PDF document.

-CL

When an application has PDF Splitting enabled, a log file can be created that describes each split PDF with
name, number of pages, data record used, etc. It will be placed in the Output folder, with the name of the
application, and a .csv extension.

-CV

Setting this parameter will open the Process Queue Manager menu with these command line applications
running.

Email Settings

-AA (Mail - to, from, cc, bcc, subject, content, html)

-AE (Mail - to, from, cc, bcc, subject, content, html)
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The settings are described in Appendix A: Command Line Interface. Automate has the additional ability to
accept HTML content. With a value of "0", normal content is expected. A value of "1" will properly
process HTML content.

Dynamic Versioning

-Vvariable=value

One or more variables may be assigned values, overriding the initial default values defined in the
application. Each of the variable and value may be quoted, which is required if either has space or
equal-sign characters. The variables will be assigned these value on the first occurrence of usage of each
variable. It should be noted that increments and conditionally set variables will cause the values to change
from what is assigned here. This command line parameter is only available in VisionDP Automate.
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Defining Email Client
When sending variable emails from VisionDP, you have the option to either use your company's email client
(Microsoft Outlook for example) or use the Internal email SMTP Client software provided within
VisionDP Automate.

� Defining Windows Email Client

1. Select Edit and then choose Preferences. The Preferences menu will appear.

2. Select the checkbox for the option Use Windows Default Email.

This will enable your Windows Email to be used when sending out variable emails from VisionDP.

� Defining Internal Email Client

1. Select Edit and then choose Preferences. The Preferences menu will appear.

2. From the System tab, ensure the option for Use Windows Default Email is NOT checked.

3. To finish, you must also click on the SMTP Email Settings tab and define the Mail Host, Port Number, Secure
Connection, User Name and Password defined for the email account that you intend to use. You can verify
that your settings are correctly entered by clicking on the Send Test Email and verifying that you receive
the test email. To switch back to use an IMAPI email (your default email software such as Outlook,
Outlook Express, Windows Live Mail, etc.), click on the Use Windows Default Email checkbox on the
Systems tab. The SMTP settings are remembered for the next time that you remove the check mark on
this Preference setting.

When using the IMAPI type of email, VisionDP
Automate will queue the email and return
immediately, to process the next PDF, not waiting
for the email to be sent out. Your email software
will keep a record of all emails sent, usually in the
Sent Items menu. Using the SMTP email client, this
caching of the email does not occur, and VisionDP
Automate will wait until the email is sent before
continuing. It is recommended that the Create Log File
setting (accessible at the time of PDF creation) be
used so that a record of all emails are available in
this .csv log file, stored in the Output folder.
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Using VisionDP Internal Email Client - Asynchronous Email

To more efficiently issue emails from VisionDP/Automate, the internal email client has the ability to queue
the email requests. Normally when an email is sent, a connection to an SMTP server occurs and the email
is sent, waiting for the completion before continuing with processing of PDFs. When the Asynchronous Emails

checkbox is checked, an .eml file is written to the SMTPQ queue hot-folder directory, where the Chilkat
SMTPQ service processes these emails in date/time order, sending them out asynchronously. Once
successfully sent, the .eml file is moved to the Sent folder. If not successful, the .eml file will be moved to
the Undeliverable folder. It should be noted that this checkbox will only show if the SMTPQ service is active,
and the internal email client is selected for usage.

The Chilkat SMTPQ Email Queue Service must be installed in order to use the Asynchronous Email
function. Installing instructions are on next page.
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� Automatic Installation of Chilkat SMTPQ Email Queue Service

The one-time installation of Chilkat SMTPQ can be done within VisionDP if the user has not yet
installed the software and is sending variable emails using the Internal Email Client.

1. Once your variable design is completed and you have clicked on the Create PDF Job button, you will be
prompted to save the PDF file and then the PDF creation menu will appear where you can define the
composition settings. When the PDF Completion Action is changed to Email To:, and the internal
email client is being used, the software checks to see if the Chilkat Smtp Queue service is active. If it
isn’t, you will be asked to install it.
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2. Answering Yes will start the installation and the Chilkat SMTPQ Setup Wizard will appear. Click Next to
continue through the wizard menus.

3. Once the wizard has completed, the SMTP configuration tool is started so that you can complete the
installation by clicking on the Install Service button.

4. Once installation is completed, you can
click on the Start Service button.

5. Close this program and return to
VisionDP. Within VisionDP you will
now see the Asynchronous Emails
checkbox within the PDF creation
menu and can check this box to
achieve a faster processing of the
PDF as it does not have to wait for
the completion of sending each email
before continuing processing the PDF
documents.
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Installation of Chilkat SMTPQ Email Queue Service

The Chilkat SMTPQ Email Queue can be installed prior the PDF composition, or as an automatic
download option if it is detected that you are using the internal email client and Chilkat has not yet been
installed.

� Manual Installation of Chilkat SMTPQ Email Queue Service

1. Locate the ChilkatSmtpQ.msi file within your VisionDP folder (C:\Program Files\VisionDP) and double
click on it to launch the program.

2. The Chilkat SmtpQ Setup Wizard will appear. Click Next to continue through the wizard menus. Once
this is completed, you will need to run the SMTPQ configuration program.

3. Locate the SMTPQ install program - by default the file will be placed in C:\Program Files\Chilkat
Software Inc\Chilkat SmtpQ\SmtpQConfig.exe. Double click on SmtpQConfig.exe to launch the program
and the Chilkat SMTPQ Manager will appear.

4. If you are using a 64-bit version of Windows, click on the 64-bit Windows checkbox.

5. Verify all of the specified directories are correct. Also verify the Max Threads and Max Retries settings.

6. Click on the Install Service button.
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7. Once complete, click on the Start Service button. This service will continue to be active until the
SmtpQConfig program is run again to Stop or Uninstall the service.

8. You may now close the Chilkat SMTPQ Manager and return to VisionDP. Within VisionDP you will
now see the Asynchronous Emails checkbox within the PDF creation menu and can check this box
to achieve a faster processing of the PDF as it does not have to wait for the completion of sending
each email before continuing processing the PDF documents.

Batch Jobs
Multiple applications can be defined in a single Batch Command-Set file (*.bcs) to instruct VisionDP
Automate to process more than one application at a time. If Hot-Folders are also defined as the data
source, this Batch Job will run indefinitely, or until the user terminates the running of the job. A batch job
can contain any number of Command-Sets or application files (*.cos, *.pfj, *.dtd). Batch Command-Sets
can be created from Batch Command Set… under the File menu, or within the Process Queue Manager window.

Job Modification During Processing

Command-Set files allow for modifications to the job when processed, while application files (*.pfj, *.dtd)
will run without modification to how they were designed.

Hot Folders

The total number of unique Hot-Folder folders used in all of the command-sets defined in a single Batch
Command Set is 64. This is a Windows limitation. The number of applications defined in a Batch
Command Set is truly limited only by memory and the processing speed of your PC, as long as they don’t
all use unique Hot-Folders.

Dynamic Updating of Applications using HotFolders

HotFolders may also have .cos and .bcs files dropped into them when VisionDP is processing in
Hot-Folder mode. This applies only to the default Hot-Folder named HotFolder found in the VisionDP
folder. These files will be processed, and added to the current set of applications being processed in
Hot-Folder mode, after which the .cos/.bcs file will be removed from the HotFolder. This permits the
modification of the existing list of running applications. If the .cos has a named entity, and this name
matches the name of one of the running applications, the new .cos information will replace the stored
information for this application. Otherwise, the processed application will be added to the list of running
applications.
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� To Create a Batch Job

1. Without any applications open, select File and click on Batch Command Set…

2. The Batch PDF Applications window will open. Type in a Command-Set (.cos) , or application (.pfj or .dtd)
file in the Command Set edit box, or click on the browse button to browse for the files that you
would like in your Batch Command-Set.

3. After each file name is chosen, click on the Add button to add them to the Active Command Sets list.

4. Once your Batch Command-Set is finished, click on OK. You will be prompted to name your .bcs file.

� To Edit an existing Batch Command-Set

1. With the Batch PDF Applications menu open, click on the Import Batch Job button.

2. Choose the .bcs file to be edited and click Open.

3. Edit the .bcs file by adding, deleting, and changing the order of the Active Command-Sets.

4. Once the edits have been made, click the Update button and then click OK. A Submit Batch Job button
is available to open the Process Queue Manager menu with the current Batch-Command-Set
contents active in the Queue.
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Action after Processing HotFolder data in VisionDP/Automate
Data dropped into a designated HotFolder is grabbed by VisionDP/Automate, processed to produce one
or more PDF documents, and once finished, is either deleted or moved to another folder. Controlled by
the “Save HotFolder Data After Processing” option in the General Preferences dialog. When checked, a
ColdFolder folder is created in the VisionDP directory where these data files are moved to, unless a
ColdFolderArchive folder already exists. In this case, this folder is renamed to ColdFolder. If this option is
unchecked, and a ColdFolder folder exists, it is renamed to ColdFolderArchive. When a ColdFolder
directory does not exist, the data files are deleted once processing of the data file in the HotFolder is
completed. It is the user’s responsibility to maintain files in this folder. Data files moved to this folder will
overwrite any existing file using the same name.

� To Create a ColdFolder for Data after processing

1. Select Edit > Preferences. The Preferences Menu will appear.

2. Check the option for Save HotFolder Data After Processing.
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Appendix A

Command Line Interface

VisionDP may be started up from a command prompt by typing, at a minimum: VISIONDP

LetterApplication.PFJ or VISIONDP TaxForm.DTD. This permits batch processing of PDF creation to
occur, either by a user typing these commands, or through another software program.

In the following diagram, a choice of items is available when these items are on top of one another.
Bracketed items indicate optional settings. While the diagram indicates that most parameters start with a
minus (-) character, they also may start with a slash (/) character. Only the final parameter, which is required,
does not have a minus or slash character preceding it. No spaces are permitted in a parameter unless the
parameter is quoted. To have spaces, or any character which would conflict in the parameter, you can use the
notation: %hh where h is a hexadecimal character. For example, a space has a value of hex 20, so %20
would be used within a parameter anywhere a space is necessary. Single or double quote marks can also be
used for any parameter or sub-parameter. For example: -D’C:\Program
Files\VisionDP\Data\AcmeData.csv’ It should be noted that on some versions of Windows Command
Prompt, quotes are not allowed within a parameter, and you may need to use the %20 notation for spaces.
The command_file method can be used if you have problems with Window’s Command Prompt.

One or more sets of application definitions may be present on a command line. All of the –parameters are
optional, but the final definition of @command_file, file.DTD or file.PFJ is required and specifies the end of a set.
The processing of each set is from left to right on the command-line. Any set defined with -Hhot_folder
parameter will make VisionDP to be placed in a Hot-Folder processing state, in which VisionDP will never
finish, waiting forever for data files to be placed and processed in a hot-folder. If non-hot-folder data files
are also present on a command-line, these will be processed first before entering Hot-Folder mode.

For example: -O’User Output Document.pdf ’ indicates that the produced PDF document will be placed in a file called User

Output Document.pdf. By default, this will be in the VisionDP\Output folder, but any location may also be specified with a

file name. All user defined information in the diagram is listed in lower-case characters, to allow ease of understanding this

diagram.
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Error Handling:
Any errors that occur during processing of each application will be written to a file VisionDP.err, placed in
the VisionDP folder. A text file that contains any error messages describing problems encountered during
the entire process of producing the current PDF document. If processing multiple applications, this file
will be available only until the next application is finished creating the PDF document file, and will either be
removed, if no errors were found, or overwritten with new error messages for this next application.

Resource-Set:
-Eresource_set

When an application is known to use a resource set that may not be the current one, this parameter is
recommended. All resource-sets are required to exist in the VisionDP folder, so this location doesn’t need
to be defined. The .ENV file extension does not need to be defined.

Output File Name:
-Ooutput_file

By default, the PDF file will be named with the application’s file name, and always with a PDF file
extension. Placed in the VisionDP\Output folder. You may specify a different location and name with this
option.

Data File Name:
-Ddata_file

To use a different data file than what is currently being called in by your VisionDP project file, choose the
data file using the -D parameter. It must use the same data format as what the application was originally
designed for. If the path for this data file is not specified, it will look for the file in the default data location
defined in the current Resource-Set.

Setting Print Range:
-RPnumber:number

To limit the set of pages to be produced, you can define a range based on page numbers. The first number
is the starting page number, which may be 1 or larger. The second number is the ending page number.

-RDnumber:number

To limit the set of data records to be used in the document, you can define a range based on data record
numbers. The first number is the first data record to use, which may be 1 or larger. The second number is
the ending data record to use.

If the :number is missing, the ending range will have an assumed value of '999999'.
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Splitting PDF Into Multiple Files:
-SPnumber

Separate PDF files will be created after the number of pages have been created.

-SDnumber

Separate PDF files will be created after the number of data records have been processed.

-SThours

Separate PDF files will be created after the time in hours have been expended. The hours may contain a
fractional part.

-SCcondition

Separate PDF files will be created after the evaluation of the condition becomes true.

-SE

Separate PDF files will be created after the end of the job set has occurred.

Creation of a Demographic Report:
-GE

A demographic statistical report page will be placed as the last page of the last PDF produced.

-GX

A demographic statistical report page will be placed in a file named DEMOGRAPHICS.PDF.

Send Email Notification with Optional PDF Attachment:
-AAemail_to

-AA(email_to,from,cc,bcc,subject,contents)

To send an email notification with the PDF attached, use the -AA option. The short form defines just the
recipient address, while the long form in parenthesis, defines the to, from, cc, bcc, subject and content
information. To have spaces in any of this text, remember to quote the field.

-AEemail_to

-AE(email_to,from,cc,bcc,subject,contents)

To send an email notification, use the -AE option. The short form defines just the recipient address, while
the long form in parenthesis, defines the to, from, cc, bcc, subject and content information. To have spaces in
any of this text, remember to quote the field.
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-AC"condition"

Adding a quoted conditional text controls if an email/LPR?print occurs, and the type of action. Multiple
condition/action combination are permitted in this quoted text, perhaps to email some and LPR others.
Details of this condition text is not specified here, but it is generated when a Command Set (.cos) file is
produced.

Password Protected PDF
-Popen_password

A password may be defined, allowing the PDF to only be opened when the correct password is provided by
the user. Pre-defined Variable data fields may be part of the password characters, surrounded by $$ and .
For example, SSN:$$SSN. would password protect the PDF document with the characters SSN:123-45-6789 if
the current data record when the PDF is created contains 123-45-6789 in the SSN field.

-P(open_password,permission_password,permission_value,encryption)

In addition to defining a password for opening the document, a separate password (permission_password)
may be defined to limit access to the document. Like the open_password described in the preceding
paragraph, variable information may be used to create the password. If you do not desire a password for
opening the PDF document, enter a comma immediately after the left parentheses. The third parameter
permission_value permits many types of access restrictions, and is defined by:

Print = 1
Copy = 2
Change = 4
Add-Notes = 8
Fill-Fields = 16
Copy-Access = 32
Assemble = 64
Print-Full = 128

To turn on the permissions, add the values together to get the final permission_value. For example: to give
Print, Copy and Print-Full permissions, you would add 1+2+128 giving a value of 131 for the
permission_value.

To define the level of encryption used when the PDF is password protected, a value or 0-3 may be defined
for this parameter, with a value of 1 if not defined. The meaning of these values are:

0: RC4 40 bit - supported in Acrobat 3

1: RC4 128 bit - supported in Acrobat 5

2: AES 128 bit - supported in Acrobat 7

3: AES 256 bit - supported in Acrobat 9

336



LPR PDF To Printer:
-ALserver:printer

Specify both of the server and printer information for the LPR to send the PDF document to a printer.

PDF to Printer
-AP(printer,duplex,flags,copies,media,width,height,tray,quality,scaling,orientation,print-to-file,job-title)

To print the PDF to any printer defined from your PC, provide the parenthesized list of parameters.

� Printer: The printer name shown in the Printer drop-down in a Print menu.

� Duplex: 1 for simplex, 2 for tumble-duplex, and 3 for duplex.

� Flags: 1 for Auto-Rotate and Center, 2 for Collate, 4 for Monochrome, and 8 for sending the print
output to a file.

� Copies: 1 for a single copy and > 1 for multiple copies.

� Media: 1 for standard, 2 for transparency and 3 for glossy.

� Width and Height is the paper size measured in tenths of Millimeters.
Example: 8.5 x 11 paper would be: 2159 x 2794.

� Tray is a printer dependent value.

� Quality: 1 for high, 2 for medium, 3 for low and 4 for draft.

� Scaling: 0 for none, 1 for Fit-to-paper, and 2 for Shrink.

� Orientation: 1 for portrait and 2 for landscape.

� Print-to-File name of the file where the print output will be placed.

� Job-Title is the title of the document.

Quality Settings:
-QH

Highest quality for the PDF being produced (default).

-QA

Produces a PDF compliant with the PDF/A-1b standard.

-QM

Produces a PDF targeted for monochrome. Reduces the color depth of images to improve performance on
a monochrome printer. Also removes any items drawn using Clear Dry Ink.
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Miscellaneous Settings:
-CC

To create a PDF document that has been designed with Clear Dry Ink on a printer without this capability,
issue -CC to ignore any items drawn in CDI.

-CQ

When VisionDP is run in command-line mode, error messages that occurred in the processing of the
application will be displayed at the end unless Quiet mode is enabled by this parameter.

-CS

When splitting the PDF, set this option to create a master PDF containing all of the separate split PDFs.

-CU

Invoke the Update Service to check for updates through an Internet connection, and download any
available software updates.

External File Containing these commands:
@command_file

These parameters may be defined in a file if this process will be run multiple times. The default folder for
this file will be the VisionDP folder, but the command_file may specify an alternate location.

file.PDF

file.DTD

Either a single page (.DTD) or a project (.PFJ) may be specified to be used in the process of creating a
PDF document. These files are expected to be located in the "Forms" Folder defined in your Resource Set.
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Interprocess Communication
VisionDP, VisionDP Automate and VisionDP Integrate all have the capability to operate in a command-line
mode so that other software processes may invoke this software. Communication back to the invoking
software is available through a Windows Mailslot Inter-Process Communication protocol. The mailslot is
named: \\.\mailslot\VisionDP mailslot. Ten messages are currently defined with their formats documented
below:

Message # Message type
Message contents

0. Start “0|application_name|data_file_name”

1. Finished “1|application _name|#_pages”

2. Finished with Errors “2|application _name|#_pages|#_errors”

3. Page Created “3|application _name|page_#”

4. PDF Split “4|application _name|split_pdf_name”

5. PDF Emailed “5|application _name|email address”

6. PDF LPRed “6|application _name|LPR
Server,Printer_name”

7. PDF Printed “7|application _name|printer_name”

8. Error “8|application _name|error_message|line_#”

9. Missing Resource “9|application _name|missing_resource_name”

The Start message is always sent as soon as the PDF engine is started. Either the Finished or Finished with

Errors is always the last message sent for a particular PDF creation process, listing the number of pages in
the PDF, and optionally the number of errors encountered. Page Created is sent after each page has been
created, providing the page number. When a PDF has been split and saved to a file will the PDF Split

message be sent, providing the split PDF name. If any of the actions to email, LPR or print happen, a
PDF Emailed, PDF LPRed and/or PDF Printed message is sent along with the email address, LPR
Server/Printer or Printer name. As soon as an error occurs, the Error message is sent along with the
contents of the error message. If the message contains multiple lines of information, multiple Error

messages are sent with the last parameter providing the line number of the message. Mailslots are not
guaranteed to have messages read in the same order of creation, it is the Mailslot reader’s responsibility to
piece the multi-line error message back correctly. Once a resource is determined that it can’t be located, a
Missing Resource message is sent documenting this resource name.

VisionDP handles the client side of the Mailslot mechanism. The software invoking VisionDP must satisfy
the server side by creating the Mailslot, using the name listed above, before invoking VisionDP. Reading the
Mailslot by the server software will provide a real-time status of the progress of the application being
created by VisionDP.
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Appendix B

OMR Tips and Tricks

The successful creation of OMR forms relies upon several factors. Alignment of OMR elements is
critical to the scannability of the forms and must be within the tight specifications outlined. Printers
and scanners also play their own role in the process. There are important recommendations in this

appendix in reference to creating OMR forms. Everything from the paper printed on to printer hardware
will contribute to your success.

Form Alignment
Alignment issues have been a major focus of VisionDP. Procedures are in place to ensure the proper
placement of the critical OMR elements from the tracking bars to the OMR responses themselves.
However, it is best to perform a second manual check before placing a form into production to verify
proper alignment.

Plastic overlays are available upon request from Lytrod Software, Inc. Often times, the scanner
manufacturer will provide these overlays as well. The purpose of the overlays is to assist in determining
proper alignment.

Alignment Checklist
1. Line up plastic overlay with form.

2. Check alignment of Tracking Bars in relation to the scannable form elements (Form Identification
Marks (FIMs) and Responses).

� Form Identification Marks should be both horizontally and vertically centered by scan row and
column.

� Tracking Bars should be vertically centered in responses.

� Tracking Bars should be proper distance from the edge of the paper.

Individual objects cannot and should not be moved. They are placed in relation to each other and
controlled by VisionDP. If you believe there is improper alignment of tracking bars and/or Form
Identification Marks to responses, please contact Lytrod Software, Inc.
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Customer Checks
� Ensure form is center lined. Sample 25 prints of the form to be used. Pick out the two samples that vary

from the centerline the most in each direction.

� If variation (float) from the specification (+/- .85mm) is noticed, adjust the paper feed if possible to
recenter the paper through the printer.

Scanner Specifications

Scanner Service

Prior to running test forms through scanner, verify that the scanner has been properly serviced by the
manufacturer.

Verify Printer Accuracy

Print 1000 to 1500 of internal test form to determine reject rate at the scanner due to inability to detect one
or more alignment marks and the validity of the scanned data. If the results of this test are not satisfactory,
re-check form alignment, printer alignment and scanner service records.

Paper Recommendations

Type of Paper

� Paper weight of 24 lb. is recommended for all OMR forms.

� Brightness should be as high as possible with a target brightness of 87.

Handling & Storage

This application can be affected by paper edge defects such as bent corners, damaged edges and other
similar defects. Changes in humidity and temperature can affect the natural curl and size of the paper which
can also affect printing and scanning registration.
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Appendix C

Icon Quick Reference

Standard Tool Bar

Icon Function

New Form

Open Form

Create New Resource Set

Save

Proof Print

Preview Form

Import Text

Import Image File

Import Data

Cut
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Copy

Paste

Undo

Redo

What’s This

Help

Text Format Tool Bar

Icon Function

Bold

Underline

Italic

Subscript

Superscript

Font Increase
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Font Decrease

Left Align Text

Center Align Text

Right Align Text

Justify Text

Top Align Text

Center Align Text

Bottom Align Text

Correct Word Spellings

Attach to Box/Circle

Position Object to Box/Circle

Toggle Text Margin

Pre-defined Point Sizes

Pre-defined Typefaces
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Pre-defined Images

View Toolbar

Icon Function

Grids

Rulers

Margins

Fit Page to Screen

Enlarge Drawn Area

Magnify Area 25%

Demagnify Area 25%

Pan Mode

View Data

View Line Data

Imposition Mode
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Add Page

Rotate Page 90

Object Format Toolbar

Icon Function

Toggle Line Direction

Toggle Diagonal Line

Toggle Circle Segment

Round/Square Corner

Close/Open Path

Add New Point

Continue Path from end

Add Light Shading

Add Medium Shading
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Add Heavy Shading

Increase Border Thickness

Decrease Border Thickness

Change Border Style

Change Border Color

Change Text Image Color

Change Fill Color

Set White Clear Dry Ink Fill

Palette

Grouping Toolbar

Icon Function

Left Align Group Items

Right Align Group Items
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Center Align Group Items

Top Align Group Items

Bottom Align Group Items

Vertical Center Align Items

Make Same Width

Make Same Height

Make Same Size

Stretch Left Group Items

Stretch Right Group Items

Stretch Top Group Items

Stretch Bottom Group Items

Repetition Toolbar

Icon Quick Reference 349



Icon Function

Even Repetitions

Exact Repetitions

Staggered Repetitions

Random Repetitions

Break Repetition

Join Into Repetition

Drawing Toolbar

Icon Function

Select Mode

Select Group Mode

Text Draw

Box Draw

Line Draw
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Circle Draw

Path Draw

OMR Bubbles

2D Barcode

Current Grids

OMR Toolbar

Icon Function

Response Direction

Response Shape

Written Response Box

Number OMR

Pre-defined OMR Sequences

Data View Toolbar
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Icon Function

Rewind Data

Data Backwards

Data Forwards

Fast Forward Data

Select Field Name

Data Driven Graph

Conditional Text

Conditional Image

Create New Frame

Attach Relative Object

Data Formula

Edit Job Conditions
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Appendix D

Clear Dry Ink

The Xerox Color 800/1000 Presses offer an option to print a light gloss coating with Clear Dry Ink
(CDI). VisionDP allows you to easily design documents that have this clear coating applied to text
and objects in both static and variable environments. While flooding the entire application may be a

desirable effect in some instances, VisionDP allows the application of Clear Dry Ink to select areas on your
form. This enables you to make certain areas, whether they are text or objects, stand out by having a glossy
coating.

Create background designs and visually enhancing effects using Clear Dry Ink with Lytrod Software's user
friendly drawing tools such as Box, Circle and Line Draw.

By using the Path Draw tool, portions of images or logos can be enhanced by tracing or outlining the
desired areas and then filling the "path" with the Clear Dry Ink.
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Enabling Clear Dry Ink
Clear Dry Ink can be applied to ANY element on the form, it is as simple as changing one option in the
Color Selection window. Clear Dry Ink can be used to outline or fill elements on your form. The glossy
coating can be applied as is (no coloring, just Clear Dry Ink) or on top of an existing color setting.

Clear Dry Ink is most visible when used alone or over light/pastel colors.

To enable the Color Settings to be defined as only Clear Dry Ink (no color, just a clear gloss coating) make
sure 100% white is selected and 100% Clear Dry Ink is selected. This will not print a white color, but
instead tells the software to ONLY print CDI.

Text

� To apply Clear Dry Ink to Static/Variable Text

1. Select the desired static/variable text block that the Clear Dry Ink will be applied to. If you wish to
only have select text within the text block to appear with Clear Dry Ink, highlight the desired text
within the text block.

2. Right click and choose Font from the context menu.

3. From the Font window, select the color drop-down menu.

4. Choose the button on the bottom of the Color drop-down menu that says Other.

5. The Color Selection window will appear.

6. Select the desired text color from the color wheel, input CMYK/RGB values, or use the color
selector.

7. Enter the desired percentage of Clear Dry Ink to be applied to the text in the Clear Ink % input box.

8. Click OK to accept defined settings in the Color Selection window.

9. Click OK to accept defined settings in the Font window.
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Form Elements
Drawn form elements such as paths, lines, boxes and circles can be outlined or "filled" with Clear Dry Ink.

� To Outline drawn elements with Clear Dry Ink

1. Select the desired form element.

2. Right click and select Format from the Context menu.

3. The Properties window will appear. From the General tab, select the Color drop-down menu.

4. Choose the button on the bottom of the Color drop-down menu that says Other.

5. The Color Selection window will appear.

6. Select the desired outline color from the color wheel, input CMYK/RGB values, or use the color
selector.

7. Enter the desired percentage of Clear Dry Ink to be applied to the element outline in the Clear Ink %
input box.

8. Click OK to accept defined settings in the Color Selection window.

9. Input the desired border Style/Thickness and click OK to accept defined settings.

� To Fill drawn elements with Clear Dry Ink

1. Select the desired form element.

2. Right click and select Format from the Context menu.

3. The Properties window will appear. From the Shading/Fill tab, check the Fill box to enable the Color Fill
options.

4. Select the Color drop-down menu and choose the button on the bottom of the menu that says Other.

5. The Color Selection window will appear.

6. Select the desired fill color from the color wheel, input CMYK/RGB values, or use the color selector.

7. Enter the desired percentage of Clear Dry Ink to be applied to the filled element in the Clear Ink %
input box.

8. Click OK to accept defined settings in the Color Selection window.

9. Click OK to accept defined settings in the Properties window.
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Paths
The Path Draw tool is useful when accenting applications with Clear Dry Ink. The Path Draw tool can be
used to draw or trace individual shapes or elements on the form to be filled with Clear Dry Ink. In order for
the paths to be "filled" with Clear Dry Ink, they must be closed. This means both ends of the path must be
touching to ensure the fill option is enabled.

� To draw a path and fill using Clear Dry Ink

1. Click on the Path Draw tool to begin drawing your path.

2. Draw the desired path by clicking on the form to create different points along the path.

3. When finished, with the drawn path selected, click on the Close/Open Path button to ensure the path is
closed.

4. Right click on the path and choose the Format Path option from the Context menu.

5. The Path Properties window will appear opened to the General tab.

6. If your path was properly closed, the Fill option should be available to select. If the Fill checkbox is
"grayed-out" it means your path needs to be closed before you continue. Check the Fill checkbox to
enable the Path Fill color options.

7. Select the Color drop-down menu
and choose the button on the
bottom of the menu that says Other.

8. The Color Selection window will
appear.

9. Select the desired fill color from the
color wheel, input CMYK/RGB
values, or use the color selector.

10. Enter the desired percentage of
Clear Dry Ink to be applied to the
filled path in the Clear Ink % input
box.

11. Click OK to accept defined settings
in the Color Selection window.

12. Click OK to accept defined settings
in the Properties window.
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Clear Dry Ink filled Path Art shapes provided in VisionDP
VisionDP comes with pre-defined Path Art shapes that are available to be imported onto your form. Each
of these shapes were created using VisionDP's Path Draw tool and are formatted to be filled with Clear
Dry Ink. These Path Art shapes are examples of accent designs that can be applied to the design of your
Clear Dry Ink applications. These shapes may be imported and duplicated by copying and pasting to create
a patterning effect.
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Examples of the Path Art files provided within your Images folder. The paths appear magenta in color because they
are defined as being "filled" with Clear Dry Ink.
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The pre-defined Clear Dry Ink Path Art shapes are provided in two ways:

� Each Path Art shape is saved as an *.art file that can be individually imported onto your form

� A form called PREDEFINED_CDI_PATHS.DTD can be opened that displays all the paths. The paths can be
individually selected, copied, and pasted onto other forms.

All pre-defined paths are formatted to be filled with Clear Dry Ink when printed.

� Import Pre-defined Path Art

1. With your form open, select the Import Image button.

2. From the Image Type drop-down in the Import Image menu, select Path Art File *.art.

3. Select the desired *.art file and select OK.

4. The Path Art will be placed on the form in the top-left corner of the form. With the Path Art
elements selected, they may be easily moved by dragging them to the desired location.

� Copy Path shapes from PREDEFINED_CDI_PATHS.DTD

1. Open the PREDEFINED_CDI_PATHS.DTD file.

2. Open the form (.dtd) to which the path(s) will be copied onto.

3. From the Windows menu, select Tile. This will display both form windows.

4. Select the desired path(s) to be copied from the predefined_CDI_paths.dtd form and copy by right clicking
and selecting Copy from the context menu.

5. Select the form that the paths will be copied to. Right click on the form and select Paste from the
context menu.
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Clear Dry Ink PDF Layer Name
By default, the Clear Dry Ink layer will be recognized by the printer as a layer named "Clear", which is
proprietary to Xerox printers. If the PDF with a Clear Dry Ink layer is being printed on a printer other than
Xerox, the layer name may need to be renamed in order for the printer to recognize the Clear Dry Ink layer.

� To define a Clear Dry Ink layer name:

1. Select the Edit and choose Preferences from the drop-down menu.

2. Select the Design tab.

3. From the PDF Clear name drop-down, select the desired name, or type a custom name.

4. Click OK to accept the defined settings.
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PDF Settings to view Clear Dry Ink layer
When printing applications that contain Clear Dry Ink, a good way to see if the Clear Dry Ink is layered
correctly is to open the PDF in Acrobat and go into “Advanced>Print Production>Overprint Preview”.
Make sure the Overprint Preview is checked, then look at the form objects that are defined to be filled with
Clear Dry Ink.

The Clear Dry Ink layer will appear magenta in color and should be transparent.

If your PDF does not show magenta filled objects where Clear Dry Ink is supposed to be applied, go back
to your application in VisionDP and ensure the Clear Ink percentage box is enabled within the form object's
Color Selection menu.
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Appendix E

VisionDP Automate LCDS

VisionDP Automate LCDS is a tier of the VisionDP Suite that enables you to open, edit, and modernize
your Xerox® Metacode documents without sacrificing design capabilities or composition efficiencies. With
VisionDP Automate LCDS, you can bring your LCDS forms (FRM or FSL) and resources
(FNT,IMG,LGO) in directly, have fonts map automatically and drag and drop existing LCDS data fields.

VisionDP allows you to call in your Metacode resources, convert them to VisionDP file formats, and output
to PDF; enabling an easy transition from a Print workflow to a PDF workflow. Output back to Xerox
LCDS FSL or FRM is not possible within VisionDP. An automatic conversion to DTD will be performed
when the design files are saved.

File Types Supported

Supported Input File Formats:

(.FSL) Proform Designer/Xerox FDL/HFDL Source

(.FRM) Xerox Form File

(.DTD) VisionDP Form File

(.PFJ) VisionDP Project File (may reference .fsl or .dtd form files)

Supported Output File Types

(.DTD) VisionDP Form File

(.PFJ) VisionDP Project File (will reference .dtd form files)

(.PDF) Adobe PDF

Supported Image Formats

(.LGO) Xerox LCDS Logo file. Automatically converted to .bmp images during the reading of the form.

(.IMG) Xerox LCDS Image file. Automatically converted to .bmp images during the reading of the form.
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Font Support
All Xerox A03 standard fonts will be automatically substituted with either fonts supported within the PDF
(Helvetica and Times) or by Lytrod Software developed TrueType fonts, as listed below.

When placing Data Areas onto your page, where using a fixed pitch A03 font was typically used in the past,
the following table shows the mapping of these A03 fonts to the TrueType fonts, style and size. If the AO3
font is known, find it in the list to see the point size that will need to be used.

Univers UN fonts are substituted with PostScript Helvetica font.

Press Roman PR fonts are substituted with PostScript Times font.

TrendPS Trend PS fonts will use the A03TrendPS TrueType font.

L00TPA, L00TPB, L00TP 12 point Landscape

P00TPA, P00TPB, P00TPC 12 point Portrait

Xerox 1200 Xerox 1200 fonts (including Bold and Italic) will use the A03Xerox1200
TrueType fonts

L0112A, L0112B, L0112C 8.5 point Landscape

P0612A, P0612B, P0612C 8.5 point Portrait

L0212A, L0412A 8 point Landscape

L0312A, L0512A, L0512B, L0512C 12 point Landscape

P0812A, P0812B, P0812C 12 point Portrait

L0912A 6 point Landscape

P1012A, P1012B 6.75 point Portrait

P1112A 5.75 point Portrait

L01BOA, L01BOB, L03BOA 8.5 point Bold Landscape

P06BOA, P06BOB 8.5 point Bold Portrait

L02BOA, L04BOA 7.5 point Bold Landscape

L09BOA 5.75 point Bold Landscape

L01ITA, L01ITB, L03ITA 8.5 point Italic Landscape
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P06ITA, P06ITB 8.5 point Italic Portrait

L02ITA, L04ITA 7.5 point Italic Landscape

L05ITA 12 point Italic Landscape

P07ITA 9.75 point Italic Portrait

P08ITA 12 point Italic Portrait

L09ITA 5.75 point Italic Landscape

OCR-A OCA-R will be substituted with WASP OCR A, and OCR-B will be substituted
with WASP OCR B.

L05OAA 11.75 point WASP OCR A Landscape

P08OAA 11.75 point WASP OCR A Portrait

L05OBA 11.75 point WASP OCR B Landscape

P08OBA 11.75 point WASP OCR B Portrait

Script Script fonts will be substituted with either of the A03Script or
A03Script12CPI TrueType fonts.

L05SCA 12 point Landscape

P08SCA 12 point Portrait

P07SCA 12 point Portrait (A03Script12CPI)

Serified Courier Serified Courier fonts will be substituted with either the
A03SerifiedCourier or A03SerifiedCourier12CPI TrueType fonts.

L05TYA 12 point Landscape

P08TYA 12 point Portrait

P07TYA 12 point Portrait (A03SerifiedCourier12CPI)

Titan (including Bold) Titan will be substituted with the A03Titan TrueType font.

L05TAA, L05TAB, L05TAC 12 point Landscape

P08TAA, P08TAB, P08TAC 12 point Portrait

L05TBA, L05TBB, L05TBC 11.75 point Bold Landscape
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P08TBA, P08TBB, P08TBC 11.75 point Bold Portrait

Prestige Elite Prestige Elite fonts will be substituted with the A03PrestigeElite TrueType
font.

P07TCA, P07TCB, P07TCC 12 point Portrait

Artisan Artisan fonts will be substituted with the A03Artisan TrueType font.

P07TDA, P07TDB, P07TDC 12 point Portrait

Format Format fonts will be substituted with the A03Format TrueType font.

FFMT01, FFMT03 8.75 point Landscape

FFMT02, FFMT04 8 point Landscape

FFMT10 6.75 point Portrait

FFMT11 6 point Portrait

While many of the Xerox A03 FNT fonts have limited character sets, the VisionDP TrueType version fonts
do not, and therefore will show character cells that may not show using the original A03 FNT font. Any
point size is possible with these A03 TrueType fonts to allow use well beyond the original limited A03 FNT
font sizes available. Serified Courier and Script TrueType fonts (A03SerifiedCourier, A03Script) have been
developed in two CPI sizes, a normal 10 CPI size, and a 12 CPI (narrow) version. All other A03 TrueType
fonts are scaled by point size to the desired size. A separate font is not necessary for differing sizes and
orientations, like what the original A03 FNT fonts required. Of the TrueType fonts developed,
A03TrendPS is proportional, while all of the others are fixed pitch. The A03Format font is used for
drawing of lines and shadings.
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Preparing Your Resources
Prior to opening your forms in VisionDP, all your resources need to placed in the folders that are
referenced in your Resource Set. (Detailed information on resource Sets in Chapter 2) In addition to your
resources being placed in your Resource Folders, LCDS fonts (.FNT) need to be imported into your
resource set through VisionDP. This process will create Windows .FON fonts and install them into
C:\Windows\Fonts.

� To import fonts into the resource set

1. With no forms open, go to Edit and select Resource Set. The Edit Resource Set menu will appear.

2. Select the Fonts tab.

3. Click on the Import button to browse for the desired LCDS font files. Select multiple fonts by holding
down the <SHIFT> key while selecting fonts.

4. Once the fonts have been imported, they will be displayed in your Available Fonts list within the
Edit Resource Set menu and will be available to use during the design process.
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Opening Form Files
.FSL or .FRM form files can be opened within VisionDP to be edited and then converted into a .DTD file
format from which a PDF can be produced. It is recommended that an .FSL file is used if available, as they
contain more information than a .FRM file. Once you have opened a .FSL or .FRM in VisionDP, it will
automatically be converted into a .DTD upon saving.

Prior to opening any forms, make sure all your resources (Forms, Fonts, Images, Data) are located in the
folders that your Resource set is pointing to; for example: C:\Program Files\VisionDP\Forms and
C:\Program Files\VisionDP\Fonts, etc.

� To Open an .FSL Form File

1. From the Welcome Menu, enabled the Show Form Files checkbox.

2. Select the desired form and click the Open button.

OR

1. Select File and choose Open Design.

2. Select the desired form and click the Open button.
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� To Open an .FRM form File

1. From the Welcome Menu, enabled the Show Form Files checkbox.

2. Select the desired form and click the Open button.

3. The Form Resources Menu will appear opened to the General tab. Use this menu to verify the Form
settings and change any if needed.

� Paper Size

� Page Orientation

� Form Measurement Unit

� Form Origin

� Predefined Grid Formats

� User Defined Grid
Formats

� Input Options: Choose
from None, Standard or
Maximum. This will
determine how much
emphasis is put on
grouping like items
together, such as lines into
boxes.

� Text Grouping Tolerance:
This optimization setting
helps group together
words into a single line of text. It's common for Elixir produced .FRMs to have lines of text
separated by each individual word. Increasing the Text Group Tolerance value will have the
software combine the positioning of similar text items.

4. Once all settings have been verified, click OK and your form design will open.
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Mapping Data To Your Design
VisionDP/LCDS combines the processes of forms design with variable data design. With the ability to
input existing LCDS FSL or FRM forms, the final steps are to input a small sample data file, define data
variables, place data onto the page, and possibly add conditional data or images.

LCDS data is historically limited to Line-Mode (e.g. print ready) data. Although delimited and XML are
also supported within VisionDP, unless the data is reformatted into these other formats, it is assumed that
line-mode is what typically will be used when migrating these forms to the PDF workflow. Support is
available for various methods to define a record break, such as PCC, fixed length lines/characters, and
single or multiple character searches. Refer to page 144 for further detailed information on importing
Line-Mode data.

� To Import Line Data

1. With your Form open (.FSL, .FRM, or .DTD) select the Import Data button on the toolbar.

2. The Data Import Wizard will appear. By default, VisionDP will automatically detect the data record
length and data splitting options. If changes need to be made that are different than the default, they
can be done through this Wizard.

3. Once all data settings have been defined/verified, click OK to complete the data import process.

4. The Data View menu will now appear to the right of your screen, with the first record of data
displayed. You can expand this menu if the entire record is not visible.
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In most cases, the entire contents of the data record is placed onto the page. This “Data Area” is
pre-defined under the title: EntireRecord. Go to your data drop-down on the toolbar and select this data
name.

Click on the page where your data is to be placed. This will map your data record on the page. While still
selected, you need to determine the fixed-pitch font to use, and it’s point size. If it is known what font the
static form is designed for, look up this A03 font name in the Font Support table on page 364 to determine
the A03 TrueType font name, and its size. It should be noted that font sizes are supported in fractional
sizes of .25, .50 and .75. Many of the TrueType fonts developed by Lytrod Software for the LCDS A03
fixed pitched fonts uses sizes that are fractional.

Further forms design instructions can be found starting on Chapter 4.
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